a start job is running for lsb - no time

Ogólne pytania dotyczące systemu
sebastiank
Posty: 5
Rejestracja: 25 stycznia 2019, 00:12

a start job is running for lsb - no time

Post autor: sebastiank » 25 stycznia 2019, 00:16

Cześć

mam duży problem z moim serwerem na debian, nie może się uruchomić do końca bo widać:

a start job is running for lsb: VMware tools service (xx.xx min / no limit)

Kiedy kliknę CRTL + F2 - to też widzę... start job is running for lsb: VMware tools service (xx.xx min / no limit)

Nie mogę się podłączyć po ssh - bo nie startuje serwis - zostaje tylko modyfikacje w konsoli grub.. Ma ktoś pomysł jak to naprawić?

Debian 9 64x

Pozdrawiam
Sebastian

Awatar użytkownika
LordRuthwen
Moderator
Posty: 2080
Rejestracja: 18 września 2009, 21:45
Lokalizacja: klikash?

Re: a start job is running for lsb - no time

Post autor: LordRuthwen » 25 stycznia 2019, 06:26

Zmień kolejność uruchamiania, niech vmware będzie miało w zależnościach sshd.
Niemniej wypadało by sprawdzić dlaczego vmtoolsy nie chcą się uruchomić

sebastiank
Posty: 5
Rejestracja: 25 stycznia 2019, 00:12

Re: a start job is running for lsb - no time

Post autor: sebastiank » 25 stycznia 2019, 09:23

jak to zmienic?

Awatar użytkownika
LordRuthwen
Moderator
Posty: 2080
Rejestracja: 18 września 2009, 21:45
Lokalizacja: klikash?

Re: a start job is running for lsb - no time

Post autor: LordRuthwen » 25 stycznia 2019, 09:38

masz systemd czy sysvinit?

sebastiank
Posty: 5
Rejestracja: 25 stycznia 2019, 00:12

Re: a start job is running for lsb - no time

Post autor: sebastiank » 25 stycznia 2019, 09:48

z tego co pamiętam, sysemd

Tylko proszę pamiętaj, że jedyne co mogę robić to grzebanie w grub - e lub c podczas uruchomienia

Awatar użytkownika
dedito
Moderator
Posty: 2971
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: a start job is running for lsb - no time

Post autor: dedito » 25 stycznia 2019, 09:52

A tryb recovery już próbowałeś?

sebastiank
Posty: 5
Rejestracja: 25 stycznia 2019, 00:12

Re: a start job is running for lsb - no time

Post autor: sebastiank » 25 stycznia 2019, 09:55

w trybie przywracania, też zatrzymuje się na tym samym. Próbowałem :)

Awatar użytkownika
LordRuthwen
Moderator
Posty: 2080
Rejestracja: 18 września 2009, 21:45
Lokalizacja: klikash?

Re: a start job is running for lsb - no time

Post autor: LordRuthwen » 25 stycznia 2019, 10:02

No to pozostaje livecd i chroot oraz edycja unita systemd dla obu usług (Before i After)
Tu jest to sensownie opisane: https://fedoramagazine.org/systemd-gett ... -on-units/

sebastiank
Posty: 5
Rejestracja: 25 stycznia 2019, 00:12

Re: a start job is running for lsb - no time

Post autor: sebastiank » 25 stycznia 2019, 10:04

ok czyli tego nie zrobie - bo to VPS w Aruba... :(

------
edit

dostałem się przez dodanie init=/bin/sh teraz szukam gdzie to wyłączyć...


-----
edit

Dla potomnych:

Podczas uruchomienia grub - wciskamy "e"
Przy parametrze gdzie startuje nasz system na końcu linijki jest quiet dopisujemy init=/bin/sh
System wystartuje
wpisujemy: mount -rw -o remount /
następnie: sudo sudo systemctl disable NAME.service
i system w pelni normalnie się uruchomi :)

ODPOWIEDZ