Dovecot - nie działa odbieranie poczty po STARTTLS

Konfiguracja serwerów, usług, itp.
armen10
Posty: 44
Rejestracja: 16 września 2008, 11:02
Lokalizacja: Polska

Dovecot - nie działa odbieranie poczty po STARTTLS

Post autor: armen10 »

Witam, po ostatniej aktualizacji Debiana10 przestał mi działać dovecot... Nie mogę odbierać poczty, ani połączyć się
telnet localhost 995. Bez szyfrowania działa normalnie, ale wcześniej działało, a teraz nawet nie wiem, jak sprawdzić co się zepsuło, bo w logach niby poczta przychodzi i wpada do skrzynki, ale nie mogę jej odebrać.
Czy mógłby mi ktoś z Was pomoc, bardzo proszę... Dzięki z góry
Ostatnio zmieniony 28 października 2020, 11:57 przez armen10, łącznie zmieniany 3 razy.
Awatar użytkownika
LordRuthwen
Moderator
Posty: 2263
Rejestracja: 18 września 2009, 21:45
Lokalizacja: klikash?

Re: Dovecot - nie działa odbieranie poczty po STARTTLS

Post autor: LordRuthwen »

1. Popraw błędy ortograficzne w poprzednim poście bo aż oczy bolą jak się to czyta i wątroba mi ze złości nadgryza płuca... każda przeglądarka podkreśla błędy...
2. W logach niby... a logi gdzie?
3. Po co wklejasz konfigurację postfixa skoro problem masz z dovecotem?
armen10
Posty: 44
Rejestracja: 16 września 2008, 11:02
Lokalizacja: Polska

Re: Dovecot - nie działa odbieranie poczty po STARTTLS

Post autor: armen10 »

@LordRuthwen, ja używał przeglądarki Brave, ona nie podkreśla ;)
PS
Ty to potrafisz człowieka rozszmieszyć :D
Awatar użytkownika
LordRuthwen
Moderator
Posty: 2263
Rejestracja: 18 września 2009, 21:45
Lokalizacja: klikash?

Re: Dovecot - nie działa odbieranie poczty po STARTTLS

Post autor: LordRuthwen »

W logach nic nie ma, mówisz?

Kod: Zaznacz cały

master: Error: service(auth): command startup failed, throttling for 16 secs
Zrestartuj dovecota i wklej logi jakie wypluje po restartcie.
Wklej konfigurację dovecota.
Robiłeś to z jakiegoś poradnika? Jakiego?
armen10
Posty: 44
Rejestracja: 16 września 2008, 11:02
Lokalizacja: Polska

Re: Dovecot - nie działa odbieranie poczty po STARTTLS

Post autor: armen10 »

Skasowałem te kody wyżej, bo widziałem, że ostatnia data była jakoś z marca.
Konfigurację robiłem z różnych źródeł kiedyś...

w związku z tym, że nie mam pliku /var/log/dovecot.log, ani nic podobnego, wrzucam status usługi.
A tak z innej beczki, to cały czas booty próbują się wstrzelić na jakiś login i go przejąć...

Kod: Zaznacz cały

paź 28 11:57:48 xxx.pl dovecot[9546]: pop3-login: Login: user=<loginfirmowy>, method=PLAIN, rip=192.168.1.9, lip=217.153.12.242, mpid=10537, session=<Ha26CLmy5+XAqAEJ>
paź 28 11:57:48 xxx.pl dovecot[9546]: pop3(loginfirmowy)<10537><Ha26CLmy5+XAqAEJ>: Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
paź 28 11:57:48 xxx.pl dovecot[9546]: pop3-login: Login: user=<loginfirmowy>, method=PLAIN, rip=192.168.1.9, lip=217.153.12.242, mpid=10539, session=<ikG9CLmy6OXAqAEJ>
paź 28 11:57:48 xxx.pl dovecot[9546]: pop3(loginfirmowy)<10539><ikG9CLmy6OXAqAEJ>: Disconnected: Logged out top=0/0, retr=1/3994, del=1/1, size=3977
paź 28 11:57:49 xxx.pl dovecot[9546]: pop3-login: Login: user=<loginfirmowy>, method=PLAIN, rip=81.190.116.177, lip=217.153.12.242, mpid=10541, TLS, session=<X3PFCLmyFNBRvnSx>
paź 28 11:57:49 xxx.pl auth[9557]: pam_unix(dovecot:auth): check pass; user unknown
paź 28 11:57:49 xxx.pl auth[9557]: pam_unix(dovecot:auth): authentication failure; logname= uid=0 euid=0 tty=dovecot ruser=wws@xxx.pl rhost=45.142.120.209
paź 28 11:57:49 xxx.pl dovecot[9546]: pop3(loginfirmowy)<10541><X3PFCLmyFNBRvnSx>: Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0
paź 28 11:57:50 xxx.pl auth[10111]: pam_unix(dovecot:auth): check pass; user unknown
paź 28 11:57:50 xxx.pl auth[10111]: pam_unix(dovecot:auth): authentication failure; logname= uid=0 euid=0 tty=dovecot ruser=pinder@xxx.pl rhost=212.70.149.84

Kod: Zaznacz cały

root@proxy:~/scripts# doveconf -n -P
# 2.3.4.1 (f79e8e7e4): /etc/dovecot/dovecot.conf
# Pigeonhole version 0.5.4 ()
# OS: Linux 4.19.0-10-amd64 x86_64 Debian 10.6
# Hostname: xxx.pl

auth_mechanisms = plain login
disable_plaintext_auth = no
mail_location = maildir:~/Maildir
mail_privileged_group = mail
namespace inbox {
  inbox = yes
  location =
  mailbox Drafts {
    special_use = \Drafts
  }
  mailbox Junk {
    special_use = \Junk
  }
  mailbox Sent {
    special_use = \Sent
  }
  mailbox "Sent Messages" {
    special_use = \Sent
  }
  mailbox Trash {
    special_use = \Trash
  }
  prefix =
}
passdb {
  driver = pam
}
plugin {
  sieve = file:~/sieve;active=~/.dovecot.sieve
}
pop3_client_workarounds = outlook-no-nuls oe-ns-eoh
protocols = " imap lmtp pop3"
service auth {
  unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0660
    user = postfix
  }
  user = dovecot
}
service lmtp {
  unix_listener /var/spool/postfix/private/dovecot-lmtp {
    group = postfix
    mode = 0600
    user = postfix
  }
}
service pop3-login {
  inet_listener pop3 {
    port = 110
  }
  inet_listener pop3s {
    port = 995
    ssl = yes
  }
}
service submission-login {
  inet_listener submission {
    port = 587
  }
}
ssl_cert = </etc/ssl/certs/xxx.pl.crt
ssl_client_ca_dir = /etc/ssl/certs
ssl_dh = </usr/share/dovecot/dh.pem
ssl_key = </etc/ssl/private/xxx.pl.key
userdb {
  driver = passwd
}
Awatar użytkownika
LordRuthwen
Moderator
Posty: 2263
Rejestracja: 18 września 2009, 21:45
Lokalizacja: klikash?

Re: Dovecot - nie działa odbieranie poczty po STARTTLS

Post autor: LordRuthwen »

Dovecot w Debianie pisze do daemon.log, chyba, że skonfigurujesz inaczej :P
To twoje logowanie?

Kod: Zaznacz cały

paź 28 11:57:49 xxx.pl auth[9557]: pam_unix(dovecot:auth): check pass; user unknown
paź 28 11:57:49 xxx.pl auth[9557]: pam_unix(dovecot:auth): authentication failure; logname= uid=0 euid=0 tty=dovecot ruser=wws@xxx.pl rhost=45.142.120.209[/code
armen10
Posty: 44
Rejestracja: 16 września 2008, 11:02
Lokalizacja: Polska

Re: Dovecot - nie działa odbieranie poczty po STARTTLS

Post autor: armen10 »

To ktoś się próbuje do mnie włamać...
Do tej pory odbierałem pocztę szyforwaną, a teraz mam komunikat, jak niżej.
Nic nie robiłem. A SSL jest kupiony... Co się mogło zmienić ?

Kod: Zaznacz cały

root@xxx:/etc/postfix# telnet localhost 995
Trying ::1...
Connected to localhost.
Escape character is '^]'.

Kod: Zaznacz cały

Oct 31 19:45:58 xxx dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=217.999.66.223, lip=217.999.66.223, TLS handshaking: SSL_accept() failed: error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown: SSL alert number 46, session=<R/WL7PuyW9LZmQzy>
Aby to jakoś obejść musiałem zrobić to:

Kod: Zaznacz cały

disable_plaintext_auth = no
armen10
Posty: 44
Rejestracja: 16 września 2008, 11:02
Lokalizacja: Polska

Re: Dovecot - nie działa odbieranie poczty po STARTTLS

Post autor: armen10 »

Cześć, chciałbym odkopać temat, bo dzisiaj chciałem sobie podpiąć skrzynkę pod thunderbirda i nie mogę.

Co tu może być nie tak... ? Dziękuję za jakąkolwiek pomoc...
Certyfikaty generowałem sobie sam tymi poleceniami:

Kod: Zaznacz cały

openssl genrsa -des3 -out xxxyyy.pl.key 2048
chmod 600 xxxyyy.key
openssl req -new -key xxxyyy.pl.key -out xxxyyy.pl.csr
openssl x509 -req -days 365 -in xxxyyy.pl.csr -signkey xxxyyy.pl.key -out xxxyyy.pl.crt
openssl x509 -in xxxyyy.pl.crt -out xxxyyy.pl.pem -outform PEM
openssl rsa -in xxxyyy.key -out xxxyyy.pl.key.nopass
mv xxxyyy.pl.key.nopass xxxyyy.pl.key
Oto główny błęd:

Kod: Zaznacz cały

cat /var/log/syslog
May  4 12:27:46 mail dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=my_public_ip, lip=ip_hosta, TLS handshaking: SSL_accept() failed: error:14094416:SSL routines:ssl3_read_bytes:sslv3 alert certificate unknown: SSL alert number 46, session=<8QiMEy3ee/LZmQzy>
disable_plaintext_auth = no - nie pomogło :(


Inne rzeczy configuracyjne:

Kod: Zaznacz cały

root@mail:/etc/dovecot/conf.d# doveconf -n -P
# 2.3.4.1 (f79e8e7e4): /etc/dovecot/dovecot.conf
# Pigeonhole version 0.5.4 ()
# OS: Linux 4.19.0-20-amd64 x86_64 Debian 10.12
auth_mechanisms = plain login
mail_location = mbox:~/mail:INBOX=/var/mail/%u
mail_privileged_group = mail
namespace inbox {
  inbox = yes
  location =
  mailbox Drafts {
    special_use = \Drafts
  }
  mailbox Junk {
    special_use = \Junk
  }
  mailbox Sent {
    special_use = \Sent
  }
  mailbox "Sent Messages" {
    special_use = \Sent
  }
  mailbox Trash {
    special_use = \Trash
  }
  prefix =
}
passdb {
  driver = pam
}
plugin {
  sieve = file:~/sieve;active=~/.dovecot.sieve
}
protocols = " imap pop3"
service auth {
  unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0660
    user = postfix
  }
}
service pop3-login {
  inet_listener pop3 {
    port = 110
  }
  inet_listener pop3s {
    port = 995
    ssl = yes
  }
}
service submission-login {
  inet_listener submission {
    port = 587
  }
}
ssl_cert = </etc/dovecot/ssl/xxxyyy.pl.crt
ssl_client_ca_dir = /etc/ssl/certs
ssl_dh = </usr/share/dovecot/dh.pem
ssl_key = </etc/dovecot/ssl/xxxyyy.pl.key
userdb {
  driver = passwd
}
root@mail:/etc/dovecot/conf.d#

Kod: Zaznacz cały

root@mail:/etc/dovecot/conf.d# cat /var/log/daemon.log
May  4 12:30:54 mail systemd[1]: postfix.service: Succeeded.
May  4 12:30:54 mail systemd[1]: Stopped Postfix Mail Transport Agent.
May  4 12:30:54 mail systemd[1]: Stopping Postfix Mail Transport Agent...
May  4 12:30:54 mail systemd[1]: Stopping Postfix Mail Transport Agent (instance -)...
May  4 12:30:54 mail systemd[1]: Stopping Dovecot IMAP/POP3 email server...
May  4 12:30:54 mail systemd[1]: postfix@-.service: Succeeded.
May  4 12:30:54 mail systemd[1]: Stopped Postfix Mail Transport Agent (instance -).
May  4 12:30:54 mail systemd[1]: Starting Postfix Mail Transport Agent (instance -)...
May  4 12:30:54 mail systemd[1]: Started Postfix Mail Transport Agent (instance -).
May  4 12:30:54 mail systemd[1]: Starting Postfix Mail Transport Agent...
May  4 12:30:54 mail systemd[1]: Started Postfix Mail Transport Agent.
May  4 12:30:55 mail systemd[1]: dovecot.service: Succeeded.
May  4 12:30:55 mail systemd[1]: Stopped Dovecot IMAP/POP3 email server.
May  4 12:30:55 mail systemd[1]: Started Dovecot IMAP/POP3 email server.
root@mail:/etc/dovecot/conf.d#
ODPOWIEDZ