kolory w konsoli przez ssh - katalogów i podfolderów

Ogólne pytania dotyczące systemu
przemekpol
Posty: 17
Rejestracja: 17 maja 2008, 23:59
Lokalizacja: Manchester UK

kolory w konsoli przez ssh - katalogów i podfolderów

Post autor: przemekpol » 08 listopada 2008, 05:38

Witam, małe pytanko, mianowicie miałem wcześniej Centosa i gdy byłem zalogowany przez ssh putty na serwer pokazywało mi kolory danych plików i podkatalogów.
Mam teraz Debiana i wszystkie pliki i podkatalogi są w jednym kolorze białym. Co trzeba zrobić aby system pokazywał różne kolory folderów i podkatalogów?

Lukeman
Posty: 19
Rejestracja: 19 lutego 2008, 23:08

Post autor: Lukeman » 08 listopada 2008, 17:07

Odpowiedź powinieneś znaleźć tutaj: http://debian.linux.pl/viewtopic.php?t= ... +pow%B3oka , a następnym razem wystarczy poszukać na forum

przemekpol
Posty: 17
Rejestracja: 17 maja 2008, 23:59
Lokalizacja: Manchester UK

Post autor: przemekpol » 09 listopada 2008, 22:42

Tak szukałem ale nie wiedziałem pod jakimi słowami kluczowymi może być ujęcie mojego kontekstu, przejrzałem ten link i w systemie znajduje się tylko bash, bashrc. W /etc jedynie działa mi komenda

Kod: Zaznacz cały

ls --color
a nie przy użyciu
A ten opis nic mi nie pomaga http://debian.linux.pl/viewtopic.php?t=10871

Utumno
Beginner
Posty: 432
Rejestracja: 09 listopada 2008, 13:04
Lokalizacja: Gdansk

Post autor: Utumno » 10 listopada 2008, 06:56

Opis z powyzszego watku jest prawidlowy, tylko zapomniano tam dodac, ze zeby to zadzialalo trzeba sie jeszcze wylogowac z systemu i zalogowac spowrotem (plik .bashrc jest czytany tylko przy logowaniu).

fnmirk
Senior Member
Posty: 8037
Rejestracja: 03 grudnia 2007, 06:37

Post autor: fnmirk » 10 listopada 2008, 15:44

Ten link jest na forum w paru wątkach i sprawdza się:
http://night.jogger.pl/2007/02/03/chodz ... ole-linux/

przemekpol
Posty: 17
Rejestracja: 17 maja 2008, 23:59
Lokalizacja: Manchester UK

Post autor: przemekpol » 10 listopada 2008, 21:20

też nie działa kiedy go dodaje i odchaczam wszystko :( wylogowuje sie z ssh i ponownie łącze,
to jest moja orginalna zawartosć pliku bash.bashrc w /etc

Kod: Zaznacz cały

# System-wide .bashrc file for interactive bash(1) shells.

# To enable the settings / commands in this file for login shells as well,
# this file has to be sourced in /etc/profile.

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, overwrite the one in /etc/profile)
#PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '

# Commented out, don't overwrite xterm -T "title" -n "icontitle" by default.
# If this is an xterm set the title to user@host:dir
#case "$TERM" in
#xterm*|rxvt*)
#    PROMPT_COMMAND='echo -ne "\033]0;${USER}@${HOSTNAME}: ${PWD}\007"'
#    ;;
#*)
#    ;;
#esac

# enable bash completion in interactive shells
#if [ -f /etc/bash_completion ]; then
#    . /etc/bash_completion
#fi



Utumno
Beginner
Posty: 432
Rejestracja: 09 listopada 2008, 13:04
Lokalizacja: Gdansk

Post autor: Utumno » 11 listopada 2008, 11:45

Masz dodac

Kod: Zaznacz cały

# enable color support of ls and also add handy aliases
if [ "$TERM" != "dumb" ]; then
    eval "`dircolors -b`"
    alias ls='ls --color=auto'
    #alias dir='ls --color=auto --format=vertical'
    #alias vdir='ls --color=auto --format=long'
fi
do pliku .bashrc w SWOIM KATALOGU DOMOWYM a nie w /etc, wylogowac sie i zalogowac spowrotem.

ODPOWIEDZ