Strona 1 z 1

MiniDLNA - problem z uruchomieniem.

: 24 lutego 2019, 10:50
autor: kpietrek
Witajcie

Zainstalowałem miniDLNA skonfigurowałem i uruchomiłem:

Kod: Zaznacz cały

pietrek@Asus-LAN:~$ sudo service minidlna status
● minidlna.service - LSB: minidlna server
   Loaded: loaded (/etc/init.d/minidlna; generated; vendor preset: enabled)
   Active: active (running) since Sun 2019-02-24 10:38:11 CET; 5s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 3729 ExecStop=/etc/init.d/minidlna stop (code=exited, status=0/SUCCESS)
  Process: 3775 ExecStart=/etc/init.d/minidlna start (code=exited, status=0/SUCCESS)
    Tasks: 2 (limit: 4915)
   CGroup: /system.slice/minidlna.service
           └─3785 /usr/sbin/minidlnad -f /etc/minidlna.conf -P /run/minidlna/minidlna.pid

lut 24 10:38:11 Asus-LAN.example.com systemd[1]: Starting LSB: minidlna server...
lut 24 10:38:11 Asus-LAN.example.com systemd[1]: Started LSB: minidlna server.
Czy coś jest nie tak bo w sieci nadal go nie widzę.

Na routerze mam uruchomione UPnP. Przekierowane porty na tcp 8200 i udp 1900 na ten port IP. A może czegoś mi brakuje??
Podpowiecie co może być nie tak i co sprawdzić??
Mój system to Debian 9.

Re: MiniDLNA - problem z uruchomieniem.

: 24 lutego 2019, 13:50
autor: dedito
A firewall?

Re: MiniDLNA - problem z uruchomieniem.

: 24 lutego 2019, 14:23
autor: kpietrek
Coś takiego wpisałem do firewalla:

Kod: Zaznacz cały

iptables -A INPUT -p tcp -m tcp -s 10.1.1.0/24 --dport 8200 -j ACCEPT
iptables -A INPUT -p udp -m udp -s 10.1.1.0/24 --dport 1900 -j ACCEPT
iptables -A INPUT -i eth1 -s 0.0.0.0/32 -d 224.0.0.1/32 -p igmp -j ACCEPT
iptables -A INPUT -i eth1 -d 239.0.0.0/8 -p igmp -j ACCEPT
Już wiem zauważyłem, że po restarcie te wpisy znikają. Więc muszę powalczyć z iptables.

Jakieś pomysły?

Re: MiniDLNA - problem z uruchomieniem.

: 24 lutego 2019, 17:07
autor: dedito
A co tu wymyślać, ustawić firewall i tyle.
Poradnik stary ale jary. https://wiki.debian.org/DebianFirewall

Re: MiniDLNA - problem z uruchomieniem.

: 24 lutego 2019, 17:09
autor: marcin1982
W tych regułach masz dwa razy podany port 8200, choć może to tylko pomyłka przy podawaniu na forum. Ma być też port 1900/udp.

Co do ustawień iptables "na stałe", zajrzyj:
https://wiki.debian.org/iptables .

Re: MiniDLNA - problem z uruchomieniem.

: 25 lutego 2019, 13:47
autor: kpietrek
marcin1982 pisze:
24 lutego 2019, 17:09
W tych regułach masz dwa razy podany port 8200, choć może to tylko pomyłka przy podawaniu na forum. Ma być tez port 1900/udp.

Co do ustawieniach iptables "na stałe", zajrzyj:
https://wiki.debian.org/iptables .
Działa.
Dziękuję za pomoc.