ATI - otwarte i zamknięte sterowniki

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
dawideo
Beginner
Posty: 141
Rejestracja: 25 czerwca 2007, 11:46
Lokalizacja: Zbychowo

Post autor: dawideo » 28 lipca 2007, 15:15

Witam
Czy otwarte sterowniki są odrazu zainstalowane z systemem czy muszę je jakoś doinstalować?? Bo jak wpisuje

Kod: Zaznacz cały

glxinfo | grep direct
to wyskakuje mi

Kod: Zaznacz cały

bash: glxinfo: command not found
Więc nie wiem o co chodzi:/

Awatar użytkownika
darkwater
Junior Member
Posty: 828
Rejestracja: 25 stycznia 2007, 14:01
Lokalizacja: Częstochowa

Post autor: darkwater » 28 lipca 2007, 15:39

otwarte sterowniki są instalowane razem ze środowiskiem graficznym (przeważnie). polecenie glxinfo jest w pakiecie mesa-utils - zainstaluj go

Kod: Zaznacz cały

aptitude update
aptitude install mesa-utils

kret
Posty: 18
Rejestracja: 22 lipca 2007, 23:05
Lokalizacja: in±d

Post autor: kret » 28 lipca 2007, 17:17

hmm..no to może ja też dodam swoje trzy grosze ;) ostatnio się przesiadłem na lennego no i przyznam, że nie żałuje ;) netinstall i potem wszystko spokojnie z apt ;) no i fajnie, dałem szansę gnome, ale jednak nie wytrzymałem :P no i wróciło kde :) w kompie siedzi zakurzona już nieco karta Ati Radeon 9100 ;) z którą to zawsze miałem problemy..czy to na FreeBSD, czy na Kubuntu no i początkowo na Debianie też :) no ale dzięki naprawdę świetnemu wsparciu stąd, instalacja sterów zamkniętych poszła bez problemu, nie było potrzebne męczenie któregoś z forumowiczów czy coś ;) no ale uznałem, ze chyba jednak wolę stery otwarte :) now więc biorąc pod uwagę, ze coś pokopałem a nie zrobiłem jeszcze nic konkretnego, to poszła kolejna instalka od zera :) no i przyznam..heh..opłaciło się :) stery otwarte śmigają..na samych otwartych miałem 1700-1800 w glxgears..ale ustawiłem wczoraj jaokś AIXGL no i..mam 3000-3600 :) mniamuśnie :) ale w sumie się teraz zastanawiam..czy oprócz ewidentnych zysków wizualno-bajerowych beryl albo compiz jest wart zainstalowania? a jesli tak to który? w sensie beryl, compiz czy może szukac compiz-fusion?

Kaka'
Senior Member
Posty: 3019
Rejestracja: 30 lipca 2006, 13:17
Lokalizacja: Kartuzy

Post autor: Kaka' » 28 lipca 2007, 17:19

darkwater pisze:otwarte sterowniki są instalowane razem ze środowiskiem graficznym (przeważnie).
Wydaje mi się, że się mylisz, bo, z tego co mi wiadomo, sterowniki otwarte są zawarte w jądrze.

Awatar użytkownika
darkwater
Junior Member
Posty: 828
Rejestracja: 25 stycznia 2007, 14:01
Lokalizacja: Częstochowa

Post autor: darkwater » 28 lipca 2007, 19:49

Kaka', mnie wydaje sie że to ty sie mylisz :) sterowniki otwarte do radeonów zawarte są w pakiecie xserver-xorg-video-ati.

Kod: Zaznacz cały

xserver-xorg-video-ati - X.Org X server -- ATI display driver

Kaka'
Senior Member
Posty: 3019
Rejestracja: 30 lipca 2006, 13:17
Lokalizacja: Kartuzy

Post autor: Kaka' » 28 lipca 2007, 20:22

Nie no, ja słyszałem, że za to jądro odpowiada - podczas konfiguracji jądra można też wybrać czy chce się używać otwartych sterów (chyba, o ile dobrze pamiętam).

//edit

Ale chyba była już kiedyś dyskusja na ten temat...

Trzeba jakoś rozstrzygnąć kto ma rację... ;)

Awatar użytkownika
darkwater
Junior Member
Posty: 828
Rejestracja: 25 stycznia 2007, 14:01
Lokalizacja: Częstochowa

Post autor: darkwater » 28 lipca 2007, 20:28

co do wyboru podczas konfiguracji jądra to imo wybiera sie czy sterowniki nie-gpl będą mogły być używane. sam sterownik jak zapewne wiesz wybiera sie podczas konfiguracji xorg. a rozstrzygnąć spór można przy pomocy rzutu monetą :D

offspring
Posty: 4
Rejestracja: 09 sierpnia 2007, 22:47

pomocy

Post autor: offspring » 09 sierpnia 2007, 23:05

witam

próbowałem już wszystkiego ale nie mogę zmusić do szybszego działania swojej karty.
Próbowałem na jednych sterownikach (fglrx) drugich (ati) ale przy tescie:

Kod: Zaznacz cały

tower:~/kasacja$ glxgears -printfps
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
1335 frames in 5.0 seconds = 266.894 FPS
1523 frames in 5.4 seconds = 280.719 FPS
1527 frames in 5.4 seconds = 282.481 FPS
mój komputer osiąga marne rezultaty.

Mam podłączony do karty graficznej monitor i telewizor. Pamięci na karcie jest chyba 128MB a sprzęt to Sempron 2500+, 2.5GB RAM.




zainstalowane pakiety:

Kod: Zaznacz cały

tower:~# dpkg -l | grep video-ati
ii  xserver-xorg-video-ati           6.6.3-2                         X.Org X server -- ATI display driver

Kod: Zaznacz cały

tower:~# dpkg -l | grep mesa
ii  libgl1-mesa-dev                  6.5.1-0.6                       A free implementation of the OpenGL API -- G
ii  libgl1-mesa-dri                  6.5.1-0.6                       A free implementation of the OpenGL API -- D
ii  libgl1-mesa-glx                  6.5.1-0.6                       A free implementation of the OpenGL API -- G
ii  libglu1-mesa                     6.5.1-0.6                       The OpenGL utility library (GLU)
ii  libglu1-mesa-dev                 6.5.1-0.6                       The OpenGL utility library -- development su
ii  mesa-common-dev                  6.5.1-0.6                       Developer documentation for Mesa
ii  mesa-utils                       6.3.2-2.1                       Miscellaneous Mesa GL utilities
ii  xlibmesa-dri                     7.1.0-16                        transitional package for Debian etch
rc  xlibmesa-gl                      4.3.0.dfsg.1-14sarge3           Mesa 3D graphics library [XFree86]
ii  xlibmesa-glu                     7.1.0-16                        transitional package for Debian etch  

Kod: Zaznacz cały

tower:~# uname -a
Linux tower 2.6.18-3-k7 #1 SMP Mon Dec 4 17:23:11 UTC 2006 i686 GNU/Linux

Kod: Zaznacz cały

tower:~# lspci | grep ATI
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R350 [Radeon 9800]
01:00.1 Display controller: ATI Technologies Inc Radeon R350 [Radeon 9800] (Secondary)

Kod: Zaznacz cały

tower:~# cat /etc/X11/xorg.conf
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"dri"
	Load	"int10"
	Load	"record"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"pl"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"ImPS/2"
EndSection

Section "Device"
	Identifier	"ATI Technologies Inc Radeon R350 [Radeon 9800]"
	Driver		"ati"
#	Driver		"fglrx"
	BusID		"PCI:1:0:0"
	Option		"UseFBDev"		"true"
	Screen		0
EndSection

Section "Device"
	Identifier	"ATI Technologies Inc Radeon R350 [Radeon 9800]2"
	Driver		"ati"
#	Driver		"fglrx"
	BusID		"PCI:1:0:0"
	Option		"UseFBDev"		"true"
	Screen		1
EndSection

Section "Monitor"
	Identifier	"Philips 190B"
	Option		"DPMS"
EndSection

Section "Monitor"
	Identifier	"Samsung"
	HorizSync	37-60
	VertRefresh	60-75
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Screen tv"
	Device		"ATI Technologies Inc Radeon R350 [Radeon 9800]2"
	Monitor		"Samsung"
	DefaultDepth	24
	SubSection "Display"
		Depth		24
		Modes		"1024x768"
	EndSubSection
EndSection


Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies Inc Radeon R350 [Radeon 9800]"
	Monitor		"Philips 190B"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
Depth		16
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	Screen		"Screen tv" LeftOf "Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	#Option "xinerama" "off"
	Option "clone" "on"
EndSection

Section "DRI"
	Mode	0666
EndSection

Kod: Zaznacz cały

tower:~/kasacja$ glxinfo | grep direct
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
Xlib:  extension "XFree86-DRI" missing on display ":0.0".
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect
direct rendering: No
OpenGL renderer string: Mesa GLX Indirect
Czy ktoś wie dlaczego mi to nie chce zadziałać poprawnie?
Ponadto nie wiem jak zmusić kartę do rozdzielczości 1360x768 na telewizorze (próbowałem wpisać w sekcji Modes ale tv mówi, że nie rozpoznaje takiej rozdzielczości - w dokumentacji napisane jest ze rozpoznaje i na windowsie dziala)
Pozdrawiam,
offspring

LuQ
Posty: 1
Rejestracja: 21 września 2007, 15:23

Post autor: LuQ » 21 września 2007, 15:26

czy otwarte sterowniki beda chodzic pod zintegrowana karta x1250?
jesli nie to czy zainstaluje beryla na sterownikach zamknietych do tej karty?

lootek
Posty: 4
Rejestracja: 17 września 2007, 12:11
Lokalizacja: Kraków

Post autor: lootek » 21 września 2007, 18:02

Czy jest jakakolwiek nadzieja na uruchomienie TV-OUT z Radeona 9200 pod otwartymi ("ati") sterownikami (czy w tym celu muszę się przestawić na zamknięte)? I czy jest możliwość posiadania zainstalowanych sterowników i otwartych, i zamkniętych - i wybierania w zależności od potrzeb za pomocą xorg.conf?

Zablokowany