Brak WIFI hp510

Masz problemy z siecią bądź internetem? Zapytaj tu
nowy2020
Posty: 33
Rejestracja: 04 maja 2020, 18:59

Brak WIFI hp510

Post autor: nowy2020 » 04 maja 2020, 19:06

Witam.
Brakuje mi wifi w takim starym laptopie hp510. Na kablu wszystko dziala, problem jest z wifi.System na ktorym dzialam to Debianedu10 skolelinux. Zakrecilem sie w terminalu i nic mi nie wyszlo. Moze ktos mi pomoc w tym temacie?

Awatar użytkownika
dedito
Moderator
Posty: 3139
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Brak WIFI hp510

Post autor: dedito » 04 maja 2020, 19:27

Pokaż wynik:

Kod: Zaznacz cały

lspci -vk

nowy2020
Posty: 33
Rejestracja: 04 maja 2020, 18:59

Re: Brak WIFI hp510

Post autor: nowy2020 » 06 maja 2020, 19:33

https://pastebin.com/0q6ti9nV

Kod: Zaznacz cały

adminq@q4os-desktop:~$ lspci -vk
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
        Subsystem: Hewlett-Packard Company Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller
        Flags: bus master, fast devsel, latency 0
        Capabilities: <access denied>

00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03) (prog-if 00 [VGA controller])
        Subsystem: Hewlett-Packard Company Mobile 915GM/GMS/910GML Express Graphics Controller
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at d0600000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at 3000 [size=8]
        Memory at c0000000 (32-bit, prefetchable) [size=256M]
        Memory at d0680000 (32-bit, non-prefetchable) [size=256K]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
        Subsystem: Hewlett-Packard Company Mobile 915GM/GMS/910GML Express Graphics Controller
        Flags: bus master, fast devsel, latency 0
        Memory at d0700000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: <access denied>

00:1d.0 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03) (prog-if 00 [UHCI])
        Subsystem: Hewlett-Packard Company 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI
        Flags: bus master, medium devsel, latency 0, IRQ 19
        I/O ports at 3020 [size=32]
        Kernel driver in use: uhci_hcd
        Kernel modules: uhci_hcd

00:1d.7 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03) (prog-if 20 [EHCI])
        Subsystem: Hewlett-Packard Company 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller
        Flags: bus master, medium devsel, latency 0, IRQ 19
        Memory at d0780000 (32-bit, non-prefetchable) [size=1K]
        Capabilities: <access denied>
        Kernel driver in use: ehci-pci
        Kernel modules: ehci_pci

00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3) (prog-if 01 [Subtractive decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=02, subordinate=03, sec-latency=32
        I/O behind bridge: 00002000-00002fff
        Memory behind bridge: d0000000-d05fffff
        Capabilities: <access denied>

00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
        Subsystem: Hewlett-Packard Company 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller
        Flags: bus master, medium devsel, latency 0, IRQ 17
        I/O ports at 3100 [size=256]
        I/O ports at 3200 [size=64]
        Memory at d0781000 (32-bit, non-prefetchable) [size=512]
        Memory at d0782000 (32-bit, non-prefetchable) [size=256]
        Capabilities: <access denied>
        Kernel driver in use: snd_intel8x0
        Kernel modules: snd_intel8x0

00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03) (prog-if 00 [Generic])
        Subsystem: Hewlett-Packard Company 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller
        Flags: bus master, medium devsel, latency 0, IRQ 17
        I/O ports at 3400 [size=256]
        I/O ports at 3500 [size=128]
        Capabilities: <access denied>
        Kernel driver in use: snd_intel8x0m
        Kernel modules: snd_intel8x0m

00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
        Subsystem: Hewlett-Packard Company 82801FBM (ICH6M) LPC Interface Bridge
        Flags: bus master, medium devsel, latency 0
        Kernel driver in use: lpc_ich
        Kernel modules: intel_rng, lpc_ich

00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03) (prog-if 8a [ISA Compatibility mode controller, supports both channels switched to PCI native mode, supports bus mastering])
        Subsystem: Hewlett-Packard Company 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller
        Flags: bus master, medium devsel, latency 0, IRQ 16
        I/O ports at 01f0 [size=8]
        I/O ports at 03f4
        I/O ports at 0170 [size=8]
        I/O ports at 0374
        I/O ports at 3580 [size=16]
        Kernel driver in use: ata_piix
        Kernel modules: ata_piix, ata_generic

02:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
        Subsystem: Hewlett-Packard Company nc6120/nx8220/nw8240
        Flags: medium devsel, IRQ 21
        Memory at d0000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>
        Kernel modules: ipw2200

02:06.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
        Subsystem: Hewlett-Packard Company CB1410 Cardbus Controller
        Flags: bus master, medium devsel, latency 168, IRQ 18
        Memory at d0001000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=02, secondary=03, subordinate=03, sec-latency=176
        Memory window 0: 80000000-83ffffff (prefetchable)
        Memory window 1: 84000000-87ffffff
        I/O window 0: 00002400-000024ff
        I/O window 1: 00002800-000028ff
        16-bit legacy interface ports at 0001
        Capabilities: <access denied>
        Kernel driver in use: yenta_cardbus
        Kernel modules: yenta_socket

02:08.0 Ethernet controller: Intel Corporation PRO/100 VE Network Connection (rev 03)
        Subsystem: Hewlett-Packard Company PRO/100 VE Network Connection
        Flags: bus master, medium devsel, latency 64, IRQ 20
        Memory at d0002000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at 2000 [size=64]
        Capabilities: <access denied>
        Kernel driver in use: e100
        Kernel modules: e100

adminq@q4os-desktop:~$

Awatar użytkownika
dedito
Moderator
Posty: 3139
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Brak WIFI hp510

Post autor: dedito » 06 maja 2020, 20:04

Twoja karta w tych wynikach to:

Kod: Zaznacz cały

02:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
        Subsystem: Hewlett-Packard Company nc6120/nx8220/nw8240
        Flags: medium devsel, IRQ 21
        Memory at d0000000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>
        Kernel modules: ipw2200
Zapewne brakuje firmware.
Pokaż wyniki"

Kod: Zaznacz cały

apt policy

Kod: Zaznacz cały

dmesg | grep -i "error\|warn\|fail"

Kod: Zaznacz cały

rfkill list all
Jak się nie mieszczą na forum to wklej na pastebin.

nowy2020
Posty: 33
Rejestracja: 04 maja 2020, 18:59

Re: Brak WIFI hp510

Post autor: nowy2020 » 07 maja 2020, 18:25

https://pastebin.com/QgSwkG2m

Kod: Zaznacz cały

adminq@q4os-desktop:~$ apt policy
Plików pakietów:
 100 /var/lib/dpkg/status
     release a=now
 500 http://q4os.org/qextrepo buster-libreoffice-cn/main i386 Packages
     release v=1.0,o=q4os.org,a=buster-libreoffice-st,n=buster-libreoffice-cn,l=buster-libreoffice repository,c=main,b=i386
     origin q4os.org
 500 http://q4os.org/qextrepo buster-firefox-cn/main i386 Packages
     release v=1.0,o=q4os.org,a=buster-firefox-st,n=buster-firefox-cn,l=buster-firefox repository,c=main,b=i386
     origin q4os.org
 500 http://ftp.debian.org/debian buster-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=main,b=i386
     origin ftp.debian.org
 500 http://security.debian.org/debian-security buster/updates/non-free i386 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=non-free,b=i386
     origin security.debian.org
 500 http://security.debian.org/debian-security buster/updates/main i386 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=i386
     origin security.debian.org
 500 http://ftp.debian.org/debian buster/non-free i386 Packages
     release v=10.3,o=Debian,a=stable,n=buster,l=Debian,c=non-free,b=i386
     origin ftp.debian.org
 500 http://ftp.debian.org/debian buster/contrib i386 Packages
     release v=10.3,o=Debian,a=stable,n=buster,l=Debian,c=contrib,b=i386
     origin ftp.debian.org
 500 http://ftp.debian.org/debian buster/main i386 Packages
     release v=10.3,o=Debian,a=stable,n=buster,l=Debian,c=main,b=i386
     origin ftp.debian.org
 500 http://q4os.org/qtderepo buster/main i386 Packages
     release v=10.0,o=q4os.org,a=qtde-buster-st,n=buster,l=Q4OS TDE repository,c=main,b=i386
     origin q4os.org
 501 http://q4os.org/q4repo q4os-3-0-cn/main i386 Packages
     release v=3.0,o=q4os.org,a=q4os-3-0-st,n=q4os-3-0-cn,l=q4os-3-0 repository,c=main,b=i386
     origin q4os.org
Przypięte pakiety:
adminq@q4os-desktop:~$
https://pastebin.com/LtSkw6Ru

Kod: Zaznacz cały

adminq@q4os-desktop:~$ dmesg | grep -i "error\|warn\|fail"
[    0.608035] acpi PNP0A08:00: _OSC failed (AE_NOT_FOUND); disabling ASPM
[    5.361971] ACPI Warning: SystemIO range 0x0000000000001028-0x000000000000102F conflicts with OpRegion 0x0000000000001000-0x000000000000103B (\_SB.C002.C003.C085) (20180810/utaddress-213)
[    5.361987] ACPI Warning: SystemIO range 0x0000000000001130-0x000000000000113F conflicts with OpRegion 0x0000000000001100-0x000000000000113B (\_SB.C002.C003.C097) (20180810/utaddress-213)
[    5.361995] ACPI Warning: SystemIO range 0x0000000000001100-0x000000000000112F conflicts with OpRegion 0x0000000000001100-0x000000000000113B (\_SB.C002.C003.C097) (20180810/utaddress-213)
[   17.234192] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[   29.652309] ipw2200 0000:02:04.0: firmware: failed to load ipw2200-bss.fw (-2)
[   29.652317] ipw2200 0000:02:04.0: Direct firmware load for ipw2200-bss.fw failed with error -2
[   29.652591] ipw2200: probe of 0000:02:04.0 failed with error -5
https://pastebin.com/XYHSic7B

Kod: Zaznacz cały

adminq@q4os-desktop:~$ rfkill list all
Command 'rfkill' is available in the following places
 * /sbin/rfkill
 * /usr/sbin/rfkill
The command could not be located because '/sbin:/usr/sbin' is not included in the PATH environment variable.
This is most likely caused by the lack of administrative privileges associated with your user account.
rfkill: command not found
adminq@q4os-desktop:~$

Awatar użytkownika
dedito
Moderator
Posty: 3139
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Brak WIFI hp510

Post autor: dedito » 07 maja 2020, 18:56

Poczytaj:
https://wiki.debian.org/ipw2200
Niby jakieś firmware masz, ale może jakieś porady tam pomogą.
Bylebyś nie mieszał nic z repozytoriami.

nowy2020
Posty: 33
Rejestracja: 04 maja 2020, 18:59

Re: Brak WIFI hp510

Post autor: nowy2020 » 07 maja 2020, 19:28

OK wlasnie zebym nie namieszal, z terminala jak to zainstalowac?Mowimy o tych poleceniach?
# apt-get update
# apt-get install firmware-ipw2x00 wireless-tools

Nic nie zadzialalo, w terminalu nic sie nie dzieje, wpisuje pierwsza komende nic, przy drugiej to samo.

Poczatkowo mialem taki system zainstalowany na tym laptopie https://linuxiarze.pl/distro-q4os/ , pozniej zainstalowalem nakladke do q4os i otrzymalem https://linuxiarze.pl/distro-skolelinux/, glownie programy i teraz nie wiem jak powrocic do q4os.

Jednak coś się stało w konsoli, zamiast # dałem sudo i zaciagneło.Zobacze co dalej.
https://pastebin.com/9TmrWCBK

nowy2020
Posty: 33
Rejestracja: 04 maja 2020, 18:59

Re: Brak WIFI hp510

Post autor: nowy2020 » 10 maja 2020, 18:35

WIFI ZOSTAŁO POSTAWIONE. DZIĘKUJĘ WSZYSTKIM, KTÓRZY MI POMOGLI. TO OTWIERA NOWE ŚWIATŁO NA INNE LAPTOPY, LECIWE.TAM BYŁ PROBLEM Z WIFI A CZESTO ŁĄCZYŁEM SIĘ POPRZEZ KOMÓRKĘ JAKO ROUTER. TERAZ BĘDĘ MÓGŁ SPOKOJNIE POSTAWIĆ Q4OS NA INNYCH LAPTOPACH, CHYBA, ŻE KTOS DORADZI MI JAKI USTAWIĆ LINUKS NA STARYM LAPKU. Q4OS MA BARDO MAŁE WYMAGANIA...

Awatar użytkownika
dedito
Moderator
Posty: 3139
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Brak WIFI hp510

Post autor: dedito » 12 maja 2020, 16:10

Nie wrzeszcz :)
Na nowe problemy załóż nowy wątek.
Ten rozwiązany, zamykam.

Zablokowany