Instalacja PageSpeed mod

Ogólne pytania dotyczące systemu
tonymontana
Posty: 6
Rejestracja: 16 lutego 2020, 21:57

Instalacja PageSpeed mod

Post autor: tonymontana » 15 kwietnia 2020, 21:28

Witam wszystkich,

Chciałbym przyspieszyć działanie stron i próbuję zainstalować moduł PageSpeed https://www.modpagespeed.com/doc/download

Jako, że jestem serwerową lamą, może powiem krok po kroku co robię i gdzie mam jaki błąd.

Najpierw wprowadzam w terminal:

Kod: Zaznacz cały

wget https://dl-ssl.google.com/dl/linux/direct/mod-pagespeed-stable_current_amd64.deb
Mam informację:

Kod: Zaznacz cały

-bash: https://dl-ssl.google.com/dl/linux/direct/mod-pagespeed-stable_current_amd64.deb: No such file or directory
root@s:~# wget https://dl-ssl.google.com/dl/linux/direct/mod-pagespeed-stable_current_amd64.deb
--2020-04-15 21:23:20--  https://dl-ssl.google.com/dl/linux/direct/mod-pagespeed-stable_current_amd64.deb
Resolving dl-ssl.google.com (dl-ssl.google.com)... 74.125.140.93, 74.125.140.190, 74.125.140.136, ...
Connecting to dl-ssl.google.com (dl-ssl.google.com)|74.125.140.93|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 8309240 (7.9M) [application/x-debian-package]
Saving to: 'mod-pagespeed-stable_current_amd64.deb'

mod-pagespeed-stable_current_a 100%[===================================================>]   7.92M  39.3MB/s    in 0.2s    

2020-04-15 21:23:20 (39.3 MB/s) - 'mod-pagespeed-stable_current_amd64.deb' saved [8309240/8309240]
Więc chyba jest ok. Kolejnym krokiem jest wpisanie:

Kod: Zaznacz cały

 dpkg -i mod-pagespeed-stable_current_amd64.deb


I tu mam takie coś:

Kod: Zaznacz cały

(Reading database ... 32347 files and directories currently installed.)
Preparing to unpack mod-pagespeed-stable_current_amd64.deb ...
Unpacking mod-pagespeed-stable (1.13.35.2-r0) over (1.13.35.2-r0) ...
dpkg: dependency problems prevent configuration of mod-pagespeed-stable:
 mod-pagespeed-stable depends on apache2; however:
  Package apache2 is not installed.

dpkg: error processing package mod-pagespeed-stable (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 mod-pagespeed-stable

Co jest nie tak?

Awatar użytkownika
Yampress
Administrator
Posty: 6245
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Re: Instalacja PageSpeed mod

Post autor: Yampress » 16 kwietnia 2020, 07:23

Package apache2 is not installed.
A jaki serwer www masz zainstalowany? Ten moduł działa tylko z apache2

tonymontana
Posty: 6
Rejestracja: 16 lutego 2020, 21:57

Re: Instalacja PageSpeed mod

Post autor: tonymontana » 16 kwietnia 2020, 23:25

Witam,

A jak to dokładnie sprawdzić?

Awatar użytkownika
Yampress
Administrator
Posty: 6245
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Re: Instalacja PageSpeed mod

Post autor: Yampress » 17 kwietnia 2020, 09:03

Kod: Zaznacz cały

root@debian:~# dpkg -l |grep apache2
ii  apache2                       2.4.38-3+deb10u3              amd64        Apache HTTP Server
ii  apache2-bin                   2.4.38-3+deb10u3              amd64        Apache HTTP Server (modules and other binary files)
ii  apache2-data                  2.4.38-3+deb10u3              all          Apache HTTP Server (common files)
ii  apache2-utils                 2.4.38-3+deb10u3              amd64        Apache HTTP Server (utility programs for web servers)
Poza tym wydaj polecenie netstat z odpowiednimi przełącznikami i zobacz jaki serwer nasłuchuje na porcie 80

Widze kolega nie zna elementarnych podstaw , a chce się bawić w serwery...
Z taką wiedzą twój serwer szybko może zostać skompromitowany.

ODPOWIEDZ