Wolne pierwsze uruchomienie Libreoffice - debian testing z KDE

Tematy związane z oprogramowaniem, instalacją, konfiguracją
Awatar użytkownika
Gary58
Posty: 34
Rejestracja: 04 maja 2016, 18:30
Lokalizacja: PL

Wolne pierwsze uruchomienie Libreoffice - debian testing z KDE

Post autor: Gary58 » 11 kwietnia 2020, 15:11

Witam,
Pierwsze uruchomienie libreoffice bardzo wolne wg mnie, około 20 sekund. Kolejne następne już na zalogowanym systemie tylko 3-4 sekundy. Aktualnie jestem na debian testing z kde plasmą. To jedyna rzecz która mnie delikatnie wkurza.
To same libreoffice na opensuse leap czy na kubuntu uruchamia się max do 8-9 sekund.
Sam system działa bardzo szybko, wszystkie inne programy uruchamiają się błyskawicznie.
Libreoffice wersja z debiana testing.
Czy jest jakiś w miarę prosty sposób na zmianę tego.
Dodałem do autostartu na próbę no ale wtedy uruchamia sie po uruchomieniu systemu a tego nie chcę.

Moje dane:

Kod: Zaznacz cały

 System:
  Host: debian Kernel: 5.4.0-4-amd64 x86_64 bits: 64 Desktop: KDE Plasma 5.17.5 
  Distro: Debian GNU/Linux bullseye/sid 
Machine:
  Type: Laptop System: SAMSUNG product: 300E4C/300E5C/300E7C v: 0.1 
  serial: <superuser/root required> 
  Mobo: SAMSUNG model: SAMSUNG_NP1234567890 v: FAB1 
  serial: <superuser/root required> UEFI [Legacy]: Phoenix v: P01RAC 
  date: 03/22/2012 
Battery:
  ID-1: BAT1 charge: 35.5 Wh condition: 35.5/48.8 Wh (73%) 
CPU:
  Topology: Dual Core model: Intel Core i5-3210M bits: 64 type: MT MCP 
  L2 cache: 3072 KiB 
  Speed: 1198 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 1197 2: 1199 3: 1197 
  4: 1196 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
  Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] 
  driver: nouveau v: kernel 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 19.3.3 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k5.4.0-4-amd64 
Network:
  Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k 
  IF: wlp2s0 state: up mac: e8:03:9a:89:e7:88 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
  IF: enp3s0 state: down mac: e8:03:9a:a7:6b:53 
Drives:
  Local Storage: total: 465.76 GiB used: 54.88 GiB (11.8%) 
  ID-1: /dev/sda vendor: Hitachi model: HTS547550A9E384 size: 465.76 GiB 
Partition:
  ID-1: / size: 80.00 GiB used: 5.36 GiB (6.7%) fs: btrfs dev: /dev/sda1 
  ID-2: /home size: 370.83 GiB used: 49.52 GiB (13.4%) fs: ext4 dev: /dev/sda2 
  ID-3: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A gpu: nouveau temp: 29 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 177 Uptime: 12m Memory: 3.63 GiB used: 731.9 MiB (19.7%) Shell: bash 
  inxi: 3.0.38 
{/code]

Awatar użytkownika
saturno
Junior Member
Posty: 694
Rejestracja: 08 lipca 2008, 20:04

Re: Wolne pierwsze uruchomienie Libreoffice - debian testing z KDE

Post autor: saturno » 11 kwietnia 2020, 18:49

Zainteresuj się: prelink i preload

Awatar użytkownika
Gary58
Posty: 34
Rejestracja: 04 maja 2016, 18:30
Lokalizacja: PL

Re: Wolne pierwsze uruchomienie Libreoffice - debian testing z KDE

Post autor: Gary58 » 12 kwietnia 2020, 08:34

Ok. Spróbuję, gdzieś już czytałem o preload. Dam znać.
(W stabilnym z gnome pierwsze uruchomienie około 09-10 sek. )

Awatar użytkownika
Gary58
Posty: 34
Rejestracja: 04 maja 2016, 18:30
Lokalizacja: PL

Re: Wolne pierwsze uruchomienie Libreoffice - debian testing z KDE

Post autor: Gary58 » 12 kwietnia 2020, 18:49

Wróciłem z testing do stable.
Dla mnie stabilny jest wystarczający i mniej kłopotów. Problem z libreoffice został.
W stabilnym mogłem zainstalowac prelink ale preload niestety nie ma kandydata do instalacji. Zainstalowanie prelinka nic nie dało. Z tego co doczytałem się większy efekt dałby preload.
No trudno nie chcę za bardzo grzebać. Drugie i kolejne odpalenie libreofice działa szybko. Z innymi programami nie mam kłopotu. W stabilnym jak dla mnie nie ma tylko funkcji powiększania zdjęć kółkiem myszki co już jak zauważyłem jest w testowym ( jak dla mnie wizualnie nie wnikam w system). Także dzięki za pomoc.
Zastanawia mnie tylko dlaczego w gnome uruchamia się szybko a kde nie?

Awatar użytkownika
Yampress
Administrator
Posty: 6226
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Re: Wolne pierwsze uruchomienie Libreoffice - debian testing z KDE

Post autor: Yampress » 14 kwietnia 2020, 11:11

A próbowałeś uruchomić Libreofice na czystej konfiguracji?
Tzn przenieś na chwile lub zmienić nazwe katalogu konfiguracyjnego Libreoffice?

ODPOWIEDZ