Uszkodzona paczka kodeka gstreamer1.0-plugins

Tematy związane z oprogramowaniem, instalacją, konfiguracją
Awatar użytkownika
etrollo
Posty: 75
Rejestracja: 21 czerwca 2016, 08:56

Uszkodzona paczka kodeka gstreamer1.0-plugins

Post autor: etrollo » 13 sierpnia 2019, 22:07

z konsoli:

Kod: Zaznacz cały

Errors were encountered while processing:
 /tmp/apt-dpkg-install-U4amiN/0421-gstreamer1.0-plugins-base_1.14.4-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
próba naprawienia:

root@root:~# apt --fix-broken install:

Kod: Zaznacz cały

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  dmz-cursor-theme gcj-6-jre-lib gstreamer1.0-plugins-base:i386 iputils-arping libass5 libaudcore3 libaudgui3
  libaudqt0 libaudtag2 libavresample3:i386 libbdplus0 libblkid1:i386 libcapi20-3 libcapi20-3:i386
  libcdparanoia0:i386 libde265-0 libdirectfb-1.2-9 libebur128-1 libegl1-mesa:i386 libexif12:i386
  libfile-copy-recursive-perl libgbm1:i386 libgcab-1.0-0 libgcj-bc libgcj-common libgcj17 libgcr-3-common
  libgd3:i386 libglib2.0-0:i386 libgnome-autoar-common libgom-1.0-common libgphoto2-6:i386
  libgphoto2-port12:i386 libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386 libgtksourceview2.0-0
  libgtksourceview2.0-common libguess1 libidn11:i386 libieee1284-3:i386 liblivemedia57 libmount1:i386
  libmowgli-2-0 libopencv-calib3d2.4v5 libopencv-core2.4v5 libopencv-features2d2.4v5 libopencv-flann2.4v5
  libopencv-highgui2.4-deb0 libopencv-imgproc2.4v5 libopencv-objdetect2.4v5 libopencv-video2.4v5
  libopenmpt-modplug1 liborc-0.4-0:i386 libpgm-5.2-0 librarian0 libsac-java-gcj libsane:i386
  libsane-extras:i386 libsdl2-2.0-0:i386 libsmpeg0 libsodium18 libspeexdsp1:i386 libtbb2 libtwolame0:i386
  libudev1:i386 libusb-1.0-0:i386 libv4l-0:i386 libv4lconvert0:i386 libvisual-0.4-0:i386 libvte-common libvte9
  libwavpack1:i386 libwayland-client0:i386 libwayland-cursor0:i386 libwayland-egl1-mesa:i386
  libwayland-server0:i386 libwebp6:i386 libwebpmux2:i386 libx264-148 libx264-148:i386 libx265-95
  libx265-95:i386 libxcb-xfixes0:i386 libxfont1 libxkbcommongstreamer1.0-plugins-base (version 1.10.4-1+deb9u1) will be upgraded to version 1.14.4-20:i386 libxpm4:i386 libxss1:i386 libzmq5
  python-gobject python-requests python-twisted-web python-urllib3 rarian-compat tcpd wine-stable
  wine-stable-amd64 wine-stable-i386:i386 xfce4-mount-plugin
Use 'apt autoremove' to remove them.
The following additional packages will be installed:
  gstreamer1.0-plugins-base
The following packages will be upgraded:
  gstreamer1.0-plugins-base
1 upgraded, 0 newly installed, 0 to remove and 1198 not upgraded.
1370 not fully installed or removed.
Need to get 0 B/1791 kB of archives.
After this operation, 522 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Reading changelogs... Done
Setting up liblz4-1:amd64 (1.8.3-1) ...
Setting up liblzma5:amd64 (5.2.4-1) ...E: /var/cache/apt/archives/gstreamer1.0-plugins-base_1.14.4-2_amd64.deb: trying to overwrite '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstaudiomixer.so', which is also in package gstreamer1.0-plugins-bad:amd64 1:1.10.4-dmo2
Setting up libmount1:amd64 (2.33.1-0.1) ...
(Reading database ... 382658 files and directories currently installed.)
Preparing to unpack .../gstreamer1.0-plugins-base_1.14.4-2_amd64.deb ...
Unpacking gstreamer1.0-plugins-base:amd64 (1.14.4-2) over (1.10.4-1+deb9u1) ...
dpkg: error processing archive /var/cache/apt/archives/gstreamer1.0-E: /var/cache/apt/archives/gstreamer1.0-plugins-base_1.14.4-2_amd64.deb: trying to overwrite '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstaudiogstreamer1.0-plugins-base (version 1.10.4-1+deb9u1) will be upgraded to version 1.14.4-2mixer.so', which is also in package gstreamer1.0-plugins-bad:amd64 1:1.10.4-dmo2plugins-base_1.14.4-2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstaudiomixer.so', which is also in package gstreamer1.0-plugins-bad:amd64 1:1.10.4-dmo2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/gstreamer1.0-plugins-base_1.14.4-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
z Synaptic
You have 2 broken packages on your system!
- próba naprawienia przez Fix Broken Packages:

- robi to:

Kod: Zaznacz cały

gstreamer1.0-plugins-base (version 1.10.4-1+deb9u1) will be upgraded to version 1.14.4-2
i wychodzi mu taki błąd:

Kod: Zaznacz cały

E: /var/cache/apt/archives/gstreamer1.0-plugins-base_1.14.4-2_amd64.deb: trying to overwrite '/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstaudiomixer.so', which is also in package gstreamer1.0-plugins-badgstreamer1.0-plugins-base (version 1.10.4-1+deb9u1) will be upgraded to version 1.14.4-2:amd64 1:1.10.4-dmo2

Awatar użytkownika
dedito
Moderator
Posty: 2912
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Uszkodzona paczka kodeka gstreamer1.0-plugins

Post autor: dedito » 14 sierpnia 2019, 11:41

To efekt repozytorii multimedia.
Paczka gstreamer1.0-plugins-base znajduje się w repozyroriach Debiana i Deb-Multimedia.
https://packages.debian.org/buster/gstr ... ugins-base
http://www.deb-multimedia.org/dists/sta ... ugins-base
Posiadanie w bazie paczek repozytorii mutimedia powoduje czasem takie sytuacje.
Przydałby się wynik

Kod: Zaznacz cały

apt policy
i wynik

Kod: Zaznacz cały

apt policy nazwa_paczki
i informacja co właściwie chcesz zrobić.

ODPOWIEDZ