[+] Buster a autostart firewall-a

Ogólne pytania dotyczące systemu
ziomal
Posty: 27
Rejestracja: 11 lutego 2017, 11:26

[+] Buster a autostart firewall-a

Post autor: ziomal » 13 lipca 2019, 17:14

Witam,
jak w Buster z LXDE dodać firewall do autostaru?
W Stretch plik firewall umieszczłem w /etc/init.d i następnie w:
Menu programów->Preferencje->Usługi zaznaczałem pozycję firewall i restartowałem system.
W Buster po aktualizacji z Stretch brak jest pozycji Usługi podobnie jak w nowej instalacji Buster.
Czy (i jak) w Buster wykonuje się to wchodząc w:
Menu programów->Preferencje->Domyślne programy dla LXSession->Autostart
W Stretch pozycja firewall była widoczna natomiast w Buster mam jej brak.
Jak wizualnie sprawdzić czy firewall jest uruchomiony i działa?

pozdrawiam
Ostatnio zmieniony 14 lipca 2019, 15:04 przez ziomal, łącznie zmieniany 1 raz.

Awatar użytkownika
dedito
Moderator
Posty: 2949
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Buster a autostart firewall-a

Post autor: dedito » 13 lipca 2019, 17:23

https://wiki.debian.org/DebianFirewall
https://wiki.debian.org/nftables
SystemD | firewall.service

Most Debian distributions now include systemd. In order to bring up the iptable rules using systemd at start:

Create a new file using any reasonable file text editor(I called mine firewall.service)

# vim.tiny /etc/systemd/system/firewall.service

Then add the following:

[Unit]
Description=Add Firewall Rules to iptables

[Service]
Type=oneshot
ExecStart=/etc/firewall/enable.sh
#ExecStart=/etc/firewall/enable6.sh #For IPV6

[Install]
WantedBy=multi-user.target

Then enable the service:

# systemctl enable firewall.service

Awatar użytkownika
Yampress
Administrator
Posty: 6149
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Re: Buster a autostart firewall-a

Post autor: Yampress » 14 lipca 2019, 13:08

Dedito ale zapomnialeś dodać, że do pliku skryptu

Kod: Zaznacz cały

/etc/firewall/enable.sh
trzeb dodać jeszcze reguły firewall


ja robie to prościej
viewtopic.php?f=28&t=33751
O ile /etc/rc.local mamy skonfigurowany w systemd do uruchamiania

ziomal
Posty: 27
Rejestracja: 11 lutego 2017, 11:26

Re: Buster a autostart firewall-a

Post autor: ziomal » 14 lipca 2019, 15:00

Dziękuję Panowie za pomoc i naprowadzenie w temacie.
Chyba poprawnie ogarnąłem problem czego efektem jest:
root@pecet:/home/ziomal# systemctl status firewall
● firewall.service - firewall
Loaded: loaded (/etc/systemd/system/firewall.service; enabled; vendor preset: enabled)
Active: active (exited) since Sun 2019-07-14 13:23:09 CEST; 1h 14min ago
Main PID: 500 (code=exited, status=0/SUCCESS)
Tasks: 0 (limit: 4677)
Memory: 0B
CGroup: /system.slice/firewall.service

lip 14 13:23:09 pecet systemd[1]: Started firewall.
lip 14 13:23:09 pecet firewall[500]: Starting firewall
Pozdrawiam

Awatar użytkownika
Yampress
Administrator
Posty: 6149
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Re: Buster a autostart firewall-a

Post autor: Yampress » 14 lipca 2019, 15:04

Tak nas razie Ci sie uruchamia. Teraz dodaj swoje reguły firewalla aby to wszystko poprawnie działało

ziomal
Posty: 27
Rejestracja: 11 lutego 2017, 11:26

Re: [+] Buster a autostart firewall-a

Post autor: ziomal » 14 lipca 2019, 16:36

W celu uzupełnienia dodam jeszcze że w Buster polecenie:

Kod: Zaznacz cały

iptables -L
daje błąd:
bash: iptables: nie znaleziono polecenia
Naprawa polega na dodaniu do pliku ~/.bashrc UŻYTKOWNIKA, nie roota wpisu:

Kod: Zaznacz cały

export PATH="$PATH:/usr/sbin"
jak już wcześniej zauważył kolega marcin1982 w temacie:
viewtopic.php?f=18&t=35487&sid=b64be7bc ... 20#p198200
Brak tego wpisu może również stanowić przeszkodę przy instalacji innych programów.
Osobiście również bez tego wpisu nie mogłem zainstalować Notepadqq.

Awatar użytkownika
dedito
Moderator
Posty: 2949
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: [+] Buster a autostart firewall-a

Post autor: dedito » 14 lipca 2019, 19:22

iptables jest w /usr/sbin to nie dziwne, że i użytkownik nie może tego uruchomić, bo to nie jest narzędzie dla zwykłego użytkownika.
Nie rozumiem po co dodawać tą ścieżkę dla zwykłego użytkownika, przez lata jej nie było, więc po co teraz?

rc.local dalej stosuje u siebie na firewallu, no ale, że mamy systemd to podałem ścieżki do obecnych trendów.

ziomal
Posty: 27
Rejestracja: 11 lutego 2017, 11:26

Re: [+] Buster a autostart firewall-a

Post autor: ziomal » 14 lipca 2019, 19:41

Wyjaśnienie co do
iptables jest w /usr/sbin to nie dziwne, że i użytkownik nie może tego uruchomić, bo to nie jest narzędzie dla zwykłego użytkownika.
Nie rozumiem po co dodawać tą ścieżkę dla zwykłego użytkownika,
właśnie polecenie iptables wykonywane z uprawnieniami roota skutkowało takim błędem a oprócz tego brak dodania w/w kodu autorstwa marcin1982 do .bashrc uniemożliwiało instalację Notepadqq.
Pozdrawiam

Awatar użytkownika
dedito
Moderator
Posty: 2949
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: [+] Buster a autostart firewall-a

Post autor: dedito » 14 lipca 2019, 20:53

Skoro dodajesz ścieżkę do bieżącego użytkownika to co ma do tego konto root?
Może po prostu popełniasz powszechny błąd przejścia na roota?
Gwarantuję Ci, że bez problemu zainstaluje ten notepadqq bez dodawania tej ścieżki.

ziomal
Posty: 27
Rejestracja: 11 lutego 2017, 11:26

Re: [+] Buster a autostart firewall-a

Post autor: ziomal » 15 lipca 2019, 10:13

Istotnie, bez modyfikacji pliku ".bashrc" jako root czyli "su -" polecenie "iptables -L" się wykonuje, możliwe że również instalacja Notepadqq.
Przy okazji zwrócę na to uwagę jeśli wystąpi podobny problem.
Jeszcze raz dziękuję za okazaną pomoc.

Zablokowany