[+] Buster nie działaja komendy

Pomoc dotycząca instalacji systemu
ww71
Beginner
Posty: 390
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

[+] Buster nie działaja komendy

Post autor: ww71 » 07 lipca 2019, 18:58

Witam,
Zainstalowałem nowego debiana 10. Tak jak zwykle robiłem, wgrałem:

Kod: Zaznacz cały

wicd
wgrałem

Kod: Zaznacz cały

firmware-iwlwifi
do mojej karty wifi
odinstalowałem

Kod: Zaznacz cały

network-manager
Przeładowałem system i nie działają komendy:

Kod: Zaznacz cały

iwconfig
reboot
shutdown -h now
Nie wiem co robić? Proszę o wskazówki.
Ostatnio zmieniony 07 lipca 2019, 20:33 przez ww71, łącznie zmieniany 1 raz.

Awatar użytkownika
dedito
Moderator
Posty: 2912
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Buster nie działaja komendy

Post autor: dedito » 07 lipca 2019, 19:39

Przestaw się na systemd lub doinstaluj systemd-sysv, aby mieć te komendy (oprócz iwconfig)
Zamiast `reboot` wykonuj `systemctl reboot`
Zamiast `shutdown` wykonuj `systemctl poweroff`
Swoją drogą czemu nie korzystasz z narzędzie zamykania/restartowania systemu dostarczanymi razem ze środowiskiem graficznym?

iwconfig dalej powinno być, prawdopodobnie nie masz zainstalowane `wireless-tools`

ww71
Beginner
Posty: 390
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: Buster nie działaja komendy

Post autor: ww71 » 07 lipca 2019, 19:45

Kod: Zaznacz cały

# sudo apt-get install systemd-sysv
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
systemd-sysv is already the newest version (241-5).
Jak przejść na systemd?

Awatar użytkownika
dedito
Moderator
Posty: 2912
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Buster nie działaja komendy

Post autor: dedito » 07 lipca 2019, 20:01

Systemd już masz, miałem na myśli przejście na komendy systemctl

systemd-sysv zainstalowane więc pliki shutdown i reboot masz, pewnie coś źle robisz.
W takich przypadkach potrzebne szczegółowe informacje. Podejrzewam, że nie robisz to jako root lub nieprawidłowo na niego przechodzisz.

ww71
Beginner
Posty: 390
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: Buster nie działaja komendy

Post autor: ww71 » 07 lipca 2019, 20:13

Wiem, że te komendy wykonuje się jako root:

Kod: Zaznacz cały

# reboot
bash: reboot: nie znaleziono polecenia
Wifi już zainstalowałem.

Awatar użytkownika
dedito
Moderator
Posty: 2912
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Buster nie działaja komendy

Post autor: dedito » 07 lipca 2019, 20:18

No to pokaż/napisz jak przechodzisz na roota.

P.S. Szczegółowe informacje!

ww71
Beginner
Posty: 390
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: Buster nie działaja komendy

Post autor: ww71 » 07 lipca 2019, 20:22

Kod: Zaznacz cały

ww@debian:~$ su
Hasło: 
root@debian:/home/ww#

Awatar użytkownika
dedito
Moderator
Posty: 2912
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Buster nie działaja komendy

Post autor: dedito » 07 lipca 2019, 20:25

Od jakiegoś czasu przechodzi się poprzez

Kod: Zaznacz cały

su -
Poszukaj w swojej skrzynce lub na google informacji na ten temat. Znajdziesz tam też informację na temat jak przywrócić "oldstyle" tej komendy.

ww71
Beginner
Posty: 390
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

Re: Buster nie działaja komendy

Post autor: ww71 » 07 lipca 2019, 20:32

OK. Dziękuję.

Awatar użytkownika
dedito
Moderator
Posty: 2912
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: [+] Buster nie działaja komendy

Post autor: dedito » 07 lipca 2019, 20:35

Czyli OK. Zamykam.

Zablokowany