Wielki problem z paczka perla

Problemy dotyczące innych systemów operacyjnych
banan291
Posty: 20
Rejestracja: 15 marca 2017, 21:07

Wielki problem z paczka perla

Post autor: banan291 » 21 października 2018, 00:05

Siema, zainstalowalem sobie Nethuntera w Termux'ie (musialem tak bo nie moge miec roota na p10 gdyz huawei juz nie daje kodow do odblokowania bootloadera) i mam WIELKI problem. Chcialem zaaktualizowac system wiec wpisalem "apt-get upgrade" i wywala mi blad odnosnie paczki perla, wiec wpisalem "apt --fix-broken install i dalej to samo :

Kod: Zaznacz cały

root@localhost:~# apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
libperl5.26 perl-modules-5.26
The following packages will be upgraded:
libperl5.26 perl-modules-5.26
2 upgraded, 0 newly installed, 0 to remove and 292 not upgraded.
3 not fully installed or removed.
Need to get 0 B/6,279 kB of archives.
After this operation, 378 kB of additional disk space will be used.
Do you want to continue? [Y/n]
(Reading database ... 47007 files and directories currently installed.)
Preparing to unpack .../perl-modules-5.26_5.26.2-7_all.deb ...
Unpacking perl-modules-5.26 (5.26.2-7) over (5.26.0-8) ...
dpkg: error processing archive /var/cache/apt/archives/perl-modules-5.26_5.26.2-7_all.deb (--unpack):
unable to install new version of './usr/share/perl/5.26.2/pod': File exists
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../libperl5.26_5.26.2-7+b1_arm64.deb ...
Unpacking libperl5.26:arm64 (5.26.2-7+b1) over (5.26.0-8) ...
dpkg: error processing archive /var/cache/apt/archives/libperl5.26_5.26.2-7+b1_arm64.deb (--unpack):
unable to install new version of './usr/lib/aarch64-linux-gnu/perl/5.26.2/sys': File exists
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/perl-modules-5.26_5.26.2-7_all.deb
/var/cache/apt/archives/libperl5.26_5.26.2-7+b1_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Wie ktos jak to naprawic bo mecze sie z tym juz 3 dzien...

Moderowano: używaj znaczników kodu

Awatar użytkownika
dedito
Moderator
Posty: 2624
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Wielki problem z paczka perla

Post autor: dedito » 21 października 2018, 07:34

Przed upgrade robi się update.
Pokaż:

Kod: Zaznacz cały

apt-cache policy perl
oraz

Kod: Zaznacz cały

apt-cache policy

banan291
Posty: 20
Rejestracja: 15 marca 2017, 21:07

Re: Wielki problem z paczka perla

Post autor: banan291 » 21 października 2018, 09:49

Nie wytrzymalem i zrobilem reinstalacje, teraz to samo z libpam-runtime...
root@localhost:~# apt-cache policy libpam-runtime libpam-runtime:
Installed: 1.1.8-3.6 Candidate: 1.1.8-3.8
Version table: 1.1.8-3.8 500
500 http://http.kali.org/kali kali-rolling/main arm64 Packages *** 1.1.8-3.6 100 100 /var/lib/dpkg/status root@localhost:~# apt-cache policy Package files: 100 /var/lib/dpkg/status release a=now 500 http://http.kali.org/kali kali-rolling/non-free arm64 Packages release o=Kali,a=kali-rolling,n=kali-rolling,c=non-free,b=arm64 origin http.kali.org 500 http://http.kali.org/kali kali-rolling/contrib arm64 Packages release o=Kali,a=kali-rolling,n=kali-rolling,c=contrib,b=arm64 origin http.kali.org 500 http://http.kali.org/kali kali-rolling/main arm64 Packages release o=Kali,a=kali-rolling,n=kali-rolling,c=main,b=arm64 origin http.kali.org Pinned packages:

Awatar użytkownika
marcin1982
Moderator
Posty: 1703
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Wielki problem z paczka perla

Post autor: marcin1982 » 21 października 2018, 10:16

Co to jest za system w końcu? Debian, Ubuntu, Kali czy wszystko naraz?
and 292 not upgraded.
System nie jest zaktualizowany:

Kod: Zaznacz cały

# apt-get update && apt-get dist-upgrade

banan291
Posty: 20
Rejestracja: 15 marca 2017, 21:07

Re: Wielki problem z paczka perla

Post autor: banan291 » 21 października 2018, 12:07

Kod: Zaznacz cały

etting up libc6:arm64 (2.27-6) ...
Installing new version of config file /etc/ld.so.conf.d/aarch64-linux-gnu.conf ...                          Checking for services that may need to be restarted...
Checking init scripts...                                                                                    Nothing to restart.
(Reading database ... 22502 files and directories currently installed.)
Preparing to unpack .../libc-bin_2.27-6_arm64.deb ...
Unpacking libc-bin (2.27-6) over (2.24-8) ...
Setting up libc-bin (2.27-6) ...
Updating /etc/nsswitch.conf to current default.
(Reading database ... 22502 files and directories currently installed.)                                     Preparing to unpack .../debconf-i18n_1.5.69_all.deb ...
Unpacking debconf-i18n (1.5.69) over (1.5.60) ...                                                           Preparing to unpack .../debconf_1.5.69_all.deb ...
Unpacking debconf (1.5.69) over (1.5.60) ...
dpkg: warning: symbolic link '/usr/share/bash-completion/completions/debconf-show' size has changed from 18 to 7
Setting up debconf (1.5.69) ...
(Reading database ... 22483 files and directories currently installed.)
Preparing to unpack .../0-libtext-iconv-perl_1.7-5+b5_arm64.deb ...                                         Unpacking libtext-iconv-perl (1.7-5+b5) over (1.7-5+b3) ...
Preparing to unpack .../1-libtext-charwidth-perl_0.04-7.1_arm64.deb ...                                     Unpacking libtext-charwidth-perl (0.04-7.1) over (0.04-7+b3) ...
Preparing to unpack .../2-perl_5.26.2-7+b1_arm64.deb ...
Unpacking perl (5.26.2-7+b1) over (5.24.1-1) ...
dpkg: warning: symbolic link '/usr/share/doc/perl/Changes.gz' size has changed from 18 to 12
dpkg: warning: symbolic link '/usr/share/man/man1/perlthanks.1.gz' size has changed from 18 to 12
Selecting previously unselected package perl-modules-5.26.
Preparing to unpack .../3-perl-modules-5.26_5.26.2-7_all.deb ...                                            Unpacking perl-modules-5.26 (5.26.2-7) ...
dpkg: error processing archive /tmp/apt-dpkg-install-4dPTPm/3-perl-modules-5.26_5.26.2-7_all.deb (--unpack): unable to install new version of './usr/share/perl/5.26.2/pod': File exists
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Selecting previously unselected package libgdbm6:arm64.
Preparing to unpack .../4-libgdbm6_1.18-2_arm64.deb ...
Unpacking libgdbm6:arm64 (1.18-2) ...
Selecting previously unselected package libgdbm-compat4:arm64.                                              Preparing to unpack .../5-libgdbm-compat4_1.18-2_arm64.deb ...
Unpacking libgdbm-compat4:arm64 (1.18-2) ...                                                                Selecting previously unselected package libperl5.26:arm64.
Preparing to unpack .../6-libperl5.26_5.26.2-7+b1_arm64.deb ...
Unpacking libperl5.26:arm64 (5.26.2-7+b1) ...
dpkg: error processing archive /tmp/apt-dpkg-install-4dPTPm/6-libperl5.26_5.26.2-7+b1_arm64.deb (--unpack):
 unable to install new version of './usr/lib/aarch64-linux-gnu/perl/5.26.2/sys': File exists
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)                                        Preparing to unpack .../7-perl-base_5.26.2-7+b1_arm64.deb ...
Unpacking perl-base (5.26.2-7+b1) over (5.24.1-1) ...
Errors were encountered while processing:
 /tmp/apt-dpkg-install-4dPTPm/3-perl-modules-5.26_5.26.2-7_all.deb                                           /tmp/apt-dpkg-install-4dPTPm/6-libperl5.26_5.26.2-7+b1_arm64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@localhost:~#

Awatar użytkownika
dedito
Moderator
Posty: 2624
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Wielki problem z paczka perla

Post autor: dedito » 21 października 2018, 16:46

To jest, kolego, forum Debiana, nie Kali.
Przenoszę.
Jakieś ucięte wyniki.
Wklejaj pełne, razem z komendą wywołującą.

ODPOWIEDZ