[+]Debian 9 Stretch nie widzi TL-WN821N (adapter wifi) Temat rozwiązany

Masz problemy z siecią bądź internetem? Zapytaj tu
kimoki
Posty: 18
Rejestracja: 10 grudnia 2017, 16:33

[+]Debian 9 Stretch nie widzi TL-WN821N (adapter wifi)

Post autor: kimoki » 25 sierpnia 2018, 11:56

Hej,

mam zainstalowanego Debiana obok Windowsa, na windzie adapter wifi działa bez problemu i niestety tylko na windzie. Adapter podłączony do USB powinien mi się świecić i tak jest na windzie, na Debianie w ogóle nie reaguje, system również nie widzi żadnych sieci WIFI.

Próbowałem zainstalować sterowniki firmware atheros za pomocą serwerów lustrzanych, lecz system krzyczał mi, że nie może znaleźć takich pakietów, w końcu zainstalowałem je za pomocą managera synaptics.

Próbowałem skorzystać z pomocy zawartej w tym temacie: viewtopic.php?t=27135 jednak terminal nie rozpoznaje polecenia iwlist. Jestem laikiem i nie mam już kompletnie pomysłów na skonfigurowanie tego urządzenia. Obecnie ciągne internet po kablu z telefonu.

Proszę o pomoc. Jeżeli potrzebne są jakieś logi, proszę o informacje w jaki sposób je wygenerować i niezwłocznie je tutaj wrzucę.

EDIT: Zainstalowałem narzędzia i teraz wykrywa mi polecenie iwlist.

Kod: Zaznacz cały

iwlist wlan0 scanning
wyrzuca:

Kod: Zaznacz cały

wlan0     Interface doesn't support scanning.

Kod: Zaznacz cały

iwconfig: lo        no wireless extensions.

enp0s20u13  no wireless extensions.

enp3s0    no wireless extensions.

Kod: Zaznacz cały

ifconfig: enp0s20u13: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.42.21  netmask 255.255.255.0  broadcast 192.168.42.255
        inet6 fe80::6e4e:1d09:32aa:c22  prefixlen 64  scopeid 0x20<link>
        ether c2:8e:d8:08:34:81  txqueuelen 1000  (Ethernet)
        RX packets 24450  bytes 26377888 (25.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 17305  bytes 4202358 (4.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp3s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether fc:aa:14:04:09:1f  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 2248  bytes 253335 (247.3 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2248  bytes 253335 (247.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Moderowano:Używaj znaczników kodu do prezentowania wyników z terminala/konsoli.

Awatar użytkownika
dedito
Moderator
Posty: 2623
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Debian 9 Stretch nie widzi TL-WN821N (adapter wifi)

Post autor: dedito » 25 sierpnia 2018, 13:01

Wrzuć wynik:

Kod: Zaznacz cały

lsusb
następnie:

Kod: Zaznacz cały

dmesg | grep -i "error\|warn\|fail"

kimoki
Posty: 18
Rejestracja: 10 grudnia 2017, 16:33

Re: Debian 9 Stretch nie widzi TL-WN821N (adapter wifi)

Post autor: kimoki » 25 sierpnia 2018, 13:08

Kod: Zaznacz cały

root@debian:/home/kimoki/WIFI_Driver/Driver# lsusb
Bus 004 Device 002: ID 8087:8001 Intel Corp. 
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 8087:8009 Intel Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 020: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 004: ID 1a2c:0027 China Resource Semico Co., Ltd 
Bus 001 Device 003: ID 04d9:a070 Holtek Semiconductor, Inc. 
Bus 001 Device 009: ID 2717:ff80  
Bus 001 Device 021: ID 2357:0107  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Kod: Zaznacz cały

root@debian:/home/kimoki/WIFI_Driver/Driver# dmesg | grep -i "error\|warn\|fail"
[    2.074487] EXT4-fs (sdb5): re-mounted. Opts: errors=remount-ro
[    2.984213] r8169 0000:03:00.0: firmware: failed to load rtl_nic/rtl8168e-3.fw (-2)
[    2.984235] r8169 0000:03:00.0: Direct firmware load for rtl_nic/rtl8168e-3.fw failed with error -2
[ 5473.616819] usb 1-6: device descriptor read/64, error -110
[ 5473.992832] usb 1-6: device descriptor read/64, error -71
[ 5474.636842] usb 1-6: device descriptor read/64, error -71
[ 5475.012853] usb 1-6: device descriptor read/64, error -71
Pogrzebałem trochę i poinstalowałem między innymi IWIFI i teraz powyższa komenda wyrzuca mi jedynie:

Kod: Zaznacz cały

[    2.038631] EXT4-fs (sdb5): re-mounted. Opts: errors=remount-ro
Mam wrażenie, że system nie widzi, żeby urządzenie w ogóle było podłączone do portu USB. Próbowałem z różnymi portami, jednak bez skutku.

Awatar użytkownika
dedito
Moderator
Posty: 2623
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Debian 9 Stretch nie widzi TL-WN821N (adapter wifi)

Post autor: dedito » 25 sierpnia 2018, 13:55

Adapter jest widziany pod ID 2357:0107 co możesz sobie potwierdzić poprzez lsusb przy wyciągniętym adapterze.
Wynik wskazuje że posiadasz kartę TP-LINK TL-WN821N v5
, która jak wynika z podlinkowanej strony jest na chipie realteka RTL8192EU, który jest wspierany przez firmware-realtek

Spróbuj więc jako root zainstalować:

Kod: Zaznacz cały

apt install firmware-realtek
Możesz też sprawdzić na samym Windowsie w menadżerze urządzeń jak tam jest ta karta (konkretnie jej chip) identyfikowana czy jako atheros czy jako realtek.

kimoki
Posty: 18
Rejestracja: 10 grudnia 2017, 16:33

Re: Debian 9 Stretch nie widzi TL-WN821N (adapter wifi)

Post autor: kimoki » 25 sierpnia 2018, 14:10

Kod: Zaznacz cały

root@debian:/opt# sudo apt install firmware-realtek
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
firmware-realtek is already the newest version (20161130-3).
Dziwne, na samym urządzeniu jest napisane, że jest to V6.

Wciąż nie zmieniło się nic.

Awatar użytkownika
dedito
Moderator
Posty: 2623
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Debian 9 Stretch nie widzi TL-WN821N (adapter wifi)

Post autor: dedito » 25 sierpnia 2018, 14:19

Potwierdź czy to ID, które namierzyłem dotyczy tego adaptera.
Spróbuj zainstalować paczkę z backportów

kimoki
Posty: 18
Rejestracja: 10 grudnia 2017, 16:33

Re: Debian 9 Stretch nie widzi TL-WN821N (adapter wifi)

Post autor: kimoki » 25 sierpnia 2018, 14:30

Potwierdzam, po wyciągnięciu urządzenia z portu usb, komenda lsusb nie widzi więcej ID 2357:0107.

Wywaliłem też przed chwilą z systemu firmware-atheros, a zostawiłem samo realtek, żeby wykluczyć ewentualne kolidowanie ze sobą oprogramowania. Niestety zarządzanie siecią ciągle nie widzi sieci wifi.

kimoki
Posty: 18
Rejestracja: 10 grudnia 2017, 16:33

Re: Debian 9 Stretch nie widzi TL-WN821N (adapter wifi)

Post autor: kimoki » 25 sierpnia 2018, 15:02

Odinstalowałem poprzedni pakiet realtek i pobrałem ten, który zlinkowałeś. Efekt bez zmian, podsyłam nowe logi:

Kod: Zaznacz cały

root@debian:/home/kimoki# iwlist wlan0 scanning
wlan0     Interface doesn't support scanning.

Kod: Zaznacz cały

root@debian:/home/kimoki# iwconfig
lo        no wireless extensions.

enp3s0    no wireless extensions.

enp0s20u13  no wireless extensions.

Kod: Zaznacz cały

root@debian:/home/kimoki# ifconfig
enp0s20u13: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.42.21  netmask 255.255.255.0  broadcast 192.168.42.255
        inet6 fe80::628d:1996:57d7:856d  prefixlen 64  scopeid 0x20<link>
        ether c2:8e:d8:08:34:81  txqueuelen 1000  (Ethernet)
        RX packets 1070  bytes 936732 (914.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1028  bytes 313658 (306.3 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp3s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether fc:aa:14:04:09:1f  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 244  bytes 17156 (16.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 244  bytes 17156 (16.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Kod: Zaznacz cały

root@debian:/home/kimoki# dmesg | grep -i "error\|warn\|fail"
[    1.997467] EXT4-fs (sdb5): re-mounted. Opts: errors=remount-ro
Synaptic rownież potwierdza, że zainstalowana wersja to 20180518-1~bpo9+1

Pomyślałem sobie teraz, czy powodem może być możliwość wykrywania przez system, mojej obecnej wbudowanej karty sieciowej, która nie posiada wifi? Co kolidowało by z działaniem adaptera? Jeśli tak, to w jaki sposób mógłbym "wyłączyć" zintegrowaną kartę sieciową, żeby zostawić sam adapter?

Awatar użytkownika
dedito
Moderator
Posty: 2623
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Debian 9 Stretch nie widzi TL-WN821N (adapter wifi)

Post autor: dedito » 25 sierpnia 2018, 15:12

Karta przewodowa z bezprzewodową nie powinna kolidować ale wszystko możliwe.
Wrzuć wynik

Kod: Zaznacz cały

lspci -k
i podaj model komputera.
Najwyżej będziemy próbować instalować tak jak radzi producent tej karty na stronie produktu.

kimoki
Posty: 18
Rejestracja: 10 grudnia 2017, 16:33

Re: Debian 9 Stretch nie widzi TL-WN821N (adapter wifi)

Post autor: kimoki » 25 sierpnia 2018, 15:28

Kod: Zaznacz cały

root@debian:/home/kimoki# lspci -k
00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
	Subsystem: Gigabyte Technology Co., Ltd 4th Gen Core Processor DRAM Controller
	Kernel driver in use: hsw_uncore
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:14.0 USB controller: Intel Corporation 9 Series Chipset Family USB xHCI Controller
	Subsystem: Gigabyte Technology Co., Ltd 9 Series Chipset Family USB xHCI Controller
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci
00:16.0 Communication controller: Intel Corporation 9 Series Chipset Family ME Interface #1
	Subsystem: Gigabyte Technology Co., Ltd 9 Series Chipset Family ME Interface
	Kernel driver in use: mei_me
	Kernel modules: mei_me
00:1a.0 USB controller: Intel Corporation 9 Series Chipset Family USB EHCI Controller #2
	Subsystem: Gigabyte Technology Co., Ltd 9 Series Chipset Family USB EHCI Controller
	Kernel driver in use: ehci-pci
	Kernel modules: ehci_pci
00:1b.0 Audio device: Intel Corporation 9 Series Chipset Family HD Audio Controller
	Subsystem: Gigabyte Technology Co., Ltd 9 Series Chipset Family HD Audio Controller
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 9 Series Chipset Family PCI Express Root Port 1 (rev d0)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.2 PCI bridge: Intel Corporation 9 Series Chipset Family PCI Express Root Port 3 (rev d0)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.3 PCI bridge: Intel Corporation 9 Series Chipset Family PCI Express Root Port 4 (rev d0)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1d.0 USB controller: Intel Corporation 9 Series Chipset Family USB EHCI Controller #1
	Subsystem: Gigabyte Technology Co., Ltd 9 Series Chipset Family USB EHCI Controller
	Kernel driver in use: ehci-pci
	Kernel modules: ehci_pci
00:1f.0 ISA bridge: Intel Corporation 9 Series Chipset Family Z97 LPC Controller
	Subsystem: Gigabyte Technology Co., Ltd 9 Series Chipset Family Z97 LPC Controller
	Kernel driver in use: lpc_ich
	Kernel modules: lpc_ich
00:1f.2 SATA controller: Intel Corporation 9 Series Chipset Family SATA Controller [AHCI Mode]
	Subsystem: Gigabyte Technology Co., Ltd 9 Series Chipset Family SATA Controller [AHCI Mode]
	Kernel driver in use: ahci
	Kernel modules: ahci
00:1f.3 SMBus: Intel Corporation 9 Series Chipset Family SMBus Controller
	Subsystem: Gigabyte Technology Co., Ltd 9 Series Chipset Family SMBus Controller
	Kernel driver in use: i801_smbus
	Kernel modules: i2c_i801
01:00.0 VGA compatible controller: NVIDIA Corporation GM204 [GeForce GTX 970] (rev a1)
	Subsystem: Gigabyte Technology Co., Ltd GM204 [GeForce GTX 970]
	Kernel driver in use: nvidia
	Kernel modules: nvidia
01:00.1 Audio device: NVIDIA Corporation GM204 High Definition Audio Controller (rev a1)
	Subsystem: Gigabyte Technology Co., Ltd GM204 High Definition Audio Controller
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
	Subsystem: Gigabyte Technology Co., Ltd Onboard Ethernet
	Kernel driver in use: r8169
	Kernel modules: r8169
04:00.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 41)
To jest komputer stacjonarny z płytą Gigabyte Z97-HD3, LGA 1150.

Próbowałem instalacji ręcznej zgodnie z installation guide zawartego na stronie tp-link, jednak każda próbwa kończy się błędem jak tu:

Kod: Zaznacz cały

root@debian:/home/kimoki/Pobrane/driver/Driver# sudo make
"******************************************"
"NO SKRC,we will use default KSRC"
"******************************************"
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.9.0-4-amd64/build M=/home/kimoki/Pobrane/driver/Driver  modules
make[1]: Wejście do katalogu '/usr/src/linux-headers-4.9.0-4-amd64'
"******************************************"
"NO SKRC,we will use default KSRC"
"******************************************"
  CC [M]  /home/kimoki/Pobrane/driver/Driver/core/rtw_cmd.o
In file included from /home/kimoki/Pobrane/driver/Driver/include/drv_types.h:95:0,
                 from /home/kimoki/Pobrane/driver/Driver/core/rtw_cmd.c:22:
/home/kimoki/Pobrane/driver/Driver/include/hal_com.h:413:13: error: ‘file_path’ redeclared as different kind of symbol
 extern char file_path[PATH_LENGTH_MAX];
             ^~~~~~~~~
In file included from /usr/src/linux-headers-4.9.0-4-common/include/linux/seq_file.h:10:0,
                 from /usr/src/linux-headers-4.9.0-4-common/include/linux/pinctrl/consumer.h:17,
                 from /usr/src/linux-headers-4.9.0-4-common/include/linux/pinctrl/devinfo.h:21,
                 from /usr/src/linux-headers-4.9.0-4-common/include/linux/device.h:24,
                 from /usr/src/linux-headers-4.9.0-4-common/include/linux/dmaengine.h:20,
                 from /usr/src/linux-headers-4.9.0-4-common/include/linux/netdevice.h:38,
                 from /home/kimoki/Pobrane/driver/Driver/include/osdep_service_linux.h:35,
                 from /home/kimoki/Pobrane/driver/Driver/include/osdep_service.h:41,
                 from /home/kimoki/Pobrane/driver/Driver/include/drv_types.h:32,
                 from /home/kimoki/Pobrane/driver/Driver/core/rtw_cmd.c:22:
/usr/src/linux-headers-4.9.0-4-common/include/linux/fs.h:2729:14: note: previous declaration of ‘file_path’ was here
 extern char *file_path(struct file *, char *, int);
              ^~~~~~~~~
In file included from /home/kimoki/Pobrane/driver/Driver/include/drv_types.h:65:0,
                 from /home/kimoki/Pobrane/driver/Driver/core/rtw_cmd.c:22:
/home/kimoki/Pobrane/driver/Driver/core/rtw_cmd.c: In function ‘btinfo_evt_dump’:
/home/kimoki/Pobrane/driver/Driver/include/rtw_debug.h:187:19: error: void value not ignored as it ought to be
  #define _seqdump seq_printf
                   ^
/home/kimoki/Pobrane/driver/Driver/include/rtw_debug.h:242:7: note: in expansion of macro ‘_seqdump’
    if(_seqdump(sel, fmt, ##arg)) /*rtw_warn_on(1)*/; \
       ^~~~~~~~
/home/kimoki/Pobrane/driver/Driver/core/rtw_cmd.c:3293:2: note: in expansion of macro ‘DBG_871X_SEL_NL’
  DBG_871X_SEL_NL(sel, "cid:0x%02x, len:%u\n", info->cid, info->len);
  ^~~~~~~~~~~~~~~
/home/kimoki/Pobrane/driver/Driver/include/rtw_debug.h:187:19: error: void value not ignored as it ought to be
  #define _seqdump seq_printf
                   ^
/home/kimoki/Pobrane/driver/Driver/include/rtw_debug.h:242:7: note: in expansion of macro ‘_seqdump’
    if(_seqdump(sel, fmt, ##arg)) /*rtw_warn_on(1)*/; \
       ^~~~~~~~
/home/kimoki/Pobrane/driver/Driver/core/rtw_cmd.c:3296:3: note: in expansion of macro ‘DBG_871X_SEL_NL’
   DBG_871X_SEL_NL(sel, "byte2:%s%s%s%s%s%s%s%s\n"
   ^~~~~~~~~~~~~~~
/home/kimoki/Pobrane/driver/Driver/include/rtw_debug.h:187:19: error: void value not ignored as it ought to be
  #define _seqdump seq_printf
                   ^
/home/kimoki/Pobrane/driver/Driver/include/rtw_debug.h:242:7: note: in expansion of macro ‘_seqdump’
    if(_seqdump(sel, fmt, ##arg)) /*rtw_warn_on(1)*/; \
       ^~~~~~~~
/home/kimoki/Pobrane/driver/Driver/core/rtw_cmd.c:3308:3: note: in expansion of macro ‘DBG_871X_SEL_NL’
   DBG_871X_SEL_NL(sel, "retry_cnt:%u\n", info->retry_cnt);
   ^~~~~~~~~~~~~~~
/home/kimoki/Pobrane/driver/Driver/include/rtw_debug.h:187:19: error: void value not ignored as it ought to be
  #define _seqdump seq_printf
                   ^
/home/kimoki/Pobrane/driver/Driver/include/rtw_debug.h:242:7: note: in expansion of macro ‘_seqdump’
    if(_seqdump(sel, fmt, ##arg)) /*rtw_warn_on(1)*/; \
       ^~~~~~~~
/home/kimoki/Pobrane/driver/Driver/core/rtw_cmd.c:3311:3: note: in expansion of macro ‘DBG_871X_SEL_NL’
   DBG_871X_SEL_NL(sel, "rssi:%u\n", info->rssi);
   ^~~~~~~~~~~~~~~
/home/kimoki/Pobrane/driver/Driver/include/rtw_debug.h:187:19: error: void value not ignored as it ought to be
  #define _seqdump seq_printf
                   ^
/home/kimoki/Pobrane/driver/Driver/include/rtw_debug.h:242:7: note: in expansion of macro ‘_seqdump’
    if(_seqdump(sel, fmt, ##arg)) /*rtw_warn_on(1)*/; \
       ^~~~~~~~
/home/kimoki/Pobrane/driver/Driver/core/rtw_cmd.c:3314:3: note: in expansion of macro ‘DBG_871X_SEL_NL’
   DBG_871X_SEL_NL(sel, "byte5:%s%s\n"
   ^~~~~~~~~~~~~~~
/usr/src/linux-headers-4.9.0-4-common/scripts/Makefile.build:301: polecenia dla obiektu '/home/kimoki/Pobrane/driver/Driver/core/rtw_cmd.o' nie powiodły się
make[4]: *** [/home/kimoki/Pobrane/driver/Driver/core/rtw_cmd.o] Błąd 1
/usr/src/linux-headers-4.9.0-4-common/Makefile:1510: polecenia dla obiektu '_module_/home/kimoki/Pobrane/driver/Driver' nie powiodły się
make[3]: *** [_module_/home/kimoki/Pobrane/driver/Driver] Błąd 2
Makefile:150: polecenia dla obiektu 'sub-make' nie powiodły się
make[2]: *** [sub-make] Błąd 2
Makefile:8: polecenia dla obiektu 'all' nie powiodły się
make[1]: *** [all] Błąd 2
make[1]: Opuszczenie katalogu '/usr/src/linux-headers-4.9.0-4-amd64'
Makefile:1696: polecenia dla obiektu 'modules' nie powiodły się
make: *** [modules] Błąd 2

Kod: Zaznacz cały

root@debian:/home/kimoki/Pobrane/driver/Driver# sudo make install
"******************************************"
"NO SKRC,we will use default KSRC"
"******************************************"
install -p -m 644 8192eu.ko  /lib/modules/4.9.0-4-amd64/kernel/drivers/net/wireless/
install: nie można wykonać stat na '8192eu.ko': Nie ma takiego pliku ani katalogu
Makefile:1702: polecenia dla obiektu 'install' nie powiodły się
make: *** [install] Błąd 1
Sterownik, który usiłowałem zainstalować to TL-WN821N(EU)_V5_160315_Linux, jako najaktualniejszy dla linuxa dla urządzenia V5. Wersje z V6 ten sam rezultat.

Próbowałem jakoś rozwiązać ten problem googlując propozycję instalacji sudo apt-get install build-essential linux-headers-generic

Jednak zatrzymałem się tutaj:

Kod: Zaznacz cały

root@debian:/home/kimoki# sudo apt-get install build-essential linux-headers-generic
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Pakiet linux-headers-generic nie ma dostępnej wersji, ale odnosi się do niego inny pakiet.
Zazwyczaj oznacza to, że pakietu brakuje, został zastąpiony przez inny
pakiet lub nie jest dostępny przy pomocy obecnie ustawionych źródeł.

Zablokowany