[+] NeoVim-QT nie działa.

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
WojAbuk
Posty: 36
Rejestracja: 25 stycznia 2015, 10:58

[+] NeoVim-QT nie działa.

Post autor: WojAbuk » 03 sierpnia 2018, 12:55

Przy próbie uruchomienia wyskakuje mi ten komunikat i okienko z identycznym komunikatem.

Kod: Zaznacz cały

jakub@DebKuba:~$ nvim-qt 
jakub@DebKuba:~$ Neovim fatal error "API methods mismatch: Cannot connect to this instance of Neovim, its version is likely too old, or the API has changed"

Nvim w wersji konsolowej działa poprawnie.
Używam Debiana test, wczoraj robiłem pełną aktualizacje szytemu.
Wczoraj pierwszy raz zainstalowałem nvim, bo szukam nakładki graficznej na vi która prezentuje się lepiej niż gvim w środowisku KDE, więc jeśli dostanę propozycję innej ciekawej nakładki też będę wdzięczny.
Mam nadzieję że piszę w dobrym miejscu.
Ostatnio zmieniony 04 sierpnia 2018, 07:46 przez WojAbuk, łącznie zmieniany 1 raz.

Awatar użytkownika
dedito
Moderator
Posty: 2641
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: NeoVim-QT nie działa.

Post autor: dedito » 03 sierpnia 2018, 13:57

A skąd instalowałeś?

WojAbuk
Posty: 36
Rejestracja: 25 stycznia 2015, 10:58

Re: NeoVim-QT nie działa.

Post autor: WojAbuk » 03 sierpnia 2018, 14:51

Za pierwszym razem z repozytorium Debiana.
Potem uruchomiłem ten skrypt
https://codeload.github.com/gist/6e4a19 ... d38e8c6591
Jeśli ma to znaczenie to przed uruchomieniem skryptu nie usunąłem z systemu nvim.

Awatar użytkownika
dedito
Moderator
Posty: 2641
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: NeoVim-QT nie działa.

Post autor: dedito » 03 sierpnia 2018, 20:01

W repozytoriach sid masz nowszą wersję.

WojAbuk
Posty: 36
Rejestracja: 25 stycznia 2015, 10:58

Re: NeoVim-QT nie działa.

Post autor: WojAbuk » 03 sierpnia 2018, 20:10

Proszę poprawić mnie, jeśli się mylę, ale z tego co wiem

Kod: Zaznacz cały

git clone https://github.com/equalsraf/neovim-qt
pobiera kod źródłowy najnowszej wersji NVim, a dalsza część kodu ją instaluje w tym skrypcie ją instaluje.

Awatar użytkownika
dedito
Moderator
Posty: 2641
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: NeoVim-QT nie działa.

Post autor: dedito » 03 sierpnia 2018, 20:48

Zgadza się, ale to co masz w SID być może zawiera już ewentualne poprawki umożliwiające działanie w Debianie.

WojAbuk
Posty: 36
Rejestracja: 25 stycznia 2015, 10:58

Re: NeoVim-QT nie działa.

Post autor: WojAbuk » 03 sierpnia 2018, 21:57

Kod: Zaznacz cały

deb http://httpredir.debian.org/debian/ experimental main
Dodałem powyższy zapis do /etc/apt/sources.list i zaktualizowałem system, brak zmiany.

Awatar użytkownika
dedito
Moderator
Posty: 2641
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: NeoVim-QT nie działa.

Post autor: dedito » 04 sierpnia 2018, 07:31

Nie było potrzeby aktualizować/upgradować cały system, wystarczyło samą paczkę.
Poza tym nie widzę aby ta paczką była w gałęzi experimental.
Może po prostu poczekaj aż problem zostanie rozwiązany w gałęzi testowej.

WojAbuk
Posty: 36
Rejestracja: 25 stycznia 2015, 10:58

Re: [+] NeoVim-QT nie działa.

Post autor: WojAbuk » 04 sierpnia 2018, 07:48

Faktycznie ja czasem mylę gałęzie unstable i experimental.
Zamiana i aktualizacja rozwiązała problem.
Bardzo dziękuje.

Awatar użytkownika
dedito
Moderator
Posty: 2641
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: [+] NeoVim-QT nie działa.

Post autor: dedito » 04 sierpnia 2018, 09:39

Na koniec jeszcze uwaga do httpredir, to już nie funkcjonuje, przekierowuje na deb.debian.org.

Zablokowany