[+]LinuxCNC - problem z instalacją FreeCad

Problemy dotyczące innych systemów operacyjnych
szatri
Posty: 14
Rejestracja: 04 lutego 2018, 22:59

Re: Dobrego złe początki,

Post autor: szatri » 09 lutego 2018, 11:49

Ps czemu mój temat wylądował w "innych systemach", dotyczy przecież debiana 7 a nie jakiś windowsow

Awatar użytkownika
dedito
Moderator
Posty: 2511
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Dobrego złe początki,

Post autor: dedito » 09 lutego 2018, 11:50

Bo to nie jest Debian.

Kod: Zaznacz cały

apt-cache search freecad

szatri
Posty: 14
Rejestracja: 04 lutego 2018, 22:59

Re: Dobrego złe początki,

Post autor: szatri » 09 lutego 2018, 11:55

Kod: Zaznacz cały

root@cnc-lin:/home/cnc# apt-cache search freecad
root@cnc-lin:/home/cnc# 
A jak nie debian to co ja mam w takim razie:

Kod: Zaznacz cały

root@cnc-lin:/home/cnc# lsb_release -a
No LSB modules are available.
Distributor ID:	Debian
Description:	Debian GNU/Linux 7.11 (wheezy)
Release:	7.11
Codename:	wheezy
root@cnc-lin:/home/cnc# 

Awatar użytkownika
dedito
Moderator
Posty: 2511
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Dobrego złe początki,

Post autor: dedito » 09 lutego 2018, 13:26

Ja nie znam tej dystrybucji LinuxCNC.
Widzę, że korzysta z repozytoriów debianowych, ale nie mam pewności czy to nie jest jakiś "mix".
Jak jesteś w stanie dać mi jakieś info potwierdzające, że jest to 100% Debian, to wtedy przeniosę z powrotem do działu Debian.

A wracając do tematu freecad, to nie wiem jak pokazuje Ci się w centrum oprogramowania, bo wyniki poleceń pokazują, że brak repozytoriów z których program można pobrać. Może to centrum oprogramowania działa w oparciu o inną bazę pakietów.

Tak czy inaczej wersja proponowana przez CO jest bardzo stara.

Sama wersja Debiana, którą masz obecnie też jest stara.

Sugerowałbym zaktualizować obecnego "Debiana" do aktualnej wersji stabilnej lub nawet testowej (jeśli nie jest to jakaś ważna maszyna produkcyjna) i zainstalować freecada z repozytoriów Debian. Będzie wtedy w nowszej wersji.

szatri
Posty: 14
Rejestracja: 04 lutego 2018, 22:59

Re: Dobrego złe początki,

Post autor: szatri » 09 lutego 2018, 13:42

Freecad pokazuje mi się w centrum bo uruchamiam plik freecad.deb z dysku poprzez klikniecie na niego i z opcji wybieram uruchom w centrum oprogramowania, identycznie robiłem z teamviewer i to poszło.

Wiem ze to już wiekowa wersja debiana ale jak wspomniałem w 1 poście poległem przy aktualizacji do 9 wersji wiec jak nie muszę tego robić to trzymam się z daleka.
dedito pisze:
09 lutego 2018, 13:26
Jak jesteś w stanie dać mi jakieś info potwierdzające, że jest to 100% Debian, to wtedy przeniosę z powrotem do działu Debian.
Powiedz jak, bo jestem przekonany ze taki jest.

Awatar użytkownika
dedito
Moderator
Posty: 2511
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Dobrego złe początki,

Post autor: dedito » 09 lutego 2018, 14:46

szatri pisze:
09 lutego 2018, 13:42
Freecad pokazuje mi się w centrum bo uruchamiam plik freecad.deb z dysku poprzez klikniecie na niego i z opcji wybieram uruchom w centrum oprogramowania, identycznie robiłem z teamviewer i to poszło.
To niezbyt dobra metoda dla paczek, które mają dużo zależności.
Taka metoda pozbawia Cię też w przyszłości możliwości automatycznych aktualizacji.
Jak instalujesz to rób to z użyciem repozytoriów.
szatri pisze:
09 lutego 2018, 13:42
Wiem ze to już wiekowa wersja debiana ale jak wspomniałem w 1 poście poległem przy aktualizacji do 9 wersji wiec jak nie muszę tego robić to trzymam się z daleka.
W takim razie proponuję zainstalować freecada z repozytoriów wheezy-backports.
Instrukcja jest na poniższej stronie:
https://packages.debian.org/wheezy-back ... d/download
szatri pisze:
09 lutego 2018, 13:42
dedito pisze:
09 lutego 2018, 13:26
Jak jesteś w stanie dać mi jakieś info potwierdzające, że jest to 100% Debian, to wtedy przeniosę z powrotem do działu Debian.
Powiedz jak, bo jestem przekonany ze taki jest.
Informacji szukaj w na stronach i w dokumentacji tej dystrybucji.

Z innej beczki: masz drobne problemy z obecnymi repozytoriami, m.in. zdublowane wpisy.

Awatar użytkownika
saturno
Junior Member
Posty: 661
Rejestracja: 08 lipca 2008, 20:04

Re: Dobrego złe początki,

Post autor: saturno » 09 lutego 2018, 17:37

szatri pisze:
08 lutego 2018, 20:26
... mam już dość tego pingwina, ale ze go potrzebuje do pracy na maszynie to muszę go jakoś zmęczyć, ...
1. Na jakiej konkretnie maszynie?
2. Do czego konkretnie jest ci potrzebny Linux?

szatri
Posty: 14
Rejestracja: 04 lutego 2018, 22:59

Re: Dobrego złe początki,

Post autor: szatri » 09 lutego 2018, 18:31

Repozytorium dodane, widzi freecada, ale krzyczy że uszkodzony pakiet.

Kod: Zaznacz cały

root@cnc-lin:/home/cnc# sudo apt-get install freecad
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 freecad : Wymaga: libsoqt4-20 (>= 1.6) ale 1.5.0-2 ma zostać zainstalowany
           Wymaga: python-pivy (>= 0.5.0~v609hg-2) ale 0.5.0~v609hg-1 ma zostać zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
skasowałem zdublowane wpisy z listy

saturno
1) jest to zwykły pc z prockiem athlon, na kolejnej partycji jest sobie normalny windows
2) A ino do tego https://pl.wikipedia.org/wiki/LinuxCNC , tak wiem jest jeszcze mach3 na winde

Awatar użytkownika
dedito
Moderator
Posty: 2511
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Dobrego złe początki,

Post autor: dedito » 09 lutego 2018, 18:39

Kod: Zaznacz cały

apt-cache policy freecad libsoqt4-20 python-pivy

szatri
Posty: 14
Rejestracja: 04 lutego 2018, 22:59

Re: Dobrego złe początki,

Post autor: szatri » 09 lutego 2018, 18:45

Kod: Zaznacz cały

root@cnc-lin:/home/cnc# apt-cache policy freecad libsoqt4-20 python-pivy
freecad:
  Zainstalowana: (brak)
  Kandydująca:   0.14.3702+dfsg-3~bpo70+1
  Tabela wersji:
     0.14.3702+dfsg-3~bpo70+1 0
        100 http://ftp.de.debian.org/debian/ wheezy-backports/main i386 Packages
libsoqt4-20:
  Zainstalowana: 1.5.0-2
  Kandydująca:   1.5.0-2
  Tabela wersji:
     1.6.0~e8310f-1~bpo70+1 0
        100 http://ftp.de.debian.org/debian/ wheezy-backports/main i386 Packages
 *** 1.5.0-2 0
        500 http://http.debian.net/debian/ wheezy/main i386 Packages
        500 http://http.us.debian.org/debian/ wheezy/main i386 Packages
        100 /var/lib/dpkg/status
python-pivy:
  Zainstalowana: (brak)
  Kandydująca:   0.5.0~v609hg-1
  Tabela wersji:
     0.5.0~v609hg-3~bpo70+1 0
        100 http://ftp.de.debian.org/debian/ wheezy-backports/main i386 Packages
     0.5.0~v609hg-1 0
        500 http://http.debian.net/debian/ wheezy/main i386 Packages
        500 http://http.us.debian.org/debian/ wheezy/main i386 Packages
Coś takiego znalazłem:

Kod: Zaznacz cały

https://www.freecadweb.org/wiki/DebianScript

Zablokowany