Czy warto zaktualizować Debiana do wersji niestabilnej?

Pomoc dotycząca instalacji systemu
rlk120
Posty: 79
Rejestracja: 30 października 2008, 19:10

Post autor: rlk120 » 31 października 2008, 22:12

Pod koniec aktualizacji pojawia się błąd pobierania pliku, pokazuje dwie komendy (apt-get update i jeszcze jakąś) ale żadna nic nie daje.

Nie wiem co zrobić.

Mam wersję Etch (stabilną) i chcę sobie zmienić na niestabilną, nie ściągając całej płyty, więc pomóżcie :)

maly
Beginner
Posty: 289
Rejestracja: 03 lipca 2007, 14:52

Post autor: maly » 01 listopada 2008, 10:35

rlk120 pisze:Pod koniec aktualizacji pojawia się błąd pobierania pliku, pokazuje dwie komendy (apt-get update i jeszcze jakąś) ale żadna nic nie daje.

Nie wiem co zrobić.

Mam wersję Etch (stabilną) i chcę sobie zmienić na niestabilną, nie ściągając całej płyty, więc pomóżcie :)
Może na dobry początek jeśli jeszcze nie jesteś doświadczonym użytkownikiem polecałbym wersje testową ;-) . "Jeszcze jakąś" ?! jaką, wklej. Wpisy w sources.list zmieniłeś?!

pavbaranov
Senior Member
Posty: 2156
Rejestracja: 29 lipca 2007, 18:06

Post autor: pavbaranov » 01 listopada 2008, 11:55

rlk120 pisze:Pod koniec aktualizacji pojawia się błąd pobierania pliku, pokazuje dwie komendy (apt-get update i jeszcze jakąś) ale żadna nic nie daje.
A dokładnie, to co? Przecież z tego wpisu nic nie wynika, bo brzmi on tak: coś się dzieje, pomóżcie.
Na forum jest temat jak zaktualizować debiana do różnych wersji, ale generalnie, cokolwiek by nie było, to zasada winna być taka (bo inaczej się sypie).
Jeśli jest to aktualizacja z Etcha (zresztą z Lenny'ego też), to:
1. zainstalować minimalny system, z którego można podłączyć się do netu, bez żadnych środowisk graficznych itp.
2. edycja pliku sources.list i wpisanie odpowiednich repozytoriów
3. wywołanie apta z dist-upgrade (oczywiście po update)
4. dalsza instalacja wg potrzeb
Takie postępowanie daje najmniejszą możliwość, że coś się wysypie, aczkolwiek pewności nie ma.
rlk120 pisze:chcę sobie zmienić na niestabilną, nie ściągając całej płyty
Jeśli się nie mylę - w chwili obecnej nie istnieje wersja ISO Sida. Kiedyś taki projekt istniał, ale obecnie chyba nikt nie robi czegoś takiego. Przynajmniej nie ze strony "oficjalnych" deweloperów Debiana. Jedyną znaną mi dystrybucją zawierającą repo main Sida i kilka dodatków, ale pochodzącą z określonego momentu jest Sidux. Być może jest to też dla Ciebie najprostrza metoda zainstalowania sobie Sida (no, praktycznie w 95% Sida), zwłaszcza, że Sidux jest liveCD i masz możliwość wypróbowania jego funkcjonalności przed instalacją (oczywiście w granicach main, resztę musisz dociągnąć po zmianach w sources.list). Jeśli tak, to polecam wersję polską z Lin4All.

mateo1990
Posty: 54
Rejestracja: 16 listopada 2008, 15:44

Post autor: mateo1990 » 14 grudnia 2008, 10:51

Musiałem zaznaczyć w ankiecie odpowiedź "nie". A dlaczego?
Otóż już dwie próby aktualizacji mojego systemu do Sida zakończyły się niepowodzeniem, z racji licznie występujących problemów z zależnościami. Dosyć często zdarzało się, że pewien program w repozytorium Sida posiadał pakiety z różnych wersji, co oczywiście uniemożliwiało jego instalację. Zostaję przy Lennym, bo tutaj przynajmniej wszystko działa jak należy.

Kapitalista
Posty: 5
Rejestracja: 14 grudnia 2008, 23:56

Post autor: Kapitalista » 15 grudnia 2008, 00:40

Ja instalowałem system z płytki netinstall, którą uprzednio sobie ściągnąłem z internetu (wersja Etch), ale gdy po pociągnięciu środowiska graficznego ukazała się moim oczom wersja gnome z 2006 roku to trochę zwątpiłem. Zrobiłem więc ponowna instalacja i po instalacji systemu podstawowego podmieniłem wpisy na Lennego. Zaktualizowałem dystrybucję - nie wysypało się nic bo zbyt dużo tam nie było.

Do wersji Sid jednak bym się już nie pofatygował, gdyż nie mam czasu na zabawy z naprawianiem gdy coś się wysypie. Testing jak na razie chodzi bardzo stabilnie :-)

sullivan
Beginner
Posty: 126
Rejestracja: 03 września 2008, 17:07
Lokalizacja: Krosno Odrzańskie

Post autor: sullivan » 20 grudnia 2008, 12:22

Jak ktoś ma problemy na jakimkolwiek wersji Debiana ze sterownikami do grafiki NV i ATI zapraszam tutaj http://debian.linux.pl/viewtopic.php?t=11783 skrypt wymiata jeśli chodzi o grafikę. A odświeżaniem ekranu 50 Hz w ustawieniach pulpitu się nie przejmujcie. Monitor prawdę Ci powie :)

mateo1990
Posty: 54
Rejestracja: 16 listopada 2008, 15:44

Post autor: mateo1990 » 20 grudnia 2008, 12:57

Pokusiłem się jednak o aktualizację do Sida, na szczęście wszystko przebiegło bez problemów i nie spotkałem żadnych problemów z zależnościami jak podczas wcześniejszych prób.

sullivan
Beginner
Posty: 126
Rejestracja: 03 września 2008, 17:07
Lokalizacja: Krosno Odrzańskie

Post autor: sullivan » 20 grudnia 2008, 13:02

mateo1990, byłoby dobrze jakbyś napisał co uczyniłeś podczas aktualizacji do Sida, że nie miałeś z tym problemów, oraz bubli po aktualizacji ;>

mateo1990
Posty: 54
Rejestracja: 16 listopada 2008, 15:44

Post autor: mateo1990 » 20 grudnia 2008, 13:27

[quote="sullivan"][mateo1990, byłoby dobrze jakbyś napisał co uczyniłeś podczas aktualizacji do Sida, że nie miałeś z tym problemów, oraz bubli po aktualizacji ]
Standardowe przejście z Lennego. Nic specjalnego nie robiłem :) Aż sam byłem zaskoczony, że wszystko przebiegło bez żadnych komplikacji.

poliocertes
Posty: 59
Rejestracja: 21 października 2007, 10:27
Lokalizacja: Warszawa

Post autor: poliocertes » 26 grudnia 2008, 17:34

Ja zaktualizowałem. Przynajmniej tak mi się wydawało. Mój plik /etc/apt/sources.list:

Kod: Zaznacz cały

deb [url]ftp://ftp.pl.debian.org/debian/[/url] sid main non-free contrib
deb-src [url]ftp://ftp.pl.debian.org/debian/[/url] sid main non-free contrib 
deb [url]http://www.debian-multimedia.org[/url] sid main
deb-src [url]http://www.debian-multimedia.org[/url] sid main 
deb [url]http://ftp.cz.debian.org/debian/[/url] experimental main contrib non-free
deb-src [url]http://ftp.cz.debian.org/debian/[/url] experimental main contrib non-free 
deb [url]http://download.tuxfamily.org/osrdebian[/url] unstable extra
deb-src [url]http://download.tuxfamily.org/osrdebian[/url] unstable extra
deb [url]http://getswiftfox.com/builds/debian[/url] unstable non-free
Już po:

Kod: Zaznacz cały

aptitude update
i

Kod: Zaznacz cały

aptitude dist-upgrade
Wpisuję polecenie:

Kod: Zaznacz cały

cat /etc/debian_version
I otrzymuje:

Kod: Zaznacz cały

jacek:/home/jacek# cat /etc/debian_version 
5.0
Czy to dobrze? Chyba jednak numer 5 ma Lenny?

ODPOWIEDZ