Czy warto zaktualizować Debiana do wersji niestabilnej?

Pomoc dotycząca instalacji systemu
karaluch
Posty: 2
Rejestracja: 04 lutego 2008, 16:34

Post autor: karaluch » 25 lutego 2008, 11:10

Witam, mam serwer na stabilnych pakietach ale aby musze zainstalowac cupsys w wersji niestabilnej. Dodalem serwery, zrobilem apt-get update, pozniej apt-get -t unstable install cupsys, system pozbyl sie linux-kernel-headers i libopencdk8-dev ale za to chcial zaktualizowac milion pakietow. Problem z tym ze aktualizacja sie na jednek bibliotece zatrzymala bo byl problem z plikem .deb, gdy uruchamiam apt-get -f install dostaje:

Kod: Zaznacz cały

Czytanie list pakietów... Gotowe
Budowanie drzewa zależności... Gotowe
Naprawianie zależności... Gotowe
Następujące pakiety zostaną USUNIÊTE:
  alien binutils debhelper dpkg-dev g++ g++-4.1 g-wrap gcc gcc-4.1 gjdoc gnucash guile-1.6-dev language-env libc6-amd64 libc6-dev
  libcupsimage2-dev libcupsys2-dev libgcrypt11-dev libgl1-mesa-dev libglib2.0-dev libglpng-dev libgnomecups1.0-dev libgnutls-dev
  libgpg-error-dev libgwrap-runtime0-dev libjpeg62-dev liblzo-dev libmudflap0-dev libncurses5-dev libopencdk8-dev libpng12-dev libpopt-dev
  libprinterconf0c2a libprintsys libreadline5-dev libstdc++6-4.1-dev libtiff4-dev libtool locales openoffice.org-help-pl
  openoffice.org-l10n-pl pconf-detect sun-java5-bin sun-java5-fonts sun-java5-jre sun-java5-plugin tdb-dev xlibmesa-gl-dev zlib1g-dev
0 aktualizowanych, 0 nowo instalowanych, 49 usuwanych i 0 nieaktualizowanych.
5 nie w pełni zainstalowanych lub usuniętych.
Konieczne pobranie 0B archiwów.
Po rozpakowaniu zostanie zwolnione 209MB miejsca na dysku.
Czy chcesz kontynuować [T/n]? n
Przerwane.
Wiec padaka, polowe systemu jak nie caly chce mi usunac, POMOCY co z tym fantem teraz zrobic !! ??

Awatar użytkownika
3ndriu
Beginner
Posty: 246
Rejestracja: 15 kwietnia 2007, 18:00
Lokalizacja: Chodzież

Post autor: 3ndriu » 15 marca 2008, 22:03

Ja mam pytanie z nieco innej beczki: ile paczek przybywa średnio dziennie? Chodzi o to, że interesuje mnie aktualizacja do Sida, ale nie widzi mi się za bardzo ściąganie ~100 paczek dziennie (a net mam nie najlepszy i czasem przez 1-2 dni nie korzystam z Debiana, więc uaktualnienia się kumulują). Czy często zdarzają się takie sytuacje, jak znany mi przypadek, gdzie jednego dnia pojawiło się ~2800 paczek?

yantar
Member
Posty: 1225
Rejestracja: 07 czerwca 2007, 21:15
Lokalizacja: Rzeszów

Post autor: yantar » 16 marca 2008, 02:50

3ndriu, bez obaw. 2800 paczek cos mi sie nie bardzo chce w to wierzyc. Jak pamietam to na sidzie to jest kilka, kilnascie paczek dziennie (chyba najwiecej to mialem 240Mb do pobrania po dluzszej przerwie). Oczywiscie paczki, paczkom nierowne. Co innego kilka sporych paczek OpenOffica ( przykladowo 70Mb), a kilkanascie drobnych paczek bibliotek i malych programow na raptem kilka Mb. No i brac poprawke na to, ze ilosc zwieksza sie w zaleznosci od tego co mamy w systemie wiec 5000 nowych paczek nie robi roznicy skoro korzystamy z kilkuset :)

Awatar użytkownika
3ndriu
Beginner
Posty: 246
Rejestracja: 15 kwietnia 2007, 18:00
Lokalizacja: Chodzież

Post autor: 3ndriu » 16 marca 2008, 16:07

Czyli wygląda to podobnie jak w Lennym. Jak znajdę trochę czasu, to chyba się przesiądę. Dzięki yantar.

ObiWan
Posty: 6
Rejestracja: 12 kwietnia 2008, 23:34
Lokalizacja: Wroc³aw

Post autor: ObiWan » 17 kwietnia 2008, 18:01

jestem nowym uzytkownikiem debiana, ale postanowalem przeinstalowac na Sid'a

na koncu isntalacji (przy konfigurowaniu) wywalalo bledy, zrestartowalem kompa ale i tak wywala bledy, jest jakis blad z apletem wyswietlania godziny (wogole sie nie pokazuje godzina) a podczas

Kod: Zaznacz cały

apt-get -f install
pokazuje mi

http://wklej.org/id/94e5c08932

Kod: Zaznacz cały

Czytanie list pakietów... Gotowe
Budowanie drzewa zależności... Gotowe
Naprawianie zależności... Gotowe
Zostaną zainstalowane następujące dodatkowe pakiety:
  deskbar-applet hplip hplip-data libcwidget3 libffi4 libnewt0.52 libnss3-1d
  libperl5.8 libsensors3 libsnmp-base libsnmp15 libvte9 libxapian15 python
  python-dev python-gnome2-extras python-libxml2 python-minimal python-newt
  python-qt3 python-selinux python-sip4 python-vte python-xml
Sugerowane pakiety:
  hplip-doc kdeprint gtklp xpp libcwidget-dev lm-sensors xapian-tools
  python-doc python-tk python-profiler python-gnome2-extras-doc
  libqt3-mt-mysql libqt3-mt-odbc libqt3-mt-psql python-qt3-doc python-qt3-gl
  python-xml-dbg python-xml-doc
Polecane pakiety:
  python-beagle python-soappy hplip-gui openprinting-ppds python-reportlab
  libfribidi0
Następujące pakiety zostaną USUNIÊTE:
  gdebi libcamel1.2-8 libebook1.2-5 libedataserverui1.2-6 libnss3-0d
  python-apt update-manager update-notifier
Zostaną zainstalowane następujące NOWE pakiety:
  libcwidget3 libffi4 libnss3-1d libperl5.8 libsnmp15 libvte9 libxapian15
Następujące pakiety zostaną zaktualizowane:
  deskbar-applet hplip hplip-data libnewt0.52 libsensors3 libsnmp-base python
  python-dev python-gnome2-extras python-libxml2 python-minimal python-newt
  python-qt3 python-selinux python-sip4 python-vte python-xml
17 aktualizowanych, 7 nowo instalowanych, 8 usuwanych i 400 nieaktualizowanych.
44 nie w pełni zainstalowanych lub usuniętych.
Konieczne pobranie 0B/21,5MB archiwów.
Po rozpakowaniu zostanie dodatkowo użyte 7004kB miejsca na dysku.
Czy chcesz kontynuować [T/n]? t
(Odczytywanie bazy danych ... 100696 plików i katalogów obecnie zainstalowanych.)
Przygotowanie do zastąpienia deskbar-applet 2.14.2-4.2 (wykorzystując .../deskbar-applet_2.22.1-1_i386.deb) ...
INFO: using unsupported version '/usr/bin/python2.5'
INFO: using unsupported version '/usr/bin/python2.5'
Traceback (most recent call last):
  File "/usr/bin/pycentral", line 1825, in ?
    main()
  File "/usr/bin/pycentral", line 1819, in main
    rv = action.run(global_options)
  File "/usr/bin/pycentral", line 1283, in run
    requested = pyversions.requested_versions_for_runtime(version_field, version_only=True)
  File "/usr/share/pycentral-data/pyversions.py", line 213, in requested_versions_for_runtime
    raise ValueError, 'empty set of versions'
ValueError: empty set of versions
dpkg: błąd przetwarzania /var/cache/apt/archives/deskbar-applet_2.22.1-1_i386.deb (--unpack):
 podproces pre-installation script zwrócił kod błędu 1
INFO: using unsupported version '/usr/bin/python2.5'
Wystąpiły błędy podczas przetwarzania:
 /var/cache/apt/archives/deskbar-applet_2.22.1-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
co zrobic ? wywala mi bledy z locale itd.

Awatar użytkownika
Mateush
Posty: 40
Rejestracja: 26 kwietnia 2008, 14:01
Lokalizacja: Poznań

Post autor: Mateush » 26 kwietnia 2008, 17:33

Pomimo aktualizacji:

Kod: Zaznacz cały

mateusz@debian:~$ cat /etc/debian_version
4.0
mateusz@debian:~$
Może wina leży w pliku sources.list - pobrało złe pakiety albo cuś?

Kod: Zaznacz cały

mateusz@debian:~$ cat /etc/apt/sources.list
deb [url]ftp://ftp.pl.debian.org/debian/[/url] sid main non-free contrib
deb-src [url]ftp://ftp.pl.debian.org/debian/[/url] sid main non-free contrib

deb [url]http://www.kadu.net/download/binary/debian/repo[/url] testing main

#Backports
deb [url]http://www.backports.org/debian[/url] etch-backports main contrib non-free
EDIT:
Spróbowałem raz jeszcze wywalając z /etc/apt/sources.list wszystko i wklejając dwie linijki:

Kod: Zaznacz cały

debian:/# cat etc/apt/sources.list
deb [url]ftp://ftp.pl.debian.org/debian/[/url] sid main non-free contrib
deb-src [url]ftp://ftp.pl.debian.org/debian/[/url] sid main non-free contrib
debian:/#
Po ponownej próbie:

Kod: Zaznacz cały

debian:/# apt-get update
Traf [url]ftp://ftp.pl.debian.org[/url] sid Release.gpg
Traf [url]ftp://ftp.pl.debian.org[/url] sid Release
Pob: 1 [url]ftp://ftp.pl.debian.org[/url] sid/main Packages/DiffIndex [2038B]
Pob: 2 [url]ftp://ftp.pl.debian.org[/url] sid/non-free Packages/DiffIndex [2023B]
Pob: 3 [url]ftp://ftp.pl.debian.org[/url] sid/contrib Packages/DiffIndex [2023B]
Pob: 4 [url]ftp://ftp.pl.debian.org[/url] sid/main Sources/DiffIndex [2023B]
Pob: 5 [url]ftp://ftp.pl.debian.org[/url] sid/non-free Sources/DiffIndex [2023B]
Pob: 6 [url]ftp://ftp.pl.debian.org[/url] sid/contrib Sources/DiffIndex [2023B]
Pobrano 12,2kB w 2s (4613B/s)
Czytanie list pakietów... Gotowe
debian:/# apt-get dist-upgrade
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności... Gotowe
Obliczanie aktualizacji...Gotowe
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
debian:/#
Z góry dziękuję za pomoc. ;-)

yantar
Member
Posty: 1225
Rejestracja: 07 czerwca 2007, 21:15
Lokalizacja: Rzeszów

Post autor: yantar » 26 kwietnia 2008, 18:25

Probojesz przejsc bezposrednio z Etcha na Sida? Mozesz sobie kuku zrobic w systemie.
Nie uzywasz przypadkiem jakiegos pin-priority da repozytoriow?

Kod: Zaznacz cały

/etc/apt/preferences

Awatar użytkownika
Mateush
Posty: 40
Rejestracja: 26 kwietnia 2008, 14:01
Lokalizacja: Poznań

Post autor: Mateush » 26 kwietnia 2008, 19:06

Więc najpierw mam uaktualnić do Lenny'ego a dopiero później ew. do Sid'a?

Kod: Zaznacz cały

mateusz@debian:~$ cat /etc/apt/preferences
Explanation: Etch
Package: *
Pin: release o=Debian,a=stable
Pin-Priority: 900

Package: *
Pin: origin [url]www.debian-multimedia.org[/url]
Pin-Priority: 600

Package: *
Pin: release a=etch-backports
Pin-Priority: 200

Package: *
Pin: release o=Debian
Pin-Priority: -10
mateusz@debian:~$

yantar
Member
Posty: 1225
Rejestracja: 07 czerwca 2007, 21:15
Lokalizacja: Rzeszów

Post autor: yantar » 26 kwietnia 2008, 19:32

Mateush, pomiedzy pakietami Etcha i Sida jest juz spora roznica w ilosci uaktualnien (w dodatku mozna tak nieszczesliwie trafic na moment ze jakis istotny pakiet w Sidzie zostal dodany ze zlymi zaleznosciami i problem gotowy, zacznie sie mieszanie w aptitude i caly cyrk :) . Jest pewne ryzyko ze cos moze sie porobic. Lepiej na spokojnie przejsc najpierw na Lennego (przynajmniej ja jestem tego zwolennikiem)

Jak widzisz masz ustawiony priorytet na repozytoria Etcha i klepiac zwyczajnie

Kod: Zaznacz cały

aptitude update 
Aptitude bedzie ignorowal aktualizacje z repozytoriow innych wersji. (pobierze je ale nie bedzie wyswietlal)
Musisz dodac pin-priority dla repozytoriow innych wersji i ustawic repozytoria Etcha na nizszy pin-priority. (Lub konkretnie wskazywac aptitude z ktorego repozytorium ma korzystac)
Albo usunac z tego pliku wpisy, wtedy aptitude lub apt defaultowo beda brac i aktualizowac pakiety z najwyzszej wersji repozytoriow jaka znajda.

Np u mnie wyglada to tak

Kod: Zaznacz cały

Package: * 
Pin: release o=Debian,a=testing 
Pin-Priority: 900 

Package: * 
Pin: release o=Debian,a=unstable 
Pin-Priority: 800

Package: * 
Pin: release o=Debian,a=experimental 
Pin-Priority: 700 
Normalnie uzywam aptitude bez parametrow i wszystko leci z repozytoriow testinga. Jak chce cos konkretnie z sida to klepie np

Kod: Zaznacz cały

aptitude install pakiet_ktory_mnie_interesuje/unstable
analogicznie experimental.

Mozna jeszcze robic to na drugi sposob np

Kod: Zaznacz cały

aptitude -t unstable install pakiet_ktory_mnie_interesuje
Wygladaja podobnie, jednak w nieco odmienny sposob traktuja zaleznosci. (ja uzywam pierwszego)

Awatar użytkownika
Mateush
Posty: 40
Rejestracja: 26 kwietnia 2008, 14:01
Lokalizacja: Poznań

Post autor: Mateush » 26 kwietnia 2008, 20:38

Zrobiłem jak mi poleciłeś - wrzuciłem to co zamieściłeś do sources.list i dalem polecenie:
aptitude update
a potem,
aptitude -P dist-upgrade
Zobaczymy, co z tego wyjdzie, oby Lenny. :mrgreen:

ODPOWIEDZ