Czy warto zaktualizować Debiana do wersji niestabilnej?

Pomoc dotycząca instalacji systemu
mlyczek
Junior Member
Posty: 979
Rejestracja: 02 sierpnia 2006, 19:17

Post autor: mlyczek » 30 stycznia 2008, 10:55

witek pisze:Co mam ustawić/doinstalować by po instalacji z netinstall działało poprawnie zamykanie systemu?
witek pisze:dopiero z gdm mogę dać wyłącz.
Zainstaluj gdm.

giaur
Member
Posty: 1915
Rejestracja: 25 maja 2007, 22:16

Post autor: giaur » 30 stycznia 2008, 11:59

To znany problem, tyle ze juz nieaktualny. Chodzi o to, ze jezeli menedzerem logowania jest GDM, wylaczanie komputera dziala tylko w Gnome, jezeli KDM, to tylko w KDE.

Swego czasu pisalem o tym posta na forum. Jednak w Sidzie juz od dawna ten problem zostal zlikwidowany. Trudno powiedziec gdzie byl problem, podejrzewam ze aktualizacja GDM i XFCE powinna załatwic sprawe.

witek
Beginner
Posty: 117
Rejestracja: 16 kwietnia 2007, 12:39
Lokalizacja: Piekary ¦l±skie

Post autor: witek » 30 stycznia 2008, 11:59

Przecież napisałem, że mogę wyłączyć i dać restart z gdm więc po co mam go instalować jak już jest?

Singel
Posty: 18
Rejestracja: 08 stycznia 2008, 18:59
Lokalizacja: Porêba

Post autor: Singel » 30 stycznia 2008, 15:51

Jeżeli chodzi o te bajery to lubie bo jestem eststą.Lubie miec ładny pulpit z paskiem AWN,bo jest bardzo wygodny i compiza.Pnadto fktycznie jesli chce ktoś ogądać stado przesuwających sie linijek, to jego wybór,ale jeśli Linux chce pozyskac wiecej użytkowników,to musi dawać estsetyczny system.W mandrivie jesli chce ktos przy starcie ogladać co się w systemie dzieje to naciska ESC.Mnie nawet wkurza bios.Jesli nie dzieje sie nic niepokojacogo to po co mam to oglądać?Teraz pytanie:Czy jesli zaktalizuje system do Sida to po reinstalacji sterowników będzie wszystko chodziło?Czy np AWN będzie działał na Sidzie?Firma Appl wymysliła bardzo fajne ustrojsto,któr się fajnie uzywa i fajnie wygląda,dlatego wszyscy instalują je nawet na windowsach.Własnie miałem formatować Debiana a tu ten post.Czy mam wywalic wszystkie repozytoria i dodac tylko od Sida?Terza zrobiło mi się tak,ze po zalogowaniu
pokazuje sie logo Nvidii i dopiero po drugim logowaniu system startuje.Mam też Ubuntu 7.10 i wiecie co?Debian nie umywa sie do Ubuntu.Zawsze jednakowo startuje mi system i sie zmyka.

giaur
Member
Posty: 1915
Rejestracja: 25 maja 2007, 22:16

Post autor: giaur » 31 stycznia 2008, 10:02

Chyba masz sporo namieszane w systemie... jezeli instalowales sterowniki do grafiki z repo, to odinstaluj je (z opcja purge), opis jest na tym forum. Pousuwaj tez wszystkie pakiety, ktore trzeba bylo zainstalowac w celu instalacji sterów do grafy (z opcja --purge).

Jezeli z instalatora nvidia to odinstaluj uruchamiajac plik instalacyjny z opcja --uninstall.

Z sources.list usun wszystko oprocz repo sida. Potem apt-get update i apt-get dist-upgrade.
Jezeli ta operacja nie zaktualizuje kernela, zrob to recznie (polecam instalacje kernela z repo, unikniesz problemow z kompilacja i konfiguracja).

Po tym wszyskim powinienes miec Debiana Sid z kernelem bodajże 2.6.23. Zrestartuj system i zainstaluj sterowniki do karty graficznej - polecam tylko i wylacznie instalator ze strony nvidii, sciagnij najnowsza wersje. Zreszta opis tez jest na tym forum.

Masz prawdopodobnie taki bałagan, ze mozliwe ze gdzies po drodze wynikna jakies problemy - ale warto zawsze sprobowac.

P.S. Compiz-fusion sam uzywam, chodzi idealnie ale dopiero odkad mam Sida z najnowszym jądrem i sterowniki oryginalne od nvidii (na tych z repo prawie pewne jest ze compiz nie bedzie dzialac).
Co do wszelkich innych ulepszaczy, zwlaszcza tych dotyczacych bootowania graficznego systemu - moja rada, daruj to sobie. Najprawdopodobniej wlasnie przez takie rzeczy narobiles sobie problemow.

alan666888
Posty: 93
Rejestracja: 12 lutego 2007, 21:03
Lokalizacja: z Neta

Post autor: alan666888 » 06 lutego 2008, 17:17

Po zaktualizowaniu mam problem ponieważ mam dziwną rozdzielczość. Próbowałem zmieniać ale po restarcie powracało. próbowałem dpkg-reconfigure xserver-xorg ale konfiguracja kończy się na opcji emulacji 3 przycisku i nie mogę skonfigurować karty graficznej.
Oto mój xorg.conf

Kod: Zaznacz cały

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"pl"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
EndSection
prosze o pomoc bo juz usuwałem kde, a kde usunęło xorga. Później zainstalowałem na nowo xorga oraz kde 4.0 ale problem pozostał i niewiem co mam robić

yantar
Member
Posty: 1225
Rejestracja: 07 czerwca 2007, 21:15
Lokalizacja: Rzeszów

Post autor: yantar » 06 lutego 2008, 22:02

Sprobuj pod czystym terminalem zrobic rekonfiguracje z parametrem -phigh jak pisze w pliku xorga.

Kod: Zaznacz cały

dpkg-reconfigure -phigh xserver-xorg

giaur
Member
Posty: 1915
Rejestracja: 25 maja 2007, 22:16

Post autor: giaur » 16 lutego 2008, 11:35

Bartek: jaka masz karte graficzna? Instalowales do niej sterowniki? Ja ostatnio narobilem sobie podobnego bałaganu - miałem 4 wersje jądra (w tym 2 kompilowane samodzielnie) i po probie instalacji nastepnego jajka okazalo sie ze xserver w zaden sposob nie chce wstac, tylko single user mode dzialalo.

Pomoglo: wywalnie wszystkich wersji jądra oprocz najnowszej, wywalenie serwera X z wyczyszczeniem konfiguracji. Nastepnie odpalilem juz w trybie normalnym, zainstalowalem serwer X, sterowniki do karty i ruszylo.

lukas
Posty: 51
Rejestracja: 14 czerwca 2007, 14:15
Lokalizacja: Nie pamiêtam

Post autor: lukas » 20 lutego 2008, 13:06

Moim zdaniem nie warto upgradować do Sida. Dlaczego?

Bo:

Podczas upgrade, nie mógł mi skonfigurować n/w paczek:

cupsys i ssl-cert

Mimo, że miałem zainstalowane paczki "xserver-xorg", to system jechał na vesa, a podczas "dpkg-reconfigure xserver-xorg" nie pozwalał mi na wybór sterownika, rozdzielczości, ustalenia pamięci karty graficznej, w sumie to połowy ustawień nie było dostępnych.

Czy ja zrobiłem coś źle? Nie sądzę! Instalowałem Debiana Lenny kilkanaście razy i nigdy nie miałem z nim problemów, tym bardziej w/w ;-)

Lepiej postawić wersję testową i skorzystać z dobrodziejstw apt-pinning.

Edit:

Upgrade do Sida z zainstalowanym: gnome-core, gnome-audio, gdm, X-ami i innymi paczuszkami, rozwalił mi aptitude i apt-get. Nie mogłem już nic zaktualizować i zainstalować.

alan666888
Posty: 93
Rejestracja: 12 lutego 2007, 21:03
Lokalizacja: z Neta

Post autor: alan666888 » 20 lutego 2008, 16:08

ukas miałem to samo i dałem sobie z tym spokój. powróciłem po 5 nieudanych dist-upgradów do lennego.

ODPOWIEDZ