Czy warto zaktualizować Debiana do wersji niestabilnej?

Pomoc dotycząca instalacji systemu
Kaka'
Senior Member
Posty: 3019
Rejestracja: 30 lipca 2006, 13:17
Lokalizacja: Kartuzy

Czy warto zaktualizować Debiana do wersji niestabilnej?

Post autor: Kaka' » 10 kwietnia 2007, 15:20

Czy warto zaktualizować Debiana do wersji niestabilnej (Debian - Sid)?

Na powyższe pytanie postaram się dzisiaj odpowiedzieć.

Jednak zanim to zrobię, musisz poznać poszczególne wersje Debiana.


Wersje Debiana

W Debianie wyróżniamy trzy gałęzie:
- Stabilną (aktualnie Lenny),
- Testową (aktualnie Squeeze),
- Niestabilną (Sid).

Jest jeszcze wersja eksperymentalna (ang. experimental), ale jest to dopełnienie wersji niestabilnej o pakiety, które nie nadają się jeszcze do użytku przez większość ludzi - eksperymentalne wersje jednym słowem.


Debian niestabilny - Sid
Jest to wersja, do której trafiają wszystkie nowo powstałe pakiety i to tutaj rozpoczyna się rozwój dystrybucji, tutaj są wprowadzane zarówno małe poprawki tak jak i duże zmiany. Tak więc znajdują się tu pakiety, które mogą (lecz nie muszą) zawierać jakieś błędny. Jednakże w rzeczywistości pakiety nie stwarzają dużych problemów. Jeśli po upływie jakiegoś czasu w pakiecie nie zostaną wykryte poważniejsze błędy, to pakiet zostaje przeniesiony do wersji testowej.

Debian testowy - Squeeze
Tu znajdują się pakiety z wersji niestabilnej, więc są już dość przetestowane i nie stwarzają żadnych poważniejszych problemów. Pakiety są dość aktualne,a co jakiś czas wersja ta zostaje zamrożona, co oznacza że zostaje wstrzymane przenoszenie pakietów, które normalnie by trafiły tutaj z wersji niestabilnej. Po zamrożeniu cała wersja przechodzi gruntowne testy, pod względem stabilności i integralności, (dlatego nie trafiają tu pakiety z Sida bo nowe pakiety mogą zachwiać stabilność) i po zaliczeniu tych testów zamrożona wersja testowa staje się nową wersją stabilną. No i znowu wersja testowa zostaje otwarta.

Debian stabilny - Lenny
Ta wersja nie jest już rozwijana (jedynie są dodawane łaty bezpieczeństwa), ponieważ jej rozwój mógłby osłabić stabilność. W związku z tym wersja ta jest prawdę powiedziawszy przestarzała, ale za to bardzo stabilna i dlatego nadaje się idealnie na serwery, gdzie najważniejsza jest stabilność, oraz na zwykłe desktopy - jeżeli cenisz sobie stabilność.


Debian niestabilny (Sid) - czy warto?

Jak już wiesz, Debian Sid jest niestabilny. Jednakże nie bierz sobie dosłownie tego słowa. Wbrew pozorom Sid jest bardzo stabilny. Używam go od około pół roku - od tego czasu ani razu nie zdarzyła się żadna awaria, czy coś w tym stylu. Dlaczego? Ponieważ deweloperzy Debiana to doświadczeni ludzie i znają się na swojej robocie jak mało kto. Odważę się nawet stwierdzić, że Debian Sid jest stabilniejszy niż jakieś stabilne Suse, Fedora, Mandriva i inne.
Dodatkowo mając Sida na pokładzie, będziesz miał prawie najnowsze pakiety (prawie, bo jest jeszcze wersja eksperymentalna). Aktualnie w Debianie niestabilnym jest około 20300 oficjalnych pakietów + nieoficjalne. Razem to czyni pokaźny zbiór pakietów. Zyskujesz najnowsze wersje pakietów, co też jest w większości przypadków bezpieczniejsze - im nowsze, tym lepsze i bezpieczniejsze.

Kolejną zaletą Sida jest to, że tam trafiają paczki prawie codziennie - tu nie ma czegoś takiego jak w Debian testowym - Sid nigdy nie był, nie jest i nie będzie zamrożony. Dla przykładu podam, że 8 kwietnia 2007 do wersji niestabilnej trafiło około 2800 nowych pakietów - przynajmniej tak wynika z informacji podawanej przez RSS.

Dodatkowo w wersji niestabilnej oprócz nowszych programów, są też wprowadzone nowsze rozwiązania, co jedynie udoskonala Twój system.

Ponadto paczki w wersjach niestabilnych często rozwiązują problemy, na które nie znano jeszcze rozwiązania podczas premiery wersji stabilnej czy nawet testowej.

Nie wiem jakie mam podać jeszcze argumenty. Po prostu Debian Sid jest stabilny i nie wiedzę powodów, żeby jego nie używać na desktopie (bo na serwer Debian Sid to raczej nie...).


Aktualizacja do Sida

Zdecydowałeś się! ;)

Tak, tak, chcesz tego, chcesz aktualizacji do Sida.

A więc, usuń poprzednie wpisy w pliku /etc/apt/sources.list dotyczące poprzedniej wersji Debiana i dodaj poniższe wpisy dla Sida:

Kod: Zaznacz cały

#~Sid~~#
deb [url]ftp://ftp.pl.debian.org/debian/[/url] sid main non-free contrib
deb-src [url]ftp://ftp.pl.debian.org/debian/[/url] sid main non-free contrib
Teraz wykonaj:

Kod: Zaznacz cały

aptitude update && aptitude dist-upgrade
lub jeśli używasz apt-get:

Kod: Zaznacz cały

apt-get update && apt-get dist-upgrade
Teraz idź zrób sobie kawę, herbatkę, czy co tam chcesz - wróć za godzinę i zrób restart systemu i już masz Debiana w wersji niestabilnej.


Ps.
W razie uwag, propozycji i takich tam, proszę o kontakt na PW, Gadu, Jabbera, czy w tym temacie.

velmafia
Member
Posty: 1820
Rejestracja: 01 września 2006, 00:56
Lokalizacja: Wrocek

Post autor: velmafia » 10 kwietnia 2007, 22:59

strasznie mi tu moim tematem zajeżdża ;)

btw. dala tych co system mają tylko do tego aby działał i dał możliwość pracy, to bardziej polecam testing.
przecież różnica w aktualności pakietów wynos zaledwie ok 2 tygodnie, a w razie czegoś to zawsze można zmieszać testing z Sid'em.
oczywiście nie twierdzę że Sid nie jest stabilny, ale gwarancji stabilności nie mamy (w testing też, ale testing jest bardziej przetestowany).

więc podsumowując, Sid jest stabilny i jeśli czujesz potrzebę to aktualizuj system do Sid'a, ale jeśli nie czujesz takiej potrzeby, lub system masz tylko do tego aby działał, to radzę zostać przy testing i ewentualnie potrzebne pakiety doinstalowywać z Sid'a do wersji testing.


PS.
Kaka' ten opis aktualzacji jakiś taki zabiedzony, może przerób tan mój opis pod Sida uzupełnij go o to co uwarzasz.



aloha

Awatar użytkownika
Louner
Posty: 46
Rejestracja: 15 grudnia 2006, 19:20
Lokalizacja: Doliny Podlasia

Post autor: Louner » 10 kwietnia 2007, 23:14

Wywaliłem wpisy, dodałem te, które podałeś i teoretycznie zaktualizowałem system do sid, ale... mam kilka pytań:

1. Dlaczego teraz przy aptitude update wypisuje mi:
Stary ftp://ftp.pl.debian.org sid Release.gpg
...
Stary ftp://ftp.pl.debian.org sid/contrib Sources/DiffIndex
2. Dlaczego pakietach sid jest GNOME 2.16 , a u mnie został 2.14 ? :D
3. Czy w etc/issue ciągle powinno być:
Debian GNU/Linux lenny/sid

Kaka'
Senior Member
Posty: 3019
Rejestracja: 30 lipca 2006, 13:17
Lokalizacja: Kartuzy

Post autor: Kaka' » 11 kwietnia 2007, 07:02

Louner pisze:3. Czy w etc/issue ciągle powinno być:
tak.

Louner pisze:1. Dlaczego teraz przy aptitude update wypisuje mi:
IMHO - olać ]2. Dlaczego pakietach sid jest GNOME 2.16 , a u mnie został 2.14 ? :D [/quote]

Zrób upgrade gnome...

Awatar użytkownika
Louner
Posty: 46
Rejestracja: 15 grudnia 2006, 19:20
Lokalizacja: Doliny Podlasia

Post autor: Louner » 11 kwietnia 2007, 07:51

Aptitude upgrade nic nie daje, jak powinienem to zrobić? ;)

Kaka'
Senior Member
Posty: 3019
Rejestracja: 30 lipca 2006, 13:17
Lokalizacja: Kartuzy

Post autor: Kaka' » 11 kwietnia 2007, 13:48

[quote="Louner"]Aptitude upgrade nic nie daje, jak powinienem to zrobić? ]

`aptitude dist-upgrade`

Awatar użytkownika
Louner
Posty: 46
Rejestracja: 15 grudnia 2006, 19:20
Lokalizacja: Doliny Podlasia

Post autor: Louner » 11 kwietnia 2007, 14:26

Zapomniałem dodać. xd To również nic nie daje. A w repozytoriach mam dokładnie to co podałeś.

Dobra, już żałuję, że zaktualizowałem system. xd Przed chwilą wcięło mi wszystkie polskie pakiety językowe ( nawet ten w 'addons' w firefox ), zczyściło locale, konfigurację xorg i nie mogę niczego zainstalować , bo są niezłe problemy z zależnościami.

Dziękuję, postoję. :P Zaraz robię reinstalkę.

Kaka'
Senior Member
Posty: 3019
Rejestracja: 30 lipca 2006, 13:17
Lokalizacja: Kartuzy

Post autor: Kaka' » 11 kwietnia 2007, 14:53

Louner pisze:Dziękuję, postoję. :P Zaraz robię reinstalkę.
Nie rób reinstalki - to niepotrzebne i bezsensu.

Musze przyznać, że po ostatnim upgrade nieźle namieszano z zależnościami (patrz: k3b). Teraz na dodatek podczas pracy dpkg miałem zwis (a raczej brak prądu ]Dobra, już żałuję, że zaktualizowałem system.[/quote]

¯ałujesz? Dlaczego? Bo jakiś tam problem masz? Spokojnie - rozwiążemy go ;)
Przed chwilą wcięło mi wszystkie polskie pakiety językowe ( nawet ten w 'addons' w firefox ),
To znaczy jak wcięło? Chyba samo z siebie się nic nie zrobiło ;>
zczyściło locale,
To akurat przed chwilą też miałem ;) Mówię, to ostatnie upgrade nieźle namieszało (czytaj: dzisiejsze upgrade).
Louner pisze:konfigurację xorg i nie mogę niczego zainstalować , bo są niezłe problemy z zależnościami.
Jakie problemy z zależnościami? Z tego powodu chcesz robić reinstalkę? Spróbuj:

Kod: Zaznacz cały

apt-get -f install
pokaż co Ci wywala.

Awatar użytkownika
Louner
Posty: 46
Rejestracja: 15 grudnia 2006, 19:20
Lokalizacja: Doliny Podlasia

Post autor: Louner » 11 kwietnia 2007, 15:21

Dobra, przepraszam, że lekko spanikowałem. :P Z zależnościami sobie poradziłem, zostały tylko locale. A co do pakietów językowych to szczerze mówiąc też się zdziwiłem. ;) Naprawdę nic nie zostało, ani polski język do wyboru w gdm, ani paczka językowa z iceweasel'a, dosłownie nic. :D

Kaka'
Senior Member
Posty: 3019
Rejestracja: 30 lipca 2006, 13:17
Lokalizacja: Kartuzy

Post autor: Kaka' » 11 kwietnia 2007, 15:26

Może pakiety są uszkodzone?

Kod: Zaznacz cały

dpkg -l | grep pakiet
posprawdzaj to.

ODPOWIEDZ