Edimax Ralink RT61 instalacja

Wszystko związane z jądrem systemowym, sterownikami, sprzętem itp.
z3d
Posty: 71
Rejestracja: 27 lutego 2008, 20:28
Lokalizacja: ~/

Edimax Ralink RT61 instalacja

Post autor: z3d » 26 maja 2008, 12:20

Witam wszystkich,
mam problem z instalacją ratlink rt61. Postępowałem zgodnie z poradnikiem http://debian.linux.pl/index.php?sid=54 ... ad521b2acf
ale coś poszło nie tak i pod koniec instalacji komputer się zawiesił :( . Wyłączyłem go, i X-y już nie wstały. Karta przy poleceniu lspci była wykrywana prawidłowo, instalacja do pewnego momentu też przebiegła dobrze jednak teraz coś jest nie tak.
Podczas startu systemu dostaję informację że nie ma czegoś w modprobe.d - nie zdążyłem przeczytać więc dokładnie nie wiem o co chodzi, wszystko startuje niby ok ale x-y nie. Ekran jest czarny i tyle.
Jak wyciągnę kartę wszystko startuje tak jak powinno. Spróbowałem też wpiąć ją po starcie systemu, ale wiesza komputer. Macie jakiś pomysł co z tym zrobić? Aha mój komp to IBMT21

Nie mam pomysłu gdzie zacząć, bardzo proszę o jakąś radę.

Pozdrawiam

P.S.
Sterownik którego użyłem to v1.1.0-b2, ale na stronie widzę że pisze że to sterownik do wersji B, w jaki sposób po instalacji ze źródła mogę ją wyinstalować i ponownie spróbować to zrobić? Kiedy wczoraj karta nie wieszała jeszcze systemu wynik lspci nie podawał że to wersja B- czy od tego mogą brać się moje problemy ze startem x-ów?
Wczoraj zapomniałem dodać że mój system to Lenny 4.0 wersja jajka 2.6.18-4-686
Mam prośbę mógłbyś mi napisać w którym katalogu są logi ze startu systemu? Chodzi mi o tekst który widze w konsoli, czy jest on zapisywany gdzieś?

Mam jeszcze pytanie czy 2.6.24 wspiera już rt61? Jeżeli tak to może łatwiej jądro zmienić :)

Proszę o pomoc, chcę to naprawić, ale sam nie dam rady.

fnmirk
Senior Member
Posty: 8037
Rejestracja: 03 grudnia 2007, 06:37

Post autor: fnmirk » 01 czerwca 2008, 08:34

Wklej wynik polecenia:

Kod: Zaznacz cały

dpkg -l | grep $(uname -r)
I polecenia wydanego z uprawnieniami root:

Kod: Zaznacz cały

modprobe -l | grep rt61

z3d
Posty: 71
Rejestracja: 27 lutego 2008, 20:28
Lokalizacja: ~/

Post autor: z3d » 02 czerwca 2008, 22:39

Dziękuję za odpowiedź.
Ostatnio miałem trochę czasu więc postanowiłem ściągnąć ostatniego Lennego i postawić system na świeżo, bo z tym co zostało z poprzedniej wersji nic zrobić mi się nie udało. Teraz mam jajko 2.6.22, system jest czysty, wykrywa wszystko tak jak trzeba, dla przykładu podaję wynik lspci:

Kod: Zaznacz cały

00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:02.0 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:02.1 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:03.0 Ethernet controller: Intel Corporation 82557/8/9/0/1 Ethernet Pro 100 (rev 0c)
00:03.1 Serial controller: Agere Systems LT WinModem (rev 01)
00:05.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24/30 [CrystalClear SoundFusion Audio Accelerator] (rev 01)
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
01:00.0 VGA compatible controller: S3 Inc. 86C270-294 Savage/IX-MV (rev 11)
06:00.0 Network controller: RaLink RT2561/RT61 802.11g PCI

Kod: Zaznacz cały

z3d-debian:/home/z3d# dpkg -l | grep $(uname -r)
ii  linux-image-2.6.22-3-686             2.6.22-6                   Linux 2.6.22 image on PPro/Celeron/PII/PIII/
Co do modprobe nie wyświetla nic bo nie instalowałem jeszcze sterowników. Teraz system jest czysty, i bardzo prosił bym o radę, jak instalować tego ratlinka? Sterownikami, które mi zawiesiły komputer czy ndiswrapperem? Jeżeli chodzi o ndiswrappera bardzo prosiłbym o pomoc w instalacji gdyż nie miałem z nim do czynienia.
Pozdrawiam.

e-gore
Beginner
Posty: 147
Rejestracja: 26 sierpnia 2006, 21:30

Post autor: e-gore » 03 czerwca 2008, 00:10

...chyba nie Ratlink, a Ralink.
Widziałeś ten opis?

z3d
Posty: 71
Rejestracja: 27 lutego 2008, 20:28
Lokalizacja: ~/

Post autor: z3d » 03 czerwca 2008, 16:18

Masz rację e-gore Literówka w poście :)
Link który podałeś jest świetny, nie natrafiłem na ten poradnik w poszukiwaniu pomocy, bardzo dziękuję.
Pozdrawiam

e-gore
Beginner
Posty: 147
Rejestracja: 26 sierpnia 2006, 21:30

Post autor: e-gore » 03 czerwca 2008, 16:42

Niby tylko literówka, ale przez chwilę zastanawiałem się o jaką kartę chodzi (tzn. co to za Ratlink?). ;-)

z3d
Posty: 71
Rejestracja: 27 lutego 2008, 20:28
Lokalizacja: ~/

Post autor: z3d » 06 czerwca 2008, 20:29

Witam ponownie,
tak jak myślałem wcześniej tak się stało - natrafiłem na problem :(
Rozpocząłem instalację zgodnie z poradnikiem który podał e-gore, ściągnąłem driver rozpakowałem, przekopiowałem Makefile.6 ./Makefile i kiedy wpisałem make i dostałem komunikat że nie ma takiego polecenia zainstalowałem więc make przez

Kod: Zaznacz cały

 apt-get install make 
kiedy po raz kolejny wklepałem make all jak nakazuje instrukcja otrzymałem

Kod: Zaznacz cały

z3d-debian:/home/z3d/Desktop/2008_0506_RT61_Linux_STA_v1.1.2.1/Module# make all
make -C /lib/modules/2.6.22-3-686/build SUBDIRS=/home/z3d/Desktop/2008_0506_RT61_Linux_STA_v1.1.2.1/Module modules
make: *** /lib/modules/2.6.22-3-686/build: Nie ma takiego pliku ani katalogu. Stop.
make: *** [all] Błąd 2
z3d-debian:/home/z3d/Desktop/2008_0506_RT61_Linux_STA_v1.1.2.1/Module# 
nie wiem o co chodzi, w instrukcji nie widziałem komendy nakazującej założenie katalogu,

czy ktoś mógłby mi pomóc?

pozdrawiam

e-gore
Beginner
Posty: 147
Rejestracja: 26 sierpnia 2006, 21:30

Post autor: e-gore » 06 czerwca 2008, 22:10

Nie wiem czy dobrze kojarzę, ale spróbuj wejść do katalogu

Kod: Zaznacz cały

/lib/modules/2.6.22-3-686/build
i tam wykonaj make.

z3d
Posty: 71
Rejestracja: 27 lutego 2008, 20:28
Lokalizacja: ~/

Post autor: z3d » 14 czerwca 2008, 23:23

Witam ponownie,
e-gore, przepraszam, że piszę tak późno ale sesja i wiesz jak to jest,
o to co mam w katalogu 2.6.22:
z3d-debian:/lib/modules/2.6.22-3-686# ls
kernel modules.dep modules.isapnpmap modules.seriomap
modules.alias modules.ieee1394map modules.ofmap modules.symbols
modules.ccwmap modules.inputmap modules.pcimap modules.usbmap
Nie ma tutaj build, w którym kazałeś zrobić make bardzo proszę o dalsze porady, co począć żeby zainstalować Ralinka.

Za wszelką pomoc z góry dziękuję i pozdrawiam

[Dodano: 2008-06-15, 22:10]
Witam ponownie z pola walki :) Ralink dalej prowadzi :) hehehe
szukałem dalej rozwiązania mojego problemu i znalazłem posta :
wzorując się więc na nim próbowałem coś robić dalej, stworzyłem też folder"build" o który system non stop się rzuca, teraz z kolei widzę coś takiego (chciałem zobaczyć czy się coś zmieni):
z3d-debian:/home/z3d/Desktop/2008_0506_RT61_Linux_STA_v1.1.2.1/Module# make all
make -C /lib/modules/2.6.22-3-686/build SUBDIRS=/home/z3d/Desktop/2008_0506_RT61_Linux_STA_v1.1.2.1/Module modules
make[1]: Wejście do katalogu `/lib/modules/2.6.22-3-686/build'
make[1]: *** Brak reguł do wykonania obiektu `modules'. Stop.
make[1]: Opuszczenie katalogu `/lib/modules/2.6.22-3-686/build'
make: *** [all] Błąd 2
Dalej więc myślę nad tym gdzie leży błąd? System jest świeży, nic nie namieszane, a problemów z instalacją mam trochę sporo, czy ktoś ma jakiś pomysł co mogę zrobić, ewentualnie jak to zrobić?
Bardzo proszę o rady nim znów coś uda mi się popsuć.
Jedno jest jednak pewne z Debiana nie zrezygnuje.

Pozdrawiam wszystkich cierpliwych.

[Dodano: 2008-06-16, 12:41]
Witam ponownie,
chciałem zapytać, a zapomniałem zrobić tego wczoraj czy znacie jakiś sensowny sposób instalacji ndiswrappera? Czy ktoś z Was próbował może ndisgtk? Widzę, że sterowniki dedykowane dla Debiana sprawiają mi trochę problemu chciałbym więc spróbować z drugiej strony. Jeżeli ktoś z Was miał już z tym do czynienia bardzo prosiłbym o porady.

Pozdrawiam

[Dodano: 2008-06-22, 00:05]
Cześć,
Panowie i Panie (jeśli takowe tutaj mamy) powiedzcie mi skąd pobrać sterowniki do ndiswrappera. Te które dostałem na płycie (sterowniki dla Windowsa w ogóle nie podchodzą do instalacji). Jest potrzebny plik *. inf, a sterowniki windowsowe mają tylko *.exe próbowałem go rozpakować ale niestety nic z tego. Czy ktoś z Was wie skąd można pobrać sterowniki dla tej karty - stronka producenta chyba odpada - jest tylko *.exe
Pozdrawiam

Athlon
Posty: 46
Rejestracja: 06 marca 2008, 01:05
Lokalizacja: Stary S±cz

Post autor: Athlon » 23 grudnia 2008, 02:26

Witam.

Nie chce zakładać nowego tematu o podobnej tematyce więc piszę w tym. Postanowiłem po długim czasie użytkowania Etcha zainstalować na moim Stacjonarnym komputerze Lennego. Wszystko jest dobrze, ale Wifi nie działa. ¦ciągnąłem więc sterownik ze strony:
http://www.ralinktech.com/ralink/Home/S ... Linux.html

A kieruje się wskazówkami z: http://www.cyberciti.biz/tips/linux-ins ... -card.html

Na make konsola odpowiada:
athlon@debian:~/rt/2008_0723_RT61_Linux_STA_v1.1.2.2/Module$ make
make -C /lib/modules/2.6.26-1-686/build SUBDIRS=/home/athlon/rt/2008_0723_RT61_Linux_STA_v1.1.2.2/Module modules
make[1]: Wejście do katalogu `/usr/src/linux-headers-2.6.26-1-686'
scripts/Makefile.build:46: *** CFLAGS was changed in "/home/athlon/rt/2008_0723_RT61_Linux_STA_v1.1.2.2/Module/Makefile". Fix it to use EXTRA_CFLAGS. Stop.
make[1]: *** [_module_/home/athlon/rt/2008_0723_RT61_Linux_STA_v1.1.2.2/Module] BÅ‚Ä…d 2
make[1]: Opuszczenie katalogu `/usr/src/linux-headers-2.6.26-1-686'
make: *** [all] BÅ‚Ä…d 2
lspci wyświetla:

Kod: Zaznacz cały

 03:0b.0 Network controller: Ralink RT2561/RT61 802.11g PCI
Proszę o pomoc bo nie wiem dlaczego make nie działa. Muszę zrobić to jak najszybciej bo bez dostępu do internetu niewiele zrobię.

ODPOWIEDZ