[+] Bluetooth sie nie uruchamia debian 11 dell E5470

Wszystko związane z jądrem systemowym, sterownikami, sprzętem itp.
ww71
Beginner
Posty: 422
Rejestracja: 04 grudnia 2008, 11:44
Lokalizacja: lubelskie

[+] Bluetooth sie nie uruchamia debian 11 dell E5470

Post autor: ww71 »

Witam,
Mam problem z bluetooth blueman. Zapewne go niechcący wyłączyłem gdy pytał. Teraz nie moge go włączyć. W menu programy jest, ale przy uruchaminaiu ikona się pojawia na ułamek sekundy i znika, i nie ma ikony na pasku górnym w prawym rogu górnym. Mam XFCE, debian 11.6 na delu E 5470.
Wgrałem od nowa system i problem ten sam o dziwo. Pojawiła sie ikona, wlączyłem bluetooth i znów zniknęła i nie chce sie uruchomić. W Biosie mam włączonę bluetooth.
# lspci
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 08)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #11 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection I219-LM (rev 21)
01:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
uname -a
Linux debian 5.10.0-20-amd64 #1 SMP Debian 5.10.158-2 (2022-12-13) x86_64 GNU/Linux

# apt-get reinstall blueman
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności... Gotowe
Odczyt informacji o stanie... Gotowe
0 aktualizowanych, 0 nowo instalowanych, 1 ponownie instalowanych, 0 usuwanych i 0 nieaktualizowanych.
Konieczne pobranie 0 B/742 kB archiwów.
Po tej operacji zostanie dodatkowo użyte 0 B miejsca na dysku.
(Odczytywanie bazy danych ... 184415 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu .../blueman_2.1.4-1+b1_amd64.deb ...
Rozpakowywanie pakietu blueman (2.1.4-1+b1) nad (2.1.4-1+b1) ...
Konfigurowanie pakietu blueman (2.1.4-1+b1) ...
Przetwarzanie wyzwalaczy pakietu dbus (1.12.24-0+deb11u1)...
Przetwarzanie wyzwalaczy pakietu mailcap (3.69)...
Przetwarzanie wyzwalaczy pakietu desktop-file-utils (0.26-1)...
Przetwarzanie wyzwalaczy pakietu hicolor-icon-theme (0.17-2)...
Przetwarzanie wyzwalaczy pakietu libglib2.0-0:amd64
Przeinstalowałem jeszcze raz blueman i sie włączył bluetooth po przeładowaniu systemu.
Niestety problem dalej istnieje. Przy ponownym uruchomieniu lapka, ikony bluetooth na pasku górnym nie ma , i nie chce sie uruchomić. Proszę o wskazówki.
#rfkill
ID TYPE DEVICE SOFT HARD
0 wlan dell-wifi nieaktywna nieaktywna
1 bluetooth dell-bluetooth nieaktywna nieaktywna
2 wlan phy0 nieaktywna nieaktywna
3 bluetooth hci0 nieaktywna nieaktywna
Zrobiłem tak:
rfkill unblock 3
rfkill unblock 1

Przeładowalem system, ale wczesniej uruchomiłem win 11, i tam działa bluetooth, i uruchomieniu debiana bluetooth działa, ikona jest i wszystko działa.
Sytuacją obecnie tak wygląda, że bluetooth sie pojawia na pasku i działa tylko jeśli wcześniej uruchomiałem win 11 i wyłączyłem go jako : "uruchom ponownie" i zaraz uruchamiam debiana.

Problem chyba rozwiązany. Trzeba było wejść w: Usługi lokalne, w ikonie bluetooth, i tam zaznaczyć : blueman w opcjach. Działa ok. na razie.

Niestety znów ten sam problem. Chwilowo brak mi pomysłów, jeśli ktoś coś doradzi byłbym wdzięczny.

Problem rozwiązany chyba. Jak instalowałem debiana wgrałem sterowniki wifi z 1 pliku na USB. Brakowało jakichś pakietów z :
firmware-iwlwifi
Zainstalowałem cały ten pakiet i już działa bluetooth.
Zablokowany