Problem dźwiękiem

Wszystko związane z jądrem systemowym, sterownikami, sprzętem itp.
Andrzejo4
Posty: 19
Rejestracja: 03 marca 2021, 19:28

Re: Problem dźwiękiem

Post autor: Andrzejo4 » 25 czerwca 2021, 11:22

Witam nic to nie pomogło nadal nie mam dźwięku na youtube, i teraz znowu nie mam dźwięku w vlc . Mam jeszcze jeden taki komp, tylko ze na świeżym debianem okazuję się, że w kontroli dźwięku w zakładce Odtwarzanie mam dźwięki systemowe i w zakładce konfiguracja mam wbudowany dźwięk i można wybrać profil natomiast u mnie tego nie ma. W zakładka Urządzenia wejściowe na świeżym dębianie nie mam nic a u mnie jest Monitor of Głuche Wyjście to dziwne, że na wyjściu jest wejście

fnmirk
Senior Member
Posty: 8105
Rejestracja: 03 grudnia 2007, 06:37

Re: Problem dźwiękiem

Post autor: fnmirk » 25 czerwca 2021, 18:45

Czy w systemie dźwięk jest? Jeżeli tak, to ustawienie w tym serwisie muszą być związane z udostępnianiem urządzeń, czy czymś podobnym. Vcl należy skonfigurować lub dograć chyba wtyczkę do pulseaudio. Rzadko bardzo używam vcl, więc musiałbym poszukać.

Przedstaw jeszcze raz skrypt alsy. Wystarczy go ponownie uruchomić i wkleić na forum odnośnik do jego wyniku. Uruchom go jako zwykły użytkownik.

Andrzejo4
Posty: 19
Rejestracja: 03 marca 2021, 19:28

Re: Problem dźwiękiem

Post autor: Andrzejo4 » 26 czerwca 2021, 12:11

jak wybieram polecenie speaker-test to odbywa się test ale nic nie słychać to przypuszczam że nie mam dźwięków systemowych. Wydaje mi się że problem jest w w karcie wbudowanej ponieważ ja mam tak to podpięte że monitor jest podpięty pod hdmi a ja nie mam w monitorze głośników więc może wszystko jest dobrze bo dźwięk jest wysyłany na hdmi a nie na kartcie usb. Serwer mi działa ponieważ w nim wybrałem kartę dźwiękowa i wydaje mi się że tutaj może być problem i pasowałoby przypisać wszelkie audio do karty usb a to to jest link z alsy

Kod: Zaznacz cały

http://alsa-project.org/db/?f=8d34b1c67aef31d24f7ba9276b5f9bda6552a6f6

fnmirk
Senior Member
Posty: 8105
Rejestracja: 03 grudnia 2007, 06:37

Re: Problem dźwiękiem

Post autor: fnmirk » 26 czerwca 2021, 23:46

Andrzejo4, kiedy zrozumiesz, że bez serwera dźwięku i poprawnego działania karty lokalnie nie można przejść do konfiguracji tego w serwisach internetowych. Karta musi działać na komputerze. W biosie możesz wyłączyć wbudowaną kartę dźwiękową.

Zrób porządek z systemem.

W pliku /etc/apt/sources.list zostaw takie wpisy:

Kod: Zaznacz cały

deb https://deb.debian.org/debian/ buster main
deb https://security.debian.org/debian-security/ buster/updates main contrib
deb https://deb.debian.org/debian/ buster-updates main contrib
Usuń plik /etc/apt/sources.list.d/rvm-ubuntu-smplayer-impish.list lub wyłącz to repozytorium wstawiając na początku znak #.

Wykonaj kolejno polecenia:

Kod: Zaznacz cały

apt purge `dpkg -l | grep '^rc' | awk '{print $2}'`
apt update
apt autoremove
apt upgrade
Zanim potwierdzisz wykonanie polecenia „apt autoremove” wykonaj kopię tego co jest przewidziane do usunięcia.

Andrzejo4
Posty: 19
Rejestracja: 03 marca 2021, 19:28

Re: Problem dźwiękiem

Post autor: Andrzejo4 » 28 czerwca 2021, 07:27

zrobiłem tak jak napisałeś, ale gdy wpisuję pleecenie [apt purge `dpkg -l | grep '^rc' | awk '{print $2}'`][/code] to wyskakuje mi coś takiego

Kod: Zaznacz cały

root@debian:~# apt purge `dpkg -l | grep '^rc' | awk '{print $2}'`
E: Typ "deb" jest nieznany w linii 1 listy źródeł /etc/apt/sources.list
E: Nieprawidłowa linia 1 w liście źródeł /etc/apt/sources.list.d/rvm-ubuntu-smplayer-impish.list (typ)
E: Nie udało się odczytać list źródeł.
E: Typ "deb" jest nieznany w linii 1 listy źródeł /etc/apt/sources.list
E: Nieprawidłowa linia 1 w liście źródeł /etc/apt/sources.list.d/rvm-ubuntu-smplayer-impish.list (typ)
E: Nie udało się odczytać list źródeł.[/codde]

sources.lst 

[code]deb https://deb.debian.org/debian/ buster main
deb https://security.debian.org/debian-security/ buster/updates main contrib
deb https://deb.debian.org/debian/ buster-updates main contrib
rvm-ubuntu-smplayer-impish.lis

Kod: Zaznacz cały

# deb http://ppa.launchpad.net/rvm/smplayer/ubuntu impish main
# deb-src http://ppa.launchpad.net/rvm/smplayer/ubuntu impish main

fnmirk
Senior Member
Posty: 8105
Rejestracja: 03 grudnia 2007, 06:37

Re: Problem dźwiękiem

Post autor: fnmirk » 28 czerwca 2021, 17:35

Andrzejo4, załamujesz mnie. To jest błąd wynikający z Twojego braku uwagi. Masz w tych plikach linie, które są zbędne lub nie oznaczone znakiem # na początku. Prawdopodobnie coś dopisałeś.
Przedstaw wynik:

Kod: Zaznacz cały

cat -A /etc/apt/sources.list
A ten drugi plik usuń.

Z tego co przedstawiłeś to wygląda, że dopisałeś coś takiego: [ code ] itp. usuń to,

Andrzejo4
Posty: 19
Rejestracja: 03 marca 2021, 19:28

Re: Problem dźwiękiem

Post autor: Andrzejo4 » 28 czerwca 2021, 22:29

No ja nie miałem wcześniej linuksa. Nic nie dopisywałem to (code) jest jak wklejałem na forum nie wynika ono ze składni którą wpisywałem do terminala. To wynik tego polecenia

Kod: Zaznacz cały

andrzej@debian:~$ cat -A /etc/apt/sources.list
M-oM-;M-?deb https://deb.debian.org/debian/ buster main$
deb https://security.debian.org/debian-security/ buster/updates main contrib$
deb https://deb.debian.org/debian/ buster-updates main contrib$
andrzej@debian:~$ 

fnmirk
Senior Member
Posty: 8105
Rejestracja: 03 grudnia 2007, 06:37

Re: Problem dźwiękiem

Post autor: fnmirk » 28 czerwca 2021, 22:39

A to skąd się wzięło?
Andrzejo4 pisze:

Kod: Zaznacz cały

M-oM-;M-?
Usuń to z pierwszej linijki.

Jakiego edytora używasz do edycji tego pliku?

Użyj:

Kod: Zaznacz cały

nano /etc/apt/sources.list
Ctrl+O zapisz zmiany
Ctrl+X opuszczasz edytor

Andrzejo4
Posty: 19
Rejestracja: 03 marca 2021, 19:28

Re: Problem dźwiękiem

Post autor: Andrzejo4 » 29 czerwca 2021, 07:05

Faktycznie skąd to się wzięło to nie mam bladego pojęcia. do edycji pliku używam albo mc, terminala, libreoffice .Dziwne jest to że wszędzie gdzie otwieram ten plik to nie mam tego
M-oM-;M-?


przepisałem jeszcze raz i teraz jest dobrze

Kod: Zaznacz cały

root@debian:~# cat -A /etc/apt/sources.list
deb https://deb.debian.org/debian/ buster main$
deb https://security.debian.org/debian-security/ buster/updates main contrib$
deb https://deb.debian.org/debian/ buster-updates main contrib$
root@debian:~# 


teraz poszły te konendy

Kod: Zaznacz cały

apt purge `dpkg -l | grep '^rc' | awk '{print $2}'`
apt update
apt autoremove
apt upgrade
i co teraz?

fnmirk
Senior Member
Posty: 8105
Rejestracja: 03 grudnia 2007, 06:37

Re: Problem dźwiękiem

Post autor: fnmirk » 29 czerwca 2021, 07:50

Powinien cię ktoś kroić i solić dodając ostrej papryki za to. Jak można wpaść na pomysł aby pliki konfiguracyjne edytować w libreoffice?

Jeżeli do edycji plików konfiguracyjnych używasz libreoffice to pewnie większość Twoich problemów z systemem z tego wynika.

Naucz się korzystać z edytora nano lub nawet vima. Popraw ten plik i wykonaj aktualizacje systemu.

Kod: Zaznacz cały

apt purge `dpkg -l | grep '^rc' | awk '{print $2}'`
apt update
apt autoremove
apt upgrade
Zanim potwierdzisz wykonanie polecenia „apt autoremove” wykonaj kopię tego co jest przewidziane do usunięcia.

ODPOWIEDZ