[+]Laptop lenowo a instalacja Debiana

Wszystko związane z jądrem systemowym, sterownikami, sprzętem itp.
Awatar użytkownika
Spass
Beginner
Posty: 180
Rejestracja: 09 maja 2007, 16:25

Re: Laptop lenowo a instalacja Debiana

Post autor: Spass » 11 lipca 2018, 07:14

arturromarr, z poleceniem "dd" musisz być ostrożny, pomyłka może być bolesna. Jak szukasz bardzo prostego programu do tworzenia bootowalnych pendrive'ów z pliku ISO to polecam Etcher - https://etcher.io
Używam od jakiegoś czasu i jeszcze mnie nie zawiódł, działa na Linux/Windows/macOS. Mają repo dla Debiana i paczki AppImage, co kto woli.

No i jest też narzędzie gnome-disks (z paczki gnome-disk-utility, jest w repo), to chyba też daje radę - opcja "Przywróć obraz dysku".

Awatar użytkownika
arturromarr
Beginner
Posty: 109
Rejestracja: 14 sierpnia 2015, 01:21

Re: Laptop lenowo a instalacja Debiana

Post autor: arturromarr » 13 lipca 2018, 20:09

Dziękuję, fajny programik, skorzystałem.
Ustawiłem w BIOS:
USB Legacy: tak
Seccure boot: nie
Boot Mode: Legacy Suport
Boot Priority: Legacy First
USB Boot: tak
Boot Priority Order: 1.USB HDD....
Instalacja ruszyła. Ustawiłem partycje na dysku eMMC zgodnie z podpowiedzią tylko usunąłem partycję wymiany:
mmcblk0 - 62,5 GB
>1MB wolne
>nr1 1MB K biosgrub
>nr2 20.2GB f ext4 /
>nr3 42.3GB f ext4 /home
System się zainstalował, Grub spytał gdzie się zainstalować, wpisałem: mmcblk0.
Zmieniłem w BIOS kolejność uruchamiania:
Boot Priority Order: 1.eMMC Card.
Niestety system się nie uruchamia. Wyświetla się tekstowy ekran Bot Menu z wyborem karty: eMMC i po wybraniu od nowa to samo.
Co mam zmienić w Biosie?
Czy może inaczej zainstalować system, żeby uruchamiał się w trybie: UEFI ?

Awatar użytkownika
Yampress
Administrator
Posty: 6075
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Re: Laptop lenowo a instalacja Debiana

Post autor: Yampress » 13 lipca 2018, 20:32

na tym urządzeniu n którym instalowałeś system zainstaluj grub

Awatar użytkownika
arturromarr
Beginner
Posty: 109
Rejestracja: 14 sierpnia 2015, 01:21

Re: Laptop lenowo a instalacja Debiana

Post autor: arturromarr » 13 lipca 2018, 21:19

Już się udało. Zasugerowałem się jakimś opisem z netu (tyle, że tam był Mint), który uruchamiał system po staremu.
Wystarczyło zmienić w BIOS-ie:
Configuration
USB Legacy Enabled
Intel Virtual Technology Enabled
BOOT
Boot Mode Legacy Suport
Boot Priority UEFI First
USB Boot Enable
PXE Boot to LAN Disabled
Boot Priority Order USB HDD

Instalator Debiana ruszył z PenDrive, ale w trybie UEFI (jest info przy starcie i wyższa rozdzielczość).
Utworzone automatycznie partycje (bez partycji wymiany):
nr1 536,9 MB B f ESP
nr2 20,0 GB f ext4 /
nr3 42,0GB f ext4 /home

Po instalacji i restarcie pojawiło się urządzenie napędu : debian na liście bootowania. (pewnie partycja z ESP).
Muszę trochę poczytać o tym BIOS z UEFI, bo to dla mnie nowość. Zawsze korzystałem z systemu startującego z MBR. Zaleta jest taka, że faktycznie pierwsza faza uruchamiania jest szybka.

Ogólnie to miałem trochę stracha, że będą problemy z Linuxem na tym sprzęcie (w necie są opisy, że niektóre modele nie współpracują) a okazało się, że to chyba pierwszy raz kiedy wszystko po instalacji działa.
W instalatorze nie działał Tuchpad i wołał stery od sieciówki, ale po instalacji z zamkniętym oprogramowanie wszystko działa (chyba, że jszcze czegoś nie zauważyłem).
Laptop wydaje się fajny jak za taka cenę do niewymagających działań. Jedno co mogło być lepsze to większy kontrast ekranu.
Obrazek
Obrazek
PS:
Winda w wersji S to super sprawa dla linuxiarzy, nie podnosi ceny sprzętu, można przestować szybko sprzęt po zakupie i nie żal się go pozbyć instalując Linuxa.
Kolejny kawałek krzemu pod władzą Linuxa :)

ODPOWIEDZ