Problem z Instalacj

Wszystko związane z jądrem systemowym, sterownikami, sprzętem itp.
peligan
Posty: 26
Rejestracja: 09 kwietnia 2010, 08:42

Problem z Instalacją Jessie na ST32000645ss przez TX2650

Post autor: peligan » 03 czerwca 2015, 00:36

Główną nagrodą w pewnym konkursie był dysk ST32000645ss (łakomy kąsek dla wszystkich).
Po ciężkim boju stałem się "szczęśliwym" posiadaczem w/w sprzętu.
Problemy zaczęły się gdy okazało się, że jest to dysk SAS, nieobsługiwany przez większość płyt.
Konieczne okazało się dokupienie jakiegoś kontrolera. Padło na TX2650.
Drivery dostarczone z płytą nawet obsługiwały Linuksa ale z jądrem 2.6.18 (to chyba Sarge).
Próbując zgłębić problem znalazłem informację że TX2650 od dawna jest modułem we wszystkich jądrach 3.0.
lspci bardzo ładnie go pokazuje.

Kod: Zaznacz cały

00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 01)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation NM10/ICH7 Family SATA Controller [IDE mode] (rev 01)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 01)
[B]01:00.0 RAID bus controller: Promise Technology, Inc. PDC42819 [FastTrak TX2650/TX4650][/B]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
niestety, przy instalacji Jessie instalator wyrzuca

Kod: Zaznacz cały

[   10.880036] ata1: softreset failed (1st FIS failed)
[   20.880025] ata1: softreset failed (1st FIS failed)
[   55.880026] ata1: softreset failed (1st FIS failed)
[   55.880058] ata1: limiting SATA link speed to 1.5 Gbps
[   60.880025] ata1: softreset failed (1st FIS failed)
[   60.880057] ata1: reset failed, giving up
i nie widzi dysku.

Po dodaniu sterowników z płyty, instalator Windowsa pięknie zobaczył dysk SAS (więc dysk chyba jest dobry).
Po podpięciu zwykłego dysku SATA do TX2650 instalator Jessie widzi dyski SATA przez kontroler (chyba też jest dobry).

Czy może komuś udało się to rozwiązać, lub wie o jakichś nowszych driverach ?
Linux jest mocny na serwerach i dyski SAS powinien widzieć.
Trochę informacji o moim sprzęcie.

płyta ga-eg41mf-us2h
procesor e6750
ram ddr2 4Gb
debian_version 7.8 686

P.S.
Od pewnego czasu zakładka "Artykuły" na waszej stronie resetuje mi połączenie.
Nie wiem czy to to błąd na stronie czy to coś u mnie.
Możecie to sprawdzić ?
pozdrawiam

coolturka
Posty: 59
Rejestracja: 30 września 2008, 00:08

Post autor: coolturka » 18 września 2015, 00:13

Wygląda na to, że dysk i kontroler są w porządku. Czy w biosie kontrolera ustawiłeś jak ma być widoczny? Tzn czy ustawiłeś w nim logiczny dysk?

peligan
Posty: 26
Rejestracja: 09 kwietnia 2010, 08:42

Post autor: peligan » 18 września 2015, 08:41

coolturka pisze: Czy w biosie kontrolera ustawiłeś jak ma być widoczny? Tzn czy ustawiłeś w nim logiczny dysk?
Tak.
W calach kontrolnych nawet postawiłem na nim Windows 8.1, ale ze względów bezpieczeństwa (chyba jestem paranoikiem w tej kwestii) nie pasuje mi ten system.

P.S.
Odpowiedziałeś na post z przed trzech miesięcy.
Dysk i kontroler leży na półce i czeka na lepsze czasy.
Obecnie gdzieś zawieruszyła się płyta instalacyjna do TX2650 i nie powtórzę tego doświadczenia.

Pozdrawiam

Awatar użytkownika
marcin1982
Moderator
Posty: 1720
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Post autor: marcin1982 » 18 września 2015, 17:50

Patrzcie na daty postów jak odpowiadacie w wątku ...

ODPOWIEDZ