Dźwiek przez HDMI

Wszystko związane z jądrem systemowym, sterownikami, sprzętem itp.
mikmik
Beginner
Posty: 356
Rejestracja: 24 maja 2007, 22:36
Lokalizacja: Gdynia

Dźwiek przez HDMI

Post autor: mikmik » 13 lipca 2014, 13:08

Witam

Sprawa wyglada następująco, po podłaczeniu komputera przez kabel HDMI do telewizora, nie wykrywa ani obrazu ani dźwieku ( pewnie jest jakiś skrót klawiszowy albo polecenie - niestety go nie znam). Ponowne uruchomienie kompa rozwiązuje problem obrazu, niestety z dźwiękiem jest gorsza sprawa, w alxamixerze po włączeniu S/PDIF dźwięk nie włącza się (jak dotad nie udało mu się przekierować dźwięków systemowy bądź z yt na telewizor jednak w vlc można wybrać output na HDMI. Dźwięk jest bardzo nieczysty w większości sa to szumy i między nimi właściwa ścieżka...druga kwestią jest brak możliwości kontroli głośności - myślę że to może być problemem ponieważ dzięk tak przekierowany z vlc jest niezwykle głośny.

Kod: Zaznacz cały

root@debian:/home/asia# cat /proc/asound/cards      
 0 [SB             ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfeb40000 irq 16
 1 [Generic        ]: HDA-Intel - HD-Audio Generic
                      HD-Audio Generic at 0xfeb44000 irq 42

Kod: Zaznacz cały

00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Wrestler HDMI Audio
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40

Kod: Zaznacz cały

root@debian:/home/asia# cat /etc/modprobe.d/alsa-base.conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; : ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2


options snd-hda-intel index=1
options snd-emu10k1 index=2

Kod: Zaznacz cały

root@debian:/home/asia# cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel

Kod: Zaznacz cały

root@debian:/home/asia# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version k3.14-1-686-pae.
Mam 2 pytania, czy jest możliwość prostego przełączania output-u dźwięku dla całego systemu a nie tylko wybór w programie który to umożliwia.
Czy istnieje możliwość automatycznego przekierowania dźwięku po podłaczeiu kabla HDMI, jeżeli tak jak sie za to zabrać?

Proszę o jakieś sugestie...

Awatar użytkownika
kodama
Junior Member
Posty: 633
Rejestracja: 23 maja 2010, 22:30
Lokalizacja: Poznań

Post autor: kodama » 18 sierpnia 2014, 13:35

Może odświeżę temat, bo walczę z tym samym problemem. No, podobnym - o ile obraz bez problemu działa (w laptopie mam DisplayPort (cholera w sumie wie, po co to ustrojstwo montowali, zamiast kulturalnie dać HDMI i by nie trzeba dodatkowych bejmów na przejściówkę wydawać)), to z dźwiękiem jest już nieco gorzej, bo trzeba to ręcznie przełączać.

Moje pytanie brzmi tak:
Czy można tak skonfigurować system, żeby ALSA automagicznie wykrywała, że podłączony został kabel HDMI i na HDMI kierowała sygnał? W internecie znalazłem jakieś regułki dla udev, ale nie działa to u mnie niestety. Idealnie by było tak jak jest pod WIndowsem (nie bić! :P ) - podłączam kabelek - wszystko idzie na HDMI, odłączam - "wraca" do laptopowych głośników.

ODPOWIEDZ