System nie uruchamia si

Wszystko związane z jądrem systemowym, sterownikami, sprzętem itp.
Adam
Posty: 45
Rejestracja: 12 sierpnia 2007, 16:46

System nie uruchamia się na jądrze z grsec

Post autor: Adam » 19 stycznia 2009, 22:25

Witam, zainstalowałem grsec z paczki
http://www.grsecurity.net/packages.php
http://kernelsec.cr0.org/

Kiedy wykonuję restart to mam:
zrzut_1

Jak wybiorę kernel bez grsec to normalnie system startuje, a jak wybiorę ten z grsec, to coś takiego mi wyskakuje:

zrzut_2

zrzut_3

Co z tym zrobić?

Awatar użytkownika
qbsiu
Beginner
Posty: 491
Rejestracja: 19 marca 2007, 19:47
Lokalizacja: £DZ

Post autor: qbsiu » 19 stycznia 2009, 22:50

Hmmm...
Dyski montowane jako sdXX czy jako hdXX?

Adam
Posty: 45
Rejestracja: 12 sierpnia 2007, 16:46

Post autor: Adam » 19 stycznia 2009, 22:53

A jak to sprawdzić?

EDIT:
Mój grub niedziałający:
title Debian GNU/Linux, kernel 2.6.25.10-1-grsec
root (hd0,0)
kernel /boot/vmlinuz-2.6.25.10-1-grsec root=/dev/hda1 ro
initrd /boot/initrd.img-2.6.25.10-1-grsec

title Debian GNU/Linux, kernel 2.6.25.10-1-grsec (single-user mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.25.10-1-grsec root=/dev/hda1 ro single
initrd /boot/initrd.img-2.6.25.10-1-grsec
Mój grub działający:
title Debian GNU/Linux, kernel 2.6.24-etchnhalf.1-686
root (hd0,0)
kernel /boot/vmlinuz-2.6.24-etchnhalf.1-686 root=/dev/hda1 ro
initrd /boot/initrd.img-2.6.24-etchnhalf.1-686

title Debian GNU/Linux, kernel 2.6.24-etchnhalf.1-686 (single-user mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.24-etchnhalf.1-686 root=/dev/hda1 ro single
initrd /boot/initrd.img-2.6.24-etchnhalf.1-686

Awatar użytkownika
qbsiu
Beginner
Posty: 491
Rejestracja: 19 marca 2007, 19:47
Lokalizacja: £DZ

Post autor: qbsiu » 19 stycznia 2009, 22:53

Kod: Zaznacz cały

cat /etc/fstab
:)

Adam
Posty: 45
Rejestracja: 12 sierpnia 2007, 16:46

Post autor: Adam » 19 stycznia 2009, 22:56

debian:~# uname -a
Linux debian 2.6.24-etchnhalf.1-686 #1 SMP Tue Dec 2 07:56:33 UTC 2008 i686 GNU/Linux
debian:~# cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / ext3 errors=remount-ro 0 1
/dev/hda6 /home ext3 defaults 0 2
/dev/hda5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

Awatar użytkownika
qbsiu
Beginner
Posty: 491
Rejestracja: 19 marca 2007, 19:47
Lokalizacja: £DZ

Post autor: qbsiu » 19 stycznia 2009, 23:01

Na zrzucie ekranu prosi Cię, abyś spróbował z sata czyli sda1, itp.
Ryzyko :D musisz mieć jakieś live cd, itp. Bo jak system nie wstanie, to musisz odpalić z LiveCd, zamontować dysk, zmienić to co teraz zmienisz :-P
Więc... Ja bym spróbował...
1.

Kod: Zaznacz cały

nano /etc/fstab
zamienił z hda1 na sda1, zapisz, wyjdź...
2.

Kod: Zaznacz cały

nano /boot/grub/menu.lst
szukasz wpisu z grsec i zamieniasz:
(tu mój przykład)
kernel /boot/vmlinuz-2.6.26-1-686 root=/dev/hda ro quiet
na...
kernel /boot/vmlinuz-2.6.26-1-686 root=/dev/sda ro quiet
i pamiętaj, żeby nie było, że nie ostrzegałem! A jeżeli budowałeś sobie jajo, to trzeba było włączyć obsługę libata. :)

Adam
Posty: 45
Rejestracja: 12 sierpnia 2007, 16:46

Post autor: Adam » 20 stycznia 2009, 00:00

Tzn. ja z paczki calego grsec zainstalowalem

Kod: Zaznacz cały

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    errors=remount-ro 0       1
/dev/hda6       /home           ext3    defaults        0       2
/dev/hda5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
Tzn. ma to wygladac:

Kod: Zaznacz cały

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/sda1       /               ext3    errors=remount-ro 0       1
/dev/sda6       /home           ext3    defaults        0       2
/dev/sda5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
Tak? Czy jedynie hda1 na sda1?

A tutaj:
kernel /boot/vmlinuz-2.6.25.10-1-grsec root=/dev/hda1 ro
na:
kernel /boot/vmlinuz-2.6.25.10-1-grsec root=/dev/sda1 ro
Czy:
kernel /boot/vmlinuz-2.6.25.10-1-grsec root=/dev/sda ro


[Dodano: 2009-01-20, 00:28]
Zamienilem tylko hda1 na sda1 w /etc/fstab i tak samo w grubie.

Po zmianie wyrzucilo mi:

Kod: Zaznacz cały

Tue Jan 20 00:20:30 2009

fsck 1.41.3 (12-Oct-2008)
fsck.ext3: No such file or directory while trying to open /dev/hda6
/dev/hda6:
The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

fsck died with exit status 8

Tue Jan 20 00:20:30 2009
i napisalo, ze mam naprawic system plikow recznie i odpalilo jakis ,,maintrance shell'' i pozwolilo sie zalogowac na konto roota. Wiec zalogowalem sie i przywrocilem ale w tym ,,maintrance shell'' mialem:

Kod: Zaznacz cały

Linux debian 2.6.25.10-1-grsec #1 SMP Wed Jul 9 14:56:51 CEST 2008 i686 GNU/Linux
to chyba da sie jakos naprawic zeby dzialalo normalnie z tym kernelem?

A co do tego bledu:

Kod: Zaznacz cały

debian:~# cat /etc/fstab | grep hda6
/dev/hda6       /home           ext3    defaults        0       2

Awatar użytkownika
qbsiu
Beginner
Posty: 491
Rejestracja: 19 marca 2007, 19:47
Lokalizacja: £DZ

Post autor: qbsiu » 20 stycznia 2009, 08:00

Partycje / i /home zamień na sdXX. A w grubie zobacz jak było... Jeżeli było hda to zamień na sda, jeżeli było hda1 to zamień na sda1. Chociaż 1 sposób wydaje mi się bardziej prawdopodobny.

Adam
Posty: 45
Rejestracja: 12 sierpnia 2007, 16:46

Post autor: Adam » 20 stycznia 2009, 13:01

No teraz sie wszytko odpala, tylko ze nie ma internetu (karta wifi, ta co daja do liveboxa, nie ma jej widocznej).

Jak daje:

Kod: Zaznacz cały

ifconfig eth1 up
to pisze:
ERROR while getting interface flags: Nie ma takiego urzadzenia
a ze zwyklym kernelem (tym starym) to mam:
Begin: Waiting for root file system
i sie nie uruchamia.

A jak dam tak jak bylo (wszedzie hd z sd) to na zwyklym kernelu wszystko dziala znowu (lacznie z ta wifi).

Z tym zeby dzialala ta karta wifi musialem tylko
sciagnac plik z http://zd1211.wiki.sourceforge.net

Kod: Zaznacz cały

tar jxvf zd1211-firmware-1.4.tar.bz2
sudo mv zd1211-firmware /lib/firmware/zd1211
I pod tym z ,,grsec'' sa tam te pliki w /lib/firmware/zd1211 dalej i w /etc/network/interfaces jest wpisana siec, wiec nie wiem czemu nie dziala siec, pod grsec.

ODPOWIEDZ