debian 10.11 phpmyadmin nie widzi php.ini po upgrade apache2 do 2.4.52

Konfiguracja serwerów, usług, itp.
goska_23
Beginner
Posty: 277
Rejestracja: 04 września 2007, 13:40
Lokalizacja: Katowice

debian 10.11 phpmyadmin nie widzi php.ini po upgrade apache2 do 2.4.52

Post autor: goska_23 »

Czy da się coś zrobić, żeby phpmyadmin w wersji 5.2.0 widział ustawienia w php.ini PHP 7.3.33 potrzebne do importu dużych baz danych?

Mam debiana 10.11 i w marcu 2022 zrobiłam upgrade apache do nowszej wersji z wersji 11 wersja 2.4.52 ze względu na luki bezpieczeństwa jakie były opisywane że są w tej starej wersji apache który był standardowo w debianie 10.11.

Przed upgrade apache miałam dobrze skonfigurowane php.ini do importu dużych baz danych i co jakiś czas robiłam import takich baz z backupów do nowo zakładanych baz, phpmyadmin pokazywał poprawnie w zakładce "Import", jaki jest maksymalny rozmiar pliku który mogę zaimportować tak jak wpisałam w php.ini.
Po upgrade apache do 2.4.52 niestety phpmyadmin pokazuje standardowo 2,048KB chociaż w php.ini jest nadal tak samo jak było.

Mam jeszcze multiple php bo mam 4 strony na serwerze w tym jedną starszą, strony chodzą na php7.3 i php7.4 archiwalna starsza na php5.6.
standardowe php to php 7.3 i tak widzi php phpmyadmin.

Nowego debiana 11 nie będę upgradować na tym komputerze bo zwykle przy nowej wersji debiana instaluję "od zera" zapasowy serwer z nową wersją.

Czy da się coś poprawić w tej wersji debiana 10.11 żeby phpmyadmin ponownie importował duże bazy?
goska_23
Beginner
Posty: 277
Rejestracja: 04 września 2007, 13:40
Lokalizacja: Katowice

Re: debian 10.11 phpmyadmin nie widzi php.ini po upgrade apache2 do 2.4.52

Post autor: goska_23 »

Z linii poleceń serwera mysql import działa.
Mniej więcej takie polecenie:

Kod: Zaznacz cały

gunzip < databasefile.sql.gz | mysql -u root -p dbname
Ale w phpmyadmin coś się zepsuło.
Awatar użytkownika
LordRuthwen
Moderator
Posty: 2269
Rejestracja: 18 września 2009, 21:45
Lokalizacja: klikash?

Re: debian 10.11 phpmyadmin nie widzi php.ini po upgrade apache2 do 2.4.52

Post autor: LordRuthwen »

W jaki sposób uruchomiony jest php z którego korzystasz? FPM/CGI/bezpośrednio z apache?
goska_23
Beginner
Posty: 277
Rejestracja: 04 września 2007, 13:40
Lokalizacja: Katowice

Re: debian 10.11 phpmyadmin nie widzi php.ini po upgrade apache2 do 2.4.52

Post autor: goska_23 »

Nie rozumiem pytania. Mam multiple php - instalowałam tak z grubsza z jakichś manuali które są w necie.
Główne php na serwerze to php 7.3.
Przy tym multiple php które mam na serwerze od wersji debiana 8 albo 7 - dokładnie nie pamiętam to trzeba było zainstalować to FPM od php. To FPM od PHP czasem muszę zrestartować z linii poleceń jak coś się zawiesza. FPM jest osobno dla każdego php które mam zainstalowane - czyli, że trzeba restartować z linii poleceń FPM dla tego php z którym jest jakiś problem. jak jest problem ze stroną która chodzi na php7.4 to restartuję to FPM7.4.
PHPMyadmin wyświetla w środku, że chodzi na wersji php7.3.

W katalogu /etc/php/7.3 mam podkatalogI:
/apache2
/cli
/fpm
/mods-available

W każdym podkatalogu /apache2, /cli, /fpm, jest osobny plik php.ini.
To co było mi potrzebne do stron www, mysql, phpmyadmin ustawiałam zawsze tak samo w php.ini w każdym z tych trzech podkatalogów.


Te serwery debian przy każdej dużej wersji na przykład debian9 lub debian10 instaluję zawsze "od zera" na czystym dysku.
Awatar użytkownika
LordRuthwen
Moderator
Posty: 2269
Rejestracja: 18 września 2009, 21:45
Lokalizacja: klikash?

Re: debian 10.11 phpmyadmin nie widzi php.ini po upgrade apache2 do 2.4.52

Post autor: LordRuthwen »

Wklej wynik:

Kod: Zaznacz cały

egrep "(post_max_size|upload_max_filesize)" /etc/php/7.3/*/php.ini
ODPOWIEDZ