Problem zależnościami

Konfiguracja serwerów, usług, itp.
xamodoe
Posty: 2
Rejestracja: 18 marca 2019, 14:52

Problem zależnościami

Post autor: xamodoe » 18 marca 2019, 14:59

Trochę namieszałem i teraz mam problemy z którymi sobie nie radzę prośba o pomoc.
Wszystko zaczęło się od dodania repo do najnowszego python-a i a potem lepiej nie pisać...
problem z apt obecnie
Debian 8

cat /etc/apt/sources.list

Kod: Zaznacz cały


#

# deb cdrom:[Debian GNU/Linux 8.1.0 _Jessie_ - Official amd64 NETINST Binary-1 20150606-14:16]/ jessie main non-free

# deb cdrom:[Debian GNU/Linux 8.1.0 _Jessie_ - Official amd64 NETINST Binary-1 20150606-14:16]/ jessie main non-free
#deb http://ftp.de.debian.org/debian testing main
deb http://mirror.unitedcolo.de/debian/ jessie main non-free
deb-src http://mirror.unitedcolo.de/debian/ jessie main non-free

deb http://security.debian.org/ jessie/updates main non-free
deb-src http://security.debian.org/ jessie/updates main non-free

# jessie-updates, previously known as 'volatile'
deb http://mirror.unitedcolo.de/debian/ jessie-updates main non-free
deb-src http://mirror.unitedcolo.de/debian/ jessie-updates main non-free



# jessie-backports, previously on backports.debian.org
deb http://http.debian.net/debian/ jessie-backports main contrib non-free
deb-src http://http.debian.net/debian/ jessie-backports main contrib non-free



sudo apt install -f

Kod: Zaznacz cały


Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  apt
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  apt
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 3251 kB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 ?]

sudo apt upgrade

Kod: Zaznacz cały



Reading package lists... Done
Building dependency tree... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libapt-pkg5.0 : Recommends: apt (>= 1.8.0~rc4) but 1.0.9.8.5 is installed
                 Breaks: apt (< 1.6~) but 1.0.9.8.5 is installed
E: Unmet dependencies. Try using -f.
sudo dpkg --configure -a

Kod: Zaznacz cały



dpkg: dependency problems prevent configuration of apt:
 libapt-pkg5.0:amd64 (1.8.0~rc4) breaks apt (<< 1.6~) and is installed.
  Version of apt to be configured is 1.0.9.8.5.

dpkg: error processing package apt (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 apt

Awatar użytkownika
dedito
Moderator
Posty: 2770
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem zależnościami

Post autor: dedito » 18 marca 2019, 16:42

Jakiego pythona chciałeś mieć i czy jest to dalej aktualne?

xamodoe
Posty: 2
Rejestracja: 18 marca 2019, 14:52

Re: Problem zależnościami

Post autor: xamodoe » 18 marca 2019, 18:34

Pythona już mam

python3.7

Kod: Zaznacz cały

Python 3.7.2+ (default, Feb 27 2019, 15:41:59)
[GCC 8.2.0] on linux
natomiast problemy zostały...

Awatar użytkownika
dedito
Moderator
Posty: 2770
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem zależnościami

Post autor: dedito » 19 marca 2019, 07:11

Debian 8 to już przestarzała wersja, nie lpiej już przejść na 9?

zl23
Posty: 22
Rejestracja: 02 sierpnia 2016, 20:30

Re: Problem zależnościami

Post autor: zl23 » 19 marca 2019, 07:57

1. python3.7 znajduje się dopiero w Debian Buster - a ty masz Jessie.
2. otrzymałeś komunikat:
libapt-pkg5.0 : Recommends: apt (>= 1.8.0~rc4) but 1.0.9.8.5 is installed
apt 1.8.0 występuje dopiero w Debian Buster, natomiast libapt-pkg5.0 w Jessie nie występuje, jest tam za to pakiet libapt-pkg4.12.

Wg mnie podczas instalacji "na siłę" python3.7 zaktualizował do Bustera jeden z pakietów libapt.

Dziwna musiała być ta instalacja pythona3.7 gdyż :
python3.7 wymaga python3.7-minimal
a ten natomiast wymaga libc6 (2.28-8)
https://packages.debian.org/buster/python3.7-minimal
Wersja 2.28 libc6 jest dostępna dopiero w Debian Buster i ono wymaga ... etc.

Spróbuj zobaczyć jakie masz wersje:

Kod: Zaznacz cały

dpkg -l apt
dpkg -l apt-utils
dpkg -l | grep libapt
dpkg -l libc6
Być może wystarczy ściągnąć pakiety apt, apt-utils, libapt-pkg4.12, libapt-inst1.5 z Jessie w wersji 1.0.9.8.5 i zainstalować za pomocą dpkg -i *deb, oraz usunąć pakiet libapt-pkg5.0.

ODPOWIEDZ