[OpenVPN + Samba] - niskie prędkości serwera smb

Konfiguracja serwerów, usług, itp.
poganin
Posty: 6
Rejestracja: 17 lutego 2019, 15:58

[OpenVPN + Samba] - niskie prędkości serwera smb

Post autor: poganin » 18 lutego 2019, 18:00

Dzień Dobry,

Mam sieć VPN opartą na VPS'ie (ArubaCloud), a na niej dodatkowo serwer Samby. Do serwera Samby podłączane okresowo są dwa komputery (jeden z Debianem 9, drugi z Windowsem 7) oraz telefon na androidzie. Problem polega na bardzo wolnym kopiowaniu plików "do" i "z" serwera samby - typowo ok 160kb przy ściąganiu. Czasem mniej, sporadycznie więcej (ale jak już owa sporadyczna sytuacja wystąpi, to ściąga z normalną prędkością). FTP działa normalnie - dlatego chciałbym się dowiedzieć jaka może być tego przyczyna, oraz czy można coś z tym zrobić.


Debian ( z KDE na pokładzie) montuje foldery przy użyciu wbudowanego w Dolphin'a narzędzia do łączenia z Sambą,
Na Windowsie zmapowałem foldery po wpisaniu w pasku adresu przeglądarki plików adresu ip serwera.
Na Androidzie używam jakiejś apki ze sklepu do przeglądania plików, z wbudowaną obsługą samby.

Serwer:

Kod: Zaznacz cały

Linux Weles 4.9.0-8-amd64 #1 SMP Debian 4.9.144-3 (2019-02-02) x86_64 GNU/Linux
config samby:

Kod: Zaznacz cały

[global]
   workgroup = WORKGROUP
   dns proxy = no
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   server role = standalone server
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user
 ;  usershare allow guests = yes
[homes]
   path = /home/%S
   comment = Home Directories
   browseable = no
   read only = no                                                                                                                   
   create mask = 0777                                                                                                               
   directory mask = 0777                                                                                                            
   valid users = %S
   force directory mode = 0777
   force create mode = 0777
[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no

[kaliv]
comment = public anonymous access
path = /home/kamil/kaliv
browsable = yes
create mask = 0777
directory mask = 0777
writable = yes
guest ok = yes
force directory mode = 0777
force create mode = 0777
map to guest = Bad User

[Nawia]
comment = public
path = /home/kamil/Nawia
browsable = yes
create mask = 0777
directory mask = 0777
writable = yes
guest ok = yes
force directory mode = 0777
force create mode = 0777
map to guest = Bad User
Mam już jakiś czas linuksa, ale wciąż się uczę wszystkiego. Próbowałem kombinować z plikiem konfiguracyjnym samby i różnymi opcjami (przeglądając MAN'a od jego configa), ale nic nie udało się poprawić. Szukałem też jakichś informacji na internecie, znajdowałem podobne problemy, jednak nie znalazłem rozwiązania, które by i mi pomogło - proszę więc w związku z tym kolegów (i koleżanki, jeśli jakieś tu są) o pomoc.

Pozdrawiam

poganin
Posty: 6
Rejestracja: 17 lutego 2019, 15:58

Re: [OpenVPN + Samba] - niskie prędkości serwera smb

Post autor: poganin » 26 lutego 2019, 18:02

Nikt nie ma żadnej propozycji, podpowiedzi? :/

ODPOWIEDZ