[+]Samba - foldery z polskimi znakami mają dziwne nazwy

Konfiguracja serwerów, usług, itp.
jack1142
Posty: 6
Rejestracja: 09 grudnia 2017, 17:06

[+]Samba - foldery z polskimi znakami mają dziwne nazwy

Post autor: jack1142 » 09 grudnia 2017, 17:11

Witam,
mam zainstalowany na serwerze domowym Debian Jessie. Zainstalowałem ostatnio sambę i wszystko mam już skonfigurowane, ale nie wiem, co zrobić, żeby foldery z polskimi znakami się normalnie pokazywały w Windowsie.
Tak wygląda to obecnie:
Obrazek
Jak widać foldery z polskimi znakami (w tym przypadku z literą "ę") mają nazwy tj: "Z6ZISX~M", "Z7ER8S~M", "Z26RVC~U", itd.
Jak to naprawić? :(

Awatar użytkownika
marcin1982
Moderator
Posty: 1721
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Samba - foldery z polskimi znakami mają dziwne nazwy

Post autor: marcin1982 » 09 grudnia 2017, 17:30

Ustaw taką opcję w pliku smb.conf:

Kod: Zaznacz cały

dos charset = 852
Zrestartuj demony samby.

Awatar użytkownika
lizard
Beginner
Posty: 257
Rejestracja: 08 lutego 2016, 18:47

Re: Samba - foldery z polskimi znakami mają dziwne nazwy

Post autor: lizard » 09 grudnia 2017, 17:40

Pokaż zawartość /etc/default/locale i /etc/samba/smb.conf.

jack1142
Posty: 6
Rejestracja: 09 grudnia 2017, 17:06

Re: Samba - foldery z polskimi znakami mają dziwne nazwy

Post autor: jack1142 » 09 grudnia 2017, 19:14

Zawartość /etc/default/locale:

Kod: Zaznacz cały

LANG=pl_PL.UTF-8
LC_CTYPE="pl_PL.UTF-8"
LC_NUMERIC="pl_PL.UTF-8"
LC_TIME="pl_PL.UTF-8"
LC_COLLATE="pl_PL.UTF-8"
LC_MONETARY="pl_PL.UTF-8"
LC_MESSAGES="pl_PL.UTF-8"
LC_PAPER="pl_PL.UTF-8"
LC_NAME="pl_PL.UTF-8"
LC_ADDRESS="pl_PL.UTF-8"
LC_TELEPHONE="pl_PL.UTF-8"
LC_MEASUREMENT="pl_PL.UTF-8"
LC_IDENTIFICATION="pl_PL.UTF-8"
LC_ALL=pl_PL.UTF-8
Zawartość /etc/samba/smb.conf

Kod: Zaznacz cały

[global]
   dos charset = 852
   unix charset = UTF8
   display charset = UTF8
   workgroup = WORKGROUP
   server string = %h server
   dns proxy = no
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog only = no
   syslog = 0

   panic action = /usr/share/samba/panic-action %d

   security = user
   encrypt passwords = true
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes

   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user

   load printers = no

[dietpi]
   comment = DietPi Share
   path = /mnt/10F3-3464
   browseable = yes
   create mask = 0775
   directory mask = 0775
   valid users = root
   writeable = yes
I tak, jakby ktoś nie zauważył, to borykam się też z brakiem polskich znaków w SSH i bezpośrednio w konsoli tty też.

Awatar użytkownika
marcin1982
Moderator
Posty: 1721
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Samba - foldery z polskimi znakami mają dziwne nazwy

Post autor: marcin1982 » 09 grudnia 2017, 19:26

Pokaż wynik polecenia:

Kod: Zaznacz cały

locale -a

Kod: Zaznacz cały

localectl status
Jak ustawisz ręcznie to masz polskie znaki?

Kod: Zaznacz cały

loadkeys pl

Kod: Zaznacz cały

setfont lat2-16 -m 8859-2
Sprawdź co pokaże wynik komendy - jako root:

Kod: Zaznacz cały

testparm

jack1142
Posty: 6
Rejestracja: 09 grudnia 2017, 17:06

Re: Samba - foldery z polskimi znakami mają dziwne nazwy

Post autor: jack1142 » 09 grudnia 2017, 19:31

Wyniki poleceń:
Obrazek
A gdy wpisuję setfont, to wyrzuca błąd:

Kod: Zaznacz cały

mapscrn: nie można otworzyć pliku mapy _8859-2_
I czemu w sumie 8859-2, skoro to jest dla ISO, a wszystko mam w UTF-8? Choć setfont z wariantem utf-8,utf8,UTF8 i UTF-8 i tak nie działa :p
EDIT: dla testparm dostaję informację:

Kod: Zaznacz cały

Load smb config files from /etc/samba/smb.conf
Unknown parameter encountered: "display charset"
Ignoring unknown parameter "display charset"
Processing section "[dietpi]"
Loaded services file OK.
Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions

Awatar użytkownika
marcin1982
Moderator
Posty: 1721
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Samba - foldery z polskimi znakami mają dziwne nazwy

Post autor: marcin1982 » 09 grudnia 2017, 20:26

I czemu w sumie 8859-2, skoro to jest dla ISO, a wszystko mam w UTF-8?
Kontrolnie ...

U siebie mam tak i działa:

Kod: Zaznacz cały

# cat console-setup 
# CONFIGURATION FILE FOR SETUPCON
# Consult the console-setup(5) manual page.
ACTIVE_CONSOLES="/dev/tty[1-6]"
CHARMAP="UTF-8"
CODESET="Lat2"
FONTFACE="Fixed"
FONTSIZE="8x16"
VIDEOMODE=
# The following is an example how to use a braille font
# FONT='lat9w-08.psf.gz brl-8x8.psf'

Kod: Zaznacz cały

# cat keyboard 
# KEYBOARD CONFIGURATION FILE
# Consult the keyboard(5) manual page.
XKBMODEL="pc105"
XKBLAYOUT="pl"
XKBVARIANT="legacy"
XKBOPTIONS=""
BACKSPACE="guess"

Kod: Zaznacz cały

# cat locale
#  File generated by update-locale
LANG="pl_PL.UTF-8"

jack1142
Posty: 6
Rejestracja: 09 grudnia 2017, 17:06

Re: Samba - foldery z polskimi znakami mają dziwne nazwy

Post autor: jack1142 » 09 grudnia 2017, 23:22

Mam dokładnie tak samo, ale mi niestety nie działa :(

Awatar użytkownika
lizard
Beginner
Posty: 257
Rejestracja: 08 lutego 2016, 18:47

Re: Samba - foldery z polskimi znakami mają dziwne nazwy

Post autor: lizard » 10 grudnia 2017, 11:37

Pokaż wynik polecenia:

Kod: Zaznacz cały

aptitude search '?section(localization) ~i'
Masz zainstalowane pakiety: console-setup i console-setup-linux?

jack1142
Posty: 6
Rejestracja: 09 grudnia 2017, 17:06

Re: Samba - foldery z polskimi znakami mają dziwne nazwy

Post autor: jack1142 » 10 grudnia 2017, 12:01

Wynik polecenia:
Obrazek
Mam zainstalowane te pakiety.
Tak swoją drogą - może to coś pomoże - terminal normalnie pokazuje polskie znaki i mogę też je pisać, ale przy komendzie ls ich nie ma.

Zablokowany