konfiguracja posfiksa, nie wysy

Konfiguracja serwerów, usług, itp.
Globals
Posty: 53
Rejestracja: 21 maja 2011, 21:00

konfiguracja posfiksa, nie wysyła i nie odbiera wiadomości

Post autor: Globals » 22 maja 2011, 20:42

Mam problemy z działaniem posfiksa, nie chce wcale odbierać ani wysyłać wiadomości. Poniżej zamieszczam swój konfig i polecenie:

Kod: Zaznacz cały

telnet pss-spolem.pl 25

Kod: Zaznacz cały

+OK Dovecot ready.

Kod: Zaznacz cały

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.
mydomain = pss-spolem.pl
myhostname = pss-spolem.pl
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydestination = $mydomain, $myhostname, localhost, localhost.localdomain, pss-spolem.pl
mynetworks = 127.0.0.0/8 192.168.1.0/24
inet_protocols = all
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
Udało skonfigurować postfiksa tak żeby odbierał pocztę ale w czasie wysyłania przez Thunderbirda wyświetla się błąd:

Kod: Zaznacz cały

Wystąpił błąd podczas wysyłania wiadomości: Serwer pocztowy wysłał nieprawidłowe powitanie: Cannot connect to SMTP server 89.171.233.2 (89.171.233.2:465), connect error 10061.
Proszę o pomoc.

Awatar użytkownika
adasiek_j
Beginner
Posty: 141
Rejestracja: 24 kwietnia 2010, 22:24
Lokalizacja: Warszawa

Post autor: adasiek_j » 22 maja 2011, 21:38

Kod: Zaznacz cały

adasiek@sea-star:~$ telnet pss-spolem.pl 465
Trying 89.171.233.2...
telnet: Unable to connect to remote host: Connection refused
Nic nie nasłuchuje na tym porcie, więc Mozilla nie może się połączyć. tcp/465 to SMTP + SSL, być może po prostu zmień w Thunderbird port na 25 dla SMTP, powinno zadziałać. W końcu SSL nie jest niezbędne dla maili. Ale tutaj uwaga! Jeśli będziesz łączoł się z Neostrady, to najprawdopodobniej natrafisz na blokadę połączeń na port 25 przez TPSA (wprowadzona jakiś czas temu - patrz: http://forum.suse.pl/index.php/topic,22133.0.html
W sumie to najlepiej byłoby włączyć port 587, który nie jest blokowany przez TPSA, poprzez edycję pliku /etc/postfix/master.cf

Kod: Zaznacz cały

cs:/etc/postfix# cat master.cf 
#
# Postfix master process configuration file.  For details on the format
# of the file, see the master(5) manual page (command: "man 5 master").
#
# Do not forget to execute "postfix reload" after editing this file.
#
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       -       -       -       smtpd
################
#
# dodatkowy port
#
587       inet  n       -       -       -       -       smtpd
pozdrawiam,
Adam

Globals
Posty: 53
Rejestracja: 21 maja 2011, 21:00

Post autor: Globals » 22 maja 2011, 21:55

To było w porządku ale kolejny błąd:

Kod: Zaznacz cały

Wystąpił błąd podczas wysyłania wiadomości. Odpowiedź serwera: 5.7.1 <XXXXXX@interia.pl>: Relay access denied. Sprawdź adresata wiadomości (XXXXXXXX@interia.pl), a następnie ponów próbę.
A jeszcze pytanie, czy konieczne jest zainstalowanie binda jak mam wykupioną domenę?

Awatar użytkownika
adasiek_j
Beginner
Posty: 141
Rejestracja: 24 kwietnia 2010, 22:24
Lokalizacja: Warszawa

Post autor: adasiek_j » 22 maja 2011, 22:27

Serwer NIE jest Open Relay, trzeba SMPT-AUTH ustawić, odsyłam do wujka Google, jest tego pełno. A co do binda, to jeśli chcesz, aby domena X, którą wykupiłeś, była obsługiwana przez Twój serwer jako NS, to TAK. Ale jeśli jako NS masz cokolwiek innego, to nie musisz.

* NS- Name server (czyli serwer, który obsługuje nazwy dla danej domeny)

Adam

Globals
Posty: 53
Rejestracja: 21 maja 2011, 21:00

Post autor: Globals » 23 maja 2011, 16:43

jeszcze raz teraz dostaje taki komunikat jak chce wysłać pocztę na onet
Wystąpił błąd podczas wysyłania wiadomości. Odpowiedź serwera: 5.7.1 <Globals@poczta.onet.pl>: Relay access denied. Sprawdź adresata wiadomości (Globals@poczta.onet.pl), a następnie ponów próbę

Awatar użytkownika
adasiek_j
Beginner
Posty: 141
Rejestracja: 24 kwietnia 2010, 22:24
Lokalizacja: Warszawa

Post autor: adasiek_j » 23 maja 2011, 17:26

A moja odpowiedź jest identyczna jak poprzednio.

Adam

Globals
Posty: 53
Rejestracja: 21 maja 2011, 21:00

Post autor: Globals » 23 maja 2011, 19:42

Dobrze, już zrobiłem według tego opisu https://help.ubuntu.com/community/Postfix ale Thunderbird

Kod: Zaznacz cały

Logowanie na serwerze smtp.pss-spolem.pl nie powiodło się.
I każe wprowadzić hasło. Wiem, że wpisuję na 100%. Kawałek logu przedstawiam.

Kod: Zaznacz cały

May 23 19:37:20 debian postfix/smtpd[12740]: warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied
May 23 19:37:20 debian postfix/smtpd[12740]: warning: SASL authentication failure: Password verification failed
May 23 19:37:20 debian postfix/smtpd[12740]: warning: adkw215.neoplus.adsl.tpnet.pl[79.185.0.215]: SASL PLAIN authentication failed: generic failure
May 23 19:37:20 debian postfix/smtpd[12740]: warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied
May 23 19:37:20 debian postfix/smtpd[12740]: warning: adkw215.neoplus.adsl.tpnet.pl[79.185.0.215]: SASL LOGIN authentication failed: generic failure
May 23 19:39:01 debian postfix/smtpd[12740]: lost connection after AUTH from adkw215.neoplus.adsl.tpnet.pl[79.185.0.215]
May 23 19:39:01 debian postfix/smtpd[12740]: disconnect from adkw215.neoplus.adsl.tpnet.pl[79.185.0.215]
May 23 19:40:06 debian postfix/anvil[12743]: statistics: max connection rate 6/60s for (587:79.185.0.215) at May 23 19:33:23
May 23 19:40:06 debian postfix/anvil[12743]: statistics: max connection count 4 for (587:79.185.0.215) at May 23 19:33:23
May 23 19:40:06 debian postfix/anvil[12743]: statistics: max cache size 1 at May 23 19:30:06

Awatar użytkownika
adasiek_j
Beginner
Posty: 141
Rejestracja: 24 kwietnia 2010, 22:24
Lokalizacja: Warszawa

Post autor: adasiek_j » 23 maja 2011, 20:11

Coś jednak nie tak robisz, bo:

Kod: Zaznacz cały

warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied
Szczerze - bez dostępu do serwera niewiele pomogę.
Adam

ODPOWIEDZ