Konfiguracja binda

Konfiguracja serwerów, usług, itp.
bertini86
Posty: 8
Rejestracja: 28 października 2008, 19:12

Konfiguracja binda

Post autor: bertini86 » 28 października 2008, 19:50

Witam wszystkich. Jestem początkujący jeśli chodzi o Debiana, nie udało mi się znaleźć odpowiedzi na mój problem w wyszukiwarce, więc piszę. Sytuacja ma się następująco: Na Win XP mam zainstalowanego VirtualBoxa + Debiana, a na nim serwer Bind + DHCP. Skonfigurowałem DNS-a wg poradnika zamieszczonego na forum i książki 'Debian Linux 3.1' Heliona, niby wszystko działa, ale w syslogu wyrzuca mi komunikaty:

Kod: Zaznacz cały

Oct 28 20:09:49 localhost named[2882]: starting BIND 9.3.4-P1.1 -u bind -t /var/lib/named
Oct 28 20:09:49 localhost named[2882]: found 1 CPU, using 1 worker thread
Oct 28 20:09:49 localhost named[2882]: loading configuration from '/etc/bind/named.conf'
Oct 28 20:09:49 localhost named[2882]: listening on IPv4 interface lo, 127.0.0.1#53
Oct 28 20:09:49 localhost named[2882]: listening on IPv4 interface eth1, 192.168.1.100#53
Oct 28 20:09:49 localhost named[2882]: listening on IPv4 interface eth2, 192.168.0.213#53
Oct 28 20:09:49 localhost named[2882]: /etc/bind/named.conf.options:9: using specific query-source port suppresses port randomization and can $Oct 28 20:09:49 localhost named[2882]: /etc/bind/named.conf.options:9: using specific query-source port suppresses port randomization and can $Oct 28 20:09:49 localhost named[2882]: command channel listening on 127.0.0.1#953
Oct 28 20:09:49 localhost named[2882]: command channel listening on ::1#953
Oct 28 20:09:49 localhost named[2882]: zone 0.in-addr.arpa/IN: loaded serial 1
Oct 28 20:09:49 localhost named[2882]: zone 127.in-addr.arpa/IN: loaded serial 1
[color=blue][u]Oct 28 20:09:49 localhost named[2882]: /etc/bind/1.168.192:4: SOA record not at top of zone (1.168.192.IN-ADDR.ARPA.1.168.192.IN-ADDR.ARPA)
Oct 28 20:09:49 localhost named[2882]: zone 1.168.192.IN-ADDR.ARPA/IN: loading master file /etc/bind/1.168.192: not at top of zone[/u][/color]
Oct 28 20:09:49 localhost named[2882]: zone 255.in-addr.arpa/IN: loaded serial 1
Oct 28 20:09:49 localhost named[2882]: zone localhost/IN: loaded serial 1
Oct 28 20:09:49 localhost named[2882]: zone malafirma.pl/IN: loaded serial 2008102602
Oct 28 20:09:49 localhost named[2882]: running
Chodzi mi o ten nieszczęsny komunikat: "/etc/bind/1.168.192:4: SOA record not at top of zone (1.168.192.IN-ADDR.ARPA.1.168.192.IN-ADDR.ARPA)", nie wiem czy ten komunikat to poważny błąd czy nie.

Pliki konfiguracyjne: /etc/bind/named.conf.local

Kod: Zaznacz cały

zone "malafirma.pl" IN {
        type master;
        file "/etc/bind/malafirma.pl";
        allow-query { any; };
        allow-update { none; };
        allow-transfer { none; };
};

zone "1.168.192.IN-ADDR.ARPA" IN {
        type master;
        file "/etc/bind/1.168.192";
        allow-query { any; };
        allow-update { none; };
        allow-transfer { none; };

};
/etc/bind/named.conf.options

Kod: Zaznacz cały

options {
        directory "/etc/bind";
        recursion no;
        statistics-file "/etc/bind/bind.stats";
        dump-file "/etc/bind/bind.dump";
        zone-statistics yes;
        notify yes;
        transfer-format many-answers;
        query-source address * port 53;
        transfer-source * port 53;
        notify-source * port 53;
        forwarders {
                194.204.159.1;
                194.204.152.34;
        };
        auth-nxdomain yes;
        listen-on { any; };
        listen-on-v6 { none; };
};
/etc/bind/malafirma.pl

Kod: Zaznacz cały

$TTL 604800
$ORIGIN malafirma.pl.

@ IN SOA komputer1.malafirma.pl. root.malafirma.pl. (
            2008102602       ; Serial
            10800            ; Refresh
            3600             ; Retry
            86400            ; Expire
            3600 )           ; Negative Cache TTL

               IN    NS   komputer1.malafirma.pl.
komputer1       IN    A    192.168.1.100
               IN    MX    10    mail
mail            IN    A    192.168.1.100
@               IN    A    192.168.1.100
www             IN    A    192.168.1.100
ftp             IN    A    192.168.1.100
/etc/bind/1.168.192

Kod: Zaznacz cały

$TTL 604800
;$ORIGIN malafirma.pl.

1.168.192.IN-ADDR.ARPA IN SOA komputer1.malafirma.pl. root.malafirma.pl. (
            2008102602       ; Serial
            10800            ; Refresh
            3600             ; Retry
            86400            ; Expire
            3600 )           ; Negative Cache TTL

                IN    NS   komputer1.malafirma.pl.
100             IN    PTR  komputer1.malafirma.pl.
100             IN    PTR  mail.malafirma.pl.
100             IN    PTR  [url]www.malafirma.pl[/url].
100             IN    PTR  ftp.malafirma.pl.

Jeśli chodzi o konfigurację serwera, to chcę postawić na jednej maszynie wszystko co tylko mi się uda: dns, dhcp, www, ftp i serwer pocztowy (mniejsza o sens, żeby działało i można było poćwiczyć ;-) ). Adres IP wszystkiego to 192.168.1.100/24 i jeśli możecie to powiedzcie czy dobrze skonfigurowałem wszystkie te pliki. Pozdrawiam

Lukeman
Posty: 19
Rejestracja: 19 lutego 2008, 23:08

Post autor: Lukeman » 12 listopada 2008, 02:25

spróbuj dodać kropkę po

Kod: Zaznacz cały

1.168.192.IN-ADDR.ARPA
w trzeciej linijce pliku /etc/bind/1.168.192. Ostatecznie powinno to wyglądać tak:

Kod: Zaznacz cały

$TTL 604800
;$ORIGIN malafirma.pl.

1.168.192.IN-ADDR.ARPA. IN SOA komputer1.malafirma.pl. root.malafirma.pl. (
            2008102602       ; Serial
            10800            ; Refresh
            3600             ; Retry
            86400            ; Expire
            3600 )           ; Negative Cache TTL

                IN    NS   komputer1.malafirma.pl.
100             IN    PTR  komputer1.malafirma.pl.
100             IN    PTR  mail.malafirma.pl.
100             IN    PTR  [url]www.malafirma.pl[/url].
100             IN    PTR  ftp.malafirma.pl. 

ODPOWIEDZ