Problem z instalacją pakietów

Konfiguracja serwerów, usług, itp.
Kisiolpl
Posty: 2
Rejestracja: 29 listopada 2019, 18:46

Problem z instalacją pakietów

Post autor: Kisiolpl » 29 listopada 2019, 18:47

Witam jestem nowy i zielony.
w instrukcji mam takie kod
i gdzieś jest błąd. ale gdzie?

Kod: Zaznacz cały

apt-get update && apt-get upgrade && apt-get install nano wget curl screen sudo unzip && sudo apt-get update && sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF&&  sudo echo "deb http://download.mono-project.com/repo/debian stable-jessie main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list && sudo apt-get update &&  sudo apt-get install mono-devel && rm /etc/apt/sources.list && sudo sh -c "echo 'deb http://ftp.debian.org/debian jessie main contrib non-free' >> /etc/apt/sources.list" && sudo sh -c "echo 'deb http://ftp.debian.org/debian jessie-updates main contrib non-free' >> /etc/apt/sources.list" && sudo sh -c "echo 'deb http://security.debian.org jessie/updates main contrib non-free' >> /etc/apt/sources.list" && sudo sh -c "echo 'deb http://www.deb-multimedia.org jessie main non-free' >> /etc/apt
Ostatnio zmieniony 29 listopada 2019, 22:58 przez Kisiolpl, łącznie zmieniany 1 raz.

Awatar użytkownika
dedito
Moderator
Posty: 2985
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Pomocy

Post autor: dedito » 29 listopada 2019, 19:40

W jakiej instrukcji i jaki błąd?
Przy okazji stosuj znaczniki kodu i tytuł posta powinien nawiązywać do problemu. Popraw.

Kisiolpl
Posty: 2
Rejestracja: 29 listopada 2019, 18:46

Re: Pomocy

Post autor: Kisiolpl » 29 listopada 2019, 22:56

ma to być bot do ts.
jak wklejam to w putty to zamiast instalować to wyskakuje ">"

Kod: Zaznacz cały

root@vps:~# apt-get update && apt-get upgrade && apt-get install nano wget curl screen sudo unzip && sudo apt-get update && sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF&&  sudo echo "deb http://download.mono-project.com/repo/debian stable-jessie main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list && sudo apt-get update &&  sudo apt-get install mono-devel && rm /etc/apt/sources.list && sudo sh -c "echo 'deb http://ftp.debian.org/debian jessie main contrib non-free' >> /etc/apt/sources.list" && sudo sh -c "echo 'deb http://ftp.debian.org/debian jessie-updates main contrib non-free' >> /etc/apt/sources.list" && sudo sh -c "echo 'deb http://security.debian.org jessie/updates main contrib non-free' >> /etc/apt/sources.list" && sudo sh -c "echo 'deb http://www.deb-multimedia.org jessie main non-free' >> /etc/apt

Awatar użytkownika
dedito
Moderator
Posty: 2985
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z instalacją pakietów

Post autor: dedito » 30 listopada 2019, 11:28

Nie podałeś żadnych informacji o własnym systemie.
Te komendy są przeznaczone dla Debiana jessie, więc jeśli masz jessie to rób te komendy poklei.
Te znaczki && rozdzielają komendy i warunkują wykonanie następnej od wyniku poprzedniej.
Zestaw krok po kroku.
Wszystko robisz jako root.
Ale ostrzegam, mnie się ta procedura zastąpienia sources.list nie podoba, nie rozumiem jaki ma to sens.
Oszczędź nam analizy śledczej i zacznij podawać kompletne informacje.

Kod: Zaznacz cały

apt-get update
apt-get upgrade
apt-get install nano wget curl screen sudo unzip
sudo apt-get update
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
sudo echo "deb http://download.mono-project.com/repo/debian stable-jessie main" | sudo tee /etc/apt/sources.list.d/mono-official-stable.list
sudo apt-get update
sudo apt-get install mono-devel
rm /etc/apt/sources.list
sudo sh -c "echo 'deb http://ftp.debian.org/debian jessie main contrib non-free' >> /etc/apt/sources.list"
sudo sh -c "echo 'deb http://ftp.debian.org/debian jessie-updates main contrib non-free' >> /etc/apt/sources.list"
sudo sh -c "echo 'deb http://security.debian.org jessie/updates main contrib non-free' >> /etc/apt/sources.list"
sudo sh -c "echo 'deb http://www.deb-multimedia.org jessie main non-free' >> /etc/apt

mariaczi
Member
Posty: 1314
Rejestracja: 08 lutego 2008, 12:58
Lokalizacja: localhost@śląskie

Re: Problem z instalacją pakietów

Post autor: mariaczi » 02 grudnia 2019, 11:53

"Użarty" ma ten zestaw poleceń. Ostatnia linijka i tak się nie wykona. Znów dostanie ">" ;)

Awatar użytkownika
dedito
Moderator
Posty: 2985
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z instalacją pakietów

Post autor: dedito » 02 grudnia 2019, 13:30

Ano faktycznie, nie zauważyłem tego ogona.
Idea została przekazana, więc powinien sobie dać radę :)
Trzeba też chyba użyć `tee` w poleceniach z `echo`.

mariaczi
Member
Posty: 1314
Rejestracja: 08 lutego 2008, 12:58
Lokalizacja: localhost@śląskie

Re: Problem z instalacją pakietów

Post autor: mariaczi » 03 grudnia 2019, 09:59

@dedito "echo" z sudo jest w porządku. W 6-tej linii z Twojego posta jest tak jak piszesz z tee - zabangla prawilnie :) W ostatniej linii zaś sudo jest użyte do wywołania "sh -c" z zestawem komend czyli całość z pomiędzy podwójnego cudzysłowu wykonana zostanie z prawami root'a.

Awatar użytkownika
dedito
Moderator
Posty: 2985
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z instalacją pakietów

Post autor: dedito » 03 grudnia 2019, 10:49

Ok rozbiłem ten łańcuch poleceń, teraz widzę w końcu to "użarcie" w ostatniej linijce :)

ODPOWIEDZ