Sterowniki Nvidia i brak internetu

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
Orion
Posty: 30
Rejestracja: 13 marca 2008, 00:08
Lokalizacja: £ód¼

Sterowniki Nvidia i brak internetu

Post autor: Orion » 25 sierpnia 2008, 23:04

Witam
Być może ktoś się już spotkał z takim dziwnym problemem. Mam jądro 2.6.25-2-486 oraz Debiana Lenny. Wcześniej zaktualizowałem go z Etcha. Po głównej konfiguracji instaluję sterowniki nvidia wg poradnika Kaki. Następuje pytanie czy ręcznie czy automatycznie skonfigurować plik xorg. Robię ręcznie. Zmieniam w jednej z sekcji, gdzie jest driver "nv" na "nvidia", hashuję "dri" oraz "GLcore". Restartuję komputer, ekran nvidia, pulpit. Chcę ściągnąć mesa-utils. A on nic. Sprawdzam ping i tu kicha. Brak neta. Polecenia ifconfig up i down nie pomogły niestety. Zatem zabieram się za modyfikację xorg. Patrzę wszystko i zmieniam "nvidia" na "nv". Restart komputera i o dziwo sieć działa.
Powiem, iż zdarza mi się to już drugi raz na tym komputerze. Poprzednim razem pomogła aktualizacja jądra do nowszej wersji, ale w repo nie ma jeszcze 2.6.26, ani żadnego z linii 2.6.25-x-x. Z kompilacją się jeszcze nie bawiłem.

Jaka jest wasza opinia na ten temat?

Awatar użytkownika
davidoski
Beginner
Posty: 234
Rejestracja: 17 kwietnia 2007, 10:53
Lokalizacja: Poznań

Post autor: davidoski » 26 sierpnia 2008, 02:53

Spróbuj dać automatyczną konfigurację xorga przez instalator nvidii. Też mam kartę tej firmy i z xorgiem nie mam problemów - zawsze daję automatyczną konfigurację. Potem i tak możesz sobie wszystko poustawiać w Nvidia Settings, więc po co się męczyć ręcznie.

PhockouS

Post autor: PhockouS » 26 sierpnia 2008, 09:34

Spróbuj może zainstalować najnowsze sterowniki beta, być może pomoże.

Orion
Posty: 30
Rejestracja: 13 marca 2008, 00:08
Lokalizacja: £ód¼

Post autor: Orion » 26 sierpnia 2008, 12:23

Wiesz, z automatyczną też poprzednim razem zrobiłem i tylko wymiana xorga pozwalała mi korzystać z internetu. Wtedy to było uaktualnienie jądra do nowszej wersji i to pomogło.

Awatar użytkownika
ilin
Senior Member
Posty: 2288
Rejestracja: 26 sierpnia 2007, 11:54
Lokalizacja: PRLu

Post autor: ilin » 26 sierpnia 2008, 14:19

Co ma xorg do internetu?

Można xów wcale nie miec i korzystać z internetu.
Gzie tu logika.

Trzeba się zatanowic dlaczego nie działa jak nie działa anie zwalać winę na nvidię.
Ona nic do tego nie ma.

Orion
Posty: 30
Rejestracja: 13 marca 2008, 00:08
Lokalizacja: £ód¼

Post autor: Orion » 26 sierpnia 2008, 16:19

No to dziwne, czemu po zmianie właśnie "nv" na "nvidia" nie mam neta, a jak zmienie "nvidia" na "nv" to nagle mam :P Troszkę mnie to irytuje i nie wiem, jak to rozwiązać :(

Awatar użytkownika
ilin
Senior Member
Posty: 2288
Rejestracja: 26 sierpnia 2007, 11:54
Lokalizacja: PRLu

Post autor: ilin » 26 sierpnia 2008, 16:26

Może opiszesz jak ten net konfigurowales.
W jaki sposob jest dostarczany.

Wtedy można coś więcej powiedzieć.

Orion
Posty: 30
Rejestracja: 13 marca 2008, 00:08
Lokalizacja: £ód¼

Post autor: Orion » 26 sierpnia 2008, 17:01

Internet mam w Toya z własnym modem, dzięki czemu mam cały czas dostęp do neta. Net działał zaraz po włożeniu i rozpoczęciu netinstalki debian.
Oto zrzut dwóch xorg. Jeden utworzony przez nvidia, drugi przeze mnie z poleceń:

Kod: Zaznacz cały

X -config
oraz

Kod: Zaznacz cały

dpkg-reconfigure xserver-xorg
i lekko zmodyfikowany, jako że sam xserver po instalacji nie miał ochoty tego zrobić.

Kod: Zaznacz cały

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"pl"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
EndSection
Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	RgbPath      "/etc/X11/rgb"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/X11/misc"
	FontPath     "/usr/share/fonts/X11/cyrillic"
	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath     "/usr/share/fonts/X11/Type1"
	FontPath     "/usr/share/fonts/X11/100dpi"
	FontPath     "/usr/share/fonts/X11/75dpi"
	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load  "xtrap"
	Load  "extmod"
	Load  "GLcore"
	Load  "record"
	Load  "dbe"
	Load  "glx"
	Load  "dri"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"pl"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
	#DisplaySize	  330   240	# mm
	Identifier   "Monitor0"
	VendorName   "CPQ"
	ModelName    "COMPAQ P720"
 ### Comment all HorizSync and VertRefresh values to use DDC:
	HorizSync    31.0 - 96.0
	VertRefresh  55.0 - 160.0
	Option	    "DPMS"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: [i]: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "UseFBDev"           	# [<bool>]
        #Option     "Rotate"             	# [<str>]
        #Option     "VideoKey"           	# [i]
        #Option     "FlatPanel"          	# [<bool>]
        #Option     "FPDither"           	# [<bool>]
        #Option     "CrtcNumber"         	# [i]
        #Option     "FPScale"            	# [<bool>]
        #Option     "FPTweak"            	# [i]
        #Option     "DualHead"           	# [<bool>]
	Identifier  "Card0"
	Driver      "nv"
	VendorName  "nVidia Corporation"
	BoardName   "NV43 [GeForce 6600]"
	BusID       "PCI:2:0:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     4
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     8
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     15
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     16
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Kod: Zaznacz cały

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder57)  Thu Jul 17 18:40:12 PDT 2008

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder57)  Thu Jul 17 18:39:19 PDT 2008

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "COMPAQ P720"
    HorizSync       31.0 - 96.0
    VertRefresh     55.0 - 160.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 6600"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1280x960_85 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Tutaj daję zrzut polecenia lspci:

Kod: Zaznacz cały

00:00.0 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.5 PIC: VIA Technologies, Inc. K8M890CE I/O APIC Interrupt Controller
00:00.6 Host bridge: VIA Technologies, Inc. Device 6290
00:00.7 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:02.0 PCI bridge: VIA Technologies, Inc. K8T890 PCI to PCI Bridge Controller
00:03.0 PCI bridge: VIA Technologies, Inc. K8T890 PCI to PCI Bridge Controller
00:0f.0 IDE interface: VIA Technologies, Inc. VT8237A SATA 2-Port Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237A PCI to ISA Bridge
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 PCI bridge: VIA Technologies, Inc. VT8237A Host Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. VT8237A PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
02:00.0 VGA compatible controller: nVidia Corporation NV43 [GeForce 6600] (rev a2)
04:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller (rev 10)
Proszę zatem o pomoc w tej sprawie.

ODPOWIEDZ