ATI - otwarte i zamknięte sterowniki

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
fnmirk
Senior Member
Posty: 8037
Rejestracja: 03 grudnia 2007, 06:37

Post autor: fnmirk » 04 kwietnia 2008, 23:34

Wklej wynik polecenia:

Kod: Zaznacz cały

lspci

mmario
Posty: 2
Rejestracja: 04 kwietnia 2008, 16:08

Post autor: mmario » 05 kwietnia 2008, 23:37

Już działa, musiałem tylko z innych czyt. poprawnych źródeł zainstalowac.

benterenten
Posty: 25
Rejestracja: 17 marca 2008, 16:25
Lokalizacja: Lublin

Post autor: benterenten » 22 maja 2008, 16:24

siema. Po wisaniu:

Kod: Zaznacz cały

glxinfo | grep direct 
wyswietla cos takiego:

Kod: Zaznacz cały

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Error: unable to open display :0.0
Ponadto mam kopie xorg.config zaraz po skonfigurowaniu skopiowalem go przed inatsalacja kde i tam jest wszystko pieknie:

Kod: Zaznacz cały

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"pl"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
EndSection

Section "Device"
	Identifier	"ATI Technologies Inc RV350 AS [Radeon 9550]"
	Driver		"ati"
	BusID		"PCI:1:0:0"
	VideoRam	262144
EndSection

Section "Monitor"
	Identifier	"MultiSync 75"
	Option		"DPMS"
	HorizSync	31-70
	VertRefresh	55-120
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies Inc RV350 AS [Radeon 9550]"
	Monitor		"MultiSync 75"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection


A teraz wyglada to tak
Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"pl"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
	Option		"UseFBDev"		"true"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
EndSection
Wie ktos o co chodzi i jak to naprawic zeby dalo sie stery jakies zainstalowac. Pozdrawaim

godzio89
Beginner
Posty: 137
Rejestracja: 05 maja 2007, 01:28
Lokalizacja: Grudziądz

Post autor: godzio89 » 20 sierpnia 2008, 22:49

Chcę zainstalować sterowniki Ati. Wpisuje glxinfo | grep direct i pokazuje mi:

Kod: Zaznacz cały

Direct Rendering: No
Wchodze w:

Kod: Zaznacz cały

nano  /etc/X11/xorg.conf
I pokazuje mi:

Kod: Zaznacz cały

Section "Device"
        Identifier      "Generic Video Card"
        Driver          "vesa"
        BusID           "PCI:1:5:0"
EndSection
Więc jakie sterowniki zainstalować?Otwarte czy zamknięte?

Wild
Posty: 22
Rejestracja: 22 września 2008, 23:22

Post autor: Wild » 04 października 2008, 17:08

Po wpisaniu polecenia

Kod: Zaznacz cały

glxinfo | grep direct
wyświetla mi się coś takiego:

Kod: Zaznacz cały

direct rendering: No
OpenGL renderer string: Mesa GLX Indirect
Kaka napisał:
b) Jeśli natomiast wyświetli się direct rendering: No, to oznacza brak uruchomionego przyspieszenia sprzętowego. Sprawdź jakich sterowników używasz. Jeżeli zamkniętych, to zmień na otwarte. Jeżeli otwartych to zmień na zamknięte.
Po otworzeniu pliku /etc/X11/xorg.conf w Section "Device" mam coś takiego:

Kod: Zaznacz cały

Section "Device"
	Identifier	"Generic Video Card"
	Driver		"vesa"
	BusID		"PCI:1:0:0"
W Section "Device" w Driver mam "vesa" na jakie sterowniki mam zamienić ati czy fglrx wg. tego co napisał Kaka:
Powinno tam być: Driver, a zaraz za tym ati lub fglrx. Jeżeli jest tam ati to oznacza to, że korzystasz z wolnych sterowników. Natomiast jeżeli jest tam fglrx, to oznacza to, że używasz zamkniętych sterowników.

Kaka'
Senior Member
Posty: 3019
Rejestracja: 30 lipca 2006, 13:17
Lokalizacja: Kartuzy

Post autor: Kaka' » 04 października 2008, 17:14

wpisz ati

Wild
Posty: 22
Rejestracja: 22 września 2008, 23:22

Post autor: Wild » 04 października 2008, 17:33

Jaki mam zainstalować sterowniki otwarte(ati) czy zamknięte(fglrx) mam kartę Ati Radeon X2500. Jest to karta na laptopie jak sprawdzałem na stronie ati, okazało się, że nie ma sterowników do takiej karty.

Crius
Posty: 3
Rejestracja: 12 października 2008, 18:12

Post autor: Crius » 29 października 2008, 11:14

Witam,

Jestem rowniez szczesliwym posiadaczem 9600 pro. Wzialem sie za instalowanie world of warcraft, wszystko pieknie, nawet sie wlaczyl w jakis magiczny sposob. Filmik intro chodzil mi moze 3 fps a pozniej samo menu ok 5 fps. Nie logowalem sie do gry bo nie bylo sensu, zaczalem wiec grzebac w ustawieniach, w cedega pozmienialem kilka rzeczy i doszlo powiedzmy do 20 fps, wiec jest niezle.

Chcialem przeinstalowac sterowniki, minelo juz sporo czasu i z tego co widze glxinfo nie istnieje, ale za to fglrxinfo i fgl_glxgear sa z innych pakietow. Chcialem sprawdzic czy pokazuje linijke z direct renderingiem, ze sterami w xorg.info sam wow wywala ze nie ma akceleracji 3d, po zmianie na glrx wlacza sie bez problemu, jednak wydajnosc nie jest na tyle dobra a fglrxinfo NIE pokazuje zadnej informacji na temat rederingu, czy to by bylo Yes, czy No nie ma tam tej pierwszej linijki co jest troche dziwne, ale podejrzewam ze dziala, skoro wow sie wlacza. Teraz fgl_glxgear wyswietla mi ok 450 fps, gdzie widzialem u wielu ludzi z ta sama karta ok 1200 fps czasami wyzej, zastanawiam sie czy oplaca mi sie wyszukac jakichs super starych sterownikow, wyzszych niz 8.4 jak ktos wspominal i sprubowac z nimi ? Aktualnie mam zainstalowane najnowsze 8.10, wczesniejsze 8.9 dawalo mi te same rezultaty. Poza tym procek to athlon 1.9 ghz i 1 gb ddr1 400 mhz kingston.

Chcialem oprzec sie o http://debian.linux.pl/viewtopic.php?t=6032
ale niestety informacje o pakietach : fglrx-driver fglrx-kernel-src sa juz raczej nie aktualne, zaden z pakietow zaczynajacych sie na fgl* nie istnieje w moich repozytoriach. Aktualnie korzystam z Debian/lenny 2.6.26-1-686.

Bardzo bym prosil o pomoc, pozniej sprobuje przeslac dokladniejsze dane z roznych komend, ale akktualnie jestem w pracy.

M
Posty: 36
Rejestracja: 07 listopada 2007, 13:50
Lokalizacja: Czêstochowa

Post autor: M » 29 października 2008, 18:39

Ja z kolei walczę z fglrx'em w wersji 8.10 ze strony ati oraz jajkiej 2.6.27.4. Narazie nie nie chula. Ale po kolei...

Próbowałem metodą debianową: aptitude install fglrx-driver a potem m-a a-i fglrx - nie dało rady.
Zassałem źródła ze strony ati, wcześniej kompilując kernel. Następnie próba instalacji sterownika kończy się błędem zapisanym w logu:

Kod: Zaznacz cały

[Message] Kernel Module : Trying to install a precompiled kernel module.
[Message] Kernel Module : Precompiled kernel module version mismatched.
[Message] Kernel Module : Found kernel module build environment, generating kernel module now.
ATI module generator V 2.0
==========================
initializing...
doing Makefile based build for kernel 2.6.x and higher
rm -rf *.c *.h *.o *.ko *.GCC* .??* *.symvers
make -C /lib/modules/2.6.27.4/build SUBDIRS=/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Wejście do katalogu `/usr/src/linux-2.6.27.4'
  CC [M]  /lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘__ke_flush_cache’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2791: error: too many arguments to function ‘smp_call_function’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘__ke_vm_phys_addr_str’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3522: warning: return makes pointer from integer without a cast
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3523: warning: return makes pointer from integer without a cast
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3524: warning: return makes pointer from integer without a cast
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:3526: warning: return makes pointer from integer without a cast
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_enable_pat’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4063: error: too many arguments to function ‘smp_call_function’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function ‘KCL_disable_pat’:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4082: error: too many arguments to function ‘smp_call_function’
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: At top level:
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5774: warning: initialization from incompatible pointer type
/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5800: warning: initialization from incompatible pointer type
make[2]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Błąd 1
make[1]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Błąd 2
make[1]: Opuszczenie katalogu `/usr/src/linux-2.6.27.4'
make: *** [kmod_build] Błąd 2
build failed with return value 2
[Error] Kernel Module : Failed to compile kernel module - please consult readme.
Ma ktoś jakiś pomysł jak zainstalować stery, żeby zbudował się poprawnie moduł fglrx? Pracuję na Debianie/sid z jądrem 2.6.27.4, a sterowniki, które próbuje zainstalować to wersja ATI Proprietary Linux Driver-8.542. Odkąd pamiętam, to zawsze jest problem z instalacją sterowników na nowym kernelu.

Problem został rozwiązany!! :D

Awatar użytkownika
szmergiell
Beginner
Posty: 195
Rejestracja: 20 maja 2008, 00:16
Lokalizacja: Poznań

Post autor: szmergiell » 07 grudnia 2008, 20:38

Witam serdecznie. Mam pewien problem ze sterownikami, tak otwartymi jak i zamkniętymi do ATI.

xorg.conf:

Kod: Zaznacz cały

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
	Identifier  "Generic Keyboard"
	Driver      "kbd"
	Option	    "XkbRules" "xorg"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "pl"
EndSection

Section "InputDevice"
	Identifier  "Configured Mouse"
	Driver      "mouse"
	Option	    "CorePointer"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "ImPS/2"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "true"
EndSection

Section "Monitor"
	Identifier   "Samsung SyncMaster 795DF"
	HorizSync    30.0 - 85.0
	VertRefresh  50.0 - 160.0
	Option	    "DPMS"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "ATI Technologies Inc RS480 [Radeon Xpress 200G Series]"
	Driver      "fglrx"
	BusID       "PCI:1:5:0"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "ati"
	BusID       "PCI:1:5:0"
EndSection

Section "Screen"
	Identifier "Default Screen"
	Device     "ATI Technologies Inc RS480 [Radeon Xpress 200G Series]"
	Monitor    "Generic Monitor"
	DefaultDepth     24
	SubSection "Display"
		Modes    "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection
Najpierw standardowe sprawdzenie, czy mam akcelerację. Sterowniki otwarte ati

Kod: Zaznacz cały

szmergiell@debian:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: DRI R300 Project
OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX+/3DNow!+/SSE2 NO-TCL
OpenGL version string: 1.3 Mesa 7.0.4

Naruszenie ochrony pamięci
szmergiell@debian:~$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, 
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control, 
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory, 
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method, 
    GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control, 
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group, 
    GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method, 
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample, 
    GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group, 
    GLX_EXT_texture_from_pixmap
OpenGL vendor string: DRI R300 Project
OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX+/3DNow!+/SSE2 NO-TCL
OpenGL version string: 1.3 Mesa 7.0.4
OpenGL extensions:
    GL_ARB_fragment_program, GL_ARB_imaging, GL_ARB_multisample, 
    GL_ARB_multitexture, GL_ARB_texture_border_clamp, 
    GL_ARB_texture_compression, GL_ARB_texture_cube_map, 
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine, 
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3, 
    GL_ARB_texture_mirrored_repeat, GL_ARB_texture_rectangle, 
    GL_ARB_transpose_matrix, GL_ARB_vertex_program, GL_ARB_window_pos, 
    GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, 
    GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate, 
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint, 
    GL_EXT_copy_texture, GL_EXT_draw_range_elements, GL_EXT_multi_draw_arrays, 
    GL_EXT_packed_pixels, GL_EXT_polygon_offset, GL_EXT_rescale_normal, 
    GL_EXT_secondary_color, GL_EXT_separate_specular_color, 
    GL_EXT_stencil_two_side, GL_EXT_stencil_wrap, GL_EXT_subtexture, 
    GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp, 
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine, 
    GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias, 
    GL_EXT_texture_mirror_clamp, GL_EXT_texture_object, 
    GL_EXT_texture_rectangle, GL_EXT_vertex_array, GL_APPLE_packed_pixels, 
    GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once, 
    GL_ATIX_texture_env_combine3, GL_IBM_texture_mirrored_repeat, 
    GL_INGR_blend_func_separate, GL_MESA_pack_invert, GL_MESA_ycbcr_texture, 
    GL_NV_blend_square, GL_NV_light_max_exponent, GL_NV_texgen_reflection, 
    GL_NV_texture_rectangle, GL_NV_vertex_program, GL_SGI_color_matrix, 
    GL_SGI_color_table, GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp, 
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x24 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x26 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x27 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x29 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2b 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2c 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x2d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2e 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x2f 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x30 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x31 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x32 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 Slow
0x75 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon
Naruszenie ochrony pamięci
szmergiell@debian:~$ 
Jak widać, obie powyższe komendy dają na koniec "Naruszenie ochrony pamięci". Kiedy włączam OpenArena, wszystko działa OK (tzn. menu bardzo szybko się odświeża), do czasu kiedy wejdę do gry. Tam widać, jakby ktoś zabawił się nożyczkami i poprzeklejał elementy w inne miejsca.

System:
Komputer ze zintegrowaną kartą graficzną ATI, bodajże 1100. 64MB pamięci dzielonej z 512 systemu. System to Debian Sid 32bit z jądrem 2.6.26-1-amd64 ponieważ procesor to Athlon 64 3200+
Szczegóły systemu.

PS Muszę wyjść, ale jak wrócę to opiszę perypetie z instalacją zamkniętych sterowników -- tudzież brakiem takiej możliwości. :p Jeżeli w między czasie jakaś informacja się pojawi, to będę wdzięczny i z przyjemnością przetestuję :D

pzdr

Zablokowany