Usterka Xorg po instalacji sterowników, Wayland działa.

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
larcz
Posty: 38
Rejestracja: 17 sierpnia 2008, 17:23

Usterka Xorg po instalacji sterowników, Wayland działa.

Post autor: larcz » 05 kwietnia 2021, 21:47

Wita.
Zwracam się z następującym problemem. Po próbie zainstalowania sterowników nvidii (która się nie powiodła) nie mogę się zalogować do gnome przy użyciu x11. Wyskakuje błąd i każe się wylogować. Natomiast przy użyciu wayland gnome normalnie startuje. Sterowniki próbowałem zainstalować w celu podłączenia zewnętrznej karty graficznej ale w laptopie (thinkpad x201) jest zintegrowana karta intela. Czy może mnie ktoś pokierować jak to odkręcić?

fnmirk
Senior Member
Posty: 8079
Rejestracja: 03 grudnia 2007, 06:37

Re: Usterka Xorg po instalacji sterowników, Wayland działa.

Post autor: fnmirk » 10 kwietnia 2021, 20:03

Przeczytałem dwa razy, bo myślałem, że coś się stało z moją percepcją?

Spróbuj może napisać, co właściwie nie działa?

Jakieś logi, informacje o wersjach oprogramowania, sprzęcie itp.

larcz
Posty: 38
Rejestracja: 17 sierpnia 2008, 17:23

Re: Usterka Xorg po instalacji sterowników, Wayland działa.

Post autor: larcz » 11 kwietnia 2021, 19:06

System się ładuje (debian stretch) do gdm. Dalej jeżeli wybiorę gnome albo cokolwiek innego to wywala mnie znowu do logowania.
Natomiast jeżeli wybiorę gnome (wayland) to normalnie się uruchamia.
Co do sprzętu to jest to thinkpad x201. Aktualnie działa na wbudowanej karcie graficznej.
Wszystko się zaczęło po próbie instalacji sterowników do karty graficznej. Jakie logi będą najbardziej pomocne?

fnmirk
Senior Member
Posty: 8079
Rejestracja: 03 grudnia 2007, 06:37

Re: Usterka Xorg po instalacji sterowników, Wayland działa.

Post autor: fnmirk » 11 kwietnia 2021, 21:57

Przedstaw wyniki:

Kod: Zaznacz cały

uname -r
lspci -k
cat /etc/apt/sources.list
cat /var/log/Xorg.0.log

larcz
Posty: 38
Rejestracja: 17 sierpnia 2008, 17:23

Re: Usterka Xorg po instalacji sterowników, Wayland działa.

Post autor: larcz » 12 kwietnia 2021, 20:51

Kod: Zaznacz cały

root@x200:/home/larcz# uname -r
4.9.0-15-amd64
root@x200:/home/larcz# lspci -k
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
	Subsystem: Lenovo Core Processor DRAM Controller
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
	Subsystem: Lenovo Core Processor Integrated Graphics Controller
	Kernel driver in use: i915
	Kernel modules: i915
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
	Subsystem: Lenovo 5 Series/3400 Series Chipset HECI Controller
	Kernel driver in use: mei_me
	Kernel modules: mei_me
00:19.0 Ethernet controller: Intel Corporation 82577LM Gigabit Network Connection (rev 06)
	Subsystem: Lenovo 82577LM Gigabit Network Connection
	Kernel driver in use: e1000e
	Kernel modules: e1000e
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
	Subsystem: Lenovo 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
	Kernel driver in use: ehci-pci
	Kernel modules: ehci_pci
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
	Subsystem: Lenovo 5 Series/3400 Series Chipset High Definition Audio
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 06)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 06)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06)
	Subsystem: Lenovo 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
	Kernel driver in use: ehci-pci
	Kernel modules: ehci_pci
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6)
00:1f.0 ISA bridge: Intel Corporation QM57 Chipset LPC Interface Controller (rev 06)
	Subsystem: Lenovo QM57 Chipset LPC Interface Controller
	Kernel driver in use: lpc_ich
	Kernel modules: lpc_ich
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 6 port SATA AHCI Controller (rev 06)
	Subsystem: Lenovo 5 Series/3400 Series Chipset 6 port SATA AHCI Controller
	Kernel driver in use: ahci
	Kernel modules: ahci
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 06)
	Subsystem: Lenovo 5 Series/3400 Series Chipset SMBus Controller
	Kernel driver in use: i801_smbus
	Kernel modules: i2c_i801
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
	Subsystem: Lenovo 5 Series/3400 Series Chipset Thermal Subsystem
	Kernel driver in use: intel ips
	Kernel modules: intel_ips
02:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
	Subsystem: Intel Corporation WiFi Link 5100 AGN
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
	Subsystem: Lenovo Core Processor QuickPath Architecture Generic Non-core Registers
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
	Subsystem: Lenovo Core Processor QuickPath Architecture System Address Decoder
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
	Subsystem: Lenovo Core Processor QPI Link 0
ff:02.1 Host bridge: Intel Corporation 1st Generation Core i3/5/7 Processor QPI Physical 0 (rev 02)
	Subsystem: Lenovo 1st Generation Core i3/5/7 Processor QPI Physical 0
ff:02.2 Host bridge: Intel Corporation 1st Generation Core i3/5/7 Processor Reserved (rev 02)
	Subsystem: Lenovo 1st Generation Core i3/5/7 Processor Reserved
ff:02.3 Host bridge: Intel Corporation 1st Generation Core i3/5/7 Processor Reserved (rev 02)
	Subsystem: Lenovo 1st Generation Core i3/5/7 Processor Reserved
root@x200:/home/larcz# cat /etc/apt/sources.list
# 

# deb cdrom:[Official Debian GNU/Linux Live 9.11.0 gnome 2019-09-08T20:23]/ stretch main

deb http://ftp.pl.debian.org/debian/ stretch main non-free contrib
deb-src http://ftp.pl.debian.org/debian/ stretch main non-free contrib

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

#deb-multimedia
deb http://www.deb-multimedia.org stretch main non-free

root@x200:/home/larcz# cat /var/log/Xorg.0.log
[     7.139] 
X.Org X Server 1.19.2
Release Date: 2017-03-02
[     7.139] X Protocol Version 11, Revision 0
[     7.139] Build Operating System: Linux 4.19.0-13-amd64 x86_64 Debian
[     7.139] Current Operating System: Linux x200 4.9.0-15-amd64 #1 SMP Debian 4.9.258-1 (2021-03-08) x86_64
[     7.139] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-15-amd64 root=UUID=80a746cd-0d40-4c9d-8143-ad02ef4102fb ro quiet
[     7.139] Build Date: 09 December 2020  10:09:47AM
[     7.139] xorg-server 2:1.19.2-1+deb9u7 (https://www.debian.org/support) 
[     7.139] Current version of pixman: 0.34.0
[     7.139] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[     7.139] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     7.139] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr  5 19:49:33 2021
[     7.140] (==) Using config file: "/etc/X11/xorg.conf"
[     7.140] (==) ServerLayout "X.org Configured"
[     7.140] (**) |-->Screen "Screen0" (0)
[     7.140] (**) |   |-->Monitor "Monitor0"
[     7.141] (**) |   |-->Device "Card0"
[     7.141] (**) |-->Input Device "Mouse0"
[     7.141] (**) |-->Input Device "Keyboard0"
[     7.141] (==) Automatically adding devices
[     7.141] (==) Automatically enabling devices
[     7.141] (==) Automatically adding GPU devices
[     7.141] (==) Max clients allowed: 256, resource mask: 0x1fffff
[     7.171] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[     7.172] 	Entry deleted from font path.
[     7.174] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[     7.174] 	Entry deleted from font path.
[     7.174] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[     7.174] 	Entry deleted from font path.
[     7.175] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[     7.175] 	Entry deleted from font path.
[     7.175] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[     7.175] 	Entry deleted from font path.
[     7.175] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[     7.175] 	Entry deleted from font path.
[     7.175] (**) FontPath set to:
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	built-ins,
	/usr/share/fonts/X11/misc,
	/usr/share/fonts/X11/100dpi/:unscaled,
	/usr/share/fonts/X11/Type1,
	/usr/share/fonts/X11/100dpi,
	built-ins
[     7.175] (**) ModulePath set to "/usr/lib/xorg/modules"
[     7.175] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[     7.175] (WW) Disabling Mouse0
[     7.175] (WW) Disabling Keyboard0
[     7.175] (II) Loader magic: 0x55d4b502ae00
[     7.175] (II) Module ABI versions:
[     7.175] 	X.Org ANSI C Emulation: 0.4
[     7.175] 	X.Org Video Driver: 23.0
[     7.175] 	X.Org XInput driver : 24.1
[     7.175] 	X.Org Server Extension : 10.0
[     7.176] (++) using VT number 7

[     7.176] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[     7.176] (II) xfree86: Adding drm device (/dev/dri/card0)
[     7.192] (--) PCI:*(0:0:2:0) 8086:0046:17aa:215a rev 2, Mem @ 0xf2000000/4194304, 0xd0000000/268435456, I/O @ 0x00001800/8, BIOS @ 0x????????/131072
[     7.192] (II) LoadModule: "glx"
[     7.234] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[     7.296] (II) Module glx: vendor="X.Org Foundation"
[     7.296] 	compiled for 1.19.2, module version = 1.0.0
[     7.296] 	ABI class: X.Org Server Extension, version 10.0
[     7.296] (II) LoadModule: "intel"
[     7.298] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[     7.303] (II) Module intel: vendor="X.Org Foundation"
[     7.303] 	compiled for 1.19.0, module version = 2.99.917
[     7.303] 	Module class: X.Org Video Driver
[     7.303] 	ABI class: X.Org Video Driver, version 23.0
[     7.303] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
	i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
	915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
	Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
	GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[     7.304] (II) intel: Driver for Intel(R) HD Graphics
[     7.304] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[     7.304] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[     7.304] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160919
[     7.305] (II) intel(0): SNA compiled: xserver-xorg-video-intel 2:2.99.917+git20161206-1 (Timo Aaltonen <tjaalton@debian.org>)
[     7.305] (II) intel(0): SNA compiled for use with valgrind
[     7.306] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics
[     7.306] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2; using a maximum of 2 threads
[     7.306] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[     7.306] (==) intel(0): RGB weight 888
[     7.306] (==) intel(0): Default visual is TrueColor
[     7.307] (II) intel(0): Output LVDS1 using monitor section Monitor0
[     7.308] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output LVDS1
[     7.308] (II) intel(0): Enabled output LVDS1
[     7.308] (II) intel(0): Output VGA1 has no monitor section
[     7.308] (II) intel(0): Enabled output VGA1
[     7.308] (II) intel(0): Output HDMI1 has no monitor section
[     7.308] (II) intel(0): Enabled output HDMI1
[     7.308] (II) intel(0): Output DP1 has no monitor section
[     7.308] (II) intel(0): Enabled output DP1
[     7.308] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[     7.308] (II) intel(0): Output VIRTUAL1 has no monitor section
[     7.308] (II) intel(0): Enabled output VIRTUAL1
[     7.309] (--) intel(0): Output LVDS1 using initial mode 1280x800 on pipe 0
[     7.309] (--) intel(0): Output HDMI1 using initial mode 1920x1080 on pipe 1
[     7.309] (==) intel(0): TearFree disabled
[     7.309] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[     7.309] (==) intel(0): DPI set to (96, 96)
[     7.309] (II) Loading sub module "dri3"
[     7.309] (II) LoadModule: "dri3"
[     7.309] (II) Module "dri3" already built-in
[     7.309] (II) Loading sub module "dri2"
[     7.309] (II) LoadModule: "dri2"
[     7.309] (II) Module "dri2" already built-in
[     7.309] (II) Loading sub module "present"
[     7.309] (II) LoadModule: "present"
[     7.309] (II) Module "present" already built-in
[     7.309] (==) Depth 24 pixmap format is 32 bpp
[     7.313] (II) intel(0): SNA initialized with Ironlake (gen5) backend
[     7.313] (==) intel(0): Backing store enabled
[     7.313] (==) intel(0): Silken mouse enabled
[     7.314] (II) intel(0): HW Cursor enabled
[     7.314] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[     7.315] (==) intel(0): DPMS enabled
[     7.315] (==) intel(0): Display hotplug detection enabled
[     7.315] (II) intel(0): [XvMC] xvmc_vld driver initialized.
[     7.315] (II) intel(0): [DRI2] Setup complete
[     7.315] (II) intel(0): [DRI2]   DRI driver: i965
[     7.315] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[     7.315] (II) intel(0): direct rendering: DRI2 enabled
[     7.315] (II) intel(0): hardware support for Present enabled
[     7.315] (--) RandR disabled
[     7.322] (II) SELinux: Disabled on system
[     7.419] (EE) AIGLX error: dlopen of /usr/lib/x86_64-linux-gnu/dri/i965_dri.so failed (/usr/lib/x86_64-linux-gnu/dri/i965_dri.so: undefined symbol: _glapi_tls_Dispatch)
[     7.419] (EE) AIGLX: reverting to software rendering
[     7.744] (EE) AIGLX error: dlopen of /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so failed (/usr/lib/x86_64-linux-gnu/dri/swrast_dri.so: undefined symbol: _glapi_tls_Dispatch)
[     7.744] (EE) GLX: could not load software renderer
[     7.744] (II) GLX: no usable GL providers found for screen 0
[     7.789] (II) intel(0): switch to mode 1280x800@60.0 on LVDS1 using pipe 0, position (0, 0), rotation normal, reflection none
[     7.800] (II) intel(0): switch to mode 1920x1080@60.0 on HDMI1 using pipe 1, position (0, 0), rotation normal, reflection none
[     7.807] (II) intel(0): Setting screen physical size to 508 x 285
[     7.950] (II) config/udev: Adding input device Power Button (/dev/input/event5)
[     7.950] (II) No input driver specified, ignoring this device.
[     7.950] (II) This device may have been added with another device file.
[     7.950] (II) config/udev: Adding input device Video Bus (/dev/input/event9)
[     7.950] (II) No input driver specified, ignoring this device.
[     7.950] (II) This device may have been added with another device file.
[     7.951] (II) config/udev: Adding input device Lid Switch (/dev/input/event3)
[     7.951] (II) No input driver specified, ignoring this device.
[     7.951] (II) This device may have been added with another device file.
[     7.951] (II) config/udev: Adding input device Sleep Button (/dev/input/event4)
[     7.951] (II) No input driver specified, ignoring this device.
[     7.951] (II) This device may have been added with another device file.
[     7.953] (II) config/udev: Adding input device Kensington Expert Wireless TB (/dev/input/event2)
[     7.953] (II) No input driver specified, ignoring this device.
[     7.953] (II) This device may have been added with another device file.
[     7.954] (II) config/udev: Adding input device Kensington Expert Wireless TB (/dev/input/mouse1)
[     7.954] (II) No input driver specified, ignoring this device.
[     7.954] (II) This device may have been added with another device file.
[     7.954] (II) config/udev: Adding input device UVC Camera (17ef:480c) (/dev/input/event8)
[     7.954] (II) No input driver specified, ignoring this device.
[     7.954] (II) This device may have been added with another device file.
[     7.955] (II) config/udev: Adding input device HDA Intel MID Headphone (/dev/input/event12)
[     7.955] (II) No input driver specified, ignoring this device.
[     7.955] (II) This device may have been added with another device file.
[     7.955] (II) config/udev: Adding input device HDA Intel MID HDMI/DP,pcm=3 (/dev/input/event13)
[     7.955] (II) No input driver specified, ignoring this device.
[     7.955] (II) This device may have been added with another device file.
[     7.956] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event10)
[     7.956] (II) No input driver specified, ignoring this device.
[     7.956] (II) This device may have been added with another device file.
[     7.956] (II) config/udev: Adding input device HDA Intel MID Mic (/dev/input/event11)
[     7.956] (II) No input driver specified, ignoring this device.
[     7.956] (II) This device may have been added with another device file.
[     7.957] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[     7.957] (II) No input driver specified, ignoring this device.
[     7.957] (II) This device may have been added with another device file.
[     7.957] (II) config/udev: Adding input device TPPS/2 IBM TrackPoint (/dev/input/event1)
[     7.957] (II) No input driver specified, ignoring this device.
[     7.957] (II) This device may have been added with another device file.
[     7.958] (II) config/udev: Adding input device TPPS/2 IBM TrackPoint (/dev/input/mouse0)
[     7.958] (II) No input driver specified, ignoring this device.
[     7.958] (II) This device may have been added with another device file.
[     7.959] (II) config/udev: Adding input device PC Speaker (/dev/input/event7)
[     7.959] (II) No input driver specified, ignoring this device.
[     7.959] (II) This device may have been added with another device file.
[     7.959] (II) config/udev: Adding input device ThinkPad Extra Buttons (/dev/input/event6)
[     7.959] (II) No input driver specified, ignoring this device.
[     7.960] (II) This device may have been added with another device file.
[     9.310] (II) intel(0): EDID vendor "LEN", prod id 16400
[     9.310] (II) intel(0): Printing DDC gathered Modelines:
[     9.310] (II) intel(0): Modeline "1280x800"x0.0   75.16  1280 1354 1412 1522  800 803 809 823 -hsync -vsync (49.4 kHz eP)
[    37.582] (II) Server terminated successfully (0). Closing log file.

fnmirk
Senior Member
Posty: 8079
Rejestracja: 03 grudnia 2007, 06:37

Re: Usterka Xorg po instalacji sterowników, Wayland działa.

Post autor: fnmirk » 12 kwietnia 2021, 22:47

Jest błąd:
larcz pisze:

Kod: Zaznacz cały

[     7.419] (EE) AIGLX error: dlopen of /usr/lib/x86_64-linux-gnu/dri/i965_dri.so failed (/usr/lib/x86_64-linux-gnu/dri/i965_dri.so: undefined symbol: _glapi_tls_Dispatch)
[     7.419] (EE) AIGLX: reverting to software rendering
[     7.744] (EE) AIGLX error: dlopen of /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so failed (/usr/lib/x86_64-linux-gnu/dri/swrast_dri.so: undefined symbol: _glapi_tls_Dispatch)
[     7.744] (EE) GLX: could not load software renderer
karta grafiki:
larcz pisze:

Kod: Zaznacz cały

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
	Subsystem: Lenovo Core Processor Integrated Graphics Controller
	Kernel driver in use: i915
	Kernel modules: i915


Ale on może wynikać z braku instalacji plików firmware, moje doświadczenie podpowiada mi, że bez tego tryb graficzny powinien się uruchomić.

Czy próbowałeś wyłączyć uruchamianie waylanda w pliku:

Kod: Zaznacz cały

/etc/gdm/custom.conf

Kod: Zaznacz cały

# GDM configuration storage
[daemon]
WaylandEnable=false
DefaultSession=gnome-xorg.desktop
Tu masz tekst z dokładnym opisem:

https://www.tecmint.com/configure-xorg- ... e-session/

Jak się nie uruchomi po restarcie to trzeba będzie doinstalować pliki firmware.

larcz
Posty: 38
Rejestracja: 17 sierpnia 2008, 17:23

Re: Usterka Xorg po instalacji sterowników, Wayland działa.

Post autor: larcz » 14 kwietnia 2021, 17:31

Tak, próbowałem.
Wtedy nie dochodzi nawet do gdm.
Mogę prosić o wskazówki co i jak doinstalować?

Awatar użytkownika
Yampress
Administrator
Posty: 6284
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Re: Usterka Xorg po instalacji sterowników, Wayland działa.

Post autor: Yampress » 14 kwietnia 2021, 19:03

A przecież gnome chodzi default na wayland?

larcz
Posty: 38
Rejestracja: 17 sierpnia 2008, 17:23

Re: Usterka Xorg po instalacji sterowników, Wayland działa.

Post autor: larcz » 14 kwietnia 2021, 19:09

Chodzi ale nie jest w pełni funkcjonalny. Np. nie działa freetube. I mam wrażenie, że sprzęt jest bardziej obciążony (co widać po temperaturze pracy).

fnmirk
Senior Member
Posty: 8079
Rejestracja: 03 grudnia 2007, 06:37

Re: Usterka Xorg po instalacji sterowników, Wayland działa.

Post autor: fnmirk » 15 kwietnia 2021, 00:30

larcz pisze:nie jest w pełni funkcjonalny. Np. nie działa freetube. I mam wrażenie, że sprzęt jest bardziej obciążony
Zastanawiam się, w tym momencie, w jakim celu instalujesz Gnome? Wbrew pozorom, odkąd pamiętam, zawsze z nim były jakieś niedomagania.

Pobierz jakąś wersję livecd, wykonaj test sprzętu.

https://www.system-rescue.org/Download/

Do przeglądania yootube, możesz sobie wybrać inny program, i to pewnie lepszy:

https://packages.debian.org/search?keyw ... ection=all

Przedstaw jeszcze wyniki poleceń:

Kod: Zaznacz cały

 dpkg -l | grep firmware
 dpkg -l | grep intel

ODPOWIEDZ