Calligra instalacja

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
WojAbuk
Posty: 44
Rejestracja: 25 stycznia 2015, 10:58

Re: Calligra instalacja

Post autor: WojAbuk » 30 kwietnia 2019, 09:14

Zgadzam się, ale jak chce mi cofnąć wydaję jakiegoś programu to zwykle nie wiem co zrobić, bo zwykle mogę się cofnąć o kilka wersji, ale nigdy nie wiem o ile. Tak się złożyło że dopiero jutro rano mogę spróbować podam rezultat jutro.

WojAbuk
Posty: 44
Rejestracja: 25 stycznia 2015, 10:58

Re: Calligra instalacja

Post autor: WojAbuk » 30 kwietnia 2019, 20:26

Kod: Zaznacz cały

root@DebKuba:~# root@DebKuba:~# aptitude install calligraflow/stretch
Nie znaleziono pakietu, którego nazwa lub opis zawierałyby "calligraflow"
Unable to apply some actions, aborting
Taki jest efekt. (taki sam jak po po probie instancji całej calligry z pakietu stretch) Jak został poruszony temat architektury to ja używam amd64.

Spróbowałem powtórzyć proces instalacji z kodu źródłowego i tym razem doszedłem do
do uruchamiania, ale tu wystąpił mi taki błąd

Kod: Zaznacz cały

jakub@DebKuba:~$ kbuildsycoca4
realPath called with a relative path '$HOME/kde4/inst/share/config/', please fix
realPath called with a relative path '$HOME/kde4/inst/share/locale/', please fix
kbuildsycoca4 running...
realPath called with a relative path '$HOME/kde4/inst/share/kde4/services/', please fix
realPath called with a relative path '$HOME/kde4/inst/share/kde4/servicetypes/', please fix
realPath called with a relative path '$HOME/kde4/inst/share/mime/', please fix
realPath called with a relative path '$HOME/kde4/inst/share/applications/', please fix
realPath called with a relative path '$HOME/kde4/inst/share/desktop-directories/', please fix
realPath called with a relative path '$HOME/kde4/inst/share/applnk/', please fix
realPath called with a relative path '$HOME/kde4/inst/etc/xdg/menus/', please fix
kbuildsycoca4(7119) VFolderMenu::loadDoc: Parse error in  "/home/jakub/.config/menus/applications-merged/xdg-desktop-menu-dummy.menu" , line  1 , col  1 :  "unexpected end of file" 
kbuildsycoca4(7119) parseLayoutNode: The menu spec file contains a Layout or DefaultLayout tag without the mandatory Merge tag inside. Please fix your file. 
kbuildsycoca4(7119) parseLayoutNode: The menu spec file contains a Layout or DefaultLayout tag without the mandatory Merge tag inside. Please fix your file. 
Edit: Pomyślałem że to może się przydać, wydaje mi się że brakuje plików

Kod: Zaznacz cały

jakub@DebKuba:~$ tree ~/kde4/inst/ -La 2
/home/jakub/kde4/inst/
├── bin
│   ├── calligra
│   ├── calligraconverter
│   ├── calligraflow
│   ├── calligragemini
│   ├── calligrageminithumbnailhelper
│   ├── calligrasheets
│   ├── calligrastage
│   ├── calligrawords
│   ├── cstester
│   ├── cstrunner
│   └── karbon
├── etc
│   └── xdg
├── lib
│   └── x86_64-linux-gnu
└── share
    ├── applications
    ├── calligra
    ├── calligragemini
    ├── calligra_shape_music
    ├── calligrasheets
    ├── calligrastage
    ├── calligrawords
    ├── color
    ├── config.kcfg
    ├── flow
    ├── icons
    ├── karbon
    ├── kservices5
    ├── kservicetypes5
    ├── kxmlgui5
    ├── metainfo
    ├── mime
    └── templates

24 directories, 11 files

Awatar użytkownika
dedito
Moderator
Posty: 2951
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Calligra instalacja

Post autor: dedito » 30 kwietnia 2019, 21:17

Musisz mieć dodane źródła repozytorium aby używać tego polecenia.

WojAbuk
Posty: 44
Rejestracja: 25 stycznia 2015, 10:58

Re: Calligra instalacja

Post autor: WojAbuk » 30 kwietnia 2019, 21:52

Ja nie chcę dodawać całego repozytorium innej wersji, bo jak pisałem wcześniej mam z tym złe doświadczenia, a nie widzi mi się dodawanie wpisu dla każdego pakietu. Gdybym miał dodane źródło wersji stabilnej to aptitude samo by znalazło flow bez wskazywania gałęzi.

Awatar użytkownika
dedito
Moderator
Posty: 2951
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Calligra instalacja

Post autor: dedito » 01 maja 2019, 09:02

To ściągaj ręcznie paczki jak to już saturno pisał.
Ale niepotrzebnie się boisz. Wystarczy raz dodać repozytorium, poinstalować co trzeba i je zakomentować.
I sęk w tym, że tą gałąź musisz podawać, choć w przypadku aptitude to głowy nie dam.

WojAbuk
Posty: 44
Rejestracja: 25 stycznia 2015, 10:58

Re: Calligra instalacja

Post autor: WojAbuk » 01 maja 2019, 12:30

Kod: Zaznacz cały

root@DebKuba:~# aptitude install calligra-l10n-pl calligra/stretch calligraflow/stretch
Jest już zainstalowana żądana wersja pakietu "calligra-l10n-pl" (1:3.1.0+dfsg-5)
Jest już zainstalowana żądana wersja pakietu "calligra-l10n-pl" (1:3.1.0+dfsg-5)
Następujące NOWE pakiety zostaną zainstalowane:
  braindump{ab} breeze-icon-theme-rcc{a} calligra calligra-data{a} calligra-libs{a} calligra-semanticitems{ab} 
  calligraauthor{ab} calligraflow{b} calligraflow-data{a} calligraplan{a} calligrasheets{a} calligrasheets-data{a} 
  calligrastage{a} calligrastage-data{a} calligrawords{a} calligrawords-data{a} karbon{a} kexi{a} kexi-data{a} 
  libakonadi-kde4{a} libakonadiprotocolinternals1{a} libiodbc2{a} libkcalcore4{a} libkdb-data{a} libkdb3-4{a} 
  libkdb3-driver-sqlite{a} libsoprano4{a} soprano-daemon{a} 
0 pakietów aktualizowanych, 28 instalowanych, 0 do usunięcia i 6 nieaktualizowanych.
Do pobrania 39,9 MB/54,0 MB archiwów. Zajęte po rozpakowaniu: 210 MB.
Następujące pakiety mają niespełnione zależności:
 calligraauthor : Wymaga: calligra-libs (= 1:2.9.11+dfsg-4+b1) but 1:3.1.0+dfsg-5 is to be installed
 braindump : Wymaga: calligra-libs (= 1:2.9.11+dfsg-4+b1) but 1:3.1.0+dfsg-5 is to be installed
 calligra-semanticitems : Wymaga: calligra-libs (= 1:2.9.11+dfsg-4+b1) but 1:3.1.0+dfsg-5 is to be installed
 calligraflow : Wymaga: calligra-libs (= 1:2.9.11+dfsg-4+b1) but 1:3.1.0+dfsg-5 is to be installed
Następujące działania rozwiążą problemy z zależnościami:

     Zatrzymanie bieżących wersji następujących pakietów:
1)     braindump [niezainstalowany]                      
2)     calligra [niezainstalowany]                       
3)     calligra-semanticitems [niezainstalowany]         
4)     calligraauthor [niezainstalowany]                 
5)     calligraflow [niezainstalowany]                   

     Leave the following dependencies unresolved:        
6)     calligra poleca calligra-semanticitems            



Zaakceptować rozwiązanie? [Y/n/q/?] q
Porzucono próby rozwiązania problemów z zależnościami.
Przerwane.
root@DebKuba:~# aptitude install calligra-l10n-pl/stretch calligra/stretch calligraflow/stretch
Następujące pakiety zostaną COFNIĘTE:             
  calligra-l10n-pl 
Następujące NOWE pakiety zostaną zainstalowane:
  braindump{ab} breeze-icon-theme-rcc{a} calligra calligra-data{ab} calligra-libs{a} calligra-semanticitems{ab} 
  calligraauthor{ab} calligraflow{b} calligraflow-data{a} calligraplan{ab} calligrasheets{a} calligrasheets-data{ab} 
  calligrastage{a} calligrastage-data{ab} calligrawords{a} calligrawords-data{ab} karbon{ab} kexi{a} kexi-data{ab} 
  libakonadi-kde4{a} libakonadiprotocolinternals1{a} libiodbc2{a} libkcalcore4{a} libkdb-data{a} libkdb3-4{a} 
  libkdb3-driver-sqlite{a} libsoprano4{a} soprano-daemon{a} 
0 pakietów aktualizowanych, 28 instalowanych, 1 cofanych, 0 do usunięcia i 6 nieaktualizowanych.
Do pobrania 40,2 MB/54,3 MB archiwów. Zajęte po rozpakowaniu: 211 MB.
Następujące pakiety mają niespełnione zależności:
 calligraauthor : Wymaga: calligra-libs (= 1:2.9.11+dfsg-4+b1) but 1:3.1.0+dfsg-5 is to be installed
 calligrawords-data : Narusza zależności: calligra-l10n-pl (< 1:3.1.0~) but 1:2.9.11-1 is to be installed
 kexi-data : Narusza zależności: calligra-l10n-pl (< 1:2.9.11-2~) but 1:2.9.11-1 is to be installed
 calligrasheets-data : Narusza zależności: calligra-l10n-pl (< 1:3.1.0~) but 1:2.9.11-1 is to be installed
 braindump : Wymaga: calligra-libs (= 1:2.9.11+dfsg-4+b1) but 1:3.1.0+dfsg-5 is to be installed
 karbon : Narusza zależności: calligra-l10n-pl (< 1:3.1.0~) but 1:2.9.11-1 is to be installed
 calligrastage-data : Narusza zależności: calligra-l10n-pl (< 1:3.1.0~) but 1:2.9.11-1 is to be installed
 calligra-semanticitems : Wymaga: calligra-libs (= 1:2.9.11+dfsg-4+b1) but 1:3.1.0+dfsg-5 is to be installed
 calligraflow : Wymaga: calligra-libs (= 1:2.9.11+dfsg-4+b1) but 1:3.1.0+dfsg-5 is to be installed
 calligra-data : Narusza zależności: calligra-l10n-pl (< 1:3.1.0~) but 1:2.9.11-1 is to be installed
 calligraplan : Narusza zależności: calligra-l10n-pl (< 1:3.1.0~) but 1:2.9.11-1 is to be installed
Następujące działania rozwiążą problemy z zależnościami:

     Zatrzymanie bieżących wersji następujących pakietów:
1)     braindump [niezainstalowany]                      
2)     calligra [niezainstalowany]                       
3)     calligra-l10n-pl [1:3.1.0+dfsg-5 (now, testing)]  
4)     calligra-semanticitems [niezainstalowany]         
5)     calligraauthor [niezainstalowany]                 
6)     calligraflow [niezainstalowany]                   

     Leave the following dependencies unresolved:        
7)     calligra poleca calligra-semanticitems            



Zaakceptować rozwiązanie? [Y/n/q/?] n
Następujące działania rozwiążą problemy z zależnościami:

     Usunięcie następujących pakietów:                   
1)     calligra-l10n-pl [1:3.1.0+dfsg-5 (now, testing)]  

     Zatrzymanie bieżących wersji następujących pakietów:
2)     braindump [niezainstalowany]                      
3)     calligra [niezainstalowany]                       
4)     calligra-semanticitems [niezainstalowany]         
5)     calligraauthor [niezainstalowany]                 
6)     calligraflow [niezainstalowany]                   

     Leave the following dependencies unresolved:        
7)     calligra poleca calligra-semanticitems            



Zaakceptować rozwiązanie? [Y/n/q/?] n
Następujące działania rozwiążą problemy z zależnościami:

      Usunięcie następujących pakietów:                                    
1)      kde-full [5:102 (now, testing)]                                    
2)      kdeedu [4:17.08.3+5.102 (now, testing)]                            
3)      libgsl23 [2.5+dfsg-6 (now, testing)]                               
4)      libgslcblas0 [2.5+dfsg-6 (now, testing)]                           
5)      step [4:18.08.1-1+b1 (now, testing)]                               

      Instalacja następujących pakietów:                                   
6)      calligra-data [1:2.9.11+dfsg-4 (stable)]                           
7)      calligra-libs [1:2.9.11+dfsg-4+b1 (stable)]                        
8)      calligraplan [1:2.9.11+dfsg-4+b1 (stable)]                         
9)      calligrasheets [1:2.9.11+dfsg-4+b1 (stable)]                       
10)     calligrastage [1:2.9.11+dfsg-4+b1 (stable)]                        
11)     calligrastage-data [1:2.9.11+dfsg-4 (stable)]                      
12)     calligrawords [1:2.9.11+dfsg-4+b1 (stable)]                        
13)     calligrawords-data [1:2.9.11+dfsg-4 (stable)]                      
14)     karbon [1:2.9.11+dfsg-4+b1 (stable)]                               
15)     kexi [1:2.9.11+dfsg-4+b1 (stable)]                                 
16)     kexi-data [1:2.9.11+dfsg-4 (stable)]                               
17)     libakonadi-contact4 [4:4.14.10-11 (testing)]                       
18)     libboost-system1.62.0 [1.62.0+dfsg-4 (stable)]                     
19)     libgsl2 [2.3+dfsg-1 (stable)]                                      
20)     libilmbase12 [2.2.0-12 (stable)]                                   
21)     libmagick++-6.q16-7 [8:6.9.7.4+dfsg-11+deb9u6 (stable)]            
22)     libmagickcore-6.q16-3 [8:6.9.7.4+dfsg-11+deb9u6 (stable)]          
23)     libmagickwand-6.q16-3 [8:6.9.7.4+dfsg-11+deb9u6 (stable)]          
24)     libopenexr22 [2.2.0-11+b1 (stable)]                                
25)     libphononexperimental4 [4:4.10.2-1 (testing)]                      
26)     libpoppler64 [0.48.0-2+deb9u2 (stable)]                            
27)     libraw15 [0.17.2-6+deb9u1 (stable)]                                

      Zatrzymanie bieżących wersji następujących pakietów:                 
28)     calligrasheets-data [niezainstalowany]                             

      Cofnięcie następujących pakietów do wcześniejszych wersji:           
29)     enblend [4.2-4 (now, testing) -> 4.2-2 (stable)]                   
30)     enfuse [4.2-4 (now, testing) -> 4.2-2 (stable)]                    
31)     inkscape [0.92.4-3 (now, testing) -> 0.92.1-1 (stable)]            
32)     krita [1:4.1.7+dfsg-1+b1 (now, testing) -> 1:3.1.1+dfsg-1 (stable)]
33)     libgsl-dev [2.5+dfsg-6 (now, testing) -> 2.3+dfsg-1 (stable)]      



Zaakceptować rozwiązanie? [Y/n/q/?] n
Następujące działania rozwiążą problemy z zależnościami:

      Usunięcie następujących pakietów:                                    
1)      kde-full [5:102 (now, testing)]                                    
2)      kdeedu [4:17.08.3+5.102 (now, testing)]                            
3)      libgsl23 [2.5+dfsg-6 (now, testing)]                               
4)      libgslcblas0 [2.5+dfsg-6 (now, testing)]                           
5)      step [4:18.08.1-1+b1 (now, testing)]                               

      Instalacja następujących pakietów:                                   
6)      calligra-data [1:2.9.11+dfsg-4 (stable)]                           
7)      calligra-libs [1:2.9.11+dfsg-4+b1 (stable)]                        
8)      calligraplan [1:2.9.11+dfsg-4+b1 (stable)]                         
9)      calligrasheets [1:2.9.11+dfsg-4+b1 (stable)]                       
10)     calligrastage [1:2.9.11+dfsg-4+b1 (stable)]                        
11)     calligrastage-data [1:2.9.11+dfsg-4 (stable)]                      
12)     calligrawords [1:2.9.11+dfsg-4+b1 (stable)]                        
13)     calligrawords-data [1:2.9.11+dfsg-4 (stable)]                      
14)     karbon [1:2.9.11+dfsg-4+b1 (stable)]                               
15)     kexi [1:2.9.11+dfsg-4+b1 (stable)]                                 
16)     kexi-data [1:2.9.11+dfsg-4 (stable)]                               
17)     libakonadi-contact4 [4:4.14.10-11 (testing)]                       
18)     libboost-system1.62.0 [1.62.0+dfsg-4 (stable)]                     
19)     libgsl2 [2.3+dfsg-1 (stable)]                                      
20)     libilmbase12 [2.2.0-12 (stable)]                                   
21)     libmagick++-6.q16-7 [8:6.9.7.4+dfsg-11+deb9u6 (stable)]            
22)     libmagickcore-6.q16-3 [8:6.9.7.4+dfsg-11+deb9u6 (stable)]          
23)     libmagickwand-6.q16-3 [8:6.9.7.4+dfsg-11+deb9u6 (stable)]          
24)     libopenexr22 [2.2.0-11+b1 (stable)]                                
25)     libphononexperimental4 [4:4.9.0-4 (stable)]                        
26)     libpoppler64 [0.48.0-2+deb9u2 (stable)]                            
27)     libraw15 [0.17.2-6+deb9u1 (stable)]                                

      Zatrzymanie bieżących wersji następujących pakietów:                 
28)     calligrasheets-data [niezainstalowany]                             

      Cofnięcie następujących pakietów do wcześniejszych wersji:           
29)     enblend [4.2-4 (now, testing) -> 4.2-2 (stable)]                   
30)     enfuse [4.2-4 (now, testing) -> 4.2-2 (stable)]                    
31)     inkscape [0.92.4-3 (now, testing) -> 0.92.1-1 (stable)]            
32)     krita [1:4.1.7+dfsg-1+b1 (now, testing) -> 1:3.1.1+dfsg-1 (stable)]
33)     libgsl-dev [2.5+dfsg-6 (now, testing) -> 2.3+dfsg-1 (stable)]      
34)     libphonon-dev [4:4.10.2-1 (now, testing) -> 4:4.9.0-4 (stable)]    
35)     libphonon4 [4:4.10.2-1 (now, testing) -> 4:4.9.0-4 (stable)]       
36)     phonon [4:4.10.2-1 (now, testing) -> 4:4.9.0-4 (stable)]           



Zaakceptować rozwiązanie? [Y/n/q/?] n
Następujące działania rozwiążą problemy z zależnościami:

      Usunięcie następujących pakietów:                                    
1)      enfuse [4.2-4 (now, testing)]                                      
2)      kde-full [5:102 (now, testing)]                                    
3)      kdeedu [4:17.08.3+5.102 (now, testing)]                            
4)      libgsl23 [2.5+dfsg-6 (now, testing)]                               
5)      libgslcblas0 [2.5+dfsg-6 (now, testing)]                           
6)      step [4:18.08.1-1+b1 (now, testing)]                               

      Instalacja następujących pakietów:                                   
7)      calligra-data [1:2.9.11+dfsg-4 (stable)]                           
8)      calligra-libs [1:2.9.11+dfsg-4+b1 (stable)]                        
9)      calligraplan [1:2.9.11+dfsg-4+b1 (stable)]                         
10)     calligrasheets [1:2.9.11+dfsg-4+b1 (stable)]                       
11)     calligrastage [1:2.9.11+dfsg-4+b1 (stable)]                        
12)     calligrastage-data [1:2.9.11+dfsg-4 (stable)]                      
13)     calligrawords [1:2.9.11+dfsg-4+b1 (stable)]                        
14)     calligrawords-data [1:2.9.11+dfsg-4 (stable)]                      
15)     karbon [1:2.9.11+dfsg-4+b1 (stable)]                               
16)     kexi [1:2.9.11+dfsg-4+b1 (stable)]                                 
17)     kexi-data [1:2.9.11+dfsg-4 (stable)]                               
18)     libakonadi-contact4 [4:4.14.10-11 (testing)]                       
19)     libboost-system1.62.0 [1.62.0+dfsg-4 (stable)]                     
20)     libgsl2 [2.3+dfsg-1 (stable)]                                      
21)     libilmbase12 [2.2.0-12 (stable)]                                   
22)     libmagick++-6.q16-7 [8:6.9.7.4+dfsg-11+deb9u6 (stable)]            
23)     libmagickcore-6.q16-3 [8:6.9.7.4+dfsg-11+deb9u6 (stable)]          
24)     libmagickwand-6.q16-3 [8:6.9.7.4+dfsg-11+deb9u6 (stable)]          
25)     libopenexr22 [2.2.0-11+b1 (stable)]                                
26)     libphononexperimental4 [4:4.10.2-1 (testing)]                      
27)     libpoppler64 [0.48.0-2+deb9u2 (stable)]                            
28)     libraw15 [0.17.2-6+deb9u1 (stable)]                                

      Zatrzymanie bieżących wersji następujących pakietów:                 
29)     calligrasheets-data [niezainstalowany]                             

      Cofnięcie następujących pakietów do wcześniejszych wersji:           
30)     enblend [4.2-4 (now, testing) -> 4.2-2 (stable)]                   
31)     inkscape [0.92.4-3 (now, testing) -> 0.92.1-1 (stable)]            
32)     krita [1:4.1.7+dfsg-1+b1 (now, testing) -> 1:3.1.1+dfsg-1 (stable)]
33)     libgsl-dev [2.5+dfsg-6 (now, testing) -> 2.3+dfsg-1 (stable)]      

      Leave the following dependencies unresolved:                         
34)     kipi-plugins poleca enfuse                                         



Zaakceptować rozwiązanie? [Y/n/q/?] 
Nie mogę znaleźć rozwiązania do zaakceptowania. Instalacja z paczek tym bardziej się nie uda.

Awatar użytkownika
saturno
Junior Member
Posty: 681
Rejestracja: 08 lipca 2008, 20:04

Re: Calligra instalacja

Post autor: saturno » 04 maja 2019, 19:01

WojAbuk pisze:
01 maja 2019, 12:30
Nie mogę znaleźć rozwiązania do zaakceptowania.
dedito podaje ci rozwiązanie z apt-get a ty z uporem maniaka trzymasz się kapryśnego aptitude. Obecnie w Debianie aptitude nie jest nawet domyślnie instalowane. Odchodzi się od niego na rzecz apt-get a teraz właściwie na sam apt.
Mało tego popełniasz szkolne błędy:

Kod: Zaznacz cały

aptitude install calligra-l10n-pl calligra/stretch calligraflow/stretch

W poleceniu pakiet: calligra-l10n-pl nie jest oznaczony do instalacji ze stretch
WojAbuk pisze:
01 maja 2019, 12:30
Instalacja z paczek tym bardziej się nie uda.
Stwierdziłeś to na podstawie czego?
Chyba swojego widzi misie, bo ja sprawdziłem i u mnie działa.
Żeby to sprawdzić specjalnie na VMware zainstalowałem Debiana Testing z KDE.
Straciłem 2GB mobilnego internetu i pięć godzin czasu na to ;-(
Efekt na załączonym rzucie.
https://drive.google.com/open?id=1vQdZL ... tWjvvWQmlg

WojAbuk
Posty: 44
Rejestracja: 25 stycznia 2015, 10:58

Re: Calligra instalacja

Post autor: WojAbuk » 04 maja 2019, 20:18

saturno pisze:
04 maja 2019, 19:01
dedito podaje ci rozwiązanie z apt-get a ty z uporem maniaka trzymasz się kapryśnego aptitude. Obecnie w Debianie aptitude nie jest nawet domyślnie instalowane.
tak aptitude nie jest domyślnie instalowane, ale co z tego jak apt i apt-get dają taki efekt:

Kod: Zaznacz cały

root@DebKuba:~# apt install calligra-l10n-pl/stretch calligra/stretch calligraflow/stretch     
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Wybrano wersję "1:2.9.11-1" (Debian:9.9/stable [all]) pakietu "calligra-l10n-pl"
Wybrano wersję "1:2.9.11+dfsg-4+b1" (Debian:9.9/stable [amd64]) pakietu "calligra-libs", z powodu "calligra-l10n-pl"
Wybrano wersję "1:2.9.11+dfsg-4" (Debian:9.9/stable [all]) pakietu "calligra-data", z powodu "calligra-libs"
Wybrano wersję "2.9.4+dfsg-5" (Debian:9.9/stable [amd64]) pakietu "libsoprano4", z powodu "calligra-libs"
Wybrano wersję "2.9.4+dfsg-5" (Debian:9.9/stable [amd64]) pakietu "soprano-daemon", z powodu "libsoprano4"
Wybrano wersję "1:2.9.11+dfsg-4" (Debian:9.9/stable [all]) pakietu "calligra"
Wybrano wersję "1:2.9.11+dfsg-4+b1" (Debian:9.9/stable [amd64]) pakietu "calligraflow"
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 calligra : Wymaga: calligraauthor (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: calligraplan (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: calligrasheets (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: calligrastage (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: calligrawords (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: karbon (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: kexi (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
root@DebKuba:~# apt-get install calligra-l10n-pl/stretch calligra/stretch calligraflow/stretch
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Wybrano wersję "1:2.9.11-1" (Debian:9.9/stable [all]) pakietu "calligra-l10n-pl"
Wybrano wersję "1:2.9.11+dfsg-4+b1" (Debian:9.9/stable [amd64]) pakietu "calligra-libs", z powodu "calligra-l10n-pl"
Wybrano wersję "1:2.9.11+dfsg-4" (Debian:9.9/stable [all]) pakietu "calligra-data", z powodu "calligra-libs"
Wybrano wersję "2.9.4+dfsg-5" (Debian:9.9/stable [amd64]) pakietu "libsoprano4", z powodu "calligra-libs"
Wybrano wersję "2.9.4+dfsg-5" (Debian:9.9/stable [amd64]) pakietu "soprano-daemon", z powodu "libsoprano4"
Wybrano wersję "1:2.9.11+dfsg-4" (Debian:9.9/stable [all]) pakietu "calligra"
Wybrano wersję "1:2.9.11+dfsg-4+b1" (Debian:9.9/stable [amd64]) pakietu "calligraflow"
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 calligra : Wymaga: calligraauthor (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: calligraplan (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: calligrasheets (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: calligrastage (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: calligrawords (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: karbon (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: kexi (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
E: Nie udało się naprawić problemów, zatrzymano uszkodzone pakiety.
Po drugie z Debiana w ostanom czasie zginęło wiele narzędzi konsolowych takich jak ifconfig i ex (vi).
saturno pisze:
04 maja 2019, 19:01
Mało tego popełniasz szkolne błędy:
Tylko to nie jest błąd aptitude, jeśli nie poda mu się gałęzi to instaluje najnowszą wersję z wszystkich gałęzi dla których jest w stanie rozwiązać zależność, a to że dla pozostałych dwóch podałem wynika z tego że testowałem, czy wskazanie gałęzi coś zmieni.
saturno pisze:
04 maja 2019, 19:01
Stwierdziłeś to na podstawie czego?
Jeśli nie mogę zainstalować z repozytorium to niby dlaczego mógłbym zainstalować z paczek?
saturno pisze:
04 maja 2019, 19:01
Żeby to sprawdzić specjalnie na VMware zainstalowałem Debiana Testing z KDE.
Straciłem 2GB mobilnego internetu i pięć godzin czasu na to ;-(
Efekt na załączonym rzucie.
https://drive.google.com/open?id=1vQdZL ... tWjvvWQmlg
Instalacja samego Flow jest możliwa, ale usuwa calligre, a ja potrzebuje większość programów z calligry (szczególnie flow i flow jest jedynym którego nie ma w gałęzi testing z tych które potrzebuje).

Awatar użytkownika
saturno
Junior Member
Posty: 681
Rejestracja: 08 lipca 2008, 20:04

Re: Calligra instalacja

Post autor: saturno » 04 maja 2019, 23:30

ale co z tego jak apt i apt-get dają taki efekt:

Kod: Zaznacz cały

Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub użyto dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
 calligra : Wymaga: calligraauthor (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: calligraplan (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: calligrasheets (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: calligrastage (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: calligrawords (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: karbon (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany
            Wymaga: kexi (>= 1:2.9.11+dfsg-4) ale nie zostanie zainstalowany

"Może to oznaczać, że zażądano niemożliwej sytuacji" nie jest stwierdzeniem!.

"Następujące informacje mogą pomóc rozwiązać sytuację:

Następujące pakiety mają niespełnione zależności:
calligra : Wymaga: itd. itd. ..."

Oznacza mniej więcej tyle że przed powtórnym wydaniem polecenia należy spróbować zainstalować wymienione pakiety (w wymienionych wersjach). Z tym że wcześniej należy naprawić uszkodzone pakiety. (to tak w skrócie).
Jeśli nie mogę zainstalować z repozytorium to niby dlaczego mógłbym zainstalować z paczek?
Z własnego doświadczenia wiem że w takich przypadkach jest łatwiej.
Raz ze uszkodzenia pakietów prawie nigdy nie występują.
Dwa że zależności są stosowane stopniowo więc łatwiej jest je zastosować.
Trzy że ewentualne konflikty jest łatwiej wyłapać (np. chciało instalować: calligra-data w wyższej wersji).
Instalacja samego Flow jest możliwa, ale usuwa calligre, a ja potrzebuje większość programów z calligry

Samego Flow pomimo ze da się zainstalować nie uruchomisz poprawnie bez zainstalowanej Calligry.
Ja przedstawiłem sytuację gdzie jest zainstalowane wszystko (ii) i wszystko działa:

Kod: Zaznacz cały

$ dpkg -l | grep calligra
ii  calligra                                      1:2.9.11+dfsg-4              all          extensive productivity and creative suite
ii  calligra-data                                 1:2.9.11+dfsg-4              all          common shared data for the Calligra Suite
ii  calligra-l10n-pl                              1:2.9.11-1                   all          Polish (pl) localization files for Calligra
ii  calligra-libs                                 1:2.9.11+dfsg-4+b1           amd64        common libraries and binaries for the Calligra Suite
ii  calligraauthor                                1:2.9.11+dfsg-4+b1           amd64        Authoring tool for the Calligra Suite
ii  calligraflow                                  1:2.9.11+dfsg-4+b1           amd64        flowcharting program for the Calligra Suite
ii  calligraflow-data                             1:2.9.11+dfsg-4              all          data files for Flow flowcharting program
ii  calligraplan                                  1:2.9.11+dfsg-4+b1           amd64        integrated project management and planning tool
ii  calligrasheets                                1:2.9.11+dfsg-4+b1           amd64        spreadsheet for the Calligra Suite
ii  calligrastage                                 1:2.9.11+dfsg-4+b1           amd64        presentation program for the Calligra Suite
ii  calligrastage-data                            1:2.9.11+dfsg-4              all          data files for Calligra Stage
ii  calligrawords                                 1:2.9.11+dfsg-4+b1           amd64        word processor for the Calligra Suite
ii  calligrawords-data                            1:2.9.11+dfsg-4              all          data files for Words word processor
Po drugie z Debiana w ostanom czasie zginęło wiele narzędzi konsolowych takich jak ifconfig i ex (vi).
Na tę okoliczność załóż nowy temat.

ODPOWIEDZ