[+] Miganie ekranu podczas przewijania stron

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
dawideo
Beginner
Posty: 141
Rejestracja: 25 czerwca 2007, 11:46
Lokalizacja: Zbychowo

[+] Miganie ekranu podczas przewijania stron

Post autor: dawideo » 26 kwietnia 2017, 23:07

Witam
Tak jak w temacie. Podczas przewijania stron www (niezależnie od przeglądarki), ekran miga, drga. Jak by się dobrze przyjrzeć można zauważyć cieńkie poziome linie które załamują tekst, obraz podczas przewijania. Czy ktoś może się z czymś takim spotkał? Obecnie mam zainstalowane Debiana 9 z środowiskiem KDE. Karta graficzna GF 9800 GT, sterowniki Nvidia zainstalowane z rep. Niestety problem ten jest dokuczliwy, bo o ile przy oglądaniu filmów to w niczym nie przeszkadza to przy wyszukiwaniu informacji, lub czytaniu artykułów (gdzie należy dużo przewijać) to po 20 minutach mam dość (straszny ból oczu)
P.s. sprzętowo raczej OK, bo na Windowsie problem nie występuje.
Ostatnio zmieniony 29 kwietnia 2017, 22:35 przez dawideo, łącznie zmieniany 1 raz.

zbig
Posty: 88
Rejestracja: 29 stycznia 2009, 10:42

Re: Miganie ekranu podczas przewijania stron

Post autor: zbig » 27 kwietnia 2017, 07:42

Najprawdopodobniej masz wyłączoną synchronizację pionową (vblank). Włącz ją w kwin. Co nie co o tym problemie było wspomniane przez Salvadhora https://404.g-net.pl/2011/10/xubuntu-i- ... y-xrender/ , natomiast w przypadku KDE w wątku https://forum.kde.org/viewtopic.php?f=111&t=130942

dawideo
Beginner
Posty: 141
Rejestracja: 25 czerwca 2007, 11:46
Lokalizacja: Zbychowo

Re: Miganie ekranu podczas przewijania stron

Post autor: dawideo » 27 kwietnia 2017, 23:17

Hmm. Włączyłem opcję vblank zarówno w kwin, jak i w ustawieniach nvidia. Jako silnik wyświetlania raz brałem OpenGL 2.0 raz OpenGL 3.1. Po włączeniu opcji vblank przez jakieś 10-15 sekund jest bardzo dobrze (przewijam stronę i jest wszystko OK). Po tym czasie znów pojawia się te migotanie. Wchodzę w ustawienia kwin wyłączam i włączam vblan, i znów tylko na 10-15 sekund jest ok. Widać więc, że ma to coś z tą opcją wspólnego, ale nie działa do końca tak jak powinno. Czy ktoś ma jeszcze jakiś pomysł?

Ok udało mi się rozwiązać problem, więc dla potomnych:
Edytujemy nasz: /etc/X11/xorg.conf, i w sekcji "Screen" dodajemy wpis:
Option "metamodes" "nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"
Jeżeli, ktoś nie ma tej sekcji (tak jak ja), to po kolei:
1) Uruchamia Nvidia X Server Settings",
2) Przechodzi do opcji "X Server Display Configuration"
3) Klika: "Save to X Configuration file"
i nadpisuje xorga.conf , który utworzyliśmy podczas instalacji sterowników nvidia.
U mnie ten sposób zadziałał, mam nadzieje że się komuś przyda w przyszłości.
Pozdrawiam

Awatar użytkownika
marcin1982
Moderator
Posty: 1720
Rejestracja: 05 maja 2011, 12:59
Lokalizacja: Zagłębie Dąbrowskie

Re: Miganie ekranu podczas przewijania stron

Post autor: marcin1982 » 28 kwietnia 2017, 17:16

Proszę oznaczyć wątek jako rozwiązany zgodnie z regulaminem forum.

dawideo
Beginner
Posty: 141
Rejestracja: 25 czerwca 2007, 11:46
Lokalizacja: Zbychowo

Re: [+] Miganie ekranu podczas przewijania stron

Post autor: dawideo » 29 kwietnia 2017, 22:42

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 340.101 (buildd@debian) Fri Jan 13 04:25:47 UTC 2017

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "BenQ FP93GP"
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 76.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8800 GT"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "Stereo" "0"
Option "nvidiaXineramaInfoOrder" "DFP-0"
Option "metamodes" "nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"
Option "SLI" "Off"
Option "MultiGPU" "Off"
Option "BaseMosaic" "off"
SubSection "Display"
Depth 24
EndSubSection
EndSection


Awatar użytkownika
sinplez1y1
Posty: 97
Rejestracja: 13 stycznia 2017, 23:25

Re: [+] Miganie ekranu podczas przewijania stron

Post autor: sinplez1y1 » 29 kwietnia 2017, 23:32

wypiepsz opcję: (zachaszuj ją # po prostu) :

Kod: Zaznacz cały

Option "metamodes" "nvidia-auto-select +0+0 { ForceCompositionPipeline = On }"
a w iksach wyłącz kompozytor,

Zablokowany