Minimalne KDE debian 8.6 - nieprawidłowa instalacja

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
Awatar użytkownika
xzoltanx
Posty: 3
Rejestracja: 13 listopada 2016, 17:32

Minimalne KDE debian 8.6 - nieprawidłowa instalacja

Post autor: xzoltanx » 13 listopada 2016, 19:27

Witam,
staram się zainstalowąć debiana z minimalnym środowiskiem KDE korzystając z poradnika Yampressa. Zależy mi tylko na tym, żebym mógł się zalogować do środowiska graficznego bez instalacji zbędnych mi programów.
Po instalacji systemu (wersja 8.6) jedynie z Podstawowymi narzędziami systemowymi, loguję się na roota i w source-list dopisuję contrib non-free na końcu trzech poniższych linijek.

Kod: Zaznacz cały

deb http://ftp.pl.debian.org/debian/ jessie main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://ftp.pl.debian.org/debian/ jessie-updates main contrib non-free
Wpisuję apt update && apt full-upgrade, ale wyskakuje komunikat, że zaktualizowano i zainstalowano 0 plików.
Zaczynam instalację środowiska.

Kod: Zaznacz cały

apt install xorg kde-plasma-desktop kwin-x11 kde-l10n-pl kde-wallpapers sddm
apt install kde-config-gtk-style gtk3-engines-breeze
apt install dmz-cursor-theme ttf-mscorefonts-installer
Z powyższych komend kwin-x11, sddm i gtk3-engines-breeze nie zostają odnalezione. Jak powinienem zmienić te wpisy, dla mojej wersji oxygen zamiast breeze?
Zaczynam instalację oprogramowania.

Kod: Zaznacz cały

apt install akregator okular okular-extra-backends gwenview k3b k3b-i18n 
apt install ksnapshot kalarm knotes ark kget kcalc krusader mc htop spectacle
apt install firefox-esr firefox-esr-l10n-pl icedove icedove-l10n-pl chromium chromium-l10n 
apt install pepperflashplugin-nonfree  browser-plugin-freshplayer-pepperflash
apt install gimp inkscape darktable 
apt install libreoffice libreoffice-l10n-pl libreoffice-dmaths mythes-pl
apt install smplayer mencoder vlc soundkonverter qbittorrent qmmp kodi audacity 
apt install synaptic hardinfo gparted
Jedynie browser-plugin-freshplayer-pepperflash nie zostaje odnaleziony, ale przypuszczam, że to akurat nie jest konieczne. I teraz co dokładnie powinienem zrobić, żeby uruchomić system w środowisku graficznym, poprzednim razem po reboocie nadal byłem w terminalu?

Przepraszam za noobski temat, ale dopiero zacząłem działać na linuxie, a w przypadku instalacji systemu nie mam możliwości zbytnio eksperymentować z powodu braku dostępu do informacji, dlatego próbuję się upewnić jak jej ponownie nie spartolić. Dziękuję za wszelką pomoc.

Awatar użytkownika
dedito
Moderator
Posty: 2942
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Minimalne KDE debian 8.6 - nieprawidłowa instalacja

Post autor: dedito » 13 listopada 2016, 19:57

Pewnie, chodzi o viewtopic.php?f=28&t=33746
Tyle, że ten poradnik dotyczy KDE5 i Debiana Stretch/Sid.

Awatar użytkownika
xzoltanx
Posty: 3
Rejestracja: 13 listopada 2016, 17:32

Re: Minimalne KDE debian 8.6 - nieprawidłowa instalacja

Post autor: xzoltanx » 13 listopada 2016, 20:56

Dokładnie z tego poradnika korzystałem. A czy istnieje możliwość instalacji minimalnego środowiska dla mojej wersji, żebym tylko mógł się zalogować do KDE z koniecznymi do tego programami i samodzielnie zainstalować oprogramowanie? Mam na myśli wpisy jakie powinienem dodać do source-list i komendy jakimi mógłbym zainstalować środowisko dla mojej wersji debiana. W KDE zainstalowanym standardowo jest wiele programów z których nigdy nie skorzystam, a mój dysk niestety nie jest zbyt obszerny.

Awatar użytkownika
dedito
Moderator
Posty: 2942
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Minimalne KDE debian 8.6 - nieprawidłowa instalacja

Post autor: dedito » 13 listopada 2016, 21:05

Kolego określ w jakiej wersji chcesz mieć to KDE.
Jak seria 4 to zerknij do WIKI Debiana.

Awatar użytkownika
xzoltanx
Posty: 3
Rejestracja: 13 listopada 2016, 17:32

Re: Minimalne KDE debian 8.6 - nieprawidłowa instalacja

Post autor: xzoltanx » 13 listopada 2016, 22:15

Myślałem o interfejsie z poradnika. Czyli muszę zmienić instalator np. na debian-stretch-DI-alpha8 i wtedy używając dokładnie tych samych komend, które znajdują się w poradniku, zainstaluję KDE5? I jeszcze chciałbym się upewnić, czy po instalacji wszystkiego i uruchomieniu ponownie komputera system odpali się automatycznie w środowisku graficznym, czy muszę to zrobić manualnie?

Awatar użytkownika
Yampress
Administrator
Posty: 6148
Rejestracja: 09 sierpnia 2007, 21:41
Lokalizacja: PL

Re: Minimalne KDE debian 8.6 - nieprawidłowa instalacja

Post autor: Yampress » 14 listopada 2016, 13:35

Istnieje. Tylko w jessie nie ma nowego login managera sddm. Jest stary kdm. Musisz więc instalować kdm.
Paru programów też już nie ma albo mają inne nazwy.

gtk3-engines-breeze jest tylko w Stretchu, nie ma w Jessie.

AA i w jessie jak nie masz w systemie aptitude musisz zainstalować

Kod: Zaznacz cały

apt-get install aptitude
poza tym nie ma apt v2 w jessie bo wszedł dopiero od Stretcha i w wyższe smaki Debiana.

Najprościej nie instalować tak jak tam pisałem

Kod: Zaznacz cały

aptitude program1 program2 program3
tylko

Kod: Zaznacz cały

aptitude program1
kiedy się zainstaluje

Kod: Zaznacz cały

aptitude program2
i analogicznie

Kod: Zaznacz cały

aptitude program3
albo czytasz uważnie czego nie ma kiedy podasz pierwsze rozwiązanie

Kod: Zaznacz cały

aptitude program1 program2 program3
i wykreślasz z listy wpisanych programów tego którego brakuje i ponawiasz próbe instalacji ale bez tego programu



A w Jessie nie ma KDE5 jest tylko w Stretchu. W sumie podobno istnieje możliwość adaptacji kde5 z repozytorium Netrunnera
na Debianie Jessie. Ale tego nie próbowałem i nie wiem czy działa jak należy. Poa tym to zawsze inne zewnętrzne repo nie debianowe i można się kiedyś naciąć.

ODPOWIEDZ