[+] Problem z zarządzaniem energią (zamykanie klapy laptopa)

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
Awatar użytkownika
xmaster
Junior Member
Posty: 556
Rejestracja: 13 stycznia 2009, 08:19
Lokalizacja: /dev/piotrków tryb.

[+] Problem z zarządzaniem energią (zamykanie klapy laptopa)

Post autor: xmaster » 01 września 2016, 20:54

Witam.
Od kilku dni zamknięcie klapy mojego Della D630 kończy się wstrzymaniem systemu.
W ustawieniach menedżera zasilania ustawione mam od czasu instalacji opcję "wyłącz ekran", niestety pewnie po jakiejś aktualizacji ni w pięć ni w dziesięć ustawienia nie pokrywają się z działaniem systemu.

Kod: Zaznacz cały

$ uname -r
4.6.0-1-amd64

Kod: Zaznacz cały

$ cat /etc/debian_version
stretch/sid
Obrazek
Ostatnio zmieniony 01 września 2016, 21:47 przez xmaster, łącznie zmieniany 2 razy.

Awatar użytkownika
dedito
Moderator
Posty: 2942
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z zarządzaniem energią (zamykanie klapy laptopa)

Post autor: dedito » 01 września 2016, 21:17

Pokaż /etc/systemd/logind.conf

Awatar użytkownika
xmaster
Junior Member
Posty: 556
Rejestracja: 13 stycznia 2009, 08:19
Lokalizacja: /dev/piotrków tryb.

Re: Problem z zarządzaniem energią (zamykanie klapy laptopa)

Post autor: xmaster » 01 września 2016, 21:28

Kod: Zaznacz cały

cat /etc/systemd/logind.conf
#  This file is part of systemd.
#
#  systemd is free software; you can redistribute it and/or modify it
#  under the terms of the GNU Lesser General Public License as published by
#  the Free Software Foundation; either version 2.1 of the License, or
#  (at your option) any later version.
#
# Entries in this file show the compile time defaults.
# You can change settings by editing this file.
# Defaults can be restored by simply deleting this file.
#
# See logind.conf(5) for details.

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
#HandlePowerKey=poweroff
#HandleSuspendKey=suspend
#HandleHibernateKey=hibernate
#HandleLidSwitch=suspend
#HandleLidSwitchDocked=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=yes
#InhibitorsMax=8192
#SessionsMax=8192
#UserTasksMax=33%

Awatar użytkownika
dedito
Moderator
Posty: 2942
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z zarządzaniem energią (zamykanie klapy laptopa)

Post autor: dedito » 01 września 2016, 21:33

Ustaw opcje:

Kod: Zaznacz cały

HandleLidSwitch=ignore
HandleLidSwitchDocked=ignore
Zrestartuj

Kod: Zaznacz cały

systemctl restart systemd-logind.service
lub cały system i sprawdź czy coś to zmieniło.

Awatar użytkownika
xmaster
Junior Member
Posty: 556
Rejestracja: 13 stycznia 2009, 08:19
Lokalizacja: /dev/piotrków tryb.

Re: Problem z zarządzaniem energią (zamykanie klapy laptopa)

Post autor: xmaster » 01 września 2016, 21:40

Działa wielkie dzięki. Musiałem jeszcze tylko odhaszować te linijki.
Ekran gaśnie tak jak kiedyś.

Awatar użytkownika
dedito
Moderator
Posty: 2942
Rejestracja: 18 listopada 2013, 21:07
Lokalizacja: Gliwice

Re: Problem z zarządzaniem energią (zamykanie klapy laptopa)

Post autor: dedito » 01 września 2016, 21:42

Odchaszować trzeba zawsze aby ustawienie opcji zaczeło obowiązywać nad domyślnym.

Jeśli wątek rozwiązany, proszę odpowiednio oznaczyć.
Wątek oznaczony jako rozwiązany, zamykam.
W razie potrzeby otwarcia, proszę o kontakt na pw.

Zablokowany