xorg,

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
ajvens
Posty: 1
Rejestracja: 06 grudnia 2015, 01:15

xorg, środowisko graficzne kde i kilka innych problemów

Post autor: ajvens » 06 grudnia 2015, 01:29

Witam, mam kilka problemów na które szukałem odpowiedzi w sieci ale nie znalazłem (wiem ze na pewno są ale chyba szukanie mi nie wyszło)

Mianowicie moje problemy to:
1.brak automatycznego logowania do środowiska graficznego.
2.brak możliwości zalogowania sie do innych użytkowników niż root. tzn. przez putty z innego pc mogę zalogować się tylko do usera root. gdy startuje z poziomu root'a "startx" to czasami rusza czasami nie ogólnie wywala taki komunikat :

Kod: Zaznacz cały

X.Org X Server 1.17.3Release Date: 2015-10-26
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
Current Operating System: Linux ajvens 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u6 (2015-11-09) x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-amd64 root=UUID=444eeb3c-698c-4c2a-9de0-b035fcad6927 ro quiet
Build Date: 27 October 2015  11:41:02PM
xorg-server 2:1.17.3-2 (http://www.debian.org/support)
Current version of pixman: 0.33.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Sun Dec  6 01:22:47 2015
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server


Co do innych logów które (chyba) pomogą

Kod: Zaznacz cały

[124924.986]X.Org X Server 1.17.3
Release Date: 2015-10-26
[124924.986] X Protocol Version 11, Revision 0
[124924.986] Build Operating System: Linux 3.16.0-4-amd64 x86_64 Debian
[124924.986] Current Operating System: Linux ajvens 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u6 (2015-11-09) x86_64
[124924.986] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.16.0-4-amd64 root=UUID=444eeb3c-698c-4c2a-9de0-b035fcad6927 ro quiet
[124924.986] Build Date: 27 October 2015  11:41:02PM
[124924.986] xorg-server 2:1.17.3-2 (http://www.debian.org/support)
[124924.986] Current version of pixman: 0.33.4
[124924.986]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[124924.986] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[124924.986] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Dec  6 00:43:55 2015
[124924.986] (II) Loader magic: 0x7fde6b552de0
[124924.986] (II) Module ABI versions:
[124924.986]    X.Org ANSI C Emulation: 0.4
[124924.986]    X.Org Video Driver: 19.0
[124924.986]    X.Org XInput driver : 21.0
[124924.986]    X.Org Server Extension : 9.0
[124924.989] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_3246
[124924.990] (II) xfree86: Adding drm device (/dev/dri/card0)
[124924.990] (EE) systemd-logind: failed to take device /dev/dri/card0: Operation not permitted
[124924.991] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
[124924.992] (--) PCI:*(0:0:2:0) 8086:2e22:103c:2a94 rev 3, Mem @ 0xfe400000/4194304, 0xe0000000/268435456, I/O @ 0x0000cc00/8
[124924.992] (--) PCI: (0:0:2:1) 8086:2e23:103c:2a94 rev 3, Mem @ 0xfe900000/1048576
[124924.993] List of video drivers:
[124924.993]    neomagic
[124924.993]    intel
[124924.993]    cirrus
[124924.993]    mga
[124924.993]    radeon
[124924.993]    savage
[124924.993]    openchrome
[124924.993]    tdfx
[124924.993]    ati


Co do wersji debiana to ostatnio zainstalowałem Debian 9 Stretch.

3. Kolejny problem to komenda apt-get update mianowicie gdy wydam komendę to:

Kod: Zaznacz cały

root@ajvens:~# apt-get updaterun-parts: failed to open directory /etc/apt/update-pre-invoke.d: No such file or directory
 i na końcu
run-parts: failed to open directory /etc/apt/update-post-invoke-success.d: No such file or directory
run-parts: failed to open directory /etc/apt/update-post-invoke.d: No such file or directory



Jeśli to zły temat to proszę o przeniesienie. A każdego kto może o pomoc dopiero zaczynam z linuxem wiec proszę o wyrozumiałość.

ODPOWIEDZ