Sterowniki zamknięte ATI - fglrx

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
Mike013
Posty: 33
Rejestracja: 14 lutego 2008, 00:38

Post autor: Mike013 » 17 lutego 2008, 12:19

M, wszystko śmiga :)

Dzięki Wielkie :)

tydell
Posty: 60
Rejestracja: 17 lutego 2008, 18:02
Lokalizacja: Czyżew

Post autor: tydell » 17 lutego 2008, 20:11

a czy ktoś wie co poradzić na coś takiego ?
No GLXFBConfig for default depth
wszystko jest ok, fglrx zainstalowane , direct rendering Yes, Xorg.conf w porządku raczej, i gdy odpalam fusion-icon lub poprostu compiz --replace to mam coś takiego i compiz nie działą

blindman
Posty: 13
Rejestracja: 02 marca 2008, 20:07
Lokalizacja: Wroc³aw

Post autor: blindman » 07 marca 2008, 16:01

Przy instalacji sterów pojawia mi się:

Kod: Zaznacz cały

blindman:/home/eryk# apt-get install module-assistant fglrx-driver fglrx-kernel-src
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Reading state information... Gotowe
module-assistant jest już w najnowszej wersji.
Nie udało się zainstalować niektórych pakietów. Może to oznaczać,
że zażądano niemożliwej sytuacji lub używasz dystrybucji niestabilnej,
w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione
z katalogu Incoming ("Przychodzące").
Następujące informacje mogą pomóc rozpoznać sytuację:

Następujące pakiety mają niespełnione zależności:
  fglrx-driver: Wymaga: xserver-xorg (>= 1:7.1.0)
E: Pakiety są błędne
Wiem, że muszę mieć xorga ≥ 7.1.0, ale nie wiem jak to zrobić. Próbowałem już na wiele sposobów, ale nie mogę osiągnąć zamierzonego efektu. Na pewno nie pomaga:

Kod: Zaznacz cały

apt-get install xserver-xorg xbase-clients xfonts-base xterm
bo wtedy wskazuje mi, że mam:

Kod: Zaznacz cały

blindman:~# X -version

X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: Linux Debian (xorg-server 2:1.3.0.0.dfsg-12lenny2)
Current Operating System: Linux blindman 2.6.22-3-k7 #1 SMP Sun Feb 10 21:04:14 UTC 2008 i686
Build Date: 19 January 2008
        Before reporting problems, check [url]http://wiki.x.org[/url]
        to make sure that you have the latest version.
Module Loader present

Co muszę zrobić?

yantar
Member
Posty: 1225
Rejestracja: 07 czerwca 2007, 21:15
Lokalizacja: Rzeszów

Post autor: yantar » 07 marca 2008, 16:05

aktualnie w repozytoriach dla lenego jest xorg 1:7.2-5

Rozumiem ze masz aktualne wpisy repozytoriow w sources.list

Jesli tak, wydaj najpierw polecenie

Kod: Zaznacz cały

aptitude update

blindman
Posty: 13
Rejestracja: 02 marca 2008, 20:07
Lokalizacja: Wroc³aw

Post autor: blindman » 07 marca 2008, 16:26

Ale to właśnie nic nie daje. Niby się zainstalował, a po komędzie

Kod: Zaznacz cały

X -version
jest dalej to samo czyli to co w poście wyżej.

kogut
Posty: 3
Rejestracja: 14 marca 2008, 19:52

Post autor: kogut » 14 marca 2008, 19:59

Witam,
Mam problem z instalacją sterowników ATI do Radeona 9600PRO.

Po pobraniu wydaję polecenie:
./nazwapliku.run

Odpala się instalator, jednak jest problem, ponieważ jest on za duży i nie mieści się na ekranie. Nie da się go w pionie pomniejszyć (jedynie mogę zmienić szerokość). Wie ktoś w czym problem?

Zrzut ekranu:
http://images33.fotosik.pl/179/66c358897cb9aede.png

yantar
Member
Posty: 1225
Rejestracja: 07 czerwca 2007, 21:15
Lokalizacja: Rzeszów

Post autor: yantar » 14 marca 2008, 20:45

Lewy Alt + mysza zlap i przesun okno w gore, lub lewy Alt+F6 powinno dopasowac wysokosc do okna ekranu. (Zakladam, ze podobne skroty sa we wszystkich srodowiskach)

kogut
Posty: 3
Rejestracja: 14 marca 2008, 19:52

Post autor: kogut » 14 marca 2008, 23:41

Dzięki, pierwszy sposób zadziałał. Jednak po instalacji tych sterowników miałem wszystko bardzo małe. Zmiana rozdzielczości nie pomagała, glxgears pokazywało około 200fps :/ Na każdym sterowniku (ati, radeon, fglrx) mam tak mało :( Próbowałem chyba wszystkiego z tego forum, ale jako że Debiana mam od wczoraj, to mogłem zrobić jakiś błąd. Mam wszystkie wymagane paczki. Jest to dla mnie ważne, bo muszę na zajęcia pisać programy w OpenGL,a przy 200fps po prostu się nie da tego odpalać (obraz przeskakuje co chwile zamiast być płynnym). Bardzo proszę o pomoc.

yantar
Member
Posty: 1225
Rejestracja: 07 czerwca 2007, 21:15
Lokalizacja: Rzeszów

Post autor: yantar » 15 marca 2008, 02:28

200 fps to raczej wskazuje ,ze wciaz nie masz akceleracji sprzetowej.

Kod: Zaznacz cały

glxinfo | grep direct
Do sprawdzenia w konsoli czy jest akceleracja.
Najlepiej usun te stery i sprobuj zainstalowac w pierwszej kolejnosci otwarte. A dopiero pozniej jak cos nie bedzie gralo to zamkniete sterowniki z repozytoriow. (wszystko na forum co i jak)

M
Posty: 36
Rejestracja: 07 listopada 2007, 13:50
Lokalizacja: Czêstochowa

Post autor: M » 15 marca 2008, 09:05

Ważne jest, żeby robić to najlepiej pod konsolą a nie pod X'ami. Mówię oczywiście o instalacji driverów. Przeczytaj >to< a dokładniej post napisany przeze mnie 2008-02-16 o 22:32.

Zablokowany