Sterowniki zamknięte ATI - fglrx

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
Rodzyn
Posty: 9
Rejestracja: 17 grudnia 2007, 22:52
Lokalizacja: Warszawa

Post autor: Rodzyn » 02 stycznia 2008, 12:43

Chyba będzie trzeba pomyśleć nad Nvidią :(

lukas
Posty: 51
Rejestracja: 14 czerwca 2007, 14:15
Lokalizacja: Nie pamiêtam

Post autor: lukas » 02 stycznia 2008, 16:01

Chyba będzie trzeba pomyśleć nad Nvidią :(
Jak masz na płycie PCI-e, to nie problem i koszt mały. Ja jade dalej na AGP i musiałem kupić Radeon X1650XT, ponieważ od NV były już tylko wynalazki czyt. Palit. Ale teraz żałuję, że nie zainwestowałem w tą firmę :-/

[ Dodano: 2008-01-08, 14:55 ]
Właśnie przeinstalowałem Debiana Lenny i standardowo chciałem zainstalować sterowniki, ale mam mały problem. Zauważyłem, że pojawiło się nowe jajko, więc je zaktualizowałem. Poleciałem instalacje według pierwszej metody i tak jak opisywałem wyżej, monitor dostaje sygnał i noc poza tym, a dokładnie to zawiesza się cały system tj. ctrl+alt+backspace nie reaguje :evil:

Rodzyn
Posty: 9
Rejestracja: 17 grudnia 2007, 22:52
Lokalizacja: Warszawa

Post autor: Rodzyn » 12 stycznia 2008, 16:09

Ano mam na PCI-e :) Ale w sumie jakbym wymieniał to już na lepszą kartę graficzną niż x1950PRO który po roku od wydania nadal jest świetna na Windowsie w grach. Jeszcze nie miałem okazji przetestowania tej karty na linuksie przez te problemy z driverami :/ I też szkoda, że mało gier jest robionych pod Linuksa jedynie co ID software pamięta choć już jakieś pogłoski są, że raczej zrezygnują ze wspierania dla Linuksa :( To samo z America's Army :/


Edit: Na które jajko zaktualizowałeś? Bo właśnie się zastanawiam czy przed powtórną instalacją driverów nie zaktualizować kernela do wersji 2.6.23.13 Stable

lukas
Posty: 51
Rejestracja: 14 czerwca 2007, 14:15
Lokalizacja: Nie pamiêtam

Post autor: lukas » 12 stycznia 2008, 16:36

Na które jajko zaktualizowałeś? Bo właśnie się zastanawiam czy przed powtórną instalacją driverów nie zaktualizować kernela do wersji 2.6.23.13 Stable
Na Ubuntu 7.10 masz dostęp do nowszego jaja. Ja używam Debiana Lenny i tam jest dopiero 2.6.22.3. Skompilowałem sobie najnowsze jądro tj. 2.6.23.13, zainstalowałem sterowniki, system odpalił, ale nie było akceleracji. Wcześniej nigdy tego nie robiłem, ponieważ według opinii bardziej doświadczonych użytkowników- efekty są praktycznie niezauważalne. Jajo kompilowałem tylko dla najnowszych Catalyst 7.12. Skoro kompilacja przeszła bez problemów, to postanowiłem zrobić ją na świeżym systemie razem z instalacją najnowszych sterowników. Niestety, nie wiem czemu, ale jajo już nie chciało się zbootować.

Wypluwało mi mniej więcej taki błąd.

Kod: Zaznacz cały

ide0:I/O resource  not free
ide:p orts already in use, skipping probe

[/code]

Klusek
Posty: 4
Rejestracja: 07 stycznia 2008, 22:39
Lokalizacja: 16.7014°E 53.7058°N

Post autor: Klusek » 14 stycznia 2008, 01:26

Wszytko niby idzie gładko tak jak powinno, ale próba zainstalowania fglrx na Radeonie Xpress 1100 kończy się po komendzie:

Kod: Zaznacz cały

aticonfig --initial
tak

Kod: Zaznacz cały

Data incomplete in file /etc/X11/xorg.conf
	Device section "Configured Video Device" must have a Driver line.
Data incomplete in file /etc/X11/xorg.conf
	Undefined Device "(null)" referenced by Screen "Default Screen".
aticonfig: Parsing the configuration file failed.
The above error messages are reported from XFree86 and may assist you in
diagnosing the problem with your configuration input file. Try use -f option
to generate a new configuration file.
od razu mówię, że

Kod: Zaznacz cały

aticonfig --initial -f
nic nie daje.
Mój xorg też wygląda jakoś tak ubogo

Kod: Zaznacz cały

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"pl"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
	Option		"UseFBDev"		"true"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
EndSection

Rodzyn
Posty: 9
Rejestracja: 17 grudnia 2007, 22:52
Lokalizacja: Warszawa

Post autor: Rodzyn » 15 stycznia 2008, 16:49

Melduję, że stery 7.12 działają na moim x1950PRO :) Instalowałem przez Envy

adnix
Beginner
Posty: 113
Rejestracja: 17 stycznia 2008, 09:41

Post autor: adnix » 17 stycznia 2008, 09:47

Zainstalowałem zamknięte sterowniki. Direct reendering: Yes lecz jest problem z rozdzielczością. Mam możliwość wyboru wszystkich oprócz 1400x1050.
z manuala aticonfig wykminiłem takie coś aticonfig --resolution=0,1400x1050 ale dostaje informacje no screen 0.

Kod: Zaznacz cały

adnix@debian:~$ cat /etc/X11/xorg.conf
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"	"/dev/input/mice"
	Option		"Protocol"	"ImPS/2"
	Option		"ZAxisMapping"	"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"	"/dev/psaux"
	Option		"Protocol"	"auto-dev"
	Option		"HorizEdgeScroll"	"0"
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"stylus"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"stylus"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"eraser"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"eraser"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
	Driver		"wacom"
	Identifier	"cursor"
	Option		"Device"	"/dev/input/wacom"
	Option		"Type"	"cursor"
	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"Generic Video Card"
	Driver		"fglrx"
	Busid		"PCI:1:0:0"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Generic Video Card"
	Monitor		"Generic Monitor"
	Defaultdepth	24
	SubSection "Display"
		Modes		"1400x1050"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
  screen "Default Screen"
	Inputdevice	"Generic Keyboard"
	Inputdevice	"Configured Mouse"
	
	# Uncomment if you have a wacom tablet
	#	InputDevice     "stylus"	"SendCoreEvents"
	#	InputDevice     "cursor"	"SendCoreEvents"
	#	InputDevice     "eraser"	"SendCoreEvents"
	Inputdevice	"Synaptics Touchpad"
EndSection
Section "Module"
	Load		"glx"
EndSection
Section "Extensions"
	Option		"Composite"	"0"
EndSection

Awatar użytkownika
monolith
Posty: 86
Rejestracja: 09 sierpnia 2007, 01:38
Lokalizacja: Polska

Post autor: monolith » 17 stycznia 2008, 10:34

Witam,

Podobny problem u mnie na laptopie z ATI Mobility Radeon 9700. Po zainstalowaniu nowych sterowników ATI ver. 7.12, nie mogę wybrać rozdzielczości 1400x1050. Próbowałem już różnych ustawień w xorg.conf i nic. Problem rozwiązałem wracając do poprzedniego sterownika 8.40.4 :-)

adnix
Beginner
Posty: 113
Rejestracja: 17 stycznia 2008, 09:41

Post autor: adnix » 17 stycznia 2008, 11:44

z tym, że otwarte sterowniki nie wspierają mojej karty :/. Wątpię ale może jest coś takiego w Debianie jak Menedżer Sterowników Własnościowych. Taki twór jest w Ubuntu i bezproblemowo poradził sobie z konfiguracją mojej karty.

salmon
Beginner
Posty: 296
Rejestracja: 12 października 2007, 23:28
Lokalizacja: Gliwice/Bielsko-Biała

Post autor: salmon » 17 stycznia 2008, 11:45

Za https://a248.e.akamai.net/f/674/9206/0/ ... linux.html
# Connecting a display device that supports 1680x1050 to a system running Linux may result in a maximum display resolution of 1280x1024 only being available
# Custom mode lines in xorg.conf may be ignored by the fglrx driver
Może to dotyczyć też innych rozdzielczości...

Zablokowany