Sterowniki zamknięte ATI - fglrx

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
kakadu
Posty: 24
Rejestracja: 21 lipca 2007, 21:37
Lokalizacja: Gdañsk

Post autor: kakadu » 27 września 2007, 08:04

Tu żadnych błędów nie ma. Teraz wpisz

Kod: Zaznacz cały

dmesg | grep fglrx

piaskos
Posty: 29
Rejestracja: 25 września 2007, 22:43
Lokalizacja: Kalisz/Wroc

Post autor: piaskos » 27 września 2007, 10:29

jak to wpisze to nic sie nie dzieje:

Kod: Zaznacz cały


debianek:/home/piaskos# dmesg | grep fglrx
debianek:/home/piaskos#

Awatar użytkownika
darkwater
Junior Member
Posty: 828
Rejestracja: 25 stycznia 2007, 14:01
Lokalizacja: Częstochowa

Post autor: darkwater » 27 września 2007, 14:10

Informacja dla użytkowników fglrx + debian/sid. Jeśli po aktualizacji xservera nie startuje wam tryb graficzny (wywala sie fglrx z informacją o niezgodności ABI) pomaga dopisanie do xorg.conf w sekcji ServerFlags opcji IgnoreABI

Kod: Zaznacz cały

Section "ServerFlags"
        ...
        Option  "IgnoreABI" "on"
        ...
EndSection
rozwiązanie jest oczywiście tymczasowe i może powodować problemy (np nieprzewidywalne zwisy x lub nawet całego systemu) U¯YWAÆ OSTRO¯NIE !!

dlm
Posty: 1
Rejestracja: 11 października 2007, 16:32

Post autor: dlm » 11 października 2007, 16:41

Witam !!
Pierwszy post na forum, jednak niestety z problemem. Od dłuższego czasu próbuję zainstalować sterowniki do karty graficznej na swoim notebooku. Jak widać po sygnaturze udało mi się zainstalować debiana (etch) jendak instalacja sterowników do grafiki przebiega strasznie opornie. Próbowałem obu opisanych metod i nadal nic. Mam kartę ATI Radeon Mobility X2300. Nie można oczywiście uświadczyć sterowników do tej karty na stronie ati - ani dla linuksa ani dla windowsa. Po instalacji, przy restarcie x-ów otrzymuje taki komunikat http://www.wklej.org/id/32c2670570 (xorg log).

Poza tym jest jeszcze drugi problem - mianowicie notebook na panoramiczną matrycę i rozdzielczość na której się dobrze pracuje to 1280x800. Dziwne dla mnie jest to, że w xorg.conf jest taka rozdzielczość właśnie ustawiona, a manager kde czy gnoma jej nie wyświetla -> podaje tylko 3 standardowe (1024x768, 800x600, 640x480). Czy brak wskazanej wcześniej rozdzielczości jest spowodowany brakiem sterowników czy brakiem pakietów czy ich złą konfiguracją ???

Dzięęĸi za pomoc i pozdrawiam !!!

Awatar użytkownika
darkwater
Junior Member
Posty: 828
Rejestracja: 25 stycznia 2007, 14:01
Lokalizacja: Częstochowa

Post autor: darkwater » 11 października 2007, 21:39

masz strasznie stare sterowniki - nic dziwnego że nie rozpoznają twojej karty. ze strony amd-ati ściągnij nowe i wypróbuj. co prawda radeony mobility wypisane są tylko do x1800 ale spróbować warto. jeśli nie to zostaje ci tylko driver vesa lub próba zainstalowania avivo.

[ Dodano: 2007-10-26, 19:46 ]


Instalacja fglrx 8.42.3 na maszynach amd64

Ta wersja instalatora zawiera niestety błąd który uniemożliwia poprawne wygenerowanie pakietów deb w systemach 64bitowych.

Kod: Zaznacz cały

cp: cannot stat `./usr/X11R6/lib/modules/dri': No such file or directory
Na szczęście błąd ten można stosunkowo łatwo obejść.

1.¦ciągamy instalator ze strony ati ( ¬ródło: https://a248.e.akamai.net/f/674/9206/0/ ... x86_64.run )

2.Odpalamy konsolę i wchodzimy do katalogu ze ściągniętym plikiem.

3.Wydajemy polecenie

Kod: Zaznacz cały

 sh ./ati-driver-installer-8.42.3-x86.x86_64.run --extract 
. Pakiet rozpakuje sie do podkatalogu o losowo wygenerowanej nazwie (u mnie było to fglrx-install.xU6872 Przechodzimy do tego podkatalogu

Kod: Zaznacz cały

cd ./fglrx-install.xU6872 
4.następnie wydajemy kilka poleceń które utworzą niezbędne dowiązanie

Kod: Zaznacz cały

cd ./arch/x86_64/usr/X11R6/
ln -s ./lib64/ ./lib
cd ../../../..
5. I już możemy generować deby

Kod: Zaznacz cały

sh ./ati-installer.sh 8.42.3 --buildpkg Debian/unstable
Instalator zapisze nowo utworzone pakiety w katalogu nadrzędnym względem tego w którym jesteśmy. Oczywiście jeśli ktoś używa innej wersji debiana to wpis będzie wyglądał odpowiednio inaczej (np. Debian/testing zamiast Debian/unstable).

6. I to w zasadzie wszystko - reszta instalacji przebiegać będzie identycznie jak w poprzednich wersjach.

Czekam na opis wrażeń z użytkowania - nowe drivery podobno są znacznie szybsze od poprzednich wersji oraz wspierają (WRESZCIE) AIGLX. Sam również zabieram się za instalacje - może wreszcie skusze sie na zainstalowanie u używanie na codzień compiz-fusion.

//edit
wrrr - nie da sie pisać posta po postem - szkoda - troche nieczytelnie to teraz wygląda :]

Awatar użytkownika
zomer
Beginner
Posty: 322
Rejestracja: 26 października 2007, 15:52
Lokalizacja: Podkarpacie

Post autor: zomer » 12 listopada 2007, 16:39

Zmieniłem karte graficzną nz radeona 9800. Wykonałem wszystkie kroki z instrukcjiRadex, ale podczas wpisywania

Kod: Zaznacz cały

# aticonfig --initial
dosteję komunikat

Kod: Zaznacz cały

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified
Niech mi ktoś pomoże bo już nie wyrabiam. plik xorg.conf nadal pozostał bez zmian (jest tam wpis że mam Radeona 9200 SE)
Co ja robię nie tak?

Pietruch
Posty: 56
Rejestracja: 01 czerwca 2007, 01:22
Lokalizacja: Brzeg/Opole

Post autor: Pietruch » 12 listopada 2007, 18:21

Też się na to naciąłem :) Ale szybko to rozwiązałem poprzez

Kod: Zaznacz cały

dpkg-reconfigure xserver-xorg

Awatar użytkownika
zomer
Beginner
Posty: 322
Rejestracja: 26 października 2007, 15:52
Lokalizacja: Podkarpacie

Dzieki pomogło

Post autor: zomer » 13 listopada 2007, 12:14

:-) Właśnie o to chodziło. Przesiadka z fedory i Mandrivy na Debiana to dla mnie cieżka przeprawa. Dzieki!

nerwus
Posty: 25
Rejestracja: 28 kwietnia 2007, 12:41

Post autor: nerwus » 17 listopada 2007, 20:01

darkwater pisze: Czekam na opis wrażeń z użytkowania - nowe drivery podobno są znacznie szybsze od poprzednich wersji oraz wspierają (WRESZCIE) AIGLX. Sam również zabieram się za instalacje - może wreszcie skusze sie na zainstalowanie u używanie na codzień compiz-fusion.
to wrażenia:
+ szybkość
Na sterowniku radeon było 2000 fps'ów na fglrx 9000 z palcem w ..... //x800 GTO
+ niestandardowe rozdzielczości typu 1152x864
+ wreszcie zaczęła grafa działać // wcześniej wszystko brał na siebie procek
- nie ma możliwości stałego ustawienia gammy ... po każdym uruchomieniu musze rozjaśniać albo po prostu nie potrafię tego zrobić

na razie to tyle może później coś ciekawego zauważe
Pozdro

Awatar użytkownika
zomer
Beginner
Posty: 322
Rejestracja: 26 października 2007, 15:52
Lokalizacja: Podkarpacie

wruciłem na otwarte stery

Post autor: zomer » 18 listopada 2007, 12:55

Powróciłem do otwartych sterowników bo beryl mi nie działał na zamkniętych. Nie wiem może coś zrobiłem źle, bo po przeprowadzeniu procedury instalacji w /etc/X11/xorg.conf miałem dwie sekcje Device kiedy usuwałem jeden z wpisów o nazwie device to x-y nie wstawały.

Tak przy okazji to jak sprawdzić czy jest obsługa AIGLX ?
tak nie

Kod: Zaznacz cały

glxinfo | grep Direct
tak też nie

Kod: Zaznacz cały

glxgears -printfps
tutaj też nie widzę

Kod: Zaznacz cały

glxinfo

Może jest jakieś magiczne polecenie?

[ Dodano: 2007-11-19, 14:26 ]
Czy komuś udało się uruchomić beryla na zamkniętych sterownikach?
Na otwartych działał mi dość ładnie. Przeszedłem na zamknięte w.g receptury Radex, Niestety beryl się nie uruchamia.

Kod: Zaznacz cały

[size=200]# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	Tutaj ====> szkoda miejsca na forum
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"pl"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "Device"
	Identifier	"ATI Technologies Inc R350 AH [Radeon 9800]"
	Driver		"fglrx"
	BusID		"PCI:1:0:0"
	Option		"UseFBDev"		"true"
EndSection

Section "Monitor"
	Identifier	"FLATRON 775F"
	Option		"DPMS"
	HorizSync	30-70
	VertRefresh	50-160
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies Inc R350 AH [Radeon 9800]"
	Monitor		"FLATRON 775F"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	Tutaj ====> szkoda miejsca na forum
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection[/size]
Jak ktoś wie to niech się podzieli swoimi doświadczeniami. Na zamkniętych sterach faktycznie jest wiecej FPS-ów, ale przyśpieszenie jest b. zmienne
  • 1240 frames in 5.0 seconds = 247.994 FPS
    1238 frames in 5.0 seconds = 247.589 FPS
    14606 frames in 5.0 seconds = 2921.152 FPS
    32237 frames in 5.0 seconds = 6447.321 FPS
    33002 frames in 5.0 seconds = 6600.308 FPS


[ Dodano: 2007-11-20, 10:57 ]
Instaluję najnowsze sterownik ati i dostaję taki komunikat
/

Kod: Zaznacz cały

instalki/ati# sh ./ati-driver-installer-8.42.3-x86.x86_64.run --buildpkg Debian/etch
Created directory fglrx-install.PI6751
Verifying archive integrity...Error in MD5 checksums: ddcfead8ff1586dd6bae865982ddc70c is different from 12a2c940dc363fd88b141b0cc6fdf115
Co z tym zrobić?
Acha mój procesor to Atchlon 1700. Szukałem serowników dla mojej architektóry procesora, ale wygląda na to że jest tylko jeden rodzaj serowników (dla jedno i dwu-rdzeniowych procesorów)

Zablokowany