Sterowniki zamknięte ATI - fglrx

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
kakadu
Posty: 24
Rejestracja: 21 lipca 2007, 21:37
Lokalizacja: Gdañsk

Post autor: kakadu » 18 września 2007, 13:51

Nie skompilowałeś modułu kernela :!:
Poczytaj jeszcze raz opis darkwatera na stronie 5.

Bober
Beginner
Posty: 113
Rejestracja: 17 września 2007, 13:49
Lokalizacja: Gdynia

Post autor: Bober » 18 września 2007, 21:35

Zrobilem wszytsko jak w opiesie min. ze strony piatej i opisu Darkwatera.
Efekt jest ten sam - brak jakiejkolwiek akceleracji. Mimo to zrobilem wszystko jeszcze raz od poczatku i znow podaje glxinfo |grep direct

Kod: Zaznacz cały

Xlib:  extension "XFree86-DRI" missing on display ":0.0".
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
OpenGL renderer string: Mesa GLX Indirect
Zauwazylem jednak (wczesniej na to uwagi nie zwrocilem) ze paczka tworzy inne pliki *.deb niz w opisie. Moze to kwestia tego sterownika? Moze potrzeba zainstalowac te starsza wersje?

kakadu
Posty: 24
Rejestracja: 21 lipca 2007, 21:37
Lokalizacja: Gdañsk

Post autor: kakadu » 18 września 2007, 21:56

Tak, masz nowy sterownik który ma inne paczki niż tamtem.

Kod: Zaznacz cały

fglrx-amdcccle_8.41.7-1_i386.deb
fglrx-driver_8.41.7-1_i386.deb
fglrx-driver-dev_8.41.7-1_i386.deb
fglrx-kernel-src_8.41.7-1_i386.deb
Instalujesz wszystko w kolejności: driver, amdcccle, kenrl-src, driver-dev(to ostatnie możesz sobie odpuścić)
Co ci wywala ta komenda

Kod: Zaznacz cały

module-assistant a-i fglrx
I jaki masz model karty?

Bober
Beginner
Posty: 113
Rejestracja: 17 września 2007, 13:49
Lokalizacja: Gdynia

Post autor: Bober » 18 września 2007, 22:11

Wow :) Teraz juz nawet jakies bledy sie pojawiaja :D Nie wiem ale, chyba za duzo sterownikow poinstalowalem :P Wczesniej ta komenda dzialala bardzo dobrze.

Wyskakuje mi teraz:

Kod: Zaznacz cały

Package fglrx-kernel-src was not built successfully, see  x  
x /var/cache/modass/fglrx-kernel-src*buildlog* for details
Wklejam ten log o ile do czegos ma sie przydac.

Kod: Zaznacz cały

dh_testroot
rm -f configure-stamp
rm -f fglrx.ko fglrx.mod.c *.o libfglrx_ip.a
rm -f .version .*.o.flags .*.o.d .*.o.cmd .*.ko.cmd
rm -rf .tmp_versions
rm -rf patch
dh_clean
rm /usr/src/modules/fglrx/debian/control
rm /usr/src/modules/fglrx/debian/dirs
if [ -f /usr/src/modules/fglrx/debian/control.template ]; then \
		cat /usr/src/modules/fglrx/debian/control.template > /usr/src/modules/fglrx/debian/control; \
	fi
if [ -f /usr/src/modules/fglrx/debian/postinst ]; then \
		mv /usr/src/modules/fglrx/debian/postinst /usr/src/modules/fglrx/debian/fglrx-kernel-2.6.18-kanotix-1.postinst; \
	fi
dh_testdir
touch configure-stamp
dh_testdir
/usr/bin/make -C /lib/modules/2.6.18-kanotix-1/source SUBDIRS=/usr/src/modules/fglrx modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.18-kanotix-1'
  CC [M]  /usr/src/modules/fglrx/firegl_public.o
  LD [M]  /usr/src/modules/fglrx/fglrx.o
  Building modules, stage 2.
  MODPOST
  CC      /usr/src/modules/fglrx/fglrx.mod.o
  LD [M]  /usr/src/modules/fglrx/fglrx.ko
make[1]: Leaving directory `/usr/src/linux-headers-2.6.18-kanotix-1'
dh_testdir
dh_testroot
dh_clean -k
rm -f /usr/src/modules/fglrx/debian/control /usr/src/modules/fglrx/debian/dirs
sed -e 's/#KVERS#/2.6.18-kanotix-1/g' \
	    -e 's/#VERSION#/8.40.4-1/g' debian/control.template > /usr/src/modules/fglrx/debian/control
sed -e 's/#KVERS#/2.6.18-kanotix-1/g' debian/dirs.template > /usr/src/modules/fglrx/debian/dirs
dh_installdirs
dh_install fglrx.ko lib/modules/2.6.18-kanotix-1/misc
dh_testdir
dh_testroot
dh_installdocs
dh_installmodules
dh_link
dh_strip
dh_compress
dh_fixperms
dh_installdeb
dh_gencontrol -- -v8.40.4-1+1
dh_md5sums
dh_builddeb --destdir=/usr/src
tar: -: file name read contains nul character
dpkg-deb: building package `fglrx-kernel-2.6.18-kanotix-1' in `/usr/src/fglrx-kernel-2.6.18-kanotix-1_8.40.4-1+1_i386.deb'.
dh_testroot
rm -f configure-stamp
rm -f fglrx.ko fglrx.mod.c *.o libfglrx_ip.a
rm -f .version .*.o.flags .*.o.d .*.o.cmd .*.ko.cmd
rm -rf .tmp_versions
rm -rf patch
dh_clean
rm /usr/src/modules/fglrx/debian/control
rm /usr/src/modules/fglrx/debian/dirs
Build time: 13 seconds

Karta to ATI Radeon Xpress 200m - napisalem o niej w pierwszym poscie.

ari
Posty: 10
Rejestracja: 22 sierpnia 2007, 10:55
Lokalizacja: dca

Post autor: ari » 19 września 2007, 20:57

Przyłączam się do pytania. Posiadam ati x1300 wcześniej próbowałem instalować z repo ale nie wyszło :( chyba wszystko odinstalowałem i przerzuciłem się na ten sposób.. Wyskakuje mi coś podobnego..

Kod: Zaznacz cały

dh_testroot
rm -f configure-stamp
rm -f fglrx.ko fglrx.mod.c *.o libfglrx_ip.a
rm -f .version .*.o.flags .*.o.d .*.o.cmd .*.ko.cmd
rm -rf .tmp_versions
rm -rf patch
dh_clean
rm /usr/src/modules/fglrx/debian/control
rm /usr/src/modules/fglrx/debian/dirs
if [ -f /usr/src/modules/fglrx/debian/control.template ]; then \
		cat /usr/src/modules/fglrx/debian/control.template > /usr/src/modules/fglrx/debian/control; \
	fi
if [ -f /usr/src/modules/fglrx/debian/postinst ]; then \
		mv /usr/src/modules/fglrx/debian/postinst /usr/src/modules/fglrx/debian/fglrx-kernel-2.6.21-2-686.postinst; \
	fi
dh_testdir
touch configure-stamp
dh_testdir
/usr/bin/make -C /lib/modules/2.6.21-2-686/build SUBDIRS=/usr/src/modules/fglrx modules
make[1]: Wejście do katalogu `/usr/src/linux-headers-2.6.21-2-686'
  CC [M]  /usr/src/modules/fglrx/firegl_public.o
/usr/src/modules/fglrx/firegl_public.c: In function ‘__ke_pci_find_device’:
/usr/src/modules/fglrx/firegl_public.c:1886: warning: ‘pci_find_device’ is deprecated (declared at include/linux/pci.h:470)
/usr/src/modules/fglrx/firegl_public.c: In function ‘__ke_request_irq’:
/usr/src/modules/fglrx/firegl_public.c:2829: warning: passing argument 2 of ‘request_irq’ from incompatible pointer type
/usr/src/modules/fglrx/firegl_public.c: At top level:
/usr/src/modules/fglrx/firegl_public.c:5306: warning: ‘kmem_cache_t’ is deprecated
  LD [M]  /usr/src/modules/fglrx/fglrx.o
  Building modules, stage 2.
  MODPOST 1 modules
FATAL: modpost: GPL-incompatible module fglrx.ko uses GPL-only symbol 'paravirt_ops'
make[2]: *** [__modpost] Błąd 1
make[1]: *** [modules] Błąd 2
make[1]: Opuszczenie katalogu `/usr/src/linux-headers-2.6.21-2-686'
make: *** [build] Błąd 2


kakadu
Posty: 24
Rejestracja: 21 lipca 2007, 21:37
Lokalizacja: Gdañsk

Post autor: kakadu » 21 września 2007, 19:31

@ari
Musisz skompilować kernel z wyłączoną obsługą parawirulaizacji(jak się to robi poszukaj na forum lub google) albo zainstalować 2.6.18 z repo etcha.

P.S Jakieś dwie karty temu prosiłem o rozwiązanie tego samego problemu. Następnym razem czytaj cały wątek :evil:

@Bober
Wpisz:

Kod: Zaznacz cały

# modprobe fglrx
Jeśli nic się nie pojawi(to jest dobry znak), to dopisz tylko do '/etc/modules' fglrx na końcu. Twój log jest bezbłędny, więc prawdopodobnie wszystko robisz dobrze :-)

imported_Kudlaty
Posty: 5
Rejestracja: 25 lutego 2007, 23:14

Post autor: imported_Kudlaty » 23 września 2007, 00:04

no i teraz ja znow mam problem...
chce zainstalowac stery ze stronki ati (8.40.4) ale jakisik blad mi wyskakuje jak odpalam ./ati-driver-installer-8.40.4-x86.x86_64.run

Kod: Zaznacz cały

Created directory fglrx-install.X11444
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.40.4...........................................................................................
==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================

Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.22-2-686; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.X11444
Karta graficzna to 9550
linux-image 2.6.22-2-686
linux-headers 2.6.22-2-686
Debian Sid

piaskos
Posty: 29
Rejestracja: 25 września 2007, 22:43
Lokalizacja: Kalisz/Wroc

Post autor: piaskos » 25 września 2007, 22:48

witam. jestem poczatkujacym uzytkownikiem linux. probowalem zamienic sterowniki na zamkniete tak jak opis na 5 stronie. podczas wszystkich operacji nie zauwazylem zadnych nieprawidlowosci. wszystko bylo ok. ale w momencie restartu nie chce mi sie odpalic w ogole tryb X'ow :(

to jest moj log
http://wklej.org/id/cfa9e61aaf

i plik xorg.conf

http://wklej.org/id/07b617eebb

robilem to na laptopie
acer aspire 3023
sempron 3000+
ati radeon mobility X700

instalowalem te sterowniki: ati-driver-installer-8.33.6-x86.x86_64.run

Z gory dziekuje za pomoc

jeszcze takie cos dodam :P

Kod: Zaznacz cały

debianek:/home/piaskos# module-assistant a-i fglrx

Updated infos about 1 packages
Getting source for kernel version: 2.6.18-5-k7
Kernel headers available in /lib/modules/2.6.18-5-k7/build
apt-get install build-essential
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności... Gotowe
build-essential jest już w najnowszej wersji.
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.

Done!
unpack
Extracting the package tarball, /usr/src/fglrx.tar.bz2, please wait...
Target package file
/usr/src/fglrx-kernel-2.6.18-5-k7_8.33.6-1+2.6.18.dfsg.1-13etch2_i386.deb
already exists, not rebuilding!
(however, you could use the -f switch to ignore it)
dpkg -Ei /usr/src/fglrx-kernel-2.6.18-5-k7_8.33.6-1+2.6.18.dfsg.1-13etch2_i386.deb
Wersja 8.33.6-1+2.6.18.dfsg.1-13etch2 pakietu fglrx-kernel-2.6.18-5-k7 jest już zainstalowana.
debianek:/home/piaskos#

Kod: Zaznacz cały

debianek:/home/piaskos# glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
    GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX version: 1.2
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
    GLX_ARB_multisample
OpenGL vendor string: Tungsten Graphics, Inc.
OpenGL renderer string: Mesa DRI R300 20060815 TCL
OpenGL version string: 1.2 (1.3 Mesa 6.5.1)
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_transpose_matrix, GL_EXT_abgr, GL_EXT_blend_color,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_texture_env_add,
    GL_EXT_texture_env_combine, GL_EXT_texture_env_dot3,
    GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  1 0 None
0x24 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  1 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  1 0 Slow
0x26 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  1 0 Slow
0x27 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  1 0 None
0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  1 0 None
0x29 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  1 0 Slow
0x2a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  1 0 Slow
0x2b 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  1 0 None
0x2c 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  1 0 None
0x2d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  1 0 Slow
0x2e 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  1 0 Slow
0x2f 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  1 0 None
0x30 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  1 0 None
0x31 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  1 0 Slow
0x32 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  1 0 Slow
// Poprawiłem Twój post - dodałem tagi code.
Kaka'


[ Dodano: 2007-09-26, 15:15 ]
Hmmm na tym forum to zyje ktos jeszzcze?? :)

kakadu
Posty: 24
Rejestracja: 21 lipca 2007, 21:37
Lokalizacja: Gdañsk

Post autor: kakadu » 26 września 2007, 20:56

Tak, żyjemy, tylko jesteśmy zajęci....
Wpisz
module-assistant a-i fglrx -f

piaskos
Posty: 29
Rejestracja: 25 września 2007, 22:43
Lokalizacja: Kalisz/Wroc

Post autor: piaskos » 26 września 2007, 23:11

takie cos wyrzuca:

Kod: Zaznacz cały

debianek:/home/piaskos# module-assistant a-i fglrx -f

Updated infos about 1 packages
Getting source for kernel version: 2.6.18-5-k7
Kernel headers available in /lib/modules/2.6.18-5-k7/build
apt-get install build-essential
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności... Gotowe
build-essential jest już w najnowszej wersji.
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.

Done!
download
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności... Gotowe
Przeinstalowanie pakietu fglrx-kernel-src nie jest możliwe, nie może on zostać pobrany.
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.

Updated infos about 1 packages
unpack
Extracting the package tarball, /usr/src/fglrx.tar.bz2, please wait...
"/usr/share/modass/packages/fglrx-kernel-src" build KVERS=2.6.18-5-k7 KSRC=/lib/modules/2.6.18-5-k7/build KDREV=2.6.18.dfsg.1-13etch2 kdist_image
Done with /usr/src/fglrx-kernel-2.6.18-5-k7_8.33.6-1+2.6.18.dfsg.1-13etch2_i386.deb .
dpkg -i /usr/src/fglrx-kernel-2.6.18-5-k7_8.33.6-1+2.6.18.dfsg.1-13etch2_i386.deb
(Odczytywanie bazy danych ... 91359 plików i katalogów obecnie zainstalowanych.)Przygotowanie do zastąpienia fglrx-kernel-2.6.18-5-k7 8.33.6-1+2.6.18.dfsg.1-13etch2 (wykorzystując .../fglrx-kernel-2.6.18-5-k7_8.33.6-1+2.6.18.dfsg.1-13etch2_i386.deb) ...
Rozpakowanie pakietu zastępującego fglrx-kernel-2.6.18-5-k7 ...
Konfigurowanie fglrx-kernel-2.6.18-5-k7 (8.33.6-1+2.6.18.dfsg.1-13etch2) ...
//edit
używaj tagów code
mlyczek

Zablokowany