Sterowniki zamknięte ATI - fglrx

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
bartek
Beginner
Posty: 129
Rejestracja: 01 maja 2006, 08:14

Sterowniki zamknięte ATI - fglrx

Post autor: bartek » 31 maja 2006, 10:39

Przed instalacją zamkniętych sterowników, zalecam zapoznać się z tym tematem:
http://debian.linux.pl/viewtopic.php?t=952



1) Instalacja z repo

Upewniamy się, że w sources.list mamy dopisany komponent non-free

Debian~$ apt-get update
Debian~$ apt-get install module-assistant fglrx-driver fglrx-kernel-src

Kompilujemy i ładujemy sterownik
Debian~$ module-assistant prepare
Debian~$ module-assistant update
Debian~$ module-assistant a-i fglrx

Zmieniamy xorg.conf
Debian~$ aticonfig --initial

Następnie resetujemy Xorg - ctrl+alt+backspace, albo reboot systemu
Debian-& fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600 Generic
OpenGL version string: 2.0.5755 (8.24.8)

2) Instalacja z http://www.ati.com

¦ciągamy instalke ati-driver-installer-8.25.18-x86.run

Nadajemy plikowi prawa wykonywania

Debian~$ chmod +x ati-driver-installer-8.25.18-x86.run

Instalujemy potrzebne repozytoria i budujemy paczki
Debian~# apt-get install module-assistant build-essential fakeroot
dh-make debconf
Debian~# sh ./ati-driver-installer-8.25.18-i386.run --buildpkg
Debian/sid
UWAGA: wybierz zgodnie z Twoim systemem Debian/sid, Debian/sarge,
Debian/etch

Instalujemy zbudowane paczki
Debian~# fglrx-control_8.25.18-1_i386.deb
Debian~# fglrx-kernel-src_8.25.18-1_i386.deb
Debian~# fglrx-driver_8.25.18-1_i386.deb
Debian~# fglrx-driver-dev_8.25.18-1_i386.deb
Debian~# apt-get -f upgrade

Kompilujemy i ładujemy sterownik
Debian~$ module-assistant prepare
Debian~$ module-assistant update
Debian~$ module-assistant a-i fglrx

Zmieniamy xorg.conf
Debian~$ aticonfig --initial

Następnie resetujemy Xorg - ctrl+alt+backspace, albo reboot systemu
Debian-& fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9600 Generic
OpenGL version string: 2.0.5755 (8.25.18)

//Dodane Uwagi Kaki

czarny404
Posty: 75
Rejestracja: 09 lipca 2006, 08:15

Post autor: czarny404 » 09 lipca 2006, 11:15

mam pytanie jakie dokaładnie repezytorium ma wyglądać? Mi niestety nie chce zainstalować fglrx-driver oraz fglrx-kernel-src. Używam sarge r2. Dzięki z góry za pomoc :) .

Witek Baryluk
Beginner
Posty: 209
Rejestracja: 26 czerwca 2006, 01:49
Lokalizacja: Kraków za firewallem

Post autor: Witek Baryluk » 09 lipca 2006, 15:56

czarny404 pisze:mam pytanie jakie dokaładnie repezytorium ma wyglądać? Mi niestety nie chce zainstalować fglrx-driver oraz fglrx-kernel-src. Używam sarge r2. Dzięki z góry za pomoc :) .
Wystarczy kliknąć u góry forum: Szukaj, wpisać non-free, a następnie wybrać temat Etch + /etc/apt/source.list, czwarty post.

czarny404
Posty: 75
Rejestracja: 09 lipca 2006, 08:15

Post autor: czarny404 » 09 lipca 2006, 16:13

ok ale ja używam sarge jak napisałem wcześniej mogę prosić jakaś listę repezytoriów dla tej wersji?

Witek Baryluk
Beginner
Posty: 209
Rejestracja: 26 czerwca 2006, 01:49
Lokalizacja: Kraków za firewallem

Post autor: Witek Baryluk » 09 lipca 2006, 17:00

to zmień wszystkie wystąpienia testing na stable.

[ Dodano: 2006-07-09, 17:01 ]
eh, napisze, bo może to jednak jest skompilkowane. Wystarczy tyle

Kod: Zaznacz cały

deb [url]http://ftp.pl.debian.org/debian/[/url] stable main non-free contrib
deb [url]http://security.debian.org/[/url] stable/updates main contrib non-free

zjam
Posty: 49
Rejestracja: 06 czerwca 2006, 15:25

Post autor: zjam » 09 lipca 2006, 17:21

Użyj instalacji za pomocą .bin'a ze strony ati, tam są najnowsze sterowniki i nie sprawiają mi nigdy żadnych niespodzianek :)

czarny404
Posty: 75
Rejestracja: 09 lipca 2006, 08:15

Post autor: czarny404 » 10 lipca 2006, 08:39

to właśnie mnie dziwi bo mój sources.list wygląda tak:

Kod: Zaznacz cały

#deb file:///cdrom/ sarge main

deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-2 (20060419)]/ unstable contrib main
deb cdrom:[Debian GNU/Linux 3.1 r2 _Sarge_ - Official i386 Binary-1 (20060419)]/ unstable contrib main


deb [url]http://security.debian.org/[/url] stable/updates main contrib non-free
deb [url]http://www.kadu.net/download/binary/debian/repo[/url] stable main
deb [url]http://ftp.icm.edu.pl/pub/Linux/debian/[/url] sarge main non-free
deb-src [url]http://ftp.icm.edu.pl/pub/Linux/debian/[/url] sarge main non-free
deb [url]ftp://ftp.pl.debian.org/debian/[/url] stable main contrib non-free
deb-src [url]ftp://ftp.pl.debian.org/debian/[/url] sarge main contrib non-free
deb [url]http://ftp.debian-unofficial.org/debian/[/url] sarge main contrib non-free restricted
więc jest zawiera te 2 wpisy i nie mogę zainstalować. Nie rozumiem tego...

jaSS
Beginner
Posty: 388
Rejestracja: 02 czerwca 2006, 08:57

Post autor: jaSS » 13 lipca 2006, 15:31

A czy ktoś zrobił to pod AMD64 i mu to działa?

velmafia
Member
Posty: 1820
Rejestracja: 01 września 2006, 00:56
Lokalizacja: Wrocek

Post autor: velmafia » 01 września 2006, 16:04

witam

próbuje zainstalować fglrx pierwszym sposobem i przy

Kod: Zaznacz cały

module-assistant a-i fglrx 
wyskakuje błąd

Kod: Zaznacz cały

(...)
/usr/src/linux-headers-2.6.16-2-686/scripts/gcc-version.sh: line 11:   
 gcc-4.0: command not found                                                 
  /usr/src/linux-headers-2.6.16-2-686/scripts/gcc-version.sh: line 12:       
 gcc-4.0: command not found                                               
 make[1]: gcc-4.0: Polecenie nie znalezione        
 make[1]: Wejście do katalogu `/usr/src/linux-headers-2.6.16-2-686'         
 /bin/sh: gcc-4.0: command not found                 
  /bin/sh: gcc-4.0: command not found                
(...)

błąd jest związany z plikiem /usr/src/linux-headers-2.6.16-2-686/scripts/gcc-version.sh
a plik ten wygląda tak:

Kod: Zaznacz cały

velmafia:~# cat -n /usr/src/linux-headers-2.6.16-2-686/scripts/gcc-version.sh
     1  #!/bin/sh
     2  #
     3  # gcc-version gcc-command
     4  #
     5  # Prints the gcc version of `gcc-command' in a canonical 4-digit form
     6  # such as `0295' for gcc-2.95, `0303' for gcc-3.3, etc.
     7  #
     8
     9  compiler="$*"
    10
    11  MAJOR=$(echo __GNUC__ | $compiler -E -xc - | tail -n 1)
    12  MINOR=$(echo __GNUC_MINOR__ | $compiler -E -xc - | tail -n 1)
    13  printf "%02d%02d\\n" $MAJOR $MINOR
    14
problem ten związany jest z linijkami 11 i 12 wiec próbuje je wklepać w konsoli:

Kod: Zaznacz cały

velmafia:~# compiler="$*"
velmafia:~# MAJOR=$(echo __GNUC__ | $compiler -E -xc - | tail -n 1)
-su: -E: command not found
velmafia:~# MINOR=$(echo __GNUC_MINOR__ | $compiler -E -xc - | tail -n 1)
-su: -E: command not found
velmafia:~#
czyli chodzi o te "-E", ale co dokładniej to nie wiem, może ktoś mi pomoc ???


aloha

Witek Baryluk
Beginner
Posty: 209
Rejestracja: 26 czerwca 2006, 01:49
Lokalizacja: Kraków za firewallem

Post autor: Witek Baryluk » 01 września 2006, 16:36

nie masz zainstalowanych kompilatorów i innych programów.

Kod: Zaznacz cały

apt-get install build-essential
opcja -E mówi gcc aby odpalił tylko preprocesor (cpp), aby przeprocesorował dyrektywe __GNU_VERSION, i zastąił ją wersją kompilatora (i wyświetlił).

jeśli bardzo wymaga gcc-4.x i nie pojdzie na 3.x to apt-get install gcc-4.0 (i ewentualnie pokrewne cpp-4.0)

Zablokowany