nVidia - instalacja sterowników

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
mariusz13
Posty: 72
Rejestracja: 18 marca 2007, 10:09

Post autor: mariusz13 » 05 kwietnia 2008, 23:32

parrotlarch pisze:

Kod: Zaznacz cały

aptitude install linux-headers-2.6.18-6-686
i po tym jeszcze raz zainstaluj sterownik. powinno trąbić.
Dzięki, pomogło :-D

[ Dodano: 2008-04-06, 19:36 ]
Witam ponownie :)
Własnie zaktualizowałem system do lenny, wszystko ładnie śmiga ale ...

Chciałem włączyć wygaszacz OpenGl to kde sie restartuje - tz. robi się ciemny ekran i pokazuje okienko logowania - to juz podczas wejscie do centrum sterowania - wygaszacze.

Zainstalowałem sterownik nvidi (NVIDIA-Linux-x86-100.14.19-pkg1.run), podczas uruchamiania pokazuje sie ekran z logo Nvidi, niby wszystko dziala.

Polecenia glxinfo i glxgears dają takie efekty:

Kod: Zaznacz cały

diablo:~# glxinfo
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
Error: unable to open display :0

diablo:~# glxgears
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
Error: couldn't open display :0
diablo:~#
Jądro mam - 2.6.24-1-686

radian
Posty: 5
Rejestracja: 29 marca 2008, 18:08

Post autor: radian » 06 kwietnia 2008, 23:47

Witam.

Nie mogę zainstalować sterowników ze strony Nvidia.
Szukałem rozwiązania 2 dni. Byc może znalazłem je ale nie potrafilem wykorzystać.
Oto co dostaję przy próbie kompilacji sterów:

Kod: Zaznacz cały

 include/linux/highmem.h: In function ‘zero_user_segments’:
   include/linux/highmem.h:134: warning: pointer of type ‘void *’ used in a
   rithmetic
   include/linux/highmem.h:134: warning: pointer of type ‘void *’ used in a
   rithmetic
   include/linux/highmem.h:134: warning: pointer of type ‘void *’ used in a
   rithmetic
   include/linux/highmem.h:134: warning: pointer of type ‘void *’ used in a
   rithmetic
   include/linux/highmem.h:137: warning: pointer of type ‘void *’ used in a
   rithmetic
   include/linux/highmem.h:137: warning: pointer of type ‘void *’ used in a
   rithmetic
   include/linux/highmem.h:137: warning: pointer of type ‘void *’ used in a
   rithmetic
   include/linux/highmem.h:137: warning: pointer of type ‘void *’ used in a
   rithmetic
   /tmp/selfgz7193/NVIDIA-Linux-x86-96.43.05-pkg1/usr/src/nv/nv-vm.c: In functi
   on ‘nv_set_page_attrib_uncached’:
   /tmp/selfgz7193/NVIDIA-Linux-x86-96.43.05-pkg1/usr/src/nv/nv-vm.c:64: warnin
   g: ‘change_page_attr’ is deprecated (declared at include/asm/cacheflush.
   h:28)
   /tmp/selfgz7193/NVIDIA-Linux-x86-96.43.05-pkg1/usr/src/nv/nv-vm.c: In functi
   on ‘nv_set_page_attrib_cached’:
   /tmp/selfgz7193/NVIDIA-Linux-x86-96.43.05-pkg1/usr/src/nv/nv-vm.c:79: warnin
   g: ‘change_page_attr’ is deprecated (declared at include/asm/cacheflush.
   h:28)
   /tmp/selfgz7193/NVIDIA-Linux-x86-96.43.05-pkg1/usr/src/nv/nv-vm.c: In functi
   on ‘nv_flush_caches’:
   /tmp/selfgz7193/NVIDIA-Linux-x86-96.43.05-pkg1/usr/src/nv/nv-vm.c:363: error
   : implicit declaration of function ‘global_flush_tlb’
   make[4]: *** [/tmp/selfgz7193/NVIDIA-Linux-x86-96.43.05-pkg1/usr/src/nv/nv-v
   m.o] Błąd 1
   make[3]: *** [_module_/tmp/selfgz7193/NVIDIA-Linux-x86-96.43.05-pkg1/usr/src
   /nv] Błąd 2
   make[2]: *** [sub-make] Błąd 2
   NVIDIA: left KBUILD.
   nvidia.ko failed to build!
   make[1]: *** [module] Błąd 1
   make: *** [module] Błąd 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at [url]www.nvidia.com[/url].
debian lenny. Jajko kompilowane 2.6.25-rc8

Kod: Zaznacz cały

dpkg -l | grep linux-headers
ii  linux-headers-2.6.25-rc8             2.6.25-rc8-10.00.Custom               Header files related to Linux kernel, specif
Moja karta graficzna:

Kod: Zaznacz cały

01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 440] (rev a3)
Próbowałem instalować sterowniki NVIDIA-Linux-x86-96.43.05-pkg1 oraz NVIDIA-Linux-x86-71.86.04-pkg1. Za każdym razem ten sam log. Przy kompilacji kernela miałem gcc-4.2. Gdy zmieniam dowiązanie symboliczne na gc-4.1 instalator pluje, że zła wersja gcc.

Z WiFi po ciężkich bojach jakoś sobie poradziłem ale z Nvidia nie mam już pomysłów. Co jest nie tak? (Debiana mam dopiero kilka dni. Wcześniej miałem ogłupiające Ubuntu.)

dawid
Posty: 32
Rejestracja: 14 października 2007, 22:19

Post autor: dawid » 07 kwietnia 2008, 07:34

Mam dokładnie ten sam problem z tą samą wersją jądra. Na jajku 2.6.24-4 jak i wcześniejszych, stery zainstalowały się bez problemu. Na jajku 2.6.25-rc8 moduł nvidia nie chce się budować. W konfiguracji jądra nic praktycznie nie zmieniałem. linux-headers mam zainstalowane.
Jakieś pomysły na rozwiązanie tego problemu?

mariusz13
Posty: 72
Rejestracja: 18 marca 2007, 10:09

Post autor: mariusz13 » 07 kwietnia 2008, 11:40

Tak się nieśmiało spytam, ma ktoś pomysł dot. mojego problemu?
Post dodany - 2 wyżej.

radian
Posty: 5
Rejestracja: 29 marca 2008, 18:08

Post autor: radian » 07 kwietnia 2008, 12:29

Teraz to już kompletnie nie wiem co robić. Dawid pisze, że Nvidia nie chce instalować się na nowym jajku, a znów na starszym nie mogłem zainstalować WiFi. Wolałbym pozostać przy obecnym jądrze. Zna ktoś rozwiązanie?

Ventrue
Junior Member
Posty: 532
Rejestracja: 06 lipca 2007, 12:10
Lokalizacja: Lubin

Post autor: Ventrue » 07 kwietnia 2008, 14:46

mariusz13, przede wszystkim nie odpalaj glxinfo i glxgears z roota.

radian, poszukaj starszych sterów, Geforce MX 440 chodziły bodajże pod wersją 7* sterowników.

mariusz13
Posty: 72
Rejestracja: 18 marca 2007, 10:09

Post autor: mariusz13 » 07 kwietnia 2008, 14:53

Ventrue pisze:mariusz13, przede wszystkim nie odpalaj glxinfo i glxgears z roota.
Witam,
jak odpalam z usera to mam to samo jak z próbami wejscia do centrum sterowania - wygaszacze:

Kod: Zaznacz cały

tz. robi się ciemny ekran, wyskakuje logo nvidi i pokazuje okienko logowania
- jak przy odpalaniu komputera.

Ventrue
Junior Member
Posty: 532
Rejestracja: 06 lipca 2007, 12:10
Lokalizacja: Lubin

Post autor: Ventrue » 07 kwietnia 2008, 14:58

Spróbuj jeszcze raz zainstalować sterowniki, osobiście miałem taki sam przypadek kiedyś jak Ty. Ewentualnie spróbuj innej wersji niż NVIDIA-Linux-x86-100.14.19-pkg1.run

mariusz13
Posty: 72
Rejestracja: 18 marca 2007, 10:09

Post autor: mariusz13 » 07 kwietnia 2008, 15:02

Ventrue pisze:Spróbuj jeszcze raz zainstalować sterowniki, osobiście miałem taki sam przypadek kiedyś jak Ty. Ewentualnie spróbuj innej wersji niż NVIDIA-Linux-x86-100.14.19-pkg1.run
Chyba tak zrobie, ale co ciekawe wczesniej na starym jajku nie bylo tego, teraz po aktualizacji z Etch do Lenny i nowym jajku - 2.6.24-1-686 takie cuda sie pojawiły, KDE też mi sie dzisiaj zaktualizowało do 3.5.9 i nadal to samo.
A jaki sterownik polecasz na te jajco?

Ventrue
Junior Member
Posty: 532
Rejestracja: 06 lipca 2007, 12:10
Lokalizacja: Lubin

Post autor: Ventrue » 07 kwietnia 2008, 15:25

mariusz13, sterownik to do karty się dobiera, nie jajka :)
Do najnowszych spróbuj 169, ew. 100*, starsze: 9* i 7.

Zablokowany