nVidia - instalacja sterowników

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
Awatar użytkownika
najczarniejszy
Posty: 68
Rejestracja: 11 grudnia 2007, 18:28
Lokalizacja: wziąć na piwo ?

Post autor: najczarniejszy » 29 marca 2008, 19:35

jaką masz wersję gcc? musi być 4.1

Awatar użytkownika
LongeR
Posty: 71
Rejestracja: 25 marca 2008, 10:59
Lokalizacja: DT

Post autor: LongeR » 29 marca 2008, 22:40

Wiem :) gcc mam w wersji 4.1.2 czyli taka jak powinna być.

irtomek
Posty: 89
Rejestracja: 12 lipca 2007, 09:37

Post autor: irtomek » 05 kwietnia 2008, 11:27

http://kaka.ovh.org/howto/nvidia_drivers/ czemu wyskakuje "nie znaleziono obiektu !'

Orion
Posty: 30
Rejestracja: 13 marca 2008, 00:08
Lokalizacja: £ód¼

Post autor: Orion » 05 kwietnia 2008, 15:11

http://www.debian.linux.pl/viewtopic.php?t=7618
@LongeR
ten link powyżej pokazuje drobny problem, jaki ja miałem. Wpierw po zaktualizowaniu jądra musisz zainstalować nowe nagłówki, czyli polecenie:

Kod: Zaznacz cały

 apittude install linux-headers-`uname -r`
Potem dajesz polecenie i sprawdzasz, czy są zainstalowane dobrze :

Kod: Zaznacz cały

dpkg -l | grep linux-headers-`uname -r`
Jak nie masz gcc 4.1 to wydaj to polecenie:

Kod: Zaznacz cały

rm /usr/bin/gcc
ln -s /usr/bin/gcc-4.1 /usr/bin/gcc
Teraz masz już wszystko na swoim miejscu, to robisz instalację sterowników według zaleceń Kaki i wszystko działa jak należy.
W razie pytań pisz : gg:7092216, jid: olbi@maszyna.pl

mariusz13
Posty: 72
Rejestracja: 18 marca 2007, 10:09

Post autor: mariusz13 » 05 kwietnia 2008, 22:25

Witam, zrobiłem uaktualnienie systemu włacznie z jajkiem do 2.6.18-6-686
Niestety nie chca sie zainstalowac sterowniki nvidi, pisz ze sa nie dla tego jajka?!
Karta GForce FX 5200, może ma któs linka do takich sterowników albo jakiś pomysł?
Sterowniki jakich uzywałem:

Kod: Zaznacz cały

NVIDIA-Linux-x86-1.0-9746-pkg1.run
NVIDIA-Linux-x86-169.12-pkg1.run
NVIDIA-Linux-x86-96.43.05-pkg1.run
Pierwszy NVIDIA-Linux-x86-1.0-9746-pkg1.run chodzi z jajkiem - 2.6.18-5-686

Awatar użytkownika
parrotlarch
Beginner
Posty: 393
Rejestracja: 12 kwietnia 2007, 07:31
Lokalizacja: Olsztyn

Post autor: parrotlarch » 05 kwietnia 2008, 22:42

mam na dysku wersję 100.14.19...jak miałem Etcha instalowały się bez problemu...teraz działają na Lennym i na Sidzie.

mariusz13
Posty: 72
Rejestracja: 18 marca 2007, 10:09

Post autor: mariusz13 » 05 kwietnia 2008, 22:58

Nie działa, nigdy nie miałem problemów z nvidia a tu masz? Może coś źle robię?
Log:

Kod: Zaznacz cały

creation time: Sun Apr  6 22:50:01 2008

option status:
  license pre-accepted    : false
  update                  : false
  force update            : false
  expert                  : false
  uninstall               : false
  driver info             : false
  precompiled interfaces  : true
  no ncurses color        : false
  query latest version    : false
  OpenGL header files     : true
  no questions            : false
  silent                  : false
  no recursion            : false
  no backup               : false
  kernel module only      : false
  sanity                  : false
  add this kernel         : false
  no runlevel check       : false
  no network              : false
  no ABI note             : false
  no RPMs                 : false
  no kernel module        : false
  force SELinux           : default
  no X server check       : false
  force tls               : (not specified)
  X install prefix        : (not specified)
  X library install path  : (not specified)
  X module install path   : (not specified)
  OpenGL install prefix   : (not specified)
  OpenGL install libdir   : (not specified)
  utility install prefix  : (not specified)
  utility install libdir  : (not specified)
  doc install prefix      : (not specified)
  kernel name             : (not specified)
  kernel include path     : (not specified)
  kernel source path      : (not specified)
  kernel output path      : (not specified)
  kernel install path     : (not specified)
  proc mount point        : /proc
  ui                      : (not specified)
  tmpdir                  : /tmp
  ftp mirror              : [url]ftp://download.nvidia.com[/url]
  RPM file list           : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
   9746).  As part of installing this driver (version: 100.14.19), the existing
   driver will be uninstalled.  Are you sure you want to continue? ('no' will a
   bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
   ke the installer to attempt to download a kernel interface for your kernel f
   rom the NVIDIA ftp site ([url]ftp://download.nvidia.com[/url])? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
   this means that the installer will need to compile a kernel interface for
   your kernel.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
ERROR: Unable to find the kernel source tree for the currently running kernel. 
       Please make sure you have installed the kernel source files for your
       kernel and that they are properly configured; on Red Hat Linux systems,
       for example, be sure you have the 'kernel-source' or 'kernel-devel' RPM
       installed.  If you know the correct kernel source files are installed,
       you may specify the kernel source path with the '--kernel-source-path'
       command line option.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at [url]www.nvidia.com[/url].

Awatar użytkownika
parrotlarch
Beginner
Posty: 393
Rejestracja: 12 kwietnia 2007, 07:31
Lokalizacja: Olsztyn

Post autor: parrotlarch » 05 kwietnia 2008, 23:05

ERROR: Unable to find the kernel source tree for the currently running kernel.
Please make sure you have installed the kernel source files for your
kernel and that they are properly configured
masz zainstalowane linux-headers dla nowego jajka??

Kod: Zaznacz cały

linux-headers-2.6.18-6-686
?

mariusz13
Posty: 72
Rejestracja: 18 marca 2007, 10:09

Post autor: mariusz13 » 05 kwietnia 2008, 23:09

parrotlarch pisze: masz zainstalowane linux-headers dla nowego jajka??

Kod: Zaznacz cały

linux-headers-2.6.18-6-686
?
A ja wiem :-(
zaktualizowałem system:

Kod: Zaznacz cały

aptitude update
i

Kod: Zaznacz cały

aptitude -P dist-upgrade
a coś trzeba dossać?

Awatar użytkownika
parrotlarch
Beginner
Posty: 393
Rejestracja: 12 kwietnia 2007, 07:31
Lokalizacja: Olsztyn

Post autor: parrotlarch » 05 kwietnia 2008, 23:18

Kod: Zaznacz cały

aptitude install linux-headers-2.6.18-6-686
i po tym jeszcze raz zainstaluj sterownik. powinno trąbić.

Zablokowany