nVidia - instalacja sterowników

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
ts1990
Posty: 40
Rejestracja: 27 lutego 2008, 07:36

Post autor: ts1990 » 06 marca 2008, 17:11

dobra... jestem poczatkujacy jeszcze. zapomnialem sciagnac tego linux-headers :P he. przeszlo bez sciagania GCC

adamek@
Posty: 2
Rejestracja: 07 sierpnia 2007, 12:39

Post autor: adamek@ » 07 marca 2008, 12:28

Witam! Miałem też problem ze sterownikiem Linux Display Driver - x86 Wersja: 169.12 na Debianie Etch. Po każdym ponownym uruchomieniu systemu Xy nie wstawały. Rozwiązanie znalazłem tu:
http://www.nvnews.net/vbulletin/showthread.php?t=72490
najbardziej istotny fragment:
* the nvidia-glx package has been uninstalled with the --purge option and the files /etc/init.d/nvidia-glx and /etc/init.d/nvidia-kernel do not exist
czyli dajemy:

Kod: Zaznacz cały

aptitude purge nvidia-glx
i jeszcze usunąłem bo u mnie przynajmniej był plik

Kod: Zaznacz cały

rm /etc/init.d/nvidia-kernel
Nie wiem czy wszystko dobrze zrozumiałem ale to działa :) Pozdawiam.
//cc

Awatar użytkownika
zomer
Beginner
Posty: 322
Rejestracja: 26 października 2007, 15:52
Lokalizacja: Podkarpacie

Problem z NVIDIA

Post autor: zomer » 11 marca 2008, 19:39

Przeinstalowałem system Debian z Etch na Lenny. Konieczna była ponowna instalacja sterowników nvidia. unaame -r zwraca 2.6.22-3-amd64 więc zainstalowałem

Kod: Zaznacz cały

aptitude install linux-headers-2.6.22.3-amd64
ale podczas instalacji sterowników dostaję info że mam źle dobrane sterowniki (co jest niemożliwe) Przy pytaniu o kompilacje odpowiadam yes i dostaję odpowiedź o błędzie. Odpowiedź No kreator zainstalował sterownik bez kompilacji jądra, ale nie mam akceleracji. Ktoś już instalował sterowniki nvidi na 2.6.22-3-amd6
log mam taki

Kod: Zaznacz cały

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Tue Mar 11 18:24:34 2008

option status:
  license pre-accepted    : false
  update                  : false
  force update            : false
  expert                  : false
  uninstall               : false
  driver info             : false
  precompiled interfaces  : true
  no ncurses color        : false
  query latest version    : false
  OpenGL header files     : true
  no questions            : false
  silent                  : false
  no recursion            : false
  no backup               : false
  kernel module only      : false
  sanity                  : false
  add this kernel         : false
  no runlevel check       : false
  no network              : false
  no ABI note             : false
  no RPMs                 : false
  no kernel module        : false
  force SELinux           : default
  no X server check       : false
  force tls               : (not specified)
  force compat32 tls      : (not specified)
  X install prefix        : (not specified)
  X library install path  : (not specified)
  X module install path   : (not specified)
  OpenGL install prefix   : (not specified)
  OpenGL install libdir   : (not specified)
  compat32 install chroot : (not specified)
  compat32 install prefix : (not specified)
  compat32 install libdir : (not specified)
  utility install prefix  : (not specified)
  utility install libdir  : (not specified)
  doc install prefix      : (not specified)
  kernel name             : (not specified)
  kernel include path     : (not specified)
  kernel source path      : (not specified)
  kernel output path      : (not specified)
  kernel install path     : (not specified)
  proc mount point        : /proc
  ui                      : (not specified)
  tmpdir                  : /tmp
  ftp mirror              : [url]ftp://download.nvidia.com[/url]
  RPM file list           : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
   ke the installer to attempt to download a kernel interface for your kernel f
   rom the NVIDIA ftp site ([url]ftp://download.nvidia.com[/url])? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
   that the installer will need to compile a new kernel interface.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> The CC version check failed:
   
   The compiler used to compile the kernel (gcc 4.1) does not exactly match the
   current compiler (gcc 4.2).  The Linux 2.6 kernel module loader rejects kern
   el modules built with a version of gcc that does not exactly match that of t
   he compiler used to build the running kernel.
   
   If you know what you are doing and want to ignore the gcc version check, sel
   ect "No" to continue installation.  Otherwise, select "Yes" to abort install
   ation, set the CC environment variable to the name of the compiler used to c
   ompile your kernel, and restart installation.  Abort now? (Answer: No)
-> Kernel source path: '/lib/modules/2.6.22-3-amd64/build'
-> Kernel output path: '/lib/modules/2.6.22-3-amd64/build'
-> Performing rivafb check.
-> Performing nvidiafb check.
-> Performing Xen check.
-> Cleaning kernel module build directory.
   executing: 'cd ./usr/src/nv; make clean'...
-> Building kernel module:
//cc

Awatar użytkownika
ruun
Member
Posty: 1366
Rejestracja: 29 marca 2007, 21:07
Lokalizacja: Kruszwica

Post autor: ruun » 11 marca 2008, 19:48

zomer, zmień kompilator http://debian.linux.pl/viewtopic.php?t=6629 ... i zacznij używać wyszukiwarki.

Orion
Posty: 30
Rejestracja: 13 marca 2008, 00:08
Lokalizacja: £ód¼

Post autor: Orion » 25 marca 2008, 19:40

Witam
Miałem podobne problemy z kompilatorem, jednakże po którymś razie ignorowania sterowniki się zainstalowały, okienko nvidii się pokazuje, zaraz po zalogowaniu. Jednakże wynikła dość dziwna sytuacja. Wysiadł mi całkowicie net, a nie wiem, jak się połączyć. Polecenie

Kod: Zaznacz cały

ifconfig
Zwraca, że nie ma takiego polecenia :/
Logi sprawdzałem, ale nie ma tam jakiegoś błędu. Przy ładowaniu systemu pisze, że eth0 : linkup, więc podłączenie niby jest wykrywane.
Sprawdzałem

Kod: Zaznacz cały

ifconfig eth0
ifconfig down
ifconfig up
ifconfig / all
Nic nie pomogło. Pomagał mi jeszcze tata mojej koleżanki, który siedzi na Debianie od kilku lat i stwierdzamy, że coś blokuje, ale nie wiemy co to jest.
Jestem po prostu załamany i nie wiem co zrobić :( Jak temu zaradzić?

soki
Beginner
Posty: 250
Rejestracja: 27 października 2007, 21:18
Lokalizacja: Matrix

Post autor: soki » 27 marca 2008, 12:44

Mam ten sam error, na stronce wyżej nie ma patcha do kernela 2.6.24.4 - nagłówki do jądra mam.

//edit:
Już naprawiłem. :mrgreen:

Awatar użytkownika
najczarniejszy
Posty: 68
Rejestracja: 11 grudnia 2007, 18:28
Lokalizacja: wziąć na piwo ?

Post autor: najczarniejszy » 28 marca 2008, 17:42

po aktualizacji jądra do 2.6.24-1-486 nie chcą się zainstalować sterowniki nvidii. linux-headers zgodne z tą wersją mam, gcc w odpowiedniej wersji też. chcę zainstalować sterowniki 1.0-9631 do geforce mx 440. dostaję coś takiego (nvidia-installer.log - istotne fragmenty):

Kod: Zaznacz cały

 /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c: At top level
   :
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c:110: error: e
   xpected ‘=’, ‘,’, ‘;’, ‘asm’ or ‘__attribute__’ before ’
   ��*’ token
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c: In function
   ‘nvos_create_alloc’:
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c:454: error: �
   ��nv_pte_t_cache’ undeclared (first use in this function)
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c:454: error: (
   Each undeclared identifier is reported only once
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c:454: error: f
   or each function it appears in.)
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c: In function
   ‘nvos_free_alloc’:
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c:486: error: �
   ��nv_pte_t_cache’ undeclared (first use in this function)
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c: In function
   ‘nvidia_init_module’:
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c:1372: error:
   ‘nv_pte_t_cache’ undeclared (first use in this function)
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c:1372: error:
   too many arguments to function ‘kmem_cache_create’
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c:1494: error:
   void value not ignored as it ought to be
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c: In function
   ‘nvidia_exit_module’:
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c:1521: error:
   void value not ignored as it ought to be
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c:1622: error:
   ‘nv_pte_t_cache’ undeclared (first use in this function)
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c: In function
   ‘nv_kern_open’:
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c:1849: error:
   ‘SA_INTERRUPT’ undeclared (first use in this function)
   /tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.c:1849: error:
   ‘SA_SHIRQ’ undeclared (first use in this function)
   make[3]: *** [/tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src/nv/nv.o
   ] Błąd 1
   make[2]: *** [_module_/tmp/selfgz3409/NVIDIA-Linux-x86-1.0-9631-pkg1/usr/src
   /nv] Błąd 2
   NVIDIA: left KBUILD.
   nvidia.ko failed to build!
   make[1]: *** [module] Błąd 1
   make: *** [module] Błąd 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
co z tym zrobić? nawet nie ma za bardzo co do googla wpisać...



//edit

ok, problem rozwiązany. użycie sterowników 96.43.05 zamiast 1.0-9631 załatwia sprawę.

Awatar użytkownika
LongeR
Posty: 71
Rejestracja: 25 marca 2008, 10:59
Lokalizacja: DT

Post autor: LongeR » 29 marca 2008, 14:10

Mam problem z instalacją sterów sami zobaczcie:

Kod: Zaznacz cały

> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'.  This happens most
       frequently when this kernel module was built against the wrong or
       improperly configured kernel sources, with a version of gcc that differs
       from the one used to build the target kernel, or if a driver such as
       rivafb/nvidiafb is present and prevents the NVIDIA kernel module from
       obtaining ownership of the NVIDIA graphics device(s).
macie może jakieś pomysły? moja karta to geforce mx 440 i zależy mi właśnie aby zainstalować tą wersję sterownika (lub nowszą ale chyba ten jest ostatni który obsługuje moją kartę) chodzi o to że na starszych sterownikach mam akcelerację ale nie mają wbudowanych pewnych modułów które są mi potrzebne.

fnmirk
Senior Member
Posty: 8037
Rejestracja: 03 grudnia 2007, 06:37

Post autor: fnmirk » 29 marca 2008, 16:26

Pokaż wynik poleceń:

Kod: Zaznacz cały

 dpkg -l | grep `uname -r`

Kod: Zaznacz cały

lspci | grep control

Awatar użytkownika
LongeR
Posty: 71
Rejestracja: 25 marca 2008, 10:59
Lokalizacja: DT

Post autor: LongeR » 29 marca 2008, 17:40

Jest wszystko :)

Kod: Zaznacz cały

 dpkg -l | grep `uname -r`
ii  linux-headers-2.6.22-14-generic            2.6.22-14.52                         Linux kernel headers for version 2.6.22 on x
ii  linux-image-2.6.22-14-generic              2.6.22-14.52                         Linux kernel image for version 2.6.22 on x86
ii  linux-restricted-modules-2.6.22-14-generic 2.6.22.4-14.10                       Non-free Linux 2.6.22 modules on x86/x86_64
Linux modules for version 2.

Kod: Zaznacz cały

 lspci | grep control
00:0b.0 Network controller: Texas Instruments ACX 100 22Mbps Wireless Interface
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 440] (rev a3)

Zablokowany