nVidia - instalacja sterowników

Zagadnienia dotyczące menadżerów okien, środowisk graficznych - X, KDE, GNOME, Fluxbox, XFCE., Compiz itp.
Awatar użytkownika
ruun
Member
Posty: 1366
Rejestracja: 29 marca 2007, 21:07
Lokalizacja: Kruszwica

Post autor: ruun » 25 lutego 2008, 11:58

matteuszek, Amaru ma ten sam problem w temacie http://debian.linux.pl/viewtopic.php?t=6991

dawideo
Beginner
Posty: 141
Rejestracja: 25 czerwca 2007, 11:46
Lokalizacja: Zbychowo

Post autor: dawideo » 25 lutego 2008, 13:27

Mam taki oto problem. Posiadam karte GF 8800GT, i jest ona dość głośna na maxymalnych obrotach (np jak gram). Problem polega tym iż pod Windowsem chodzi ona normalnie (niskie obroty), natomiast pod Debianem cały czas na maxymalnych obrotach.
P.s Nie mam zainstalowane Beryla, ani Compiz-fusion, czegokolwiek co by obciążało karte. Ja

Awatar użytkownika
ruun
Member
Posty: 1366
Rejestracja: 29 marca 2007, 21:07
Lokalizacja: Kruszwica

Post autor: ruun » 25 lutego 2008, 14:25

dawideo, KLIK

soki
Beginner
Posty: 250
Rejestracja: 27 października 2007, 21:18
Lokalizacja: Matrix

Post autor: soki » 25 lutego 2008, 14:32

Z tymi dużymi obrotami to chyba wina sterowników więc skorzystaj z rozwiązania jakie podał runn ew. czekaj na upgrade sterowników

dawideo
Beginner
Posty: 141
Rejestracja: 25 czerwca 2007, 11:46
Lokalizacja: Zbychowo

Post autor: dawideo » 25 lutego 2008, 16:05

No o chyba poczekam do aktualizacji sterowników, jakoś nie chce mi się bawić w potencjometry:/

misiekalfa
Posty: 6
Rejestracja: 23 lutego 2008, 14:15

Post autor: misiekalfa » 29 lutego 2008, 11:49

witam

zupgradpwałem sobie wczoraj jądro do 2.6.22-4. Nie działał mi dźwięk, na etchu nic nie pomagało. Teraz mam mały problem z iksami. zainstalowałem stery 169.12 i przy uruchamianiu systemu pojawia się na krótko (właściwie to tylko mrygnie raz) logo nvidia, a potem już tylko czarny ekran... iksy się nie uruchamiają. na vesa kde chodzi, ale jakość jest co najmniej średnia. ktoś może wie w czym problem?

pozdrawiam
misiek

Awatar użytkownika
ruun
Member
Posty: 1366
Rejestracja: 29 marca 2007, 21:07
Lokalizacja: Kruszwica

Post autor: ruun » 29 lutego 2008, 12:24

misiekalfa, pokaż zawarość plików..

/var/log/nvidia-installer.log
/var/log/Xorg.0.log (po uruchomieniu na sterowniku nvidia)
/etc/X11/xorg.conf

misiekalfa
Posty: 6
Rejestracja: 23 lutego 2008, 14:15

Post autor: misiekalfa » 29 lutego 2008, 14:43

ok
xorg.log aktualny (vesa)
http://wklej.org/id/3d54eed6d4
xorg.log.old (nvidia)
http://www.wklej.org/id/eac4042101
pod linkiem poniżej znajduje się mój xorg.conf
http://www.wklej.org/id/810d671b0d

teraz jesli chodzi o log z instalacji sterów nvidii. to muszę coś wyjasnić i może to zabrzmieć trochę dziwnie.
wczoraj po wielu nie udanych próbach, udało mi się zainstalować nowe jądro. zmieniłem w /etc/apt/source.list wszędzie etch/stable na testing oraz dodalem repkę z backports (te ostatnie dopiero zadziałało). no i jak dałem aptitude update to wyskoczyło, że 182MB do pobrania (btw zajęło to 19s, z średnim transferem 10MB/s). polecenie aptitde dist-upgrade spowodowało upgrade systemu, ale w paczkach widziałem wersję 2.6.22-4. no to spoko. zainstalowałem, iksy nie wstały, to myślę sobie, że trzeba stery grafiki przeinstalować, ale Envy nie chciał działać. wypluwał błąd, że nieznana wersja systemu i sie obraził. no to ręcznie. naj[pierw ściągnąłem ze strony lenovo (mam laptopa thinkapd r61) wersję jakąś 100.coś tam. nie poszło. no to potem ze strony nvidii ściągnąłem 169.12. w między czasie gdzieś tam wpisalem apt-get update i co? zainstalował mi się kernel 2.6.22-3 i w grubie mam teraz 3 debiany... pod 2.6.22-4 stery nie poszły (problem opisany w pierwszym poście) to pomyślałem, że może pod 2.6.22-3 pójdzie. envy też wypluwało ten sam błąd, a instalacja sterów 169.12 zakończyła się niepwodzeniem, bo znalazł, że wcześniej została zainstalowana ta sama wersja i potem gdzieś wypluło błąd, że nie może załadować modułu nvidia.ko czy jakoś tak. ale log z tej próbby wrzucę, choć nie będzie dokładnie to o co chodzi. może powienienm odinstalować najpierw stery i zainstalować je jeszcze raz? spróbuję to zaraz i zobacze co to zmieni
http://www.wklej.org/id/2a992c162c

pozdrawiam
misiek

edit
usunąłem i zainstalowałem ponownie stery. nic się nie zmieniło, ale oto log z bezproblemowej instalacji sterow
http://wklej.org/id/80c9f1ea15

edit 2
no cóż, udało mi się samemu rozwiązać problem. usunąłem stery i zainstalowałem 100.14.09 (dedykowane dla mojej karty), a następnie polecenie

Kod: Zaznacz cały

dpkg-reconfigure xserver-xconf
ponowne ustawienie xorga pomogło :)

ts1990
Posty: 40
Rejestracja: 27 lutego 2008, 07:36

Post autor: ts1990 » 06 marca 2008, 15:28

Ja rowniez mam problem z zainstalowaniem sterownikow Nvidia: NVIDIA-Linux-x86-169.07-pkg1.run
mianowicie zatrzymuję kdm poleceniem:

Kod: Zaznacz cały

/etc/init.d/kdm stop
pozniej nadaje chmod +x dla pliku.

daje sh NVI...
I klikam ze akceptuje. Pozniej ze nie bo nie chce strony odwiedzac...

i wyskakuje mi:

Kod: Zaznacz cały

No precompiled kernel interface was found to match your kernel; this means that the installer will need to compile a new kernel interface.
klikam OK

Kod: Zaznacz cały

The CC version check failed
the compiler used to compile the kernel gcc 4.1 does not exactly match the current compiler gcc 4.2 the linux 2.6 kernel module loader rejects kernel modules built with a version of gcc that does not exactly match that of the compiler used to build the running kernel.
pozniej wyskakuje....

Kod: Zaznacz cały

ERROR: Unable to find the kernel source tree for the currently running kernel. please make sure you have installed the kernel source files for your kernel and that they are properly configured...
daje OK

Kod: Zaznacz cały

ERROR: installation has failed, please se the file nvidia-installer.log for details...
to te logi:

Kod: Zaznacz cały

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Mar  6 15:07:53 2008

option status:
  license pre-accepted    : false
  update                  : false
  force update            : false
  expert                  : false
  uninstall               : false
  driver info             : false
  precompiled interfaces  : true
  no ncurses color        : false
  query latest version    : false
  OpenGL header files     : true
  no questions            : false
  silent                  : false
  no recursion            : false
  no backup               : false
  kernel module only      : false
  sanity                  : false
  add this kernel         : false
  no runlevel check       : false
  no network              : false
  no ABI note             : false
  no RPMs                 : false
  no kernel module        : false
  force SELinux           : default
  no X server check       : false
  force tls               : (not specified)
  X install prefix        : (not specified)
  X library install path  : (not specified)
  X module install path   : (not specified)
  OpenGL install prefix   : (not specified)
  OpenGL install libdir   : (not specified)
  utility install prefix  : (not specified)
  utility install libdir  : (not specified)
  doc install prefix      : (not specified)
  kernel name             : (not specified)
  kernel include path     : (not specified)
  kernel source path      : (not specified)
  kernel output path      : (not specified)
  kernel install path     : (not specified)
  proc mount point        : /proc
  ui                      : (not specified)
  tmpdir                  : /tmp
  ftp mirror              : [url]ftp://download.nvidia.com[/url]
  RPM file list           : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
   ke the installer to attempt to download a kernel interface for your kernel f
   rom the NVIDIA ftp site ([url]ftp://download.nvidia.com[/url])? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
   that the installer will need to compile a new kernel interface.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> The CC version check failed:
   
   The compiler used to compile the kernel (gcc 4.1) does not exactly match the
   current compiler (gcc 4.2).  The Linux 2.6 kernel module loader rejects kern
   el modules built with a version of gcc that does not exactly match that of t
   he compiler used to build the running kernel.
   
   If you know what you are doing and want to ignore the gcc version check, sel
   ect "No" to continue installation.  Otherwise, select "Yes" to abort install
   ation, set the CC environment variable to the name of the compiler used to c
   ompile your kernel, and restart installation.  Abort now? (Answer: No)
ERROR: Unable to find the kernel source tree for the currently running kernel. 
       Please make sure you have installed the kernel source files for your
       kernel and that they are properly configured; on Red Hat Linux systems,
       for example, be sure you have the 'kernel-source' or 'kernel-devel' RPM
       installed.  If you know the correct kernel source files are installed,
       you may specify the kernel source path with the '--kernel-source-path'
       command line option.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at [url]www.nvidia.com[/url].
Co mam robic? Mam swiezo zainstalowany system. jedyne co zrobilem to dalem:

Kod: Zaznacz cały

aptitude update && aptitude upgrade && aptitude dist-upgrade
mam jajko: 2.6.22-3-486

Licze na pomoc.

Ventrue
Junior Member
Posty: 532
Rejestracja: 06 lipca 2007, 12:10
Lokalizacja: Lubin

Post autor: Ventrue » 06 marca 2008, 15:58

Zainstaluj nagłówki kernela i gcc w wersji 4.1. Jeśli masz oba to zrób dowiązanie z /usr/bin/gcc-4.1 do /usr/bin/gcc

Zablokowany